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In This Book
This guide documents how to install the Keysight 89600 software and a
transportable license. It also documents how to view the software's online help and
demo signal packages.

Other Documentation
In addition to the Quick Start Guide (this book), the following documentation is
included with your software:

The 89600 Software Installation Guide (InstallationGuide.pdf) is available on
the installation DVD in the manuals folder, during installation by clicking More
Installation Choices > View Installation Guide, or after you install the
software in C:\Program Files\Keysight\89600 Software
<ReleaseVersion>\89600 VSA Software\Help.
The 89600 Online Help is available after you install the software on your
computer. The help provides use and operation information.
If you install the IO libraries, the complete documentation for the Keysight IO
libraries is available by right-clicking the Keysight IO Libraries Suite icon in
the Windows task bar's Hidden Icons panel and selecting Documentation.
Technical Specifications are available from the 89600 web page:
http://www.keysight.com/find/89600

To read the PDF files, you must have Acrobat Reader installed
on your computer. To install the latest Acrobat Reader, go to:
http://get.adobe.com/reader/

http://www.keysight.com/find/89600
http://get.adobe.com/reader/
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Overview
The Keysight PathWave 89600 VSA Quick Start Guide provides all necessary
instructions to install the Keysight 89600 software and a transportable license

89600 Software
The Keysight 89600 software's installation wizard guides you though the installation
process.
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Licensing

Licensing
There are four types of licenses:

Demo: The Demo license is provided with the 89600 software installation and
enables you to use the 89600 software with limited functionality.
Trial: The Trial license lets you immediately start using a fully licensed 89600
software application for a temporary trail period. When the trial period expires,
you will need to purchase a valid license for continued use.
Node-locked: The node-locked license is used to license the Keysight 89600
software plus options to only run on one specified host PC.
Transportable: The Transportable license is used to license the Keysight
89600 software plus options to only run on the host PC. However, you do have
the capability to transport the license to a different PC, making it the new host
PC.
Floating: The Floating or Network license provides the ability for different PC's
to use a license that is stored on a network PC (or server).
USB portable: The USB portable license is used to license 89600 VSA
software with options to only run on one host PC with certified USB dongle,
which needs be purchased separately.
You can move the USB portable license together with the certified USB
dongle from one Host PC to another Host PC.

This Quick Start Guide documents how to install the transportable license. For
information on how to install the demo, trial, or floating license types, see the
Installation Guide (InstallationGuide.pdf) available on the installation DVD in the
manuals folder, during installation by clicking More Installation Choices > View
Installation Guide, or after you install the software in C:\Program
Files\Keysight\89600 Software <ReleaseVersion>\89600 VSA Software\Help.

Keysight 89600 Software Operating Configurations
The Host PC is the computer that will run the Keysight 89600 software. There are
two 89600 software operating configurations: Remote PC Operation and Embedded
PC Operation (also referred to as Embedded Instrument Operation). In a Remote
PC Operation, the software runs on a standalone host PC linked to the
measurement hardware via the I/O interface, such as LAN, GPIB, USB, and IEEE
1394.
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In an Embedded PC Operation, the 89600 software runs on a PC embedded in the
measurement hardware platform such as the Keysight X-Series Analyzer, Keysight
Infiniium Scope, and Keysight Logic Analyzer.

Installation and Configuration Process
The Keysight 89600 software installation process includes the following primary
steps:

1. Set up and configure the remote PC.

Skip this step if you are installing the software in an
embedded PC operation.

Go to Chapter 2 Configuring Remote PC (page 11) to setup and configure the
remote PC hardware including:

2. Install the 89600 software.
Go to Chapter 3 Installing 89600 Software (page 15) and follow the
instructions to install the Keysight 89600 software.

3. License the Keysight 89600 software.
Go to Chapter 4 Installing Licenses (page 25) and follow the instructions to
license the Keysight 89600 software and option.



10 89600 Software Quick Start Guide



Configuring Remote PC

11

Configuring Remote PC
This chapter only applies to the remote PC operation configuration. This contains
information to setup and configure the PC including system requirements, I/O
interface requirements, and the PC interface installation and setup procedure.

If you are going to install the software in an embedded PC
operation, skip this chapter and go directly to Installing 89600
Software (page 15).
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Configuration Steps
1. Verify your PC meets the system requirements listed in the following table.

Characteristic Requirement

Operating system Microsoft Windows 11 Professional or Enterprise
Microsoft Windows 10 Professional, Enterprise or
Education (64 bit)

CPU 1 GHz (>2 GHz recommended)

RAM 2 GB (16 GB recommended)

Video RAM 128 MB (1 GB recommended)

Graphics support OpenGL version of 2.1 or higher required for ren-
dering of 3D trace data in some measurement options

Hard disk 3 GB minimum available

Additional drives DVD to load the software; license transfer requires
network access or a USB memory device

Interface support LAN, GPIB, USB. For Option SSA, PCIe Express
card interface to PXI mainframe or an embedded PC
M9036A/M9037A to be used

2. Verify that your PC's I/O interface meets the requirements listed in the fol-
lowing table.

If you are only using simulated measurement hardware or
signal simulation software, you do not need to
install/configure an I/O interface. You can skip the
remainder of this chapter and go directly to Installing
89600 Software in a PC (page 16).

Using the following table, determine what type of PC and I/O interface is
required for your measurement hardware. Note that you may need to install
and configure more than one interface.

If the PC already supports the I/O interface, skip the remainder of this
chapter and install the 89600 VSA software—go to Installing 89600 Soft-
ware in a PC (page 16).
If the PC supports the I/O interface but it is not currently installed, you
will need to install and configure the I/O interface hardware on the PC—
go to Installing I/O Interface Hardware (page 14).
If the PC does not support the I/O interface, you can not use the 89600
VSA software with your measurement hardware.

12 89600 Software Quick Start Guide
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Measurement Hard-
ware Computer Type Interface

Keysight ESA Laptop or desktop PC GPIB, or USB/GPIB
adapter

Keysight ESA-E Ser-
ies Analyzer

Laptop or desktop PC GPIB or USB/GPIB

Keysight InfiniiVision
Oscilloscope

Laptop or desktop PC LAN, GPIB, or
USB/GPIB

Keysight Infiniium
Oscilloscope

Laptop or desktop PC or
embedded Windows
scope

LAN, GPIB,
USB/GPIB, or internal

Keysight Logic Ana-
lyzer

Laptop, desktop PC, or
embedded PC

LAN, IEEE-1394 (only
for 1690 Series), or
internal

Keysight X-Series Sig-
nal Analyzer

Laptop, desktop PC, or
embedded PC

LAN or internal*

Keysight Handheld RF
and Microwave Ana-
lyzer

Laptop or desktop PC LAN

Keysight modular
products

Laptop, desktop PC, or
embedded PC

LAN, GPIB, USB/GPIB
or internal

* The Keysight X-Series Signal Analyzer embedded PC operation only
supports a LAN interface between the analyzer and a Keysight Source.
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1. Installing I/O Interface Hardware
a. Install I/O Interface Card(s) in the PC.

Install all necessary I/O interface card(s) in the PC per the instructions
that came with the I/O interface card vendor documentation.
National Instruments GPIB card: For a National Instruments GPIB
card, be sure to install the NI 488.2 software first, then reboot your PC
and install the interface card.

Exclude Multiple GPIB Devices: If this PC controls
other GPIB measurement hardware or devices, you
need to exclude those devices from the 89600
identification process.

b. Configure the PC I/O Interface.
Configure the I/O interface card(s) in the PC per the instructions that
came with the I/O interface card vendor documentation.

You can typically use the default I/O interface hardware
settings.

GPIB: For GPIB interfaces, make sure that each
measurement hardware has a unique GPIB address—
multiple GPIB devices cannot use the same GPIB
address.

If the PC and measurement hardware are connected to
a local internal LAN, you may need to check with your
network administrator to verify that the IP addresses for
the PC and measurement hardware satisfy
requirements.

c. Cycle power OFF/ON on all system hardware.
After completing the hardware I/O connections, cycle the power
OFF/ON on the PC and all connected measurement hardware.

d. Next install the 89600 VSA software. Go to Installing 89600 Software in
a PC (page 16).
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Installing 89600 Software
This procedure installs the 89600 VSA software.
There are different installation procedures for each operating configuration—Remote
PC and Embedded PC configuration. Remote PC configuration requires installing
the software in a PC. Embedded PC configuration requires installing the software in
the measurement hardware; there are also different install procedures for different
measurement hardware types.
Select and use the software installation procedure for your particular installation:
Remote PC Configuration

Installing 89600 Software in a PC (page 16)
Embedded PC Configuration

Installing 89600 Software in a Keysight X-Series Signal Analyzer (page 18)
Installing 89600 Software in a Keysight Infiniium Scope (page 20)
Installing 89600 Software in a Keysight Logic Analyzer (page 22)
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Installing 89600 Software in a PC
To install the Keysight 89600 software in a remote PC configuration:

1. Close any applications you have open.

To install the Keysight 89600 software, you must have
administrator privileges.

2. Insert the Keysight 89600 software installation DVD.
3. If the installation utility does not start automatically, navigate to the DVD drive

and double-click this file:
autoplay.exe

4. When the Keysight 89600 Installation Manager window opens, click View
Readme then review the following sections of the Readme file.

Required Minimum License Version
Installation Information

5. After reviewing the Readme file, start the software installation by clicking
Install PathWave 89600 VSA. Step through the InstallShield Wizard and stop
at the Select Products and Features window.

6. Select the Products and Features you want to install, click Next then continue
through the InstallShield Wizard to complete the installation.

7. If you will be using connected hardware, see Installing or Updating Keysight
IO Libraries for Keysight 89600 VSA (page 17).

8. The installation process configures your system environment for the 89600
software applications. Some installations may required a system PC reboot. If
this occurs, click OK to reboot.
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After rebooting you will need to be logged on with
administrative privileges to complete the installation.

When installing from a remotely mounted DVD drive, the
remote drive must be configured to reconnect at logon so that
the installation files can be located after the reboot.

9. The 89600 software installation is now complete and the software can be run.
However, the software and options need to be licensed. To learn how to
obtain a license, see Installing Licenses (page 25).

Installing or Updating Keysight IO Libraries for Keysight 89600 VSA

Keysight 89600 VSA Uses IO Libraries for SCPI API support and Hardware
Connectivity. If these features are not required for anticipated usage, then IO
Libraries does not need to be installed.
Known issues that may affect VSA users when Updating Keysight IO Libraries
from a previous version

DO NOT update Keysight IO Libraries on a Keysight instrument. Please refer
to instrument specific update instructions.
Updating from a version of Keysight IO Libraries version 2024 or older will
remove connection definitions from Keysight Connection Expert. Please make
note of any VISA addresses and alias names for connections (using Keysight
Connection Expert), and manually reconfigure these connections after
installation is complete (using Keysight Connection Expert).
Updating from a version of Keysight IO Libraries version 2024 or older will
disregard settings, or previously chosen installation options. Please make
note of this and choose installation options consistent with what is required for
the installation environment, and update any settings after installation.

Installing or Updating Keysight IO Libraries
To learn about, download, install, and configure the most up-to-date version of
Keysight IO Libraries, please visit and follow the instructions provided at:
https://www.keysight.com/find/iolibs.
Installing Keysight IO Libraries from the 89600 VSA DVD
From the "89600 Software\IOLibraries" on the DVD, read the release notes and
follow installation instructions.
This directory includes pre-req and main installer packages for offline installation of
"Keysight IO Libraries Suite."

https://www.keysight.com/find/iolibs
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Installing 89600 Software in a Keysight X-Series Signal
Analyzer

Verify that the Instrument software revision (System hardkey >
Show softkey > System softkey) is A.19.05 or greater.

Since the Keysight X-Series Signal Analyzers do not have internal DVD drives, you
must first copy the contents of the Keysight 89600 software DVD onto a USB Drive.
The Keysight 89600 software DVD is not protected or encrypted. The copy will be
identical to the original DVD.

This procedure assumes that a USB Flash Drive is being used.
Other USB storage devices, such as a USB hard drive or USB
DVD drive, could also be used.

To install the 89600 VSA software in a Keysight X-Series Signal Analyzer using a
USB Flash drive:

1. Insert the Keysight 89600 software DVD into a PC’s DVD drive. If the Keysight
89600 Installation Manager window opens, close the installer program (click
Exit).

2. Insert a USB Flash Drive into a USB port on the same PC in which the
Keysight 89600 software DVD is loaded.

3. Use Windows Explorer to copy the contents of the Keysight 89600 software
DVD onto the USB Flash Drive.

4. Connect a USB keyboard and mouse to the analyzer.

To install the Keysight 89600 software on the analyzer, you
need to have administrator privileges. Press Ctrl - Alt -
Delete, then click Log Off.... Log back in as the Administrator.
Depending on your instrument’s installed Windows OS image
version, the default administrator password is either
agilent4u or Keysight4u!.

5. Insert the USB Flash Drive into an available USB port on the analyzer.
6. Open Windows Explorer and navigate to the USB drive.
7. Double-click autoplay.EXE.
8. When the Keysight PathWave Vector Signal Analyzer (89600 VSA) Installer

window opens, please read the Readme information.
9. After you read the Readme file, close it, then click Install 89600 Software.

Continue through the InstallShield Wizard until you reach the Select Products
and Features window.

10. Select the features you want to install, then continue through the InstallShield
Wizard to complete the installation.

11. When the installation is complete, exit the Installation Manager.
12. Start the X-Series analyzer application: Double-click the LaunchXSA icon on

the Windows desktop.
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13. After the X-Series analyzer finishes booting up, start the Keysight 89600
software:

Press the Mode Hardkey, then there is Launch VSA button on the left
bottom of the window. You can choose from the menu below the
"Launch VSA" button to specify the launched 89600 VSA version which
has already been installed inside this signal analyzer.

Next the software and options need to be licensed. To learn how to obtain a license,
see Installing Licenses (page 25).
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Installing 89600 Software in a Keysight Infiniium Scope

Embedded operation with the 89600 is not recommended for the
Infiniium 8000 and 80000 Series scopes.

Many Infiniium oscilloscopes provide an open Microsoft Windows operating system
that enables you to install other applications. You can install and operate the 89600
Vector Signal Analysis software on these scopes.
Some Keysight Infiniium scopes have no DVD drive, so for these scopes you must
use a USB drive. If you are installing from a USB drive, you must copy the contents
of the Keysight 89600 software DVD onto the USB Drive. The Keysight 89600
software DVD is not protected or encrypted. The copy will be identical to the original
DVD.
To install the 89600 VSA software in a Windows scope:

1. Increase the scope's virtual memory to at least 1 GB as follows:
a. Minimize the scope application.
b. Navigate to: Control Panel > Administrative Tools (double-click) >

Computer Management (double-click) > Computer Management
(Local) (right-click) > Properties > Advanced (tab)> Performance Set-
tings (button) > Virtual Memory - Change (button) to display the Virtual
Memory dialog screen.

c. Set Initial Size (MB) and Maximum Size (MB) to 1000 MB (or more if
you have sufficient Space Available), then click Set > OK > OK (reboot
message) > OK > OK.

d. When the System Settings Change dialog appears, click Yes to restart
the computer.

2. Insert the Keysight 89600 software installation DVD into the scope's DVD
drive. If your scope does not have a DVD drive, use the following procedure:

This procedure assumes that a USB Flash Drive is being
used. Other USB storage devices, such as a USB hard
drive or USB DVD drive, could also be used.

a. Insert the Keysight 89600 software DVD into a PC’s DVD drive. If the
Keysight PathWave Vector Signal Analyzer (89600 VSA) Installer win-
dow opens, close the installer program (click Exit).

b. Insert a USB Flash Drive into a USB port on the same PC that the Key-
sight 89600 software DVD is in.

c. Copy the contents of the Keysight 89600 software DVD onto the USB
Flash Drive.

d. Connect a USB keyboard and mouse to the scope.

To install the Keysight 89600 software on the scope,
you need to have administrator privileges. Press Ctrl
- Alt - Delete, then click Log Off.... Log back in as
the Administrator.

20 89600 Software Quick Start Guide



Installing 89600 Software
Installing 89600 Software in a Keysight Infiniium Scope

89600 Software Quick Start Guide 21

e. Insert the USB Flash Drive into an available USB port.
f. Open Windows Explorer and navigate to the USB drive.
g. Double-click autoplay.EXE to bring up the Keysight PathWave Vector

Signal Analyzer (89600 VSA) Installer.
3. When the Keysight PathWave Vector Signal Analyzer (89600 VSA) Installer

window opens, please read the Readme information.
4. After you read the Readme file, close it then click Install 89600 Software.

Continue through the InstallShield Wizard until you reach the Select Products
and Features window.

5. Select the features you want to install, then continue through the InstallShield
Wizard to complete the installation.

6. When the installation is complete, exit the Installation Manager.
7. Start the 89600 VSA. Click Start > (All) Programs > Keysight PathWave

89600 VSA <ReleaseVersion> > Keysight PathWave 89600 VSA
<ReleaseVersion>.

Next the software and options need to be licensed. To learn how to obtain a license,
see Installing Licenses (page 25).
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Installing 89600 Software in a Keysight Logic Analyzer
Some Keysight Logic Analyzers have no DVD drive, so for these analyzers you must
use a USB drive. If you are installing from a USB drive, you must copy the contents
of the Keysight 89600 software DVD onto the USB Drive. The Keysight 89600
software DVD is not protected or encrypted. The copy will be identical to the original
DVD.
To install the 89600 VSA software in a logic analyzer:

1. Insert the Keysight 89600 software DVD into the logic analyzer's DVD drive. If
your logic analyzer does not have a DVD drive, use the following procedure:

This procedure assumes that a USB Flash Drive is being
used. Other USB storage devices, such as a USB hard
drive or USB DVD drive, could also be used.

a. Insert the Keysight 89600 software DVD into a PC’s DVD drive. If the
Keysight PathWave Vector Signal Analyzer (89600 VSA) Installer win-
dow opens, close the installer program (click Exit).

b. Insert a USB Flash Drive into a USB port on the same PC that the Key-
sight 89600 software DVD is in.

c. Copy the contents of the Keysight 89600 software DVD onto the USB
Flash Drive.

d. Connect a USB keyboard and mouse to the analyzer.

To install the Keysight 89600 software on the logic
analyzer, you need to log on with administrator
privileges.

e. Insert the USB Flash Drive into an available USB port on the analyzer.
f. Open Windows Explorer and navigate to the USB drive.
g. Double-click autoplay.EXE to bring up the Keysight 89600 Installation

Manager.
2. When the Keysight PathWave Vector Signal Analyzer (89600 VSA) Installer

window opens, please read the Readme information.
3. After you read the Readme file, close it then click Install 89600 Software.

Continue through the InstallShield Wizard until you reach the Select Products
and Features window.

4. Select the features you want to install, then continue through the InstallShield
Wizard to complete the installation.

5. When the installation is complete, exit the Installation Manager.

When installing the 89600 VSA in a logic analyzer
mainframe, Hardware support is disabled. This prevents
using disk space for unnecessary components that are not
needed when the 89600 VSA software is installed in a
logic analyzer.
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6. Start the 89600 VSA. Click Start > (All) Programs > Keysight PathWave
89600 VSA <ReleaseVersion> > Keysight PathWave 89600 VSA
<ReleaseVersion>.

Next, the software and its options must be licensed. To learn how to obtain a license,
see Installing Licenses (page 25).
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Installing Licenses
The 89600 software and options must be licensed to operate in a useful manner.
The 89600 software has Demo, Trial, Node-locked, Transportable, Floating, and
USB portable license types. The Demo license is installed with the 89600 software.
This chapter describes how to install a Transportable license. For instructions on
installing the other types of licenses, see the Installation Guide
(InstallationGuide.pdf), which is available on the installation DVD in the manuals
folder, during installation by clicking More Installation Choices > View Installation
Guide, or after you install the software in C:\Program Files\Keysight\89600
Software <ReleaseVersion>\89600 VSA Software\Help.
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Transportable License
This section describes the steps to obtain and install a Transportable license. The
Transportable license enables the 89600 software and options that you purchased.
The license must be installed on the same computer that runs the 89600 software.
However, the license can be transferred from one computer to another computer.
Licensing the 89600 Software is a two step process:

1. Redeem the License.
Go to Redeeming a transportable license (page 26).

2. Install the License file.
Go to Installing a transportable license (page 27).

The term PC refers to any computer or instrument (such as
analyzers and oscilloscopes) running the 89600 software.

Redeeming a transportable license

To redeem a Transportable license, follow these steps:
1. Collect the Software License Entitlement Certificates for all 89600 software

options that you purchased. The Software License Entitlement Certificates are
included with the 89600 VSA Software Installation Materials envelope (printed
on gray parchment).

The Software License Entitlement Certificate also includes
instructions to redeem your licenses.

2. Obtain the license Host ID (Model Number, Serial Number) from the PC that
you installed the VSA software on.

a. Launch the PathWave License Manager. Within the VSA software, click
Utilities > Licenses > Status > PathWave License Manager..., or from
the Windows desktop, click Start > Keysight PathWave License
Manager > Keysight PathWave License Manager.

b. Copy the Keysight Host ID at the top of the Add License tab.

For Measurement Hardware (instruments), the
Keysight Host IDs consist of an Keysight instrument
model number and serial number. On a desktop or
laptop PC, the default model number is PCSERNO.

3. Redeem your licenses and obtain the license files.
Follow the instructions included on the Software License Entitlement
Certificate to redeem your licenses and obtain the license files. Go to the
Keysight Software Manager website:
http://www.keysight.com/find/softwaremanager
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First time access will require you to register.

Remember your user password. The password is
required for future access to manage your licenses.

You will need the Keysight Order Number and Keysight Certificate Num-
ber located on the top of your Software License Entitlement Certificate.

4. Install License File(s): Check your email for the license file(s) and then install
the license file(s) on the PC—go to Installing a transportable license (page
27).

Installing a transportable license

Installing the license file is necessary to license the 89600 software. After
completing Redeeming a transportable license (page 26), you will receive a
Keysight email containing your license file for the redeemed Entitlement Certificates.
Follow these steps to install the license files on the PC:

1. Copy the email attachment with the .lic file extension to a folder on your PC,
connected hard drive, or USB storage device.

2. Start the PathWave License Manager by clicking Utilities > Licenses >
Status > PathWave License Manager.

3. In PathWave License Manager, click Add License > + Add a License File.
4. Browse to the location where you saved the license file. Select the license file

and click the Open > Add Now.

The install operation can take up to 40 seconds to complete.

When the license file is successfully installed, the installed licenses that are
available are listed in the PathWave License Manager. Make sure your
licensed options and features are shown.

5. Restart the VSA software to activate the license.
6. After installing the license file, verify that the Options are licensed for use by

the Keysight 89600 software. Start the Keysight 89600 software, then open
Utilities > Licenses > Features (or Utilities > Licenses > Legacy Options for
legacy licenses) and verify the options are correctly licensed (Yes in the On
column).

"On" Column License Status

Yes Option is licensed for use.

-- Dash indicates that the license option has not been
selected for use by the VSA. To include an option, open
the Select License Options system utility and select
(check) the options that you want to include in the VSA
measurement capability (click Start > Keysight
PathWave 89600 VSA <ReleaseVersion> > Select
License Options. The VSA must be closed and restar-
ted to incorporate the changes.

No Option is not licensed for use.
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Using the VSA Online Help and Demos
Now that you have installed and licensed your Keysight 89600 software, it is time to
start using it. The best way to learn how to use the VSA software is to view the online
help and demo signal packages.
There are multiple ways to access the 89600 VSA help, as described on the
following pages in this chapter.
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Accessing Help
Start menu
After installing the 89600 VSA software, you can click the Windows Start button >
All Programs > Keysight PathWave 89600 VSA <ReleaseVersion> > Help > VSA
Help to open the 89600 VSA help system.

Help menu

While the VSA software is running, click Help from the main menu then select one of
the following menu items:

This menu item… Does this…

Show Help Opens the 89600 VSA help system in an external window.

Search Help Opens the 89600 VSA help system to the search tab.

Dynamic Help Opens the dynamic help panel. By default, dynamic help
is shown in a tool window that is docked to the right-hand
side of the VSA main window.

Getting Started Opens a topic with links to information about getting
started with the 89600 VSA.

Demos Opens a list of demo signals that are provided with the
VSA.

.NET API Reference Opens the 89600 VSA .NET API reference in a separate
help window.

SCPI Reference Opens the 89600 VSA SCPI reference in a separate help
window.

Keysight 89600 VSA
website

Opens the 89600 VSA website in the default web
browser.

Keysight VSA for-
ums

Opens the Keysight VSA forums.

Technical Support Opens the 89600 VSA Technical Support website.

About... Shows information about the VSA software, including
what software version is installed on your computer.
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Dynamic help

Dynamic help is the quickest and easiest method to find help. To open the dynamic
help window, select Help > Dynamic Help. The current topic follows the user
interface item that currently has focus.

Help button on dialogs

You can access help for any dialog box by clicking the ? button in title bar of the
dialog box.
In the following illustration, clicking the Help button opens the VSA help for the
Format tab of the Digital Demod Properties dialog box.

F1 on the keyboard

You can access context-sensitive help by pressing the F1 key.
When you are viewing a dialog box, pressing F1 shows the same information as
clicking the ? button. The F1 help also works on menus and traces.
Pressing F1 while a menu item is highlighted opens context-sensitive help for that
menu item.
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Recalling a Demo Signal Package
Recalling a demo signal package is a good way to learn about the measurement
capabilities and features of the 89600 VSA. The 89600 VSA provides various demo
signal packages that include recorded signals, signal setup files, or Signal Studio
setup files, and a demo help topic.
To view the available demo signals, open the Demo and Recorded Signals help
topic (click Help > Demos).
To recall a demo:

1. Click File > Recall > Recall Demo.
2. In the Recall Demo dialog, browse to C:\Program Files\Keysight\89600 Soft-

ware <ReleaseVersion>\89600 VSA Software\Help\Signals.
3. Select a Demo file of interest. For example, browse to AM FM PM, then select

XMITTER.htm.
4. Click Open. The VSA recalls the instrument setup (measurement state), loads

the recorded signal, and opens the corresponding help file in a separate win-
dow.

5. Read the Demo help file to learn about the recorded signal and the VSA setup
information.

6. To start the measurement, click the Restart button ( ) in the tool bar or click
Control > Restart.
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VSA Security, Advisories and Vulnerabilities
This section contains important information relating to keeping test environments
secure while using the 89600 VSA Software.

Product Information, Advisories and Reporting
Vulnerabilities

Keysight Corporate Information

https://www.keysight.com/us/en/contact.html

Keysight 89600 VSA Product Information

Use the following product information to identify product updates and security
advisories, or when reporting a vulnerability:

Product name: Keysight Pathwave Vector Signal Analysis Software
Model: 89601C
Version: 2025
URL on Keysight.com:
https://www.keysight.com/us/en/products/software/pathwave-test-
software/89600-vsa-software.html

Keysight Responsible Disclosure Program

https://www.keysight.com/us/en/contact/responsible-disclosure-program.html

Keysight Security Advisories

https://www.keysight.com/us/en/about/quality-and-security/security/product-and-
solution-cyber-security.html

Reporting Security Vulnerabilities

https://www.keysight.com/us/en/about/quality-and-security/security/product-and-
solution-cyber-security/report-a-product-cybersecurity-issue.html

Securing the VSA Software
Agilent.SA.Vsa.Vector-x64.exe may host many services listening on various ports
and bound to various interfaces. The user should take necessary means to
implement firewall rules to secure these services.

SCPI Services

The user may enable a SCPI service using HiSLIP, Telnet, or Socket protocols;
HiSLIP connections go through HppSupportService.exe but Telnet and Socket
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services are hosted by Agilent.SA.Vsa.Vector-x64.exe.
The Telnet and Socket services listen on configurable ports defaulting to 5024 and
5025 respectively, bound to all IPv4 and IPv6 interfaces. Access configuration
through VSA's SCPI Preferences: Utilities → SCPI Preferences.

.NET API Services

VSA's API is accessible to both .NET Framework clients through VSA's .NET
Remoting service as well as modern .NET clients through VSA's .NET Client access
service.
The .NET Remoting service listens on the first available port from the range 60189,
60190, … or a configured port number. The service is bound to all IPv4 interfaces.
Configure using command line argument: -port:<port>; the service supports core
functionality and cannot be disabled. See the VSA Help for more information.
The .NET Client access service listens on the first available port from the range
59189, 59190, … or a configured port number. The service is bound to all IPv4 and
IPv6 interfaces or a configured host address. Configure using command line
argument: -serveraddress:<host[:port]>; enable and disable through VSA's Startup
Preferences: Utilities → Startup Preferences. See the VSA Help for more
information.

Hardware Connectivity Services

Some hardware connectivity features enable connectivity services upon utilizing the
feature.
A Vita49 stream listener service listens on any port and interface specified. The
service is hosted by Agilent.SA.Vsa.Vector-x64.exe. Add a stream listener through
VSA's Instrument Manager: Utilities → Hardware → Instrument Manager → Add
new instrument → Custom LAN → Custom Model: Vita49.

Other VSA Services

VSA listens on port 8070 bound to the IPv4 loopback interface for core functionality.

Other Keysight Components' Services

Agilent.SA.Vsa.Vector-x64.exe installs with, or is likely to be installed with other
Keysight components which may host their own services. Users are likely to use port
4880, a HiSLIP service hosted by HppSupportService.exe and bound to all IPv4
and IPv6 interfaces. Other components include:

agileesofd.exe
AgilentLicenseService.exe
HppSupportService.exe
KeysightCommunicationsFabric.exe
LxiMdnsResponder.exe
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Securing VSA — Other Considerations

VSA is not intended to run as administrator or with elevated privileges; run VSA
under an ordinary user account.

36 89600 Software Quick Start Guide


	In This Book
	Other Documentation

	Overview
	89600 Software
	Licensing
	Keysight 89600 Software Operating Configurations
	Installation and Configuration Process

	Configuring Remote PC
	Configuration Steps

	Installing 89600 Software
	Installing 89600 Software in a PC
	Installing or Updating Keysight IO Libraries for Keysight 89600 VSA

	Installing 89600 Software in a Keysight X-Series Signal Analyzer
	Installing 89600 Software in a Keysight Infiniium Scope
	Installing 89600 Software in a Keysight Logic Analyzer

	Installing Licenses
	Transportable License
	Redeeming a transportable license
	Installing a transportable license


	Using the VSA Online Help and Demos
	Accessing Help
	Help menu
	Dynamic help
	Help button on dialogs
	F1 on the keyboard

	Recalling a Demo Signal Package

	VSA Security, Advisories and Vulnerabilities
	Product Information, Advisories and Reporting Vulnerabilities
	Keysight Corporate Information
	Keysight 89600 VSA Product Information
	Keysight Responsible Disclosure Program
	Keysight Security Advisories
	Reporting Security Vulnerabilities

	Securing the VSA Software
	SCPI Services
	.NET API Services
	Hardware Connectivity Services
	Other VSA Services
	Other Keysight Components' Services
	Securing VSA — Other Considerations



