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Where to Find the Latest Information

Documentation is updated periodically. For the latest information about this product, including instrument 
software upgrades, application information, and product information, browse to the following URL:

https://www.keysight.com/find/m9384b

To receive the latest updates by email, subscribe to Keysight Email Updates at the following URL:

http://www.keysight.com/find/MyKeysight

Information on preventing instrument damage can be found at:

http://keysight.com/find/PreventingInstrumentRepair

Is your product software up-to-date?

Periodically, Keysight releases software updates to fix known defects and incorporate product enhancements. 
To search for software updates for your product, go to the Keysight Technical Support website at:

http://www.keysight.com/find/techsupport

http://www.keysight.com/find/MyKeysight
https://www.keysight.com/find/emailupdates
https://www.keysight.com/find/emailupdates
http://www.keysight.com/find/MyKeysight
http://www.keysight.com/find/PreventingInstrumentRepair
http://www.keysight.com/find/techsupport
http://keysight.com/find/PreventingInstrumentRepair
http://keysight.com/find/PreventingInstrumentRepair
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Basic Measurements
Overview

Overview
The M9383B/M9384B signal generators provides frequency coverage from 
1 MHz to 44 GHz, with up to 2 GHz RF modulation bandwidth with an internal 
baseband generator, and over 2 GHz RF modulation bandwidth with external 
I/Q inputs. 

The measurement examples use an X-Series Signal Analyzer to view the 
results. A few measurement examples require an N9040B/42B signal analyzer 
and is called out in those specific measurement examples. For information on 
using the X-Series Signal Analyzer multi-touch user interface, refer to the 
Online Help.

Please refer to the VXG data sheet and X-Series Signal Analyzer data sheet to 
ensure your measurement setup has adequate power. 

http://literature.cdn.keysight.com/litweb/pdf/5992-4260EN.pdf

and

http://literature.cdn.keysight.com/litweb/pdf/5992-0090EN.pdf

The software versions used in this measurement guide are:

— VXG: A.11.01

— X-Series Spectrum Analyzers/N9085EM0E: A.34.xx or later

— 89601 VSA: Version 2023 or later
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Basic Measurements
Configuring the Equipment Setup

Configuring the Equipment Setup

Cables and Connections for the M9383B

— M9323A front panel RF Out to X-Series Signal Analyzer front panel RF In

— M9343A front panel Trig 1 to X-Series Signal Analyzer rear panel Trig 3 In

Trig 3 In is for an N9040B with Option H1G (1 GHz Bandwidth). For X-Series 
Signal Analyzer with Bandwidth of less than 510 MHz, use Trig 1 In.

— M9383B rear panel 10 MHz Ref Out to X-Series Signal Analyzer rear panel 
Ext Ref In
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Basic Measurements
Configuring the Equipment Setup

Equipment Setup
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Basic Measurements
Configuring the Equipment Setup

Cables and Connections for the M9384B

— M9384B front panel RF 1 Out to X-Series Signal Analyzer front panel RF In

— M9384B rear panel SYNC Out to X-Series Signal Analyzer rear panel Trig 3 
In

Trig 3 In is for anN9040B with Option H1G (1 GHz Bandwidth). For X-Series 
Signal Analyzer with Bandwidth of less than 510 MHz, use Trig 1 In.

— M9384B rear panel 10 MHz Ref Out to X-Series Signal Analyzer rear panel 
Ext Ref In
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Basic Measurements
Configuring the Equipment Setup

Equipment Setup
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Basic Measurements
Configuring the Equipment Setup

Setting Up Triggers on the X-Series Signal Analyzer

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > Spectrum Analyzer mode. 

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. From the dropdown on the top right, select Trigger and set Trigger Source 
to Free Run. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Basic Measurements
Making Measurements

Making Measurements

Creating a Continuous Waveform (CW)

This procedure will demonstrate the amplitude and frequency accuracy of the 
VXG at RF and µW frequencies.

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output area, set Frequency to 1 GHz and Power to 0 dBm.

These values are coupled to CW Frequency and Total Power (RMS) in the 
corresponding RF Output Block.

3. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

4. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

Ensure the equipment and triggers are properly configured. Refer to 
“Configuring the Equipment Setup” on page 9 and “Setting Up Triggers on 
the X-Series Signal Analyzer” on page 13. 

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.
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Basic Measurements
Making Measurements

2. From the Menu Panel, select Frequency and set Center Frequency to 
1 GHz and Span to 1 MHz.

3. Select Peak Search.

Observe the accuracy of the amplitude and frequency of the signal.

On the VXG:

1. Set Output 1 Power to –90 dBm.

2. Ensure that RF Out is On.

On the X-Series Signal Analyzer: 

1. Select Amplitude and set Ref Level to –70 dBm and Scale/Div 5 dB.

2. Select BW and set Video BW to 300 Hz.

3. Select Peak Search. 
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Basic Measurements
Making Measurements

Observe the frequency and amplitude accuracy of the VXG at low power 
levels.

On the VXG:

1. Set Frequency to 44 GHz and Power to 0 dBm.

On the X-Series Signal Analyzer:

1. Select Frequency and set Center Frequency to 44 GHz.

2. Select Amplitude and set Ref Level to 0 dBm and Scale/Div to 
10 dB. 

3. Select BW > Video BW and set to Auto.

4. Select Peak Search.
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Basic Measurements
Making Measurements

Observe the frequency and amplitude accuracy at high frequency levels.
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Basic Measurements
Making Measurements

Using the equivalent SCPI commands

Creating a CW signal on Channel 1.

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude 0dBm

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

SYSTem:PRESet

FREQuency:CENTer 1GHZ

FREQuency:SPAN 1MHZ

CALCulate:MARKer1:MAXimum

On the VXG:

RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude -90dBm

RF1:OUTPut:STATe ON

On the X-Series Signal Analyzer:

DISPlay:WINDow1:TRACe:Y:RLEVel -70

DISPlay:WINDow1:TRACe:Y:PDIVision 5

BWIDth:VIDeo 300Hz

CALCulate:MARKer1:MAXimum

On the VXG:

RF1:FREQuency:CW 44GHZ

RF1:POWer:AMPLitude 0dBm

On the X-Series Signal Analyzer:

FREQuency:CENTer 44GHZ

DISPlay:WINDow1:TRACe:Y:RLEVel 0

DISPlay:WINDow1:TRACe:Y:PDIVision 10

BANDwidth:VIDeo:AUTO ON
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Basic Measurements
Making Measurements

CALCulate:MARKer1:MAXimum

Setting Up Amplitude Modulation 

Follow the steps below for AM analog modulation using the internal or an 
external I/Q modulation source.

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

4. From the Mode dropdown, select Analog Modulation.

5. In the Analog Modulation Signal Setup:

a. Set Modulation Type to AM.

b. Set Waveform to Sine.

c. Set Rate to 100 kHz.

d. Set Depth to 50%.

Ensure the equipment and triggers are properly configured. Refer to “Configuring the 
Equipment Setup” on page 9 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.
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Basic Measurements
Making Measurements

e. Select Enable Vector Modulation Signal.

Selecting Enable automatically turns on both Output Modulation and 
Internal I/Q Modulation as displayed in the Output Modulation block.

6. Close the Vector Modulation Signal Setup by either selecting the Back 
button or the Home icon at the top of the display.

7. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to 
500 kHz.
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Basic Measurements
Making Measurements

3. Select BW and set Res BW to 100 Hz.

4. Select Peak Search.

5. Use markers to measure sideband power relative to the center frequency 
by selecting Marker Delta. Select Next Pk Right until the second marker is 
at the next highest peak. 

The Delta Marker should be approximately –12 dB for 50% AM. 
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Basic Measurements
Making Measurements

Using the equivalent SCPI commands

On The VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal:MODE AMODulation

SIGNal1:AMODulation:TYPE AM

SIGNal1:AM:SHAPe SINE

SIGNal1:AM:FREQuency 100KHZ

SIGNal1:AM 50

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

SYSTem:PRESet

FREQuency:CENTer 20GHZ

FREQuency:SPAN 500KHZ

BANDwidth 100 Hz

CALCulate:MARKer1:MODE DELTa

CALCulate:MARKer1:MAXimum:RIGHt

Repeat the above command until the marker is at the next highest peak.

To retrieve the delta marker:

CALCulate:MARKer1:Y?
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Basic Measurements
Making Measurements

Setting Up Frequency Modulation

Follow the steps below for FM analog modulation using the internal or an 
external I/Q modulation source.

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

4. Select the Mode dropdown and select Analog Modulation.

5. In the Analog Modulation Signal Setup:

a. Set Modulation Type to FM.

b. Set Waveform to Sine.

c. Set Rate to 400 Hz.

d. Set Deviation to 10 MHz.

Ensure the equipment and triggers are properly configured. Refer to “Configuring the 
Equipment Setup” on page 9 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.
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Basic Measurements
Making Measurements

e. Select Enable Vector Modulation Signal

6. Close the Vector Modulation Signal Setup by either selecting the Back 
button or the Home icon at the top of the display.

7. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to 
50 MHz.
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Basic Measurements
Making Measurements

3. Select BW and set Res BW to 240 Hz.
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Basic Measurements
Making Measurements

Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal:MODE AMODulation

SIGNal1:AMODulation:TYPE FM

SIGNal1:FM:SHAPe SINE

SIGNal1:FM:FREQuency 400HZ

SIGNal1:FM 10MHZ

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

SYSTem:PRESet

FREQuency:CENTer 20GHZ

FREQuency:SPAN 50MHZ

BANDwidth 240 Hz
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Basic Measurements
Making Measurements

Setting Up Phase Modulation

Follow the steps below for PM analog modulation using the internal or an 
external I/Q modulation source.

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block to open.

4. Select the Mode dropdown and select Analog Modulation.

5. In the Analog Modulation Signal Setup:

a. Set Modulation Type to PM.

b. Set Waveform to Sine.

c. Set Rate to 10 kHz.

d. Set Deviation to 1 rad.

Ensure the equipment and triggers are properly configured. Refer to “Configuring the 
Equipment Setup” on page 9 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.
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Basic Measurements
Making Measurements

e. Select Enable Vector Modulation Signal.

6. Close the Signal Setup by either selecting the Back icon or Home icon at 
the top of the display.

7. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Analog Demod mode > PM Measurement > Quad View.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. Select Frequency and set Center Frequency to 20 GHz.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Basic Measurements
Making Measurements

Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal:MODE AMODulation

SIGNal1:AMODulation:TYPE PM

SIGNal1:PM:SHAPe SINE

SIGNal1:PM:FREQuency 10KHZ

SIGNal1:PM 1

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:CONFigure:ADEMOD:PM

SYSTem:PRESet

DISPlay:VIEW:ADVanced:SELect "QUAD"

FREQuency:CENTer 20GHZ
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Basic Measurements
Making Measurements

Setting Up Synchronized Pulse (IQ + Analog) Modulation

You will need to create your own ASCII text marker file and a binary file with 
the exact same name. Both files must be stored in the same file folder. For this 
example, we will use example files that have been stored on the VXG.

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set the Frequency to 1 GHz and Power to 0.0 dBm.

3. Select the Signal block to open.

Ensure the equipment and triggers are properly configured. Refer to “Configuring the 
Equipment Setup” on page 9 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.
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Basic Measurements
Making Measurements

4. Set the Mode to Single Tone.

5. Close the Signal Setup by either selecting the Back or Home icon at the 
top of the display.

6. Open the Output Modulation block and select I/Q modulation and open 
the setup dialog.

7. Under I/Q DC Alignment, select Perform Alignment.

The I/Q DC alignment will take just a moment to run. When done, IQ DC 
Alignment done is displayed in the Notifications area at the bottom of 
the display. 
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Basic Measurements
Making Measurements

Performing an I/Q DC alignment helps optimize the  depth of modulation 
of the IQ pulse.  This needs to be done at every frequency change.

8. Close the Output Modulation block by selecting the Home icon.

9.  Select the Signal block to open.

10. Select the Vector Modulation Signal Mode dropdown and select 
Waveform File.
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11. In the Waveform Playback Setup area, use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
4000_SampleQPulseOnOff_50%_wfm.csv

then Select.

12. Set the Sample Rate to 2 kHz. 
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13. Select the Markers block and set Sync to None and RF Blanking to 
Marker 1. Select the Back icon (<-to close the Markers Setup. 

14. Select Enable Vector Modulation Signal.

15. Ensure that RF Out is on for channel 1.

On the X-Series Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Spectrum Analyzer mode > Swept SA Measurement > Normal View.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. Select Frequency and set Center Frequency to 1.0 GHz and Span to 0 Hz.

4. Select BW and set the Video BW to 300 Hz.

5. Select Sweep and set the Sweep Time to 4.0 s.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Setting Up an Multitone Signal

This example shows you how to create a multitone signal, which allows you to 
separate the usable frequency band into multiple channels. This can make a 
signal that is difficult to characterize in the time domain more readable.

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to -10 dBm.

3. Select the Signal block to open.

4. Set the Mode to Multitone.

5. In the Analog Modulation Signal Setup:

a. Set Tones to 15

b. Set Tone Spacing to 500 kHz.

c. Select Enable Vector Modulation Signal

6. Ensure that RF Out is On for channel 1.

Ensure the equipment and triggers are properly configured. Refer to “Configuring the 
Equipment Setup” on page 9 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.
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On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to 
10 MHz.

3. Select BW and set Res BW to 300 Hz.

Observe the 15 tones.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude -10dBm

SIGNal1:MODE MTONes

SIGNal1:MTONe:ARB:NTON 15

SIGNal1:MTONe:ARB:FSP 500KHZ

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:CONFigure:SA:SAN

SYSTem:PRESet

DISPlay:VIEW:ADVanced:SELect “NORMAL”

FREQuency:CENTer 20GHZ

FREQuency:SPAN 10MHZ

BANDwidth 300 Hz
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Setting Up Waveform File Vector Modulation

In this section, we will load a GSM and a LTE waveform into the VXG to 
demonstrate the accuracy of the VXG’s vector modulation using error vector 
magnitude (EVM) measurement applications available on the X-Series Signal 
Analyzer.

The VXG supports all ARB waveforms that are provided on the X-Series 
sources. This section will use a few of the ARB files that come with the X-Series 
sources.

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block to open.

4. Set the Mode to Waveform File.

5. Select the Markers block and set Sync to Marker 2 and then select Back to 
close the Markers Setup.

Ensure the equipment and triggers are properly configured. Refer to “Configuring the 
Equipment Setup” on page 9 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.
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6. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

7. Highlight GSM_1C_Burst.WFM, then Select. 

8. Select Enable Vector Modulation Signal.

9. Ensure that RF Out is on for channel 1.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to 
900 kHz.

3. Select BW and set Res BW to 470 Hz.

4. Select Trace and set Trace Type to Max Hold.

5. Observe the GSM signal. 
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On the VXG:

1. Select the Signal block to open.

2. Use File Select to navigate to: 
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

3. Set the file extension to All Files (*.*), highlight 
WDCMA_TM1_64DPCH_4C.WFM, then Select. 

4. Ensure that Enable Vector Modulation Signal is selected.

5. Ensure that RF Out is on for channel 1.

On the X-Series Signal Analyzer:

1. Select BW and set Res BW to 620 Hz.



M9383B/84B Measurement Guide                                                                                                                       43

Basic Measurements
Making Measurements

2. Select Frequency and set Span to 30 MHz.

3. Observe the LTE signal.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform:TRIGger:SYNC:MARKer M2

SIGNal1:WAV 
"D:\Users\Instrument\Documents\Keysight\PathWave\SignalGener
ator\Examples\GSM_1C_BURST_SECUREWAVE.wfm"

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

FREQuency:CENTer 20GHZ

FREQuency:SPAN 900KHZ

BANDwidth 470 Hz

DISPlay:TXPower:WINDow1:TRACe:MAXHold ON

On the VXG:

SIGN1:WAV 
"D:\Users\Instrument\Documents\Keysight\PathWave\SignalGener
ator\Examples\WCDMA_TM1_64DPCH_4C.wfm"

SIGNal1 ON

RF1:OUTPut:STATe ON

On the X-Series Signal Analyzer:

BANDwidth 620 Hz

FREQuency:SPAN 30MHZ
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Corrections/De-embedding Using PathWave N7653APPC Software

De-embedding is used to remove the effects of the test fixtures and cables 
from the measurement results. De-embedding uses a model of the test fixture 
and mathematically removes the fixture characteristics (cables, connectors 
and other passive components) between the source and the device under test 
(DUT). Once the desired topology has been characterized, its effects can be 
removed from the output signal, moving the effective reference plane to the 
point at which the power sensor was connected. 

Blocks can be added from supported file formats (.s2p, .csv, .uflat) or by direct 
measurement, using one of the supported power sensors (power meter, 
spectrum analyzer, or a network analyzer). 

Adding Fixture Blocks using s2p Files

Amplitude and phase can be corrected by adding multiple s2p files as Fixture 
Blocks. 

An s2p file (also known as a Touchstone file) is an ASCII text file used for 
documenting the n-port network parameter data and noise data of linear 
active devices, passive filters, passive devices, or interconnect networks. Each 
record contains 1 stimulus value and 4 S-parameters (total of 9 values)

The first line in the figure below (# GHz DB R 50) designates:

— (GHz) designates the frequency in Hz, kHz, MHz, or GHz

— (S) the measurements are in S parameters (rather than Y or Z)

— (DB) the values are given in decibel/angle. Instead of DB, you can have RI 
(real/imaginary) or MA (magnitude/angle)

— (50) the characteristic impedance is 50 ohms

1. Create s2p files in Notepad in the format shown above.

The VXG must have the N7653APPC PathWave Automatic Channel 
Response Correction and S-parameter De-embedding license installed.

If there is not a first line header, the default format is GHz, S-parameters, 
and magnitude/angle.
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TIP An s2p example file is included on the VXG. Go to 

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\simpleAt10GHzInDB.s2p

2. Select Preset > Preset to set the instrument to a known state.

3. In the VXG Output area, set the Frequency to 10 GHz and Power to 
–10 dBm. 

4. Select the Signal Block and set:

—  Mode to Multitone

— Tones to 21

— Tone Spacing to 100 MHz

— Select Enable Vector Modulation Signal

5. Close the Signal block by selecting the Back (<-) icon, and then select RF 
Out to turn on for channel 1.

6. On the X-Series Signal Analyzer spectrum analyzer in Spectrum Analyzer 
Mode:

— Preset the spectrum analyzer

— Set the Center to 10 GHz
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— Set the Span to 3 GHz

7. On the VXG, select the RF Output block > Corrections De-embedding.
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8. In the Corrections Setup dialog, select Add from File.

9. Navigate and select the s2p file and then Select. 
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\simpleAt10GHzInDB.s2p

Notice that Block B is added in the Correction Setup diagram.
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10.Turn Corrections On. View the results on the signal analyzer and observe 
how the .s2p file has impacted the signal.

11. Add a third block using the same file name as shown in the steps above. V 
Select Embed from the Apply drop down menu to set Block C Properties to 
Embed.
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View the results on the X-Series spectrum analyzer. Notice that the 
corrections are no longer shown. This is because the de-embedded 
corrections applied in Block B cancel the embedded corrections applied in 
Block C.

Using a Spectrum Analyzer to Make the Corrections Measurement

When using a spectrum analyzer, it must be locked to the VXG Frequency 
Reference. This is important because the power measurement can be 
inaccurate due to a narrow resolution bandwidth (RBW) used in the spectrum 
analyzer. Supported Keysight X-Series signal analyzers are:

— N9000A/B CXA

— N9010A/B EXA

— N9020A/B MXA

— N9030A/B PXA

— X-Series Signal Analyzer and N9041B UXA

— M90XA

Using the Graphical User Interface

On the VXG:

1. Connect the VXG 10 MHz Out to the N90x0A/B Ext Reference In. 

2. Connect cable or DUT between the VXG RF Out and the signal analyzer RF 
in.
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3. Select Preset > Preset to set the instrument to a known state.

4. Set the Frequency to 12 GHz and Amplitude to –10 dBm.

5. Select the Signal block and change the Mode from Waveform File to 
Multitone.

6. Configure the signal to have 501 Tones with 4 MHz Tone Spacing, then 
select Enable.

7. Close the Signal block and select  to turn on Channel 1’s RF Out.

On the signal analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Spectrum Analyzer mode > Occupied BW Measurement > OBW Results 
View.

2. Set the Center Frequency to 12 GHz and the Span to 3 GHz.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 



52                                                                                                                        M9383B/84B Measurement Guide

Basic Measurements
Making Measurements

Observe how the fixturing is impacting this signal, including the flatness 
and the total power.
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On the VXG:

1. Select the RF Output block > Corrections/De-embedding block to open 
the Correction Setup.

2. Select Add from Measurement to open the Measure Corrections Block 
Wizard. 
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3. Connect the power sensor (in this case, the X-Series signal analyzer) as 
shown in the diagram below. After reading the overview, select Next to 
move to the Configure Sensor setup.

4. In the Configure Sensor setup, select the Power Measurement Device 
dropdown and select Spectrum Analyzer.

5. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this 
example Start Freq 11 GHz, Stop Freq 13 GHz, Amplitude to the highest 
power used in your measurement (For this example, -10 dBm, which we 
already set in the main window. If you change the value here, it will update 
the value in the main measurement window.) and Num Steps to 101.
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6. Set Connection Type to LAN, enter the LAN Address and set the Protocol 
parameters to HiSLIP, and then select Test Connection. 

7. Once you are successfully connected, select Next to move to the Measure 
Corrections step.

8. Select Measure Correction Data. 

During the measurement, the VXG outputs a CW between the Start and 
Stop Frequencies for the specified number of steps and output power. It 
will take some time to measure all 101 points, and the progress is 
indicated by the blue bar. You can watch the signal analyzer as it steps 
through this process.
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The measurement results are saved to a csv file using an automatically 
generated file name. 

9. When the measurement is complete, select Finish, then select Corrections 
On.

The output csv file is set to Block A.

Block A is dedicated for User Correction. The image below shows how 
blocks are assigned in the User Correction and Fixture block.

10. On the signal analyzer, select Restart from the top left of the UI to Restart 
the measurement (because it is applying averaging). Observe how the 
measured corrections impacted the signal. You can easily toggle 
Corrections on and off on the VXG to see the difference. 
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Using a Power Meter to Make the Corrections Measurement

A power meter can also be used at the power measurement device. The 
following USB power sensors are supported:

— U8487A-CFG007

— U8485A-CFG006

— U2000A

— U2001A

— U2002A

— U2004A

— U2000B

— U2001B

— U2000H

— U2001H

— U2002H

Using the graphical user interface

On the VXG:

1. Connect the VXG 10 MHz Out to the N90x0A/B Ext Reference In.

2. Select the RF Output block > Corrections/De-embedding block to open 
the Correction Setup.
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3. Select Add from Measurement to open the Measure Corrections Block 
Wizard. 

4. Connect the power sensor as shown in the diagram below then select 
Next.
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5. Select Next to go to Configure Sensor dialog and select the Power 
Measurement Device dropdown > Power Meter.

6. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this 
example Start Freq 26 GHz, Stop Freq 30 GHz, Amplitude to the highest 
power used in your measurement 5 dBm, and Num Steps to 20.

7. Select the Connection Type to USB, and then specify the Device and VISA 
Address. 

8. Select Test Connection to verify connectivity, and then select OK then 
Next to continue.

You can also calibrate and zero out the power sensor before measuring 
corrections.
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9.  Select Next to go to the Measure Corrections dialog and select Measure 
Correction Data. 

During the measurement, the VXG outputs a CW between the Start and 
Stop Frequencies for the specified number of steps and output power. The 
measurement results are saved to a csv file using an automatically 
generated file name. 

10. Select Finish. The output csv file is set to Block A.
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Block A is dedicated for User Correction. The image below shows how 
blocks are assigned in the User Correction and Fixture block.

11. Select Corrections On to apply.
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Using the equivalent SCPI commands

Using a spectrum analyzer to make the corrections measurement

On the VXG:

SYSTem:PRESet

Set the power level to the highest level used in your 
measurement.

RF1:POWer:AMPLitude 5dBm

CORRection:PMDevice SANalyzer

CORRection:FLATness:STEP:STARt 26GHZ

CORRection:FLATness:STEP:STOP 30GHZ

CORRection:FLATness:STEP:POINts 20

CORRection:SANalyzer:COMMunicate:TYPE SOCKets

Set the LAN address and protocol parameters for your spectrum analyzer.

CORRection:SANalyzer:COMMunicate:LAN:IP "192.168.1.5"

CORRection:SANalyzer:COMMunicate:LAN:PORT 5025

CORRection:FLATness:CALibrate

Wait for the measurement to complete.

CORRection ON
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Using a power meter to make the corrections measurement.

On the VXG:

SYSTem:PRESet

RF1:POWer:AMPLitude 5dBm

CORRection:PMDevice PMETer

CORRection:FLATness:STEP:STARt 26GHZ

CORRection:FLATness:STEP:STOP 30GHZ

CORRection:FLATness:STEP:POINts 20

CORRection:SANalyzer:COMMunicate:TYPE USB

CORRection:PMETer:COMMunicate:USB:DEVice “instr0”

[Optional] CORRection:PMETer:CALibrate 

[Optional] CORRection:PMETer:ZERO 

CORRection:FLATness:CALibrate

CORRection ON

Use query CORRection:PMETer:COMMunicate:USB:LIST? for a list of all connected USB devices. 
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Adding fixture blocks using s2P files

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 10GHZ

RF1:POWer:AMPLitude -20dBm

SIGNal1:MODE MTONe

SIGNal1:MTONe:ARB:NTON 21

SIGNal1:MTONe:ARB:FSP 100MHZ

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

SYSTem:PRESet

FREQuency:CENTer 10GHZ

FREQuency:SPAN 3GHZ

On the VXG:
Set the path to the s2p data as block 2 (you can use 1 through 4).

CORRection:BLOCk2:FILE "FixtureChannel2"

CORRection:BLOCk2 ON

Add block C with the same file.

CORRection:BLOCk3:FILE "FixtureChannel2"

Change Block C to Embed.

CORRection:BLOCk3:APPLy EMBedding

CORRection:BLOCk3 ON
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Instrument Nonlinear Correction

Instrument Nonlinear Correction (INC) is a digital pre-distortion (DPD) based 
correction using a Keysight signal analyzer (N9042B, N9040B, or N9030B) to 
compensate for nonlinearities in the VXG. INC is useful in reducing EVM (and 
other metrics impacted distortion) at high power levels and extending the 
range of the power with linear output of the VXG. INC is a point correction valid 
for a given frequency/power/waveform combination and can be used for EVM 
and ACP measurements at high power levels (>5 dB). The VXG must have the 
N7653APPC PathWave automatic channel response correction and 
S-parameter de-embedding license installed. You must have firmware version 
A.07.01 or greater to use this feature.

Instrument nonlinear corrections compensate for nonlinearities in the VXG. 
Improvement to EVM will only be seen at power levels where distortion is the 
limiting factor. INC will not improve EVM in the area where signal to noise ratio 
(SNR) is the limiting factor.

Setting Up an INC 1CC 4 GHz, 10 dBm EVM Measurement

On the VXG:

In order to compare before and after correction results, we will start by making 
an EVM measurement without applying corrections.

1. Select Preset > Preset to set the instrument to a know state.

2. In the Output area, set Frequency to 4 GHz and Power to 
10 dBm.

3. Select the Signal block to open the Vector Modulation Signal Setup panel.
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4. In the Vector Modulation Setup, set Mode to Waveform File.

5. In the Waveform Playback Setup area, use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
5G_100MHz_1cc_FR1.wfm

then Select.
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6. Select Enable Vector Modulation Signal.

7. Set RF Out to On for channel 1. 

On the UXA:

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > 5GNR Mode > Modulation Analysis 
Measurement > OK. 

2. Select Mode Preset to set Spectrum Analyzer 5GNR mode to a known 
state.

3. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > 5GNR Mode > Modulation Analysis 
Measurement > OK. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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4. Select Recall (If accessing the X-Series Signal Analyzer remotely, select 
the Folder icon at the bottom of the display) Demod Info > Data Type set 
to CC Setup > Recall From > 

Signal Studio_5G_100 MHz_1CC_FR1.scp 

Recall

5. The Signal Stuidio_5G_100 MHz_1CC_FR1.scp file should automatically 
set the Carrier Frequency to 4 GHz. If not, got to Frequency > Carrier 
Reference Frequency > 4 GHz. 
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6. From the Main menu, select Meas Setup > Advanced tab > Advanced 
Demod Setup and set DC Punctured to On, then Close the Advanced 
Demod Setup window.

7. In the Meas Setup window, select the Settings tab > Optimize EVM.

Record the results. For this example EVM is 0.61% and EVM Peak is 2.42%

To Measure ACP:

a. Select Mode/Meas > 5GNR Mode > ACP > OK. 

b. Select Amplitude > Signal Path tab > and set µW Path Control to 
Low Noise Path Enable.
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Record the results for the Lower and Upper ACP results. For this 
example -50.9 dBc (lower) and -50.9 (upper).

c. Select Mode/Meas > 5GNR Mode > Modulation Analysis > OK. 

On the VXG:

1. Open the Signal block and select Configure to open the Nonlinear 
Correction Setup. 
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2. In the Instrument Nonlinear Correction area, select Measure Correction to 
open the Instrument Nonlinear Calibration screen.

3. Under the Receiver tab (opened by default), enter your connection 
information and test the connection. For this example, select LAN as the 
Connection Type > Enter the IP address for you signal analyzer (for this 
example, 141.121.149.32) as the Hostname > Test Connection. 
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The Connection status will be displayed in the Notifications area at the 
bottom of the main window.

4. Select the Calibrations tab and select EVM and ACP for the Calibrations, 
then Start Calibration.
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The calibration will take a few minutes to complete. Once done, the INC 
file will be created and it will automatically be used in place of the .wfm 
file originally loaded. An "I" will be displayed in the Signal block indicating 
this status.

On the UXA:

1. Select Optimize EVM.
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Note the changes to EVM RMS and EVM Peak values. For this example 
EVM RMS is 0.27% (before 0.61%) and EVM Peak is 2.64% (before 2.42%).

To Measure ACP:

a. Select Mode/Meas > 5GNR Mode > ACP > OK. 

b. Select Amplitude > Signal Path tab > and set µW Path Control to 
LNP (Low Noise Path) Enable.
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Note the changes to the Lower and Upper ACP values. For this 
example Lower -58.67 dBc (before -50.9 dBc) and Upper 
-57.85 dBc (before -50.9).

Setting Up an INC 8CC 28 GHz, 10 dBm EVM Measurement

On the VXG:

In order to compare before and after correction results, we will start by making 
an EVM measurement without applying corrections.

1. Select Preset > Preset to set the instrument to a know state.

2. In the Output area, set Frequency to 28 GHz and Power to 
10 dBm.

3. Select the Signal block to open the Vector Modulation Signal Setup panel.
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4. In the Vector Modulation Setup, set Mode to Waveform File.

5. In the Waveform Playback Setup area, use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
5G_100MHz_8cc_FR2.wfm

then Select.

6. Select Enable Vector Modulation Signal and close the Signal block.

7. Set RF Out to On. 
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On the UXA:

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > 5GNR Mode > OK. 

2. Select Mode Preset to set Spectrum Analyzer 5GNR mode to a known 
state.

3. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > 5GNR Mode > Modulation Analysis 
Measurement > OK. 

4. Select Recall (If accessing the X-Series Signal Analyzer remotely, select 
the Folder icon at the bottom of the display) Demod Info > Set Data Type 
to CC Setup > Recall From > 

5G_100 MHz_8CC_FR2.scp 

Recall

5. The .scp file should automatically set the Carrier Frequency to 28 GHz. If 
not, got to Frequency > Carrier Reference Frequency > 28 GHz. 

6. Select Meas Setup > Advanced tab > Advanced Demod Setup and set DC 
Punctured to On, then Close the Advanced Demod Setup window.

7. Select the Sweep > Single Sweep.

8. Select Meas Setup > Settings tab > Optimize EVM. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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It will take a couple of minutes for the UXA to measure all 8 carriers.

Record the results. 

For this example CC0 EVM RMS is 6.21%, EVM Peak is 27.33% and for CC7 
EVM RMS is 4.51% and EVM Peak is 15.75%

To Measure ACP:

a. Select Mode/Meas > 5GNR Mode > ACP > OK. 

b. Select Amplitude > Signal Path tab > and set µW Path Control to 
LNP (Low Noise Path) Enable.

c. Select Sweep > Restart to take a new sweep.
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Note the values of the Lower and Upper ACP. For this example 
Lower, at 100 MHz offset is -26.7 dBc and Upper 
-27.06 dBc.

d. Select Mode/Meas > 5GNR Mode > Modulation Analysis > OK. 
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On the VXG:

1. In the Signal block and select Configure to open the Nonlinear Correction 
Setup. 

2. In the Instrument Nonlinear Correction area, select Measure Correction to 
open the Instrument Nonlinear Calibration screen.

3. Under the Receiver tab (opened by default), enter your connection 
information and test the connection. For this example, select LAN as the 
Connection Type > Enter the IP address for you signal analyzer (for this 
example, 141.121.149.32) as the Hostname > Test Connection. 
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The Connection status will be displayed in the Notifications area at the 
bottom of the main window.

4. Select the Calibrations tab and select EVM and ACP for the Calibrations, 
then Start Calibration.
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The calibration will take a few minutes to complete. Once done, the INC 
file will be created and it will automatically be used in place of the .wfm 
file originally loaded. An "I" will be displayed in the Signal block indicating 
this status.

On the UXA:

1. Select the Sweep > Restart.

2. Select Optimize EVM.

Note the changes to EVM RMS and EVM Peak values..

For this example CC0 EVM RMS went from 6.21% to 3.13%, EVM Peak 
went from 27.33% to 11.68% and for CC7 EVM RMS went from 4.51% to 
2.87% and EVM Peak went from 15.75% to 10.55%.

To Measure ACP:

a. Select Mode/Meas > 5GNR Mode > ACP > OK. 

b. Select Amplitude > Signal Path tab > and set µW Path Control to 
LNP (Low Noise Path) Enable.
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c. Select Sweep > Restart to take a new sweep.

Note the changes to the Lower and Upper ACP values. For this 
example Lower, at 100 MHz offset is -32.27 (before -26.7 dBc) and 
Upper -31.15 (before -27.06 dBc).
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2 5G New Radio (NR) Measurements using X-Apps

This section includes the following topics:

— “5G Waveform, EVM, and ACP Analysis Using X-Applications” on page 86

— “Setting Up Triggers on the Signal Analyzer using 5G NR Mode” on 
page 86

— “Setting Up a 1 CC 28 GHz EVM Measurement” on page 88

— “Setting up an 8 CC 28 GHz EVM Measurement” on page 95

— “Setting Up a 1 CC 3.5 GHz ACP Measurement” on page 103

— “Using PathWave N7631APPC to Create a Waveform File then 
Automatically Configure the Analyzer to View the Results” on 
page 107
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5G Waveform, EVM, and ACP Analysis Using X-Applications
The VXG enables 5G testing with a low error vector magnitude (EVM) at high 
frequencies. The VXG has extremely good EVM at high power levels. However, 
not all signal analyzers can capture this low value. We will use the X-Series 
Signal Analyzer UXA signal analyzer with the 5G NR X-Series application to 
observe EVM and adjacent channel power (ACP). 

Setting Up Triggers on the Signal Analyzer using 5G NR Mode

Setting Up Triggers on the X-Series Signal Analyzer

Using the graphical user interface

1. From the X-Series Signal Analyzer, select Mode/Meas > 5G NR mode. 

2. Select Mode Preset to set 5G NR mode to a known state.

3. Select Mode/Meas > 5G NR Mode > Modulation Analysis Measurement.

4.  From the Menu Panel (on the top right of the display), select Trigger and 
set Select Trigger Source to External 1 and Trigger Level to 1 V.

Refer to “Configuring the Equipment Setup” on page 9 for connecting the 
instruments and accessing the VXG SFP.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Using the equivalent SCPI commands

On the X-Series Signal Analyzer:

INSTrument:CONFigure:NR

SYSTem:PRESet

Change the current window to 5G NR Modulation Analysis Measurement Mode

INSTrument:CONFigure:NR5G:EVM

TRIGger:EVM:SOURce EXTernal1

TRIGger:EXTernal1:LEVel 1V
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Setting Up a 1 CC 28 GHz EVM Measurement 

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output 1 area, set Frequency to 28 GHz and Power to 
5 dBm.

3. Select Signal block to open.

4. Select the Markers block and set Sync to Marker 2 and then select Back 
(<-) to close the Markers Setup. 

5. In the Waveform Playback Setup area, use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave

Ensure the equipment and triggers are properly configured. Refer to 
“Configuring the Equipment Setup” on page 9 and “Setting Up Triggers on 
the Signal Analyzer using 5G NR Mode” on page 86. 
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\SignalGenerator\Examples

and choose
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DCPunctured_28GHz.wfm

then Select.

6. Select Enable to turn on the Vector Modulation Signal.

7. Close the Vector Modulation Signal Setup by either selecting the Back 
button or the Home icon at the top of the display.

8. Select the Adjustments block and select Optimize Dynamic Range with 
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW  This setting filters the system 
RF flatness correction coefficients over the instantaneous bandwidth 
indicated in the waveform header (or in the “Occupied Bandwidth” 
settings area under the Signal block > Occupied Bandwidth setting). 
This has the potential to improve EVM performance by not having to 
correct for flatness errors outside the requested bandwidth. For 
example, if RF flatness correction was done at 2 GHz, but you are 
only interested in an 800 MHz section, then applying the correction 
flatness to that portion only can improve signal to noise ratio, and 
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction -   Disabling this function 
disables the factory calibrated RF channel flatness equalizer. 
Depending on the hardware channel response, this may hurt or 
improve the EVM. This is due to the dynamic range implications as it 
relates to signal to noise ratio. The greater the RF hardware 
variations in flatness, the greater the amount of correction is 
required, the greater the correction effectively reduces the number of 
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resolution DAC bits that can be used, which degrades the signal to 
noise ratio and therefore potentially EVM. The trade-off is to balance 
between flatness and signal to noise ratio.

9.  Close the Adjustments Setup by either selecting the Back button or the 
Home icon at the top of the display.

10. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

11. For two channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.
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On the X-Series Signal Analyzer:

1. Select Recall (If accessing the X-Series Signal Analyzer remotely, select 
the Folder icon at the bottom of the display) Demod Info > Set Data Type 
to CC Setup > Recall From > 

1CC_FR2_120kHz_SCS_100MHz_256QAM_DCpunctured_
28GHz_34.scp 

Recall

2. Select Meas Setup > Meas Time and set:

— Search Length to 10 ms

— Result Length to 2 Sub Frame

— Frame Trigger to On

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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3. Select Advanced tab > Advanced Demod Setup and set DC Punctured to 
On, (highlighted in blue).

4. Ensure that RF for Phase Compensation Auto is not selected and the value 
is 0 Hz. Close the Advanced Settings table.

5. Select the Settings tab > Optimize EVM.

The Optimize EVM function automatically sets the combination of 
preamplification, mechanical and electronic attenuation, and IF gain based 
on the measured signal peak level. 

EVM should be less than 1%. 
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude 5dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform:TRIGger:SYNC:MARKer M2

Navigate to the desired waveform file.

SIGNal1:WAVeform “D:\Users\Instrument\Documents\demo 
waveforms 
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DCPunctured_28GHz.
wfm”

SIGNal1 ON

IQO:CORR:OPT:DYN:RANG:OBW ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

Navigate to the desired waveform file.

MMEMory:LOAD:EVM:SETup CC0, 
“D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\5GNR_1CC_FR2_120kHz 
SCS_100MHz_256QAM_DCpunctured_28GHz.scp”

EVM:CCARrier0:TIME:LENGth:SEARch 10ms

EVM:CCARrier0:TIME:LENGth:RESult 2

EVM:CCARrier0:FRAMe:TRIGger ON

EVM:CCARrier0:DC:PUNCture ON

EVM:CCARrier0:PHASe:COMPensation:AUTO OFF

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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EVM:CCARrier0:PHASe:COMPensation:FREQuency 0 Hz

EVM:OPTimize
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Setting up an 8 CC 28 GHz EVM Measurement

This procedure shows you how to USE the X-Series Signal Analyzer signal 
analysis 5G NR X-Series application to observe EVM on an eight-carrier 
waveform.

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 28 GHz and Amplitude to 5 dBm. 

3. Select the Signal block to open.

4. Select the Markers block and set Sync to Marker 2 and then select Back to 
close the Markers Setup.

Ensure the equipment and triggers are properly configured. Refer to 
“Configuring the Equipment Setup” on page 9 and “Setting Up Triggers on 
the Signal Analyzer using 5G NR Mode” on page 86.
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Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose

5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz.
wfm

then Select.

5. Select Enable Vector Modulation Signal.

6.  Close the Signal Setup by either selecting the Back button or the Home 
icon at the top of the display.

7. Select the Adjustments block and select Optimize Dynamic Range with 
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW  This setting filters the system 
RF flatness correction coefficients over the instantaneous bandwidth 
indicated in the waveform header (or in the “Occupied Bandwidth” 
settings area under the Signal block > Occupied Bandwidth setting). 
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This has the potential to improve EVM performance by not having to 
correct for flatness errors outside the requested bandwidth. For 
example, if RF flatness correction was done at 2 GHz, but you are 
only interested in an 800 MHz section, then applying the correction 
flatness to that portion only can improve signal to noise ratio, and 
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction -   Disabling this function 
disables the factory calibrated RF channel flatness equalizer. 
Depending on the hardware channel response, this may hurt or 
improve the EVM. This is due to the dynamic range implications as it 
relates to signal to noise ratio. The greater the RF hardware 
variations in flatness, the greater the amount of correction is 
required, the greater the correction effectively reduces the number of 
resolution DAC bits that can be used, which degrades the signal to 
noise ratio and therefore potentially EVM. The trade-off is to balance 
between flatness and signal to noise ratio.

8.  Close the Adjustments Setup by either selecting the Back button or the 
Home icon at the top of the display.

9.  Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.



98                                                                                                                        M9383B/84B Measurement Guide

5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

10. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

1. Select Recall (If accessing the X-Series Signal Analyzer remotely, select 
the Folder icon at the bottom of the display) > Demod Info > set Data Type 
to CC Setup > Recall From > 
5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz
_34.scp 
Recall.

You must be in the correct analysis mode to recall the .scp file. 

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC 
running the VSA application.
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2. Select Meas Setup > Meas Time tab and set:

— Search Length to 10 ms

— Result Length to 2 Sub Frame

— Frame Trigger to On

3. Select Meas Setup > Advanced tab > Advanced Demod Setup and select 
both Multi-Carrier Filter and DC Punctured to turn on.

The multi-carrier filter is used to filter out the unwanted carriers and 
minimize leakage into the component carrier of interest.
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4. Ensure that RF for Phase Compensation is not selected and the value is 
0 Hz, then Close the Advanced Settings table.

5. Select the Sweep > Single Sweep.

6. Select Meas Setup > Settings tab > Optimize EVM. 

It will take a couple of minutes for the UXA to measure all 8 carriers.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude 5dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform:TRIGger:SYNC:MARKer M2

Navigate to the desired waveform file.

SIGNal1:WAVeform “D:\Users\Instrument\Documents\demo 
waveforms\5GNR_8CC_FR2_120kHz_SCS_100MHz_Corrected_28GHz.wfm
”

SIGNal1 ON

IQO:CORR:OPT:DYN:RANG:OBW ON

IQO:CORR:CHANNel:FLATness ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

Navigate to the desired waveform file.

MMEMory:LOAD:EVM:SETup CC0, 
“D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz.scp”

EVM:CCARrier0:TIME:LENGth:SEARch 10ms

EVM:CCARrier0:TIME:LENGth:RESult 2

EVM:CCARrier0:FRAMe:TRIGger ON

EVM:CCARrier0:MCFilter ON

EVM:CCARrier0:DC:PUNCture ON

EVM:CCARrier0:PHASe:COMPensation:AUTO OFF

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC 
running the VSA application.
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EVM:CCARrier0:PHASe:COMPensation:FREQuency 0 Hz

To Optimize EVM for Multi-Carrier Waveforms

POWer:ATTenuation 0dB

[POWer:ATTenuation 2dB], …

EVM:IF:GAIN:LEVel 0dB

To View the Results of Two Carriers

Set the top right window (Window 2) to display IQ Meas Time

DISPlay:EVM:WINDow2:DATA MTIM

Set the top right window to display Component Carrier 1

DISPlay:EVM:WINDow2:CCARrier CC1

Set the middle right window to display the FFT of the Raw Main Time waveform

DISPlay:EVM:WINDow4:DATA SPEC

DISPlay:EVM:WINDow4:CCARrier CC1

Set the bottom right window to display a table of general measurement numeric results

DISPlay:EVM:WINDow6:DATA DRES

DISPlay:EVM:WINDow6:CCARrier CC1

Set the bottom left window to display the error summary for CC0

DISPlay:EVM:WINDow5:DATA DRES
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Setting Up a 1 CC 3.5 GHz ACP Measurement

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 3.5 GHz and Amplitude to 0 dBm. 

3. Select the Signal block to open the Vector Modulation Signal Setup panel.

4. Select the Markers block and set Sync to Marker 2 and then select Back to 
close the Marker Setup.

Ensure the equipment and triggers are properly configured. Refer to 
“Configuring the Equipment Setup” on page 9 and “Setting Up Triggers on 
the Signal Analyzer using 5G NR Mode” on page 86.
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5. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose

5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DCPunctured.wfm

then Select.

6. In the Vector Modulation Signal Setup, ensure that Enable Vector 
Modulation Signal is selected, then close the Signal block.

7. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.
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8. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

1. Select Mode Preset to set 5G NR mode to a known state.

2. Select Mode/Meas > 5G NR Mode > ACP Measurement.

3. Select Frequency and set Carrier Reference Frequency to 3.5 GHz.

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 3.5GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform:TRIGger:SYNC:MARKer M2

SIGNal1:WAVeform “D:\Users\Instrument\Documents\MCS demo 
waveforms\5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DCPunctured.w
fm”

SIGNal1 ON

DM:OPTimization:CHANnel ACP

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

SYSTem:PRESet

INSTrument:CONFigure: NR5G:ACP

CCARrier:REFerence 3.5GHZ

ACPower:CORRection:NOISe ON
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Using PathWave N7631APPC to Create a Waveform File then 
Automatically Configure the Analyzer to View the Results

PathWave software tools can be used to create, download, and playback 
waveforms through the VXG.

This example shows you how to create and analyze a 5G NR signal using the 
embedded PathWave software and then automatically configure the analyzer 
to make the measurement. 

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 28 GHz and Power to 
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.

The VXG must have the N7631APPC Signal Generation for 5G NR license 
installed.

If you have previously opened any of your available applications, the dialog 
box will not be displayed. Instead, you will see tabs of the applications that 
have already been used. You can view all of your available applications by 
selecting the Apps tab.
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4. Select 5G NR to enter the 5G NR signal mode.

5. In the 5G NR setup, select the Waveform tab and observe the Phase 
Compensation and Radio Frequency settings.

Phase Compensation is applied by default at baseband for RF 
up-conversion. This means it depends on the carrier frequency, and the 
waveform should only be played at the carrier frequency it was generated 
for, unlike conventional Signal Studio waveforms, which are independent 
from carrier frequency. Phase Compensation is set to Auto by default. The 
frequency is coupled with the VXG frequency setting. You can select 
Manual to specify a different frequency, or turn it off.

TIP Some applications, like power amplifier measurements use the same 
waveform at different frequencies and can be time consuming to generate a 
separate waveform for each frequency. In this case, you would turn Phase 
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Compensation Off, so the waveform becomes independent from the carrier 
frequency. You need to do the same on the analysis side, or the demodulation 
will fail.

6. Select the Carrier tab.

7. Select Full-Filled Config and set Bandwidth to 
FR2 100 MHz, Numerology to  3:120 kHz, Duplex Type to FDD. 
Modulation to 256 QAM.

Full Filled Configurations is a great place to start creating your waveform. 
You can select FR, bandwidth, and modulation format with a fully 
allocated PDSCH data channel. This would represent a spectrally correct 
signal that is typically used in power amplifier measurements. You can 
modify the RB allocations and Slot allocations if fully allocated data 
channels are not desired.

8. Select OK to exit the Full Filled Config setup. 

9. From the Carrier panel (in the left pane), select Spectrum Control > DC 
Punctured On. 

If you have a signal analyzer with demodulation bandwidth that is wide 
enough to cover the other FR2 bandwidths, 200 MHz or 400 MHz, you can 
choose to use a wider bandwidth.
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When DC Punctured is enabled, the DC subcarrier is excluded from the 
measurement results. This is often helpful to avoid obscuring 
measurement results with artifacts of LO feedthrough.

10.From the Carrier panel (in the left pane), select Downlink > SS PBCH > SS 
PBCH Block and set Lmax to 64 and Active Indices to = 0:7.

Instead of transmitting all 64 beams, we enable only 8 of them by setting 
Active Indices to 0:7.

11. From the Carrier panel (in the left pane), select Downlink > DL-SCH > 
DL-SCH0 > Modulation and Coding and set MCS Table to Table 5.1.3.1-2 
(256QAM) and MCS to 20.

Lmax sets the maximum number of possible SS/PBCH blocks in a transmission 
opportunity. This value is fixed for a given carrier bandwidth. Typically, higher 
frequency and bandwidth carriers use a larger set of SS/PBCH opportunities to 
support a larger set of antenna beams.Lmax is either 4 or 8 for FR1 and 64 for 
FR2. 
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The Modulation Coding Scheme (MCS) specifies the modulation, coding 
and overall spectral efficiency of the PDSCH as specified in 3GPP Table 
5.1.3.1.

12. Select Generate to generate the Waveform, and then select Home to 
return to the main window.
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13. Select the Markers block and set Sync to Marker 2, then select Back.

14. Select Enable Vector Modulation Signal.

15. Return to the window and turn RF Out to On by selecting the numbered 
channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.



M9383B/84B Measurement Guide                                                                                                                       113

5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

Setup Auto Configure Analyzer 

1. Select the System menu (triple bar tab at the top left of the window) to 
open the System Menu and then select Configure Analyzer.

2. In the System Configuration setup, click on the Remote Signal Analyzer 
block (on far right) to setup the communication channel to the Keysight 
X-Series Signal Analyzer. 

3. Set Connection Type to LAN.

4. In the Connect Remote X-Series Signal Analyzer setup, enter the 
Hostname or IP Address for the signal analyzer.

5. Under Set Protocol, select HiSLIP and use the Remote name hislip0.
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6. Select Test Connection to verify, then Back.

7. Select Auto Configure Analyzer to send the VXG settings to the analyzer. 

The System Configuration selection brings up a screen that lets you perform a 
Generation-to-Analysis work flow. The “Auto Configure Analyzer” button will 
automatically transfer the setup from the source to a Keysight X-Series signal 
analyzer, in order to measure the desired signal from the source. If you are gen-
erating a 3GPP 5G New Radio signal, and the 5G New Radio application is 
licensed on the analyzer, the analyzer will perform demodulation of the signal. 
Otherwise, the analyzer will auto-tune on the signal being generated. The Key-
sight X-Series Signal Analyzer requires firmware version x.24.00 or greater.

On the X-Series Signal Analyzer

1. Set up triggers, refer to “Setting Up Triggers on the Signal Analyzer using 
5G NR Mode” on page 86.

2. From the menu panel, select Meas Setup > Advanced > Advanced Demod 
Setup > DC Punctured On. 
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3. View the results on the signal analyzer. 

More About the 5G NR Traces

— Trace 1: shows the composite constellation diagram showing different 
modulation formats for the different channels/signals present in the 
transmitted signal. See Trace 6 (Frame Summary) for the list of channels. 
Again, when enabling BWP, SS Block is grayed out. When enabling SS 
Block, channels withing BWP are grayed out.

— Trace 2: shows the envelope of the captured raw data. This data is 
unprocessed and includes additional points acquired for settling of the 
filters involved in subsequent processing, such as the demodulation 
filtering.

— Trace 3: shows the FTT of the Raw Main Time waveform.

— Trace 4: shows the general measurement numeric results.

— Trace 5: shows the detected allocations of all channels/signals within the 
measurement interval (2 Subframes in this example).

— Trace 6: shows EVM, Power, and Number of RB of the individual 
channels/signals.

TIP The Frame Summary table shows Num. RB for PDSCH of 1056 and 1016 for 
PDSCH-DMRS. The signal configuration has only 66 RBs. The RB result in the 
Frame Summary Table is per Slot. In this example procedure, we changed the 
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measurement interval to 2 Subframes, which is 16 slots for 120 kHz 
numerology (8 slots/subframe). 66 * 16 = 1056. For PDSCH-DMRS, the value 
is 1016 because two of the 16 slots overlap with the SS Block which occupies 
20 RBs resulting in 20 RBs being punctured from DMRS in these two slots. 
Therefore, the total RB Number for DMRS is 1056 - 20 * 2 = 1016.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude -10dBm

SIGNal1:MODE NR

SIGNal1:NR5G:CCARrier:BWIDth FR2BW100M

Select µ = 3: 120kHz:

SIGNal1:NR5G:CCARrier:SNUMerology MU3

SIGNal1:NR5G:CCARrier:DLINk:SSBLock:LMAX 64

SIGNal1:NR5G:CCARrier:DLINk:SSBLock:ACTive:INDices "0:7"

SIGNal1:NR5G:CCARrier:DLINk:SCH0:MCS 20

SIGNal1:NR5G:CCARrier:DLINk:SCH0:MCS:TABLe TABL52

SIGNal1:NR5G:WAVeform:GENerate

SIGNal1:NR5G:TRIGger:SYNC:MARKer M2

SIGNal1 ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON
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3 5G NR Measurements Using the VSA Software

This section includes the following topics:

— “5G Waveform and EVM Analysis Using VSA Software” on page 120

— “Setting Up a 1 CC 28 GHz EVM Measurement” on page 120

— “Setting Up an 8 CC 28 GHz EVM Measurement” on page 128

— “Creating a Basic 5G NR Signal Using PathWave N7631APPC 
Embedded Software” on page 136

— “Creating a DL MIMO Signal Using PathWave N7631APPC Signal 
Generation” on page 157
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5G Waveform and EVM Analysis Using VSA Software
The VXG enables 5G testing with a low error vector magnitude (EVM) at high 
frequencies. The VXG has extremely good EVM at high power levels. However, 
not all signal analyzers can capture this low value. We will use the X-Series 
Signal Analyzer with the Vector Signal Analysis (VSA) software to observe EVM. 

Setting Up a 1 CC 28 GHz EVM Measurement

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output 1 area, set Frequency to 28 GHz and Power to 
5 dBm.

3. Select the Signal block to open the Vector Modulation Signal Setup panel.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 10.
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4. Select the Markers block and set Sync to Marker 2, then select Back.

5. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

 and choose

5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DCPunctured_28GHz.wfm

then Select.

6. Select Enable Vector Modulation Signal.

7. Close the Vector Modulation Signal Setup window by selecting the Back 
or Home icon (<-).

8. Select the Adjustments block and select Optimize Dynamic Range with 
OBW and Enable System RF Flatness Correction. Close the Adjustments 
block by selecting the Back icon (<-).

Optimize Dynamic Range with OBW  This setting filters the system 
RF flatness correction coefficients over the instantaneous bandwidth 
indicated in the waveform header (or in the “Occupied Bandwidth” 
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settings area under the Signal block > Occupied Bandwidth setting). 
This has the potential to improve EVM performance by not having to 
correct for flatness errors outside the requested bandwidth. For 
example, if RF flatness correction was done at 2 GHz, but you are 
only interested in an 800 MHz section, then applying the correction 
flatness to that portion only can improve signal to noise ratio, and 
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction -   Disabling this function 
disables the factory calibrated RF channel flatness equalizer. 
Depending on the hardware channel response, this may hurt or 
improve the EVM. This is due to the dynamic range implications as it 
relates to signal to noise ratio. The greater the RF hardware 
variations in flatness, the greater the amount of correction is 
required, the greater the correction effectively reduces the number of 
resolution DAC bits that can be used, which degrades the signal to 
noise ratio and therefore potentially EVM. The trade-off is to balance 
between flatness and signal to noise ratio.

9.  Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.
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10. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

— Open the VSA software by selecting Mode Meas > Launch VSA. 

In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known 
state.

2. Select File > Recall > Recall Setup and navigate to 
D:Users\Instrument\Documents\NR5G\data\NR5GEvm\Carrier Setup, 
then open 5GNR_1CC_FR2_120kHz SCS_100MHz_256QAM_DC 
Punctured_28GHz.setx 

3. From the toolbar, select the Pause Icon. 

Pausing the measurement will help to speed up the setup time.

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC 
running the VSA application.
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4. From the menu bar, select Input > Trigger and set Style to External and 
Level to 1.0 V.

5. Select the Extensions tab and change the External Trigger location to 
Trigger 3 In (if using an N9040B with Option H1G) and Phase Noise 
Optimization to Best Wide Offset, then close the window.
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6. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time 
tab.

— Set Result Length to 10 Subframes

— Set Meas Interval to 2 Subframes

— Select Frame Trigger is Present

7. From the toolbar, select the Auto-Range dropdown and select EVM-Table 
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based 
on prescribed table/algorithm instead of using EVM in the feedback 
loop. This method of EVM auto-range is normally faster than Meas 
Based Iteration, but may not achieve the most optimal setup for 
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire 
measurement, uses the measured EVM in the feedback loop, and 
tries to adjust hardware parameters to minimize the EVM. It is the 
slowest EVM auto-range method, but it should achieve the most 
optimal setup for good EVM.

8. Select the Auto-Range icon to run the measurement for EVM optimization. 
This may take a few minutes to complete.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude 5dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform:TRIGger:SYNC:MARKer M2

SIGNal1:WAVeform “D:\Users\Instrument\Documents\MCS demo 
waveforms 
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DCPunctured_28GHz.wfm”

SIGNal1 ON

IQO:CORR:OPT:DYN:RANG:OBW ON

IQO:CORR:CHAN:FLAT ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:SELect VSA89601

SYSTem:PRESet

MMEMory:LOAD 
“D:Users\Instrument\Documents\NR5G\data\NR5GEvm\Carrier 
Setup\5GNR_1CC_FR2_120kHz 
SCS_100MHz_256QAM_DCPunctured_28GHz.setx”

INITiate:PAUSe

INPut:TRIGger:STYle "EXTERNAL"

INPut:TRIGger:LEVel:EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC 
running the VSA application.
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Set the 5G NR Demod Result Length to 10 Subframes:

NR5G:RLENgth 10

NR5G:SUBFrame:INTerval 2

Set the Acquisition Mode to “Frame Trigger is Present”

nr5g:FRAMe:TRIGger:ENABled 1
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Setting Up an 8 CC 28 GHz EVM Measurement

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output 1 area, set Frequency to 28 GHz and Power to 
5 dBm.

3. Select the Signal block to open the Vector Modulation Signal Setup panel.

4. Set Vector Modulation Signal Mode to Waveform File.

5. Select the Markers block and set Sync to Marker 2, then select Back (<-).

6. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 10.
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and choose

5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_1.wfm 

then Select.

7. Select Enable Vector Modulation Signal.

8. Close the Vector Modulation Signal Setup window by selecting the Back 
(<-) button.

9. Select the Adjustments block and select Optimize Dynamic Range with 
OBW and Enable System RF Flatness Correction. Close the Adjustments 
window by selecting the Back (<-) button.

Optimize Dynamic Range with OBW  This setting filters the system 
RF flatness correction coefficients over the instantaneous bandwidth 
indicated in the waveform header (or in the “Occupied Bandwidth” 
settings area under the Signal block > Occupied Bandwidth setting). 
This has the potential to improve EVM performance by not having to 
correct for flatness errors outside the requested bandwidth. For 
example, if RF flatness correction was done at 2 GHz, but you are 
only interested in an 800 MHz section, then applying the correction 
flatness to that portion only can improve signal to noise ratio, and 
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction -   Disabling this function 
disables the factory calibrated RF channel flatness equalizer. 
Depending on the hardware channel response, this may hurt or 
improve the EVM. This is due to the dynamic range implications as it 
relates to signal to noise ratio. The greater the RF hardware 
variations in flatness, the greater the amount of correction is 
required, the greater the correction effectively reduces the number of 
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resolution DAC bits that can be used, which degrades the signal to 
noise ratio and therefore potentially EVM. The trade-off is to balance 
between flatness and signal to noise ratio.

10. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

11. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

— Open the VSA software by selecting Mode Meas > Launch VSA. 

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known 
state.

2. Select File > Recall > Recall Setup and navigate to 
D:Users\Instrument\Documents\NR5G\data\NR5GEvm\Carrier Setup, 
then open 
5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_1.setx 

3. From the toolbar, select the Pause Icon. 

Pausing the measurement will help to speed up the setup time.

4. Select the Extensions tab and change the External Trigger location to 
Trigger 3 In and Phase Noise Optimization to Best Wide Offset. 

5. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time 
tab.

— Set Result Length to 10 Subframes.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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— Set Meas Interval to 2 Subframes.

6. In the bottom center trace window, select the Trace Data menu and select 
Demod: > CC Summary. 

7.  In the Spectrum trace window (bottom left window), select Center and 
change the frequency to 28 GHz.

8.  From the toolbar, select the Auto-Range dropdown and select EVM-Table 
or Algorithm Based.
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— EVM - Table or Algorithm Based performs EVM optimization based 
on prescribed table/algorithm instead of using EVM in the feedback 
loop. This method of EVM auto-range is normally faster than Meas 
Based Iteration, but may not achieve the most optimal setup for 
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire 
measurement, uses the measured EVM in the feedback loop, and 
tries to adjust hardware parameters to minimize the EVM. It is the 
slowest EVM auto-range method, but it should achieve the most 
optimal setup for good EVM.

9.  Select the Auto-Range icon to run the measurement for EVM optimization 
on all eight channels. This may take a few minutes to complete.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude 5dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform:TRIGger:SYNC:MARKer M2

SIGNal1:WAVeform “D:\Users\Instrument\Documents\MCS demo 
waveforms\5GNR_8CC_FR2_120kHz_SCS_100MHz_Corrected_28GHz.wfm
”

SIGNal1 ON

IQO:CORR:OPT:DYN:RANG:OBW ON

IQO:CORR:CHAN:FLAT ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer
INSTrument:SELect VSA89601

MMEMory:LOAD:DEMO 
"D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\1CC_FR2_120kHz SCS_100MHz_256QAM_DC Punctured_28GHz.setx"

INITiate:PAUSe

INPut:TRIGger:STYLe "External"

INPut:TRIGger:LEVel:EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

NR5G:RLENgth 10 

NR5G:SUBFrame:INTerval 2

NR5G:FRAMe:TRIGger:ENABled 1

NR5G:CAGGregation:CONFigure "Contiguous8CC"

NR5G:DC:PUNCtured 1

NR5G:MCFilter:ENABled 1
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FREQuency:CENTer 28 GHz

INPut:ANALog:CRITeria:RANGe:AUTO "EVM", -1 

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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Creating a Basic 5G NR Signal Using PathWave N7631APPC 
Embedded Software

PathWave software tools can be used to create, download, and playback 
waveforms through the VXG.

This example shows you how to create and analyze a 5G NR signal using the 
embedded PathWave software. Your VXG must include the N7631APPC 
license. 

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 28 GHz and Power to 
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.

The VXG must have the N7631APPC Signal Generation for 5G NR license 
installed.

If you have previously opened any of your available applications, the dialog 
box will not be displayed. Instead, you will see tabs of the applications that 
have already been used. You can view all of your available applications by 
selecting the Apps tab.



M9383B/84B Measurement Guide                                                                                                                       137

5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

4. Select 5G NR to enter the 5G NR signal mode.

5. In the 5G NR setup, select the Waveform tab and observe the Phase 
Compensation and Radio Frequency settings.

TIP Phase Compensation is applied by default at baseband for RF up-conversion. 
This means the waveform generation is per the carrier frequency, unlike 
conventional Signal Studio waveforms, which are independent from carrier 
frequency. Phase Compensation is set to Auto by default. The frequency is 
coupled with the VXG frequency setting under the Instrument node. You can 
select Manual to specify a different frequency, or turn it off.

Some applications, like power amplifier measurements use the same 
waveform at different frequencies and can be time consuming to generate a 
separate waveform for each frequency. In this case, you would turn Phase 
Compensation Off, so the waveform becomes independent from the carrier 
frequency. You need to do the same on the analysis side, or the demodulation 
will fail.

6. Select the Carriers tab and then select the Full-Filled Config tab.
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7. Select the Full-Filled Config tab and set Bandwidth to FR2 100 MHz, 
Numerology to  3: 120 kHz, Modulation to 256QAM and then select 
OK.

Full Filled Configurations is a great place to start creating your waveform. 
You can select FR, bandwidth, and modulation format with a fully 
allocated PDSCH data channel. This would represent a spectrally correct 
signal that is typically used in power amplifier measurements. You can 
modify the RB allocations and Slot allocations if fully allocated data 
channels are not desired.

8. Select OK to exit the Full Filled Config setup.

9. From the Carrier panel (in the left pane), select Downlink > SS PBCH > SS 
PBCH Block and change Lmax to 64 and Active Indices to = 0:7.

If you have a signal analyzer with demodulation bandwidth that is wide 
enough to cover the other FR2 bandwidths, 200 MHz or 400 MHz, you can 
choose to use a wider bandwidth.
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 Instead of transmitting all 64 beams, we enable only 8 of them be setting 
Active Indices to 0:7.

10. From the Carrier panel (in the left pane), select Downlink > DL-SCHs > 
DL-SCH0 > Modulation and Coding and set MCS Table to Table 5.1.3.1-2 
(256QAM) and MCS to 20.

Lmax sets the maximum number of possible SS/PBCH blocks in a transmission 
opportunity. This value is fixed for a given carrier bandwidth. Typically, higher 
frequency and bandwidth carriers use a larger set of SS/PBCH opportunities to 
support a larger set of antenna beams.Lmax is either 4 or 8 for FR1 and 64 for 
FR2. 
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11. Select Generate to generate the Waveform, and then select Back.

12. Select the Markers block and set Sync to Marker 2, set ALC Hold and RF 
Blanking to None and then select Back.

13. Select Enable Vector Modulation Signal, then close the Signal block.
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14. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

— Open the VSA software by selecting Mode Meas > Launch VSA. 

In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known 
state.

2. Set the Center Frequency to 28 GHz, then select Auto Range.

Auto Range samples the current input signal and then sets the full scale 
input range to the minimum range that includes the peak voltage sample 
of the input signal.

3. From the toolbar, select the Pause Icon. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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TIP Pausing the measurement will help to speed up the setup time.

4. From the menu bar, select Input > Trigger and set Style to External and 
Level to 1.0 V.
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5. Select the Extensions tab and change the External Trigger location to 
Trigger 1 In or Trigger 3 In (Use Trigger 3 if your N9040B has Option H1G, 
1 GHz BW) and set Phase Noise Optimization to Best Wide Offset. 

6. From the menu bar, select MeasSetup > Measurement Type > Cellular > 
5G NR.

7. From the menu bar, select MeasSetup > 5G NR Demod Properties > 
Configuration tab. 

TIP Use Quick Setups for convenient saving and loading of common 
configurations. Quick Setups are factory supplied configurations and cannot 
be deleted by users. (This includes Signal Studio Downlink and Uplink 
defaults.)
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Save As Quick Setup (saved by the user) can be specific to the current user or 
can be made available to others users. These setups can also be deleted.

8. Select the Carrier panel. 

The Carrier dialog is used to configure component carrier level 
parameters: Cell ID, Bandwidth, and Resource Grid for each Numerology.

— Set Cell ID to 0

When the checkbox is selected, Cell ID auto-detection is enabled 
for the carrier.

— Set Bandwidth to FR2 100 MHz

9. Select the Bandwidth panel and set Numerology to  3: 120 kHz

For FR2 100 MHz, the Max RB for 120 kHz numerology is 
66 RB. This value will be used when we configure BWP, SS/PBCH, and 
PDSCH.

Cell ID is carried on PSS and SSS so the SS/PBCH must be transmitted 
and enabled for Auto Cell ID to work. It must also be a downlink since 
SS/PBCH is only transmitted on a downlink.
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FR2 only uses 60, 120, or 240 kHz numerologies. This is why 15 and 
30 kHz numerologies do not show under the Resource Grid.

10. Select the BWP pane, then enable DL-BWP.

This section is used to configure the Downlink BWP allocation within the 
component carrier and the control resource set (CORESET). CORESET is 
used for PDCCH configuration and will not be used in this example. We 
will use the default values of:

— Numerology  120 kHz

— RB offset 0 RB

— RB Number 66 RB
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A component carrier with 100 MHz at FR2 has a maximum RB of 66 
for 120 kHz numerology. In this example, DL-BWP uses the full 
carrier bandwidth of 66 RBs as shown below.

TIP VSA supports a single BWP within a component carrier (CC). Signal Studio 
and X-Apps support multiple BWPs within a CC. You can use VSA 
multi-measurement to analyze multiple BWPs simultaneously. 

11. Select the Channel pane > SS/PBCH, enable SS/PBCH and set the 
following parameters:

— Lmax to L64

Lmax specifies the maximum number of SS/PBCH Blocks (that is, 
beams) in an SS Block period. 

— FR1 up to 3 GHz, Lmax = 4

— FR1 3 to 6 GHz, Lmax = 8

— FR2 6 to 52.6 GHz, Lmax = 64

— SSB Transmitted to 0:7
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For this example, we will not use all 64 SS Blocks; we will activate 
only 8 of them. You can also select the Auto Detect Active Block 
and set the Det Power Threshold to auto detect the active SS 
Blocks. 

These following settings use the default values.

— RB Offset(60kHz) = 46 RB

— kSSB(60kHz) = 0

— Periodicity = 10 ms

— Numerology =  120 kHz
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The frequency location of an SS Block is not fixed. The default value of 46 
RB and kSSB of 0 subcarriers places it in the center of the carrier 
bandwidth. This value is calculated based on the 60 kHz numerology as 
defined by 3GPP (15 and 30 kHz sub-carrier spacing uses 15 kHz 
numerology, 120 and 240 kHz spacing uses 60 kHz numerology.)

For example, to calculate the 120 kHz sub-carrier spacing, the value 
would be 

66RB/2 = 33 RB

This is the center of the carrier bandwidth. However, the SS Block is 
20 RB wide, so the start of the SS Block is 23 RB.

23 RB in 120 kHz is 23 * 2 = 46 RB in 60 kHz 

This is the default value used in the VSA software for 120 kHz numerology. 

12. From the Channel pane, select PDSCH and then set the following 
parameters: 

— Under Modulation and Config section, set MCS Table to Table 
256QAM and MCS to 20.
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TIP 3GPP has different Tables for PDSCH MCS. 

Table 5.1.3.1-2 has 256 QAM as maximum modulation

Table 5.1.3.1-3 has 64 QAM as maximum modulation

Table 5.1.3.1-1 has 64 QAM as maximum modulation, and is for low 
spectrum efficiency (LowSE). 

See 3GPP TS38.214 for more information.

— Under the Time/Freq Allocation section, set

— Allocated Slots to 0:79

— Slot Format to 0

— First Symbol to 0

— Last Symbol to 13

— RB Offset to 0 RB

— RB Number to 66 RB
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We will use the default values for RS Sequence, Power Boosting, and 
Antenna Port. Power s would not change the DMRS sequences, but they 
might be interested in modifying Power Boosting.

13. Select the Time tab and set:

— Result Length to 10 Subframes.

— Meas Interval to 2 Subframes.

— Select Frame Trigger is Present.

14. Select the Advanced Settings tab and select DC Punctured.

5G NR counts the DC subcarrier as a valid subcarrier for rate-matching 
purposes. The network decides if the DC subcarrier is modulated or not. 
High LO feedthrough will impact demodulation and EVM performance of 
the input signal. This setting is off by default.

Use Extend Frequency Lock Range if you cannot lock to the input signal.
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Compensate Symbol Clock Offset is used along with timing track to 
compensate for clock error in the input signal. The Symbol Clock Error 
result is reported in the Summary trace.

Symbol Phase Compensation > From Measurement Center is enabled by 
default. It is specified in the 3GPP requirement and is used to compensate 
for phase differences between symbols caused by up conversion or down 
conversion. Getting this setting wrong will cause demod issues. 

15. From the menu bar, select Window > Trace Layout > Tile Visible.

This will display all six 5G NR traces on the display.

16. Select the Auto-Range icon to run the measurement for EVM-Table or 
Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based 
on prescribed table/algorithm instead of using EVM in the feedback 
loop. This method of EVM auto-range is normally faster than Meas 
Based Iteration, but may not achieve the most optimal setup for 
minimized EVM).
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— EVM - Meas Based Iteration has a feedback loop around the entire 
measurement, uses the measured EVM in the feedback loop, and 
tries to adjust hardware parameters to minimize the EVM. It is the 
slowest EVM auto-range method, but it should achieve the most 
optimal setup for good EVM.

TIP The VSA has color coding based on channel type, marker coupling to pinpoint 
error, symbol level analysis (by changing the measurement interval, and 
measurement offset into a single symbol).

More About the 5G NR Traces

— Trace A: shows the composite constellation diagram showing different 
modulation formats for the different channels/signals present in the 
transmitted signal.

— Trace B: shows the frequency spectrum.

— Trace C: shows the composite error metrics. You can also see the 
automatically detected Cell ID value and the Channel Power.

— Trace D: shows the EVM versus subcarrier and symbol.

— Trace E: shows the detected allocations of all channels/signals within the 
measurement interval. (For this example, 2 Subframes) You can see the 8 
active SS Blocks in the first four slots.

— Trace F: shows the frame summary: EVM Power per RE, Modulation format, 
Number of RB and RTNI of the individual channels/signals.

For more information on these traces, see the Online help.
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Trace Filtering

The VSA has per-trace filtering to filter by subsegments and channels. 
Subsegment refers to Layers, (in case of MIMO), BWP, and SS Block. In the 
downlink, Layers in DL-BWP and SS Block are presented as subsegments. In 
the uplink, Layers in UL-BWP are presented as subsegments.

The following traces can be filtered by subsegments and channel types.

— OFDM Meas

— OFDM Ref

— Error Vector Spectrum

— Error Vector Time

— Detected Allocations Time trace can be filtered per channel only

The rest of the traces do not support per-trace filtering. 

A Simple Example

We will apply per-trace filtering to Error Vector Spectrum (Trace D) and 
Detected Allocations Time (Trace E) traces.

1. From the menu bar, select Trace > Digital Demod.

2. In the Trace Dialog, select Trace D (OFDM Error Vector Spectrum) from the 
dropdown.

3. In the Filtered SubSegments area, clear the Layer0 check box.
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This allows you to take a look at SS Block. You can also filter with SS 
Block Channels/Signals you want to see by using the Filtered Channel 
Type.

4. Select Trace E (OFDM Detected Allocations Time) from the Trace dialog.

5. In the Filtered SubSegments area, clear the SS Block0 check box.

This alloys you to look at Layer 0 information, which is the DL-BWP 
information. 

6. In the Filter Channel Types area, Clear All selections, then select just 
PDSCH-DMRS. 

You now see a gap in two of the DMRS symbols. Why is this?

Notice that the Frame Summary table shows Num. of RBs for PDSCH of 
1056 and 1016 for PDSCH-DMRS. The signal configuration only had 66 
RBs. Why the change in the measurement result?

The RB result in the Frame Summary table is per Slot. In this example, we 
changed the measurement interval to 2 Subframes, which is 16 slots for 
120 kHz numerology (8slots/subframe). 66*16=1056. For PDSCH-DMRS, 
the value is 1016 because of the 16 slots overlap with the SS Block, which 
occupies 20 RBs. This results in 20 RBs being punctured from DMRS in 
these two slots, so the total RB Number for DMRS is 1056-20*2 = 1016.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude -10dBm

SIGNal1:MODE NR

SIGNal1:NR5G:CCARrier:BWIDth FR2BW100M

SIGNal1:NR5G:CCARrier:SNUMerology MU3

SIGNal1:NR5G:CCARrier:DLINk:SSBLock:LMAX 64

SIGNal1:NR5G:CCARrier:DLINk:SSBLock:ACTive:INDices "0:7"

SIGNal1:NR5G:CCARrier:DLINk:SCH0:MCS 20

SIGNal1:NR5G:WAVeform:GENerate

SIGNal1:NR5G:TRIGger:SYNC:MARKer M2

SIGNal1 ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:SELect VSA89601

SYSTem:PRESet

FREQuency:CENTer 28 GHz

INPut:ANALog:RANGe:AUTO

INITiate:PAUSe

INPut:TRIGger:STYLe "External"

INPut:TRIGger:LEVel:EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2 (This will 
set it to Trigger 3)

NR5G:FRAMe:TRIGger:ENABled 1

INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

MEASure:CONFigure NR5G

NR5G:CCARrier:CIDentity:AUTO 1 |OR| NR5G:CCARrier:CIDentity 
0
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NR5G:CCARrier:TBANdwidth "FRTwo100MHz"

NR5G:DBWP:ENABled 1

NR5G:DBWP:NUMerology "Mu3"

NR5G:DBWP:ROFFset 0

NR5G:DBWP:RNUMber 66

NR5G:SSBLock:ENABled 1

NR5G:SSBLock:LMAX "L64"

NR5G:SSBLock:AINDexes "0:7"

NR5G:DBWP:PDSCh1:MCS:TABLe "Table2"

NR5G:DBWP:PDSCh1:MCS 20

NR5G:DBWP:PDSCh1:SLOT:ALLocated "0:79"

NR5G:CCAR:PDSCH1:SFI 0

NR5G:CCAR:PDSCH1:SINDex:FIRSt 0

NR5G:CCAR:PDSCH1:SINDex:LAST 13

NR5G:CCAR:PDSCH1:ROFFset 0

NR5G:CCAR:PDSCH1:RNUMber 66

NR5G:RLENgth 10 

NR5G:SUBFrame:INTerval 2

NR5G:FRAMe:TRIGger:ENABled 1

NR5G:DC:PUNCtured 1

NR5G:MCFilter:ENABled 1

NR5G:FREQuency:LOCK:EXTended 1

NR5G:COMPensate:SYMBol:CLOCk:OFFset 1

DISPlay:LAYout 3,2 

INPut:ANALog:CRITeria:RANGe:AUTO "EVM", -1
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Creating a DL MIMO Signal Using PathWave N7631APPC Signal 
Generation

This procedure will show you how to configure and analyze a downlink (DL) 
multiple input, multiple output (MIMO) signal using PathWave Signal 
Generation and the 89600 VSA software. The hardware setup below includes a 
2-channel VXG signal generator and a 2+ channel, 33 GHz or higher Infiniium 
UXR-Series Oscilloscope.

TIP If you do not have access to a Keysight Infiniium UXR Real-Time Oscilloscope, 
a UXR recording waveform file has been included in the Example waveform 
file folder:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy the 5GNR_UXR_Recording_28GHz.csv file to the 
X-Series Signal Analyzer or the PC running the VSA application. Steps have 
been included below to successfully run the recording.

The VXG must have the N7631APPC Signal Generation for 5G NR license 
installed.
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Equipment Setup for the M9383B

— CH1 M9323A front panel RF Out to UXR front panel CH1

— CH2 M9323A front panel RF Out to UXR front panel CH3

— CH1 M9343A front panel Trig 1 to UXR rear panel Aux Trig In

Equipment Setup for the M9384B

— M9384B CH1 front panel RF Out to UXR front panel CH1

— M9384B CH2 front panel RF Out to UXR front panel CH3

— M9384B rear panel TCH1 Sync Out to UXR rear panel Aux Trig In
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Using the graphical user interface

To generate the waveform in PathWave:

On the VXG:

1. Select Preset > Preset to set the VXG to a known state:

2. In the Output area for both Channel 1 and Channel 2, set Frequency to 
28 GHz and Power to 0 dBm.

3. In the Menu/Tool Bar, select the Triple Bar icon (top left corner of the 
display, and then select Configure Channels. Change the signal 
configuration from Independent to 2 Tx Coherent.

4. Select the Radio Apps block to open the mode selection panel.

If you have previously opened any of your available applications, the dialog 
box will not be displayed. Instead, you will see tabs of the applications that 
have already been used. You can view all of your available applications by 
selecting the Apps tab.
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5. Select 5G NR to enter the 5G NR signal mode.

6. Select the Waveform tab and observe that Total Number of Antennas has 
been automatically set to 2. This means that two antenna port signals will 
be generated.

7. Select the Carriers tab > Cell Specific node, and confirm the following 
settings: 

— Carrier Type = Downlink

— Cell ID = 0

— Bandwidth FR1 100 MHz

— Numerology =  1:30 kHz
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— Max RB = 273

8. Select the Downlink node > SS PPCH > SS PBCH Block and set: 

— Periodicity to 10 ms

— RB Offset by 15 kHz SCS to 0

Notice that this automatically changes the Delta Frequency to Carrier 
Center to –45.54 MHz.

9. Select the DL-SCH node > Transmission Settings and verify that DMRS 
port(s) is set to 0,1.
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The Number of Layers is updated to 2 and each layer is assigned with a 
particular DMRS port. Also, Antenna Ports Generated is automatically set 
to p0,p1. This will map generated multiple antenna port signals to 
different antennas (instruments).

10. Select the Resource Allocation node and set:

— Allocated Slots to 2:19

— RB Offset to 40

— RB Number to 80

DL-SCH0 will occupy the RBs 40-80 and DL-SCH1 will occupy the rest of 
the resources.

11. Select the Modulation and Coding node and set:

— MCS to 20

— MCS Table to 5.1.3.1-2 (256 QAM)
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Notice that modulation is updated to 256 QAM. 

12. Select the DMRS Settings node and set DMRS Power Boosting to 3 dB.

13. Under the DL-SCH 0 node, select the + icon to add a new DL-SCH 
(DL-SCH1).
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14. From the Channels node, select DL-SCH > DL-SCH1 > Transmission 
Settings and verify that DMRS port(s) is set to 0,1.

Notice that Number of Layers is updated to 2 and each layer is assigned 
with a particular DMRS port. Antenna Ports Generated is automatically 
assigned P0,P1, which will map generated multiple antenna port signals 
to different antennas (instruments). 

15. Select the Resource Allocation node and set:

— Allocated Slots to 2:19

— RB Offset to 150

— RB Number to 100

This will create a conflict between DL-SCH0 and DL-SCH1. This will be resolved in a later 
step.
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Notice that this resolves the conflict between DL-SCH channels. (The pink 
shading is removed from the Channel Allocation graph. To clear the 
conflict error message at the bottom of the display, select the Message 

icon  (bottom, right corner) and select Clear.

16. Select the Modulation and Coding node, and set:

— MCS to 20

— MCS Table to Table 5.1.3.1-1 (64 QAM)

17. Select the Waveform Tab and select Generate. 

18. In the bottom panel, select Spectrum.
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You should see a spectrum like the one below.

19. Return to the Carriers tab and select Export 89600 VSA Setup. Save the 
.setx file to a USB drive to transfer to the VSA.

20. Select the Back (<-) button to return to the Signal Setup dialog, then 
select the Enable Vector Modulation Signal check box. 

21. Select the Markers block, and set the Sync marker to Marker 2. 
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Marker 2 is the Frame Trigger.

22. Close the Signal Setup block and set RF Out to On by selecting the 
numbered channel indicator switches, and then select RF Out (All) master 
control switch to turn the RF output On for both channels or off for both 
channels.

On the UXR Oscilloscope (or X-Series Signal Analyzer with VSA):

To analyze the signal using the VXS on the UXR

— Open the VSA software by selecting Mode Meas > Launch VSA. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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In the VSA software:

1. From the VSA menu bar, select File > Preset > All to set the VSA to a 
known state.

— If you have access to a Keysight Infiniium UXR Real Time Scope, 
Continue with step 2 below. 

— If you do not have access to a Keysight Infiniium UXR Real-Time 
Oscilloscope, a UXR recorded waveform file has been included in 
the Example waveform file folder of the VXG:

a. Go to: 
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

Copy the 5GNR_UXR_Recording_28GHz.csv file to the 
X-Series Signal Analyzer or the PC running the VSA 
application.

b. To simulate the UXR, select Utilities > Hardware > 
Configurations.

c. Select the + icon, then in the New Hardware Configuration 
dialog, select Simulate Hardware.
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d. Scroll down the Possible Logical Instruments and select 
Keysight/Agilent Infiniium Series Oscilloscope and select 
the right arrow to move it under Configuration. 

e. In the Hardware dialog, select Analyzer 3 (or the 
associated analyzer number for the new configuration.) as 
the Current Analyzer Configuration. In the Channels 
dropdown menu, select Baseband 2 Channel, then close 
the dialog box.

f. Select File > Recall > Recall Setup and load the .setx file 
created in PathWave.
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g. Select File > Recall > Recall Recording, select 
UXR_Recording_28_GHz.csv, then Open. 

h. Continue with Step 4.

2. From the menu bar, select Input > Channels > User > 2 Channels.

3. If you are using a UXR, Select Autorange . 

Auto Range samples the current input signal and then sets the full scale 
input range to the minimum range that includes the peak voltage sample 
of the input signal.

4. From the menu bar, select MeasSetup > Measurement Type > Cellular > 
5G NR.

Autorange does not work if you are simulating the waveform with the UXR 
recording. Continue with the next step.
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5. Select MeasSetup > 5G NR Demod Properties > Configuration tab > 
Bandwidth pane and note that the Num of Meas. Channels is set to 2.

6. Select the BWP pane and confirm that DL-BWP is enabled. We will use the 
default settings of:

— Numerology =  1:30 kHz

— RB Offset = 0 RB

— RB Number = 273 RB
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7. Select the Channel pane > SS/PBCH and verify RB Offset (15 kHz) is set to 
0 RB and Periodicity to 10 ms.

8. Select the PDSCH pane and for PDSCH 0, set:

— MCS Table to Table 256 QAM

— MCS to 20

— Allocated Slots to 2:19

— RB Offset to 40 RB
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— RB Number to 80 RB

9.  Scroll down and select the Antenna Port dropdown and set:

— Antenna Ports Used,1 to 0,1

— DMRS CDM Group(s) without data to 2 (to match the PathWave 
setup)

10. Select the Power Boosting dropdown and verify that DMRS Power 
Boosting has automatically been set to 3 dB.
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According to the 3GPP definition, DMRS power boosting is 3 dB for CDM 
Group Number = 2 and VSA, similar to PathWave, changes the DMRS 
power boosting to 3 dB. 

Now you should see the demodulated 256 QAM constellation and EVM 
results per layer in frame summary for PDSCHO.

11. To add and configure PDSCH1, select Add PDSCH. 

12. Select PDSCH1 and set:

— MCS Table to Table 64 QAM

— MCS to 20

— Allocated Slots to 2:19

— RB Offset to 150 RB
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— RB Number to 100 RB

13. Scroll down and open the Antenna Port dropdown and set:

— Antenna Ports Used to 0:1

— DMRS CDM group(s) without data to 2.
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14. Select the Power Boosting dropdown and verify that DMRS Power 
Boosting is set to 3 dB. 

15. To configure the time settings, select the Time tab and set:

— Result Length to 10 Subframes

— Meas Interval to 2 Subframes
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— Enable Frame Trigger is present. NOTE: if using the UXR recording, 
leave Frame Trigger set to Normal. 

16. To configure the PDSCH decoding, select the Decode tab and set PDSCH 
Decode to Decoded TB.

This will decode PDSCH to the transport block, which is exactly the 
payload bits we configured in PathWave. Ensue that the Transport Block 
Size (TBS) 901344 is the same as in PathWave as this is the criteria to 
check the parameter alignment for channel decoding. TBS is auto 
calculated with MCS, Time/Frequency allocation, DMRS settings and 
Antenna Port settings.

Different decode levels are supported. This allows advanced users to be 
able to check into the intermediate step data for algorithm or 
troubleshooting. 
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17. Select the Advanced tab and select the DC Punctured check box then 
close the 5G NR Demod Properties dialog box. 

18. From the menu bar, select Input > Trigger and set:

— Style to External

— Level to 1 V
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NOTE: if using the UXR recording, skip this step as you cannot set 
up an external trigger.

19. Change the traces so you can see the following traces, plus any 
additional traces.

— Demod: IQ Meas/OFDM Meas Trace (Constellation diagram)

— Demod: Summary

— Demod: Frame Summery

— Demod: RE Power 3D

— Demod: OFDM Detected Allocations Time
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— MIMO Info

Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHz

RF1:POWer:AMPLitude 0dBm

RF2:FREQuency:CW 28GHz

RF2:POWer:AMPLitude 0dBm

CONFigure TX2

SIGNal:MODE NR

SIGNal:NR5G:CCARrier0:TYPE DL

SIGNal:NR5G:CCARrier0:CIDentity 0

SIGNal:NR5G:CCARrier0:NUM:MODE SINGLE

SIGNal:NR5G:CCARrier0:BWID FR1BW100M

SIGNal:NR5G:CCARrier0:SNUM MU1

SIGNal:NR5G:CCARrier0:SNUM:RB:NUMB 273

SIGNal:NR5G:CCARrier0:DLINk:SSBL:PERiodicity P10MS

SIGNal:NR5G:CCARrier0:DLINk:SSBL:RB:OFFSet 0
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SIGNal:NR5G:CCARrier0:DLINk:SCH0:DMRS:PORT '0,1'

SIGNal:NR5G:CCARrier0:DLINk:SCH0:SLOT "2:19"

SIGNal:NR5G:CCARrier0:DLINk:SCH0:RB:OFFSet 2

SIGNal:NR5G:CCARrier0:DLINk:SCH0:RB:NUMBer 80

SIGNal:NR5G:CCARrier0:DLINk:SCH0:MCS:TABL TABL52

SIGNal:NR5G:CCARrier0:DLINk:SCH0:MCS 20

SIGNal:NR5G:CCARrier0:DLINk:SCH0:DMRS:POWer 3

SIGNal:NR5G:CCARrier0:DLINk:SCH0:ADD

SIGNal:NR5G:CCARrier0:DLINk:SCH1:DMRS:PORT '0,1'

SIGNal:NR5G:CCARrier0:DLINk:SCH1:DMRS:CGWD:COUN 2

SIGNal:NR5G:CCARrier0:DLINk:SCH1:SLOT "2:19"

SIGNal:NR5G:CCARrier0:DLINk:SCH1:RB:OFFSet 150

SIGNal:NR5G:CCARrier0:DLINk:SCH1:RB:NUMBer 100

SIGNal:NR5G:CCARrier0:DLINk:SCH1:MCS:TABL TABL51

SIGNal:NR5G:CCARrier0:DLINk:SCH1:MCS 20

SIGNal:NR5G:WAVeform:GENerate

SIGNal ON

SIGNal:NR5G:TRIGger:SYNC:MARKer M2

RF1:OUTPut ON

RF2:OUTPut ON

RFAL1:OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:SELect VSA89601

SYSTem:PRESet

FREQuency:CENTer 28 GHz

FREQuency:SPAN 122.88 MHz

INPut:ANALog:RANGe:AUTO

INITiate:PAUSe

INP:CHAN:CONF RF,RF

MEASure:CONFigure NR5G

NR5G:DBWP:ENABled 1
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NR5G:SSBLock:ENABled 1

NR5G:SSBLock:ROFFset 0

NR5G:SSBLock:PERiodicity "Period10Milliseconds"

NR5G:DBWP:PDSCh1:MCS:TABLe "Table2"

NR5G:DBWP:PDSCh1:MCS 20

NR5G:DBWP:PDSCh1:SLOT:ALLocated "2:19"

NR5G:CCARrier:PDSCh1:ROFFset 40

NR5G:CCARrier:PDSCh1:RNUMber 80

NR5G:CCARrier:PDSCh1:ANTenna:PORT:USED 3

NR5G:CCARrier:PDSCh1:RCGNumber "Two"

NR5G:DBWP:PDSCh1:BPOWer:DMRS 3

NR5G:DBWP:PDSCh2:MCS:TABLe "Table1"

NR5G:DBWP:PDSCh2:MCS 20

NR5G:DBWP:PDSCh2:SLOT:ALLocated "2:19"

NR5G:CCARrier:PDSCh2:ROFFset 150

NR5G:CCARrier:PDSCh2:RNUMber 100

NR5G:CCARrier:PDSCh2:ANTenna:PORT:USED 3

NR5G:CCARrier:PDSCh2:RCGNumber "Two"

NR5G:DBWP:PDSCh2:BPOWer:DMRS 2

NR5G:RLENgth 10 

NR5G:SUBFrame:INTerval 2

NR5G:FRAMe:TRIGger:ENABled 1

NR5G:DC:PUNCtured 1

NR5G:MCFilter:ENABled 1

NR5G:COMPensate:SYMBol:CLOCk:OFFset 1

INPut:TRIGger:STYLe "External"

INPut:TRIGger:LEVel:EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

NR5G:FRAMe:TRIGger:ENABled 1
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NR5G:DECode:MODE "DecodedTB"

DISPlay:LAYout 3,2 
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