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M9484C VXG Basic Measurements
Overview

The M9484C VXG Vector Signal Generator provides frequency coverage from
9 kHz to 54 GHz, with up to 2.5 GHz RF modulation bandwidth per channel
using an internal baseband generator, and up to 5 GHz RF modulation
bandwidth with channel bonding.

The measurement examples use an X-Series Signal Analyzer to view the
results. A few measurement examples require an N9042B signal analyzer and is
called out in those specific measurement examples. For information on using
the X-Series Signal Analyzer multi-touch user interface, refer to the Online
Help.

Please refer to the VXG data sheet and X-Series Signal Analyzer data sheet to
ensure your measurement setup has adequate power.

https://www.keysight.com/us/en/product/M9484C/m9484c.html

The software versions used in this measurement guide are:

— VXG: A.12.02
— X-Series Spectrum Analyzers/N9085EMOE: A.34.xx or later
— 89601 VSA: Version 2023 or later

M9484C VXG and X-Series SA Measurement Guide
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Equipment Setup

Equipment Setup

— M9484C front panel RF T Out to X-Series Signal Analyzer front panel RF In
— M9484C front panel Event 2 to X-Series Signal Analyzer rear panel Trig 1 In

Trig 3 In is used for an N9040B with Option H1G (1 GHz Bandwidth). For
N9O040B with Bandwidth 510 MHz or less, use Trig 1 In.

— M9484C rear panel 10 MHz Ref Out to X-Series Signal Analyzer rear panel
Ext Ref In

M9484C
(front panel)

X-Series Signal Analyzer
(front panel)
N9042B, N9041B, N9040B,

N9032B, N9030B, or N9021B
(minimum frequency 28 GHz)

M9484C
(rear panel)

For N9040B with Bandwidth of

Trig 3 In is for an N9040B with
Option H1G (1 GHz Bandwidth).
less than 510 MHz use Trig 1 In.

Trigger 3 In

X-Series Signal Analyzer
(rear panel)
N9042B, N9041B, N9040B,

N9032B, N9030B, or N9021B
(minimum frequency 28 GHz)

Trigger 1 In

m9484c2x_series.png
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Required Software

Required Software

— M9484C
— N7631APPC - 5GNR
— N7608APPC - Custom Modulation
— N7605APOC - 3GPP Real Time/Fading

— PathWave Automatic Channel Response Correction and S-parameter
De-embedding (N7653APPC)

12 M9484C VXG and X-Series SA Measurement Guide
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Setting Up Triggers on the X-Series Signal Analyzer

Setting Up Triggers on the X-Series Signal Analyzer

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > Spectrum Analyzer mode.

If accessing the instrument via a Remote Desktop connection, select the
NOTE Screen tab (at the top of the display) to open the

Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. From the dropdown on the top right, select Trigger and set Trigger Source
to Free Run.

ﬁ Trigger

Select Tng Source
Free Run v

| Jdle
Source

= Gate
Video Settings

) Periodic
Line Sync Src

External 1 ﬁi:g;;ﬁ
External 2

RF Burst

Periodic

™
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Basic Measurements

Generating a Continuous Waveform (CW)

This procedure will demonstrate the amplitude and frequency accuracy of the
VXG at RF and pW frequencies.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. In the Output area, set Frequency to 1 GHz and Power to 0 dBm.

These values are coupled to CW Frequency and Total Power (RMS) in the
corresponding RF Output Block.

1.00000000000 GHz

0.00 dBm

3. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

IHHHI\

4. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the X-Series Signal Analyzer:
1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. From the Menu Panel, select Frequency and set Center Frequency to
1 GHz and Span to 1 MHz.

14 M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

3. Select Peak Search.

Observe the accuracy of the amplitude and frequency of the signal.

KEYSIGHT |Input:RF Input Z: 50 Q Atten: 10 dB PNO: Balanced Avg Type: Log-Power 23 4
Coupling: DC Cormections: Off Preamp: Off Gate: Off Trig: Free Run
Align: Off Freq Ref: Int (S) uW Path: Standard IF Gain: Low w
NFE: Adaptive Source: Off Sig Track: Off

1 Spectrum v Mkr1 1.000 000 GHz
Scale/Div 10 dB Ref Level 0.00 dBm -0.02 dBm
1

Center 1.0000000 GHz Video BW 9.1 kHz Span 1.000 MHz,
Res BW 9.1 kHz Sweep 1.00 ms (1001 pts)

On the VXG:
1. Set Output 1 Power to =90 dBm.
2. Ensure that RF Out is On.

On the X-Series Signal Analyzer:

1. Select Amplitude and set Ref Level to =70 dBm and Scale/Div 5 dB.
2. Select BW and set Video BW to 300 Hz.

3. Select Peak Search.

M9484C VXG and X-Series SA Measurement Guide 15
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Basic Measurements

Observe the frequency and amplitude accuracy of the VXG at low power
levels.

ik l A WHMW

[

On the VXG:

1.

Set Frequency to 44 GHz and Power to 0 dBm.

On the X-Series Signal Analyzer:

1.
2.

Select Frequency and set Center Frequency to 44 GHz.

Select Amplitude and set Ref Level to 0 dBm and Scale/Div to
10 dB.

3. Select BW > Video BW and set to Auto.

Select Peak Search.

M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

KEYSIGHT
[rel

 Video BWO.1kHz

Observe the frequency and amplitude accuracy at high frequency levels.

M9484C VXG and X-Series SA Measurement Guide 17
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Using the equivalent SCPI commands
Creating a CW signal on Channel 1.

On the VXG:

SYSTem: PRESet

RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude 0dBm
RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:
FREQuency:CENTer 1GHZ
FREQuency: SPAN 1MHZ

CALCulate:MARKerl :MAXimum

On the VXG:
RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude -90dBm

RF1:0UTPut:STATe ON

On the X-Series Signal Analyzer:
DISPlay:WINDowl:TRACe:Y:RLEVel -70

DISPlay:WINDowl:TRACe:Y:PDIVision 5
BWIDth:VIDeo 300Hz
CALCulate:MARKerl :MAXimum

On the VXG:

RF1:FREQuency:CW 44GHZ
RF1:POWer:AMPLitude 0dBm

On the X-Series Signal Analyzer:
FREQuency:CENTer 44GHZ
DISPlay:WINDowl:TRACe:Y:RLEVel O
DISPlay:WINDowl:TRACe:Y:PDIVision 10
BANDwidth:VIDeo:AUTO ON

CALCulate:MARKerl :MAXimum

M9484C VXG and X-Series SA Measurement Guide
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Generating Amplitude Modulation

The VXG must have the N7642APPC PathWave Signal Generation for 1Q
Based AM, FM, Phase license installed.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

Follow the steps below for AM analog modulation using the internal or an
external I/Q modulation source.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

M9484C VXG and X-Series SA Measurement Guide 19
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RF Out {All) Trigy
o Ly

7

LIU » Group 1: Signal Summary T

Enabled Signal Mode Frequency Offset Attenuation

File: N

5. In the Mode dropdown, select Analog Modulation and then select the
Analog Modulation tab in the left pane.

EEE v @ @ > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

i 0dB
Analog Modulation U e

it Frequency Offset Power

0Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

6. In the Analog Modulation Signal Setup:
a. Set Modulation Type to AM.
b. Set Waveform to Sine.
c. Set Rate to 100 kHz.

. Set Depth to 50%.

o

@ > Group 1: Signal Setup

General Modulation Type Rate

Analog Modulation AM 100.000 0 kHz

Waveform Depth

Trigger

Sine 50.0 %

20 M9484C VXG and X-Series SA Measurement Guide
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7. Select the General tab > Enable.

— EEE Ev @ @ > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

@ cnable

i 0dB
Analog Modulation il b

T Frequency Offset Power

0 Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

Selecting Enable automatically turns on both Output Modulation and
Internal I/Q Modulation as displayed in the Output Modulation block.

8. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

[’ “ ] > Group 1: Signal Summary » Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:
1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to
500 kHz.

M9484C VXG and X-Series SA Measurement Guide 21
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Basic Measurements

3. Select BW and set Res BW to 100 Hz.

w ‘ | ‘
R b \‘MW i H W‘ ’ Il M i W\‘ il ’\ ll MIUMMMJHMMMMMM5M

4, Select Peak Search.

5. Use markers to measure sideband power relative to the center frequency
by selecting Marker Delta. Select Next Pk Right until the second marker is
at the next highest peak.

The Delta Marker should be approximately -12 dB for 50% AM.

KEYSIGHT ImputRE — nputZ:50Q — Atten:10d8  |PNO: Balanc ed 'Avg Type: Log-Power 1234
i o o ate: Off Free Run
IF Gain: Auto
off
AMkr1 100.0 kHz|
-12.32 dB|

IMMMMMMMMWMMWM MMMWMWN MWMWMW l bt H\\u il

Sweep (FFT) ~1
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Using the equivalent SCPI commands

On The VXG:

SYSTem: PRESet
RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude 0dBm
SIGNal:MODE AMODulation
SIGNall:AMODulation:TYPE AM
SIGNall:AM:SHAPe SINE
SIGNall:AM:FREQuency 100KHZ
SIGNall:AM 50

SIGNall ON

RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALL :OUTPut ON

On the X-Series Signal Analyzer:
FREQuency:CENTer 20GHZ
FREQuency:SPAN 500KHZ
BANDwidth 100 Hz
CALCulate:MARKerl :MODE DELTa

CALCulate:MARKerl :MAXimum:RIGHt

Repeat the above command until the marker is at the next highest peak.

To retrieve the delta marker:

CALCulate:MARKerl:Y?

M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

Generating Frequency Modulation

The VXG must have the N7642APPC PathWave Signal Generation for 1Q
Based AM, FM, Phase license installed.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

Follow the steps below for FM analog modulation using the internal or an
external I/Q modulation source.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

» Group 1: Signal Summary

Frequency Offset Attenuation

?
2
?
?
?
?
>
?
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Basic Measurements

5. In the Mode dropdown, select Analog Modulation and then the Analog
Modulation tab.

sss v @ @ > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation
Enable

Analog Modulation 0dB

Analog Modulation

e Frequency Offset Power

0 Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

a. Set Modulation Type to FM.
b. Set Waveform to Sine.

c. Set Rate to 400 Hz.

d. Set Deviation to 10 MHz.

LJ:I_| » Group 1: Signal Summary » Signal 1: Setup

General Modulation Type Rate

Analog Modulation AM ! f PM 400.0 Hz

Trigger Waveform ._De\, iation

Sine 10.000 000 0 MHz

6. Select the General tab > Enable.

— @ > Group 1: Signal Summary > Signal 1: Setup

General Mode Signal Attenuation

@ cnable
Analog Modulation il LEL

Mute
T Frequency Offset Power

0 Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

M9484C VXG and X-Series SA Measurement Guide 25
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Basic Measurements

7. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

|_|_|_| » Group 1: Signal Summary » Signal 1: Setup

8. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:
1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to
50 MHz.

Ay Type. Lug-Power E
w

.

Zenter 20.00000 GHz Video BW 240 Hz
#Res BW 240 Hz

M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

Using the equivalent SCPI commands

On the VXG:

SYSTem: PRESet
RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude 0dBm
SIGNal:MODE AMODulation
SIGNall:AMODulation:TYPE FM
SIGNall:FM:SHAPe SINE
SIGNall:FM:FREQuency 400HZ
SIGNall:FM 10MHZ

SIGNall ON

RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALL :OUTPut ON

On the X-Series Signal Analyzer:
FREQuency:CENTer 20GHZ
FREQuency:SPAN 50MHZ

ACPower :BANDwidth 240 Hz

M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

Generating Phase Modulation

The VXG must have the N7642APPC PathWave Signal Generation for 1Q
Based AM, FM, Phase license installed. The X-Series Analyzer must have
N9063EMOE Analog Demodulation Measurement license installed.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

Follow the steps below for PM analog modulation using the internal or an
external I/Q modulation source.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to 0 dBm.
3. Select the Signal block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

M9484C VXG and X-Series SA Measurement Guide
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(11} I ~— » ~ c c
waw (&) (-] » Group1:Signal Summary
Hbae ) l: | , p 1: Signal Summary

Enabled  Si Frequency Offset Attenuation

?
2
>
>
>
?
>
?

Fading Remain

5. In the Mode dropdown, select Analog Modulation and then the Analog
Modulation tab.

@ > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation
Enable

i 0dB
Analog Modulation S Moclianor
it Frequency Offset Power

0Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

6. In the Analog Modulation Signal Setup:
a. Set Modulation Type to PM.
b. Set Waveform to Sine.
c. Set Rate to 10 kHz.
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General

Analog Modulation

Trigger

M9484C VXG Basic Measurements
Basic Measurements

d. Set Deviation to 1 rad.

General Modulation Type

Analog Modulation A

Mave
Trigger Waveform

Sine

7. Select the General tab > Enable.

LJ:LJ > Group 1: Signal Summary » Signal 1: Setup

Rate

PM 10.000 0 kHz

Deviation

1.00 rad

@ > Group 1: Signal Summary » Signal 1: Setup

Mode

. Enable

Frequency Offset

0 Hz

Sample Rate

Analog Modulation

Signal Attenuation

0dB

Power

0dB

1.280 000 000 000 MHz

Reset Phase Accumulator

8. Close the Vector Modulation Signal Setup by selecting the Home icon at

the top of the display.

> Group 1: Signal Summary > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1

if using a multi-channel VXG.
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On the X-Series Signal Analyzer:
1. From the Menu Panel (on the top right of the display), select Mode/Meas >
Analog Demod mode.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. From the Menu Panel (on the top right of the display), select Mode/Meas >
Analog Demod mode > PM Measurement > Quad View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

4. Select Frequency and set Center Frequency to 20 GHz.

Input Z: 50 O |Atten: 10 dB [LPF- Off Center Freq: 20.000000000 GHz

@ Coupling: DC RCal Preamp: Off HPF: 20 Hz Avg|Hold:>10/10

Align: Off

1 RF Spectrum

Freq Ref: Ext (S) pW Path: Standard BPF: Off Trig: Free Run
Chan BW: 25.000 kHz | Meas Time: 72.0 ms

2 Demod Waveform

Scale/Div 10.0 dB Ref Value 0.00 dBm Scale/Div 1.000 rad Ref Value 0.000 rad

Center 20.00000000 GHz
Res BW 680 Hz

3 AF Spectrum

Start 0.000 s Points 1001 Stop 2.000 ms
4 Mefrics

Scale/Div 10.0 dB Ref Value 6.280 rad

AF Start Freq 0 Hz
AF Res BW 180 Hz

PM Deviation Average Max Hold

Peak+ 8499 mrad 902.7 mra
Peak- -850.4 mrad -807.3 mra
(Pk-Pk)/2 850.1 mrad 905.0 mra
RMS 646.3 mrad 646.5 mra

Carrier Power -8.331dBm SINAD 30.486 dB
Carrier Freq Emr 2.068 mHz SNR 30.486 dB

Mod Rate 10.0000 kHz  Dist/Total Vims 3110 %
AF Stop Freq 20.000 kH
Sk 7 ) %
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Using the equivalent SCPI commands

On the VXG:

SYSTem: PRESet

RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude 0dBm
SIGNal:MODE AMODulation
SIGNall:AMODulation:TYPE PM
SIGNall:PM:SHAPe SINE
SIGNall:PM:FREQuency 10KHZ
SIGNall:PM 1

SIGNall ON

RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.
RFALL :0OUTPut ON

On the X-Series Signal Analyzer:
INSTrument : CONFigure: ADEMOD: PM
SYSTem: PRESet
DISPlay:VIEW:ADVanced:SELect "QUAD"

FREQuency:CENTer 20GHZ
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Generating Synchronized Pulse (IQ + Analog) Modulation

Ensure the equipment and triggers are properly configured. Refer to
NOTE “Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series

Signal Analyzer” on page 13.

You will need to create your own ASCII text marker file and a binary file with
the exact same name. Both files must be stored in the same file folder. For this
example, we will use example files that have been stored on the VXG.

(D) » Users » Instrument *» Documents * Keysight » PathWave » SignalGenerator » Examples v
A [0 Name ~ Date modified Type
[£] 56NR_1CC_FR1_30kHz SC5_100MHz_2560AM_DC ...  9/20/2018 10:53 PM  Text Document

|_] 5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC ... 8/29/2018 11:57 PM  SETX File
| ] SGNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC ... 2019 1:47 AM WFM File

[E] 56MR_1CC_FR2_120kHz_SCS_100MHz_256QAM DC ... 2/20/2019 %:58PM  Text Document

I
1
|_] 5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC ... 2/20/2019 10:01 PM  SETX
|_] 5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC ... 7/14/2019 207 AM  WFM
J 5GMNR_2:x2_MIMO_VXG_Scope_Updated.scp 5 2019 Text Document
| 5GMNR_2x2_MIMO_VXG_Scope_Updated.sebx 5/14/2019 SET
|=] 5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Cor... 2/20/2013 Text Document
1] 5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM Cor.. 7/14/2019 WFM
[] 5GMR_8CC_FR2_120kHz_SCS5_100MHz_256QAM DC ... 2/20/2019 %:05PM  SETX
| ] 5GNR_UXR_Recording_28_GHz.csv ] S\

| 10GHzInDB.s2p

|| 4000_SamplelQPulseOnOff_50% wfm.csv 5/8/20
] 4000_SamplelQPulseOnOff_50%_wfm.wmk 6/3/20
| GSM_1C_BURST_SECUREWAVE.wfm 717,

| simpleAt10GHzINDB.s2p

[] WCDMA_TM1_64DPCH_4C.wim

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set the Frequency to 1 GHz and Power to 0.0 dBm.
3. Select the Signal block to open.

Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
NOTE generators) is installed. For all other option configurations, continue to the
next step.
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. r al Summary
e =) ) | Surmmary

Enabled  Sig Mode Frequency Offset

WOW NV WV VWV WV VYV

Fading

Enable

|_|_|_| > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform File Waveform File 0dB

Trigger Frequency Offset Power
0 Hz 0dB
Markers

Sample Rate
3.000 000 000 D00 000 GHz

Reset Phase Accumulator

6. Select the Waveform File tab (left pane), and then in the Waveform Setup
area, use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathlWave
\SignalGenerator\Examples

and choose
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4000 _SampleQPulseOnOff 50% wfm.csv

then Select.

RFOUt(Al) ~ Trigger

= EEE [Ej_ LJ:LJ » Group 1: Signal Summary > Signal 1: Setup - .1'7

General
s\Instrument . Ke ve\SignalG 3 _Sa DNOff_50%_wf Select »

Waveform File
Nonlinear Correction

Trigger off Configure »

Markers Sample Rate RMS Power Scale Occupied Bandwidth

3.000 000 00O 000 000 GHzZ 1.412 667 100.00 % 0Hz

7. Set the Sample Rate to 2 kHz.

— ~ § RF Out (All)
: Y ] > Group 1: Signal Summary » Signal 1: Setup -

General
eysight\Pat ve\Sig =nerator\Exa s\4000_SamplelC ,e0n0ff_50%_wfm Select »

Waveform File
Nonlinear Correction

Trigger off Configure

Markers CEDEET RMS Power Scale Occupied Bandwidth

2.000 000 000 kHz 1.412 667 100.00 % 0Hz

8. Select the General tab > Enable.

@ > Group 1: Signal Summary » Signal 1: Setup

® b Mode Signal Attenuation
nable

i 0dB
Analog Modulation LTI

Frequency Offset Power

OHz 0dB

Trigger

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

9. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

» Group 1: Signal Summary » Signal 1:S

10. Set RF Out to On by selecting the numbered channel indicator switch.
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This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas >
Spectrum Analyzer mode > Swept SA Measurement > Normal View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. Select Frequency and set Center Frequency to 1.0 GHz and Span to 0 Hz.
4. Select BW and set the Video BW to 300 Hz.

5. Select Sweep and set the Sweep Time to 4.0 s.

yzer 1 o [

KEYS'G HT flnpui: RF Input Z: 50 O ‘Atten: 10 dB EPNO: Fast |Avg Type: Log-Power
L |Coupling: DC Cormr CCorr RCal Pre: Int off, LNA off |Gate: Off Trig: Free Run
@ \Align: Off Freq Ref: Ext (S) MW Path: Standard \IF Gain: Low
NFE: Adaptive | |Sig Track: Off

Scale/Div 10 dB Ref Level 0.00 dBm

enter 1.000000000 GHz ' ' ~ #Video BW 300 Hz
Res BW 3.0 MHz
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Generating a Multitone Signal

This example shows you how to create a multitone signal, which allows you to
separate the usable frequency band into multiple channels. This can make a
signal that is difficult to characterize in the time domain more readable.

The VXG must have the N7621APPC PathWave Signal Generation for
Multitone license installed.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to -10 dBm.
3. Select the Signal block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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=

Enabled  Signal Mode Frequency Offset Attenuation

>
?
>
?
>
?
>
>

Fading

5. Select the Mode dropdown and select Mutitone.

— EEE v @ @ > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation
Enable g

Multitone Multitone )
Trigger Frequency Offset Bower

0Hz 0dB

Sample Rate
60.000 000 000 kHz

Reset Phase Accumulator

6. Select the Multitone tab and set:
a. Set Vector Modulation Signal Mode to Multitone.
b. Set Tones to 15.
c. Set Tone Spacing to 500 kHz.

EEE I‘Ejv |_|:|_| » Group 1: Signal Summary » Signal 1: Setup

General Tones

Multitone 15

Tone Spacing

Trigger

500.000 000 00 kHz

# of Points
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7. Select the General tab > Enable.

E ::: A @ @ > Group 1: Signal Setup

General Mode Signal Attenuation

@ cnable

Multitone Multitone 0dB

et Frequency Offset

0Hz

Reset Phase Accumulator

8. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

['-J'l'] » Group 1: Signal Summary » Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to
10 MHz.

3. Select BW and set Res BW to 300 Hz.

Observe the 15 tones.
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KEYSIGHT frps i

Raf Lovel 0.00 Bm

* Spen 10.00
Swoap 282 ms (1001
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude -10dBm
SIGNall:MODE MTONes
SIGNall:MTONe:ARB:NTON 15
SIGNall:MTONe:ARB:FSP 500KHZ
SIGNall ON

RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:

Change to Spectrum Analyzer mode, Swept SA measurement.

INSTrument : CONFigure: SA: SAN
DISPlay:VIEW:ADVanced:SELect “NORMAL”
FREQuency:CENTer 20GHZ

FREQuency:SPAN 10MHZ
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Setting Up Waveform File Vector Modulation

In this section, we will load a GSM and a LTE waveform into the VXG to
demonstrate the accuracy of the VXG’s vector modulation using error vector
magnitude (EVM) measurement applications available on the X-Series Signal
Analyzer.

The VXG supports all ARB waveforms that are provided on the X-Series
sources. This section will use a few of the ARB files that come with the X-Series
sources.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Group 1: Signals block to open.

' Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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[ 1 » Group 1: Signal Summary

Frequency Offset Attenuation

?
2
>
>
>
?
>
?

Fading

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_|:|_| > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform File Waveform File 0dB

Trigger Frequency Offset Power
0 Hz 0dB
Markers

Sample Rate
3.000 000 000 DOO 00D GHZ

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples
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d. Highlight GSM 1C BURST SECUREWAVE.wfm, then Select.

£ Back

@ Recent 1[‘* D: » Users > Instrument » Documents ) Keysight » PathWave ) SignalGenerator ) Examples

@ Waveforms Name ~ Date Modified

D THE IR 4000_SamplelQPulseOnOff_50%_wfm.csv Aug 23, 2021, 3:19:46 AM Delete

5G_100MHz_1CC_FR1.wfm Aug 22, 2021, 7:43:56 AM
[@ Rename
5G_100MHz_8CC_FR2.wfm Aug 22, 2021, 7:44:04 AM
5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured wfm Aug 23,2021, 3:19:46 AM
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz.wfm Aug 23, 2021, 3:19:46 AM
5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz.wfm Aug 23, 2021, 3:19:46 AM
5GNR_UXR_Recording_28_GHz.csv Aug 23,2021, 3:19:52 AM
GSM_1C_BURST_SECUREWAVE.wfm Aug 23, 2021, 3:19:52 AM
WCDMA_TM1_64DPCH_AC.wfm Aug 23, 2021, 3:19:52 AM

File Properties
Clear Arb Memory Name: GSM_1C_BURST_SECUREWAVE.wfm
‘Sample Rate: 1083333
Scale: 99.0
Signal Attenuation: -10.0 dB
Occupied Bandwidth:  N/A
Required License(s):

Show files of type  All Supported Formats (*:wfm, *.wiq, *.bin, *.csv, *.txt, *.seq, * mat, *hdf, *.h5, *.inc) Vv

e. Select the General tab > Enable.

(1 » Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

@ Enabie

Waveform File Waveform File 0dB

Trigger Power

0dB
Markers

) 000 000 000 MHz

Reset Phase Accumulator

6. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

lJlI % Group 1: Signal Summary % Signal 1: Setup

7. Set RF Out to On by selecting the numbered channel indicator switch.
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This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:
1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to
900 kHz.

3. Select BW and set Res BW to 470 Hz.
4. Select Trace and set Trace Type to Max Hold.
5. Observe the GSM signal.

KEYSIGHT o»:

Aten: 10 4B PNO:Balanced  Avg Type: Log-Power [
Gate:Of

Input Z:50 0
Conections: Off reamp: at AvgHold >100/100
Freq Ref: Int (S) WW Path: Standard  IF Gain: Low Trig: Free Run
NFE: Adaptive ource: Off Sig Track: O

Ref Leve! 0.00 dBm

rdL S/l

Center 20.0000000 GHz Video BW 4.7 kiz Span 900.0 kHz|
#Res BW 470 Hz Sweep 10.6 ms (1001 p‘s)‘

On the VXG:
1. Select the Group 1: Signals block to open.

| Group 1: Signals
File None selected
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2. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

was ~, o = _
- T (&) (] » Group 1:Signal Summary
- &) l: | p 1: Signal Summary

Enabled  Signal Mode Frequency Offset Attenuation

>
?
>
?
>
?
>
>

Fading

Enable

3. Select the Mode drop down menu and select Waveform File and then
select the Waveform File tab on the left side.

AN RF Out (All)
(1] > Group 1:Signal Summary » Signal1: Setup i .'

General Mode Signal Attenuation

P —— Waveform File ~ 0dB

T Frequency Offset Power
0Hz 0dB
Markers

Sample Rate
3.000 000 00D 000 000 GHz

Reset Phase Accumulator
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4, Use File Select to navigate to:
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

RF Out (All)
[ > Group 1: Signal Summary » Signal 1: Setup ;

General
Select >

Waveform File
lied Signal Studio to create waveforms Nonlinear Correction

Trigger Custom Modulation 2( Launch f Configure »

Markers sample Rate RMS Power 2 Occupied Bandwidth

7.680 000 000 000 MHzZ 0.606 600 E 7.680 000 MHz

5. Set the file extension to All Files (*.*), highlight
WDCMA TM1 64DPCH 4C.wfm, then Select.

Recent p D: » Users > Instrument » Documents ) Keysight » PathWave ) SignalGenerator ) Examples

@ Waveforms Date Modified

D This Computer :
MHz_1CC_FR1.wfm Aug 22, 2021, 7:43:56 AM Delete

5G_100MHz_8CC_FR2.wfm Aug 22, 2021, 7:44:.04 AM
[@ Rename

5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured.wfm Aug 23, 2021, 46 AM

SGNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz.wfm Aug 23, 2021, 3:19:46 AM

5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz.wfm Aug 23,202 46 AM

5GNR_UXR_Recording 28 GHz.csv Aug 23, 2021, 3:19:52 AM

GSM_1C_BURST_SECUREWAVE.wfm Aug 23, 2021, 3:19:52 AM

UserCom-2022-01-14_001.csv Jan 14, 2022, 7:51:43 AM

WCDMA_TM1_64DPCH_4C.wfm Aug 23, 2021, 52 AM

Clear Arb Memory File Properties
Name: WCDMA_TM1_64DPCH_4C.wfm

Sample Rate: 26880000.0 Hz
Scale: 99.900002
Signal Attenuation: 0.952698 dB
Occupied Bandwidth: N/A

Regquired License(

Show files of type  All Supported Formats (*:wfm, *.wiq, *.bin, *.csv, *.txt, *.seq, * mat, *hdf, *.h5, *.inc) Vv Cancel
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6. Select the General tab > Enable.

@ > Group 1: Signal Summary » Signal 1: Setup

General = Mode Signal Attenuation
Enable

P Dol celLd At Analog Modulation 0dB

Frequency Offset Power

0Hz 0dB

Trigger

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

7. Ensure that RF Out is on.

On the X-Series Signal Analyzer:

1. Select BW and set Res BW to 620 Hz.

2. Select Frequency and set Span to 30 MHz.
3. Observe the WCDMA signal.

Ref Level 0.00 dBm

|
n..l~|lL\,'1‘l-{J"l. pain ™ "‘"""""’LJ

I el e

Center 20.00000 GHz Video BW 6.2 kHz Span 30.00 MHz,
#Res BW 620 Hz Sweep 204 ms (1001 pts)|
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude 0dBm
SIGNall:MODE WAVeform

SIGN1:WAV " D:\Users\Instrument\Documents\Demo
Waveforms\GSM 1C Burst.wfm"

SIGNall ON
RF1:0UTPut:STATe ON
For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:
FREQuency:CENTer 20GHZ
FREQuency: SPAN 900KHZ
ACPower:BANDwidth 470 Hz

DISPlay:TXPower:WINDowl: TRACe :MAXHold ON

On the VXG:

SIGN1:WAV " D:\Users\Instrument\Documents\Demo
Waveforms\WDCMA TM1 64DPCH 4C.wfm"

SIGNall ON

RF1:0UTPut:STATe ON

On the X-Series Signal Analyzer:
ACPower:BANDwidth 620 Hz

FREQuency:SPAN 30MHZ

M9484C VXG and X-Series SA Measurement Guide
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M9484C and X-Series Analyzer Measurement Guide

2  Corrections

— “Corrections/De-embedding Using PathWave N7653APPC Software” on
page 52

— “Using a Spectrum Analyzer to Make the Corrections Measurement”
on page 58

— “Using a Power Meter to Make the Corrections Measurement” on
page 65

— “Adding Fixture Blocks using s2p Files” on page 52

— “Instrument Nonlinear Correction” on page 71

— “Setting Up an INC 1CC 4 GHz, 10 dBm EVM Measurement” on
page 71

— “Setting Up an INC 8CC 28 GHz, 10 dBm EVM Measurement” on
page 82

KEYSIGHT

TECHNOLOGIES

51



Corrections
Corrections/De-embedding Using PathWave N7653APPC Software

Corrections/De-embedding Using PathWave N/653APPC Software

De-embedding is used to remove the effects of the test fixtures and cabling
from the measurement results. De-embedding uses a model of the test fixture
and mathematically removes the fixture characteristics (cables, connectors
and other passive components) between the source and the device under test
(DUT). Once the desired topology has been characterized, its effects can be
removed from the output signal, moving the effective reference plane to the
point at which the power sensor was connected.

Blocks can be added from supported file formats (.s2p, .csv, .uflat) or by direct
measurement, using one of the supported power sensors (power meter,
spectrum analyzer, or a network analyzer).

The VXG must have the N7653APPC PathWave Automatic Channel
Response Correction and S-parameter De-embedding license installed.

Adding Fixture Blocks using s2p Files

Amplitude and phase can be corrected by adding multiple s2p files as Fixture
Blocks.

An s2p file (also known as a Touchstone file) is an ASCII text file used for
documenting the n-port network parameter data and noise data of linear
active devices, passive filters, passive devices, or interconnect networks. Each
record contains 1 stimulus value and 4 S-parameters (total of 9 values)

The first line in the figure below (# GHz DB R 50) designates:
— (GHz) designates the frequency in Hz, kHz, MHz, or GHz
S) the measurements are in S parameters (rather than Y or Z)

—

— (DB) the values are given in decibel/angle. Instead of DB, you can have Rl
(real/imaginary) or MA (magnitude/angle)

—

50) the characteristic impedance is 50 ohms

152P File: Measurements: s11,521,512,522:
# GHz S DB R 50
9.0 -100 -106 10.0 -160 10.0 -100 -100 -100

9.5 -100 -100 .0 -100 5.0 -100 -100 -100

10.0 -100 -1060 0.0 -108 P.0
10.5 -100 -100 .0 -100 -5.0 :
11.8 -100 -100 8 -1ee 8 -180 -108 -108

If there is not a first line header, the default format is GHz, S-parameters,
and magnitude/angle.

1. Create s2p files in Notepad in the format shown above.
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An s2p example file is included on the VXG. Go to

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\simpleAt10GHzInDB.s2p

2. Select Preset » Preset to set the instrument to a known state.

3. In the VXG Output area, set the Frequency to 10 GHz and Power to
-10 dBm.

10.000 000 000 000 00 GHz

-10.00 dBm

ALC ON

4. Select the Group 1: Signals block to open.

| Group 1: Signals
File None selected

5. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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wss T ~, L c g
waw (&) (=] > Group 1:Signal Summary
Hbae =) l; | p p 1: Signal Summary

Enabled  Si Frequency Offset Attenuation

WOV OV WV OV WV WV YV

Fading

Enable

— @ > Group 1: Signal Setup

General Enable Mode Signal Attenuation

Multitone Multitone )
Trigger Frequency Offset

0Hz

Reset Phase Accumulator

7. From the left pane, select Multitone and set:
— Vector Modulation Signal Mode to Multitone
— Tones to 21
— Tone Spacing to 100 MHz

ass v @ @ > Group 1: Signal Summary > Signal 1: Setup

General

Multitone 2

Tone Spacing

Trigger

100.000 000 000 00 MHz
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11. On the VXG, select the RF Output block > Corrections/De-embedding.

RF Out (All) Tigger
@ > Output 1: RF Output % L}' D v

Power (Total RMS) ALC
-10.00 dBm On V| Auto

@ Enable RF Output

Frequency (CW)
Peak Envelope Power

10.000 000 000 000 00 GHz 1.10 dBm

& ALC Edge Detection On

Phase Transition Mode User Power Limit Channel Gain Headroom

Coherent 0dBm 11.10 dE W Auto

Phase Attenuation Hold Mode Channel Gain Power Reference

0deg Outpu 1 Br ¥ Auto
12. In the Corrections Setup dialog, select Add from File.

@ > Output 1: RF Output

General
Corrections On Absolute Power Corrections Only

Freq and Amp Adjustment

Corrections/De-embedding

~ Embed

Add from File

13. Navigate and select the s2p file and then Select.
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\simpleAt10GHzInDB.s2p

Notice that Block B is added in the Correction Setup diagram.
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RFOut (All)  Trigger
@ @ > Output 1: RF Output - L& ? v [PRESET

General
Corrections On Absolute Power Corrections Only —
: Block B Properties ® Enable
Freq and Amp Adjustment =
3 % File
Corrections/De-embedding

\simpleAt6GHzInDB.s2p >
Optimizations

Deembed

Deembed

Reverse Ports

Add from File Delete Block

14. Turn Corrections On.

View the results on the signal analyzer. Observe how the .s2p file has
impacted the signal.

KEYSIGHT [Input RE Input Z 50 O #Atten 0 dB PNO: Fast Avg Type: Log-Power
Coupling: DC Corrections: Off Preamp. Off Gate: Off Trig: Free Run
':J \Align: Auto Freq Ref: Int (S)  pW Path: Standard IF Gain: High
NFE: Adaptive Sig Track Off

1 Spectrum
| Scale/Div 10 dB Ref Level -20.00 dBm

Video BW 3.0 MHz Span 3.000 GHz|
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15. Add a third block using the same file name as shown in the steps above.
Under Block C Properties, set to Embed.

Block C Properties & Enable

File

..amples\simpleAt10GHzInDB.s2p >

Embed ~

Reverse Ports

View the results on the X-Series spectrum analyzer. Notice that the
corrections are no longer shown. This is because the de-embedded

corrections applied in Block B cancel the embedded corrections applied in
Block C.

Using a Spectrum Analyzer to Make the Corrections Measurement

When using a spectrum analyzer, it must be locked to the VXG Frequency
Reference. This is important because the power measurement can be
inaccurate due to a narrow resolution bandwidth (RBW) used in the spectrum
analyzer. Supported Keysight X-Series signal analyzers are:

— N9Y000A/B CXA

M9484C VXG and X-Series SA Measurement Guide



Corrections
Corrections/De-embedding Using PathWave N7653APPC Software

— NO9OT0A/B EXA
— N9Y020A/B MXA
— NO9030A/B PXA
— NO9040B and N9041B UXA

On the VXG:

1. Connect the VXG 10 MHz Out to the N90x0OA/B Ext Reference In.

2. Connect cable or DUT between the VXG RF Out and the signal analyzer
RF in.

Select Preset > Preset to set the instrument to a known state.
Set the Frequency to 12 GHz and Amplitude to -10 dBm.
Select the Signal block to open.

o g w0

Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

1 > Group 1: Signal Summary

Enabled  Sig Frequency Offset Attenuation

?
2
>
>
>
?
>
?

7. Select the Mode dropdown and select Multitone.
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8. Select the Multitone tab from the left pane and then, configure the signal

to have 501 Tones with 4 MHz Tone Spacing, then select the General tab
> Enable.

|_|_|_| > Group 1: Signal Summary > Signal 1: Setup

General Tones

Multitone =i

Trigger Tone Spacing

4.000 000 000 00 MHzZ

9. Select the Home icon and set RF Out to On by selecting the numbered
channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.
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On the Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas >
Spectrum Analyzer mode > Occupied BW Measurement > OBW Results
View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Set the Center Frequency to 12 GHz and the Span to 3 GHz.

Observe how the fixturing is impacting this signal, including the flatness
and the total power.

KEYSIGHT nput RF -~ inputZ 500 Aften: 10 dB Trig: FreeRun  Center Freq: 12.000000000 GHz
L Coupling: DC Corrections- Off  Preamp: Off Gate: Off Avg|Hold >1010
[:] Align: Off Freq Ref. Ext(S) pW Path: Standard #IF Gain: Low Radio Std: None
NFE: Adaptive
1 Graph
| Scale/Div 10.0 dB Ref Value -30.00 dBm

T P S SR (PO et
T ST PSS

R —— |

Center 12.000 GHz Video BW 50.000 MHZ* ' ' Span 3 GHz
|Res BW 3.0000 MHz Sweep 5.00 ms (1001 pts)

Occupied Bandwidth ]
1.9700 GHz Total Power -17.3dBm

Transmit Freq Error -213.66 kHz % of OBW Power 99.00 %
x dB Bandwidth 2.010 GHz xdB -26.00 dB

d | Jan 30, 2020 G
=I w) fq - ? 1:58:40 PM J: L‘B
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On the VXG:

1. Select the RF Output block > Corrections/De-embedding tab to open the
Correction Setup.

2. Select Block A to highlight > Add from Measurement to open the Measure
Corrections Block Wizard.

A~ REOWAN)  Tgger
(] > Output 1: RF Output - l% ) v s

General
Corrections On Absolute Power Corrections Only

Block A Properties Enable
Freq and Amp Adjustment P v

i e Fil
Corrections/De-embedding A

Optimizations @ __LT‘ E}..‘_ }_

Add from Measurement

Add from File

3. Connect the power sensor (in this case, the X-Series signal analyzer) as
shown in the diagram below. After reading the overview, select Next to
move to the Configure Sensor setup.

RF Out (All)

= @ @ > Output 1: RF Output > Measure Corrections -

Overview

Overview
This wizard will guide you through the simple process of measuring an external network of cables, connectors and other passive components
connected between this source and the device under test.

Configure Sensor SOURCE
Measuring Device

@ p=== Cables/Connectors/Fixtures to be characterized
Measure Corrections

Power meter or
Output 1 spectrum analyzer

Connect the equipment (power meter or spectrum analyzer) as shown in the diagram above. Once the desired topology has been characterized, its
effects can be removed from the output signal, moving the effective reference plane to the point at which the measuring device was connected.

Cancel Next »

4. In the Configure Sensor setup, select the Power Measurement Device
dropdown and select Spectrum Analyzer.

e RF Out (All)
Ll'lJ > Output 1: RF Output » Measure Corrections Ut

Configure Sensor
Overview

: Power Measurement Device Spectrum Analyzer
Use Device List

Spectrum Analyzer Connection Type Hostname or IP Address
Configure Sensor

LAN Test Connection
Start Frequency Power e
Measure Corrections 1.000 000 00O 00O 00 GHz -10.00 dBm Protocol Address

Stop Frequency Number of Steps FhsLIE ¥ st

2.000 000 000 000 00 GHz 10

£ Back Next »
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5. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this
example Start Freq 11 GHz, Stop Freq 13 GHz, Amplitude to the highest
power used in your measurement (For this example, -10 dBm, which we
already set in the main window. If you change the value here, it will update
the value in the main measurement window.) and Number of Steps to 101.

RF Out (All) Trigger
(R > Output 1: RF Output > Measure Corrections g . [Lr

b7

Configure Sensor
Overview

Power Measurement Device Spectrum Analyzer
Use Device List

Spectrum Analyzer Connection Type Hostname or IP Address
Configure Sensor

LAN S| Test Connection
Start Frequency Power
Measure Corrections 11.000 000 000 000 00 GHz -10.00 dBm Pratocol Address

HISLIP hislipo
Stop Frequency Number of Steps i i —

13.000 000 000 000 00 GHzZ 101

Ccancel ¢ Back Next >

6. Set Connection Type to LAN, enter the LAN Address and set the Protocol
parameters to HiSLIP, and then select Test Connection.

A~ : - RF Out (All)
LILJ > Output 1: RF Qutput » Corrections Setup » Measure Corrections [’ 2:‘

Configure Sensor
Overview
Power Measurement Device Spectrum Analyzer
Spectrum Analyzer ~ Connection Type Hostname or IP Address
Configure Sensor
LAN uxa-us90420008 Test Connection

Start Frequency Power
Measure Cofrections 11.000 000 000 00 MHz -10.00 dBm Protocol Address
Stop Frequency Number of Steps ikt b ol

13.000 000 000 000 00 GHz 101

Cancel £ Back

B REFINT Locked Oct 12, 2022, 10:03:44 AM ) Connection Test to Remote Instrument TCPIP:uxa-us90420008: hislip0:INSTR Successful.

7. Once you are successfully connected, select Next to move to the Measure
Corrections step.

8. Select Measure Correction Data.
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During the measurement, the VXG outputs a CW between the Start and
Stop Frequencies for the specified number of steps and output power. It
will take some time to measure all 101 points, and the progress is
indicated by the blue bar. You can watch the signal analyzer as it steps
through this process.

Measure Cormection Data

The measurement results are saved to a csv file using an automatically
generated file name.

9. When the measurement is complete, select Finish, then select Corrections
On.

The output csv file is set to Block A.

Add from Measurement Add from File

A

UserCom-2021-08-17_001

Ma384B

") —F

e

Output 1
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Block A is dedicated for User Correction. The image below shows how
blocks are assigned in the User Correction and Fixture block.

Factory Cal

10. On the signal analyzer, Restart (on the left corner of the user interface)
the measurement (because it is applying averaging). Observe how the
measured corrections impacted the signal. You can easily toggle
Corrections on and off on the VXG to see the difference.

Using a Power Meter to Make the Corrections Measurement
The following USB power sensors can be used for the power measurement.
— UB8487A-CFG0O07
— UB485A-CFG0O06
— U2000A
— U2001A
— U2002A
— U2004A
— U2000B
— U2001B
— U2000H
— U2001H
— U2002H
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On the VXG:
1. Connect the VXG 10 MHz Out to the N90x0OA/B Ext Reference In.

2. Select the RF Output block > Corrections/De-embedding block to open
the Correction Setup.

3. Select the A Block (to highlight) then Add from Measurement to open the
Measure Corrections Block Wizard.

RF O All) Trigger
Y > Output 1:RF O =0 T o, g
utput 1: utput - [% (

General
Corrections On Absolute Power Corrections Only

Block A Properties Enable
Freq and Amp Adjustment P! v

Corrections/De-embedding File

Optimizations @ I ‘

Add from Measurement

Add from File

4. Connect the power sensor as shown in the diagram below then select
Next.

RF Out (All) Trigger

o ) @ @ > Output 1: RF Output > Measure Corrections -

Overview

Overview
This wizard will guide you through the simple process of measuring an external network of cables, connectors and other passive components
connected between this source and the device under test

Configure Sensor SOURCE
Measuring Device

@ ===  Cables/Connectors/Fixtures to be characterized [~
Measure Corrections

Power meter or
Output 1 spectrum analyzer

Connect the equipment (power meter or spectrum analyzer) as shown in the diagram above. Once the desired topology has been characterized, its
effects can be removed from the output signal, moving the effective reference plane to the point at which the measuring device was connected.

Cancel Next »

5. Select Next to go to Configure Sensor dialog and select the Power
Measurement Device dropdown > Power Meter.

. Power Measurement Device Power Meter
Overview

Start Frequency 11.00000000000 GHz Stop Frequency 30.00000000000 GHz

Number of Steps ] 5.00 dBm

Measure Corrections

6. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this
example Start Freq 26 GHz, Stop Freq 30 GHz, Amplitude to the highest
power used in your measurement 5 dBm, and Num Steps to 20.
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7. Select the Connection Type to USB, and then specify the Device and VISA
Address.

8. Select Test Connection to verify connectivity, and then select OK then
Next to continue.

You can also calibrate and zero out the power sensor before measuring
corrections.

9. Select Next to go to the Measure Corrections dialog and select Measure
Correction Data.

Correction measurement

Abort

During the measurement, the VXG outputs a CW between the Start and
Stop Frequencies for the specified number of steps and output power. The
measurement results are saved to a csv file using an automatically
generated file name.

10. Select Finish. The output csv file is set to Block A.

Add from Measurement Add from File

A

UserCom-2021-08-17_001

Ma384B

") —F

e

Output 1
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Block A is dedicated for User Correction. The image below shows how
blocks are assigned in the User Correction and Fixture block.

Factory Cal

11. Select Corrections On to apply.
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Using the equivalent SCPI commands

Using a spectrum analyzer to make the corrections measurement

On the VXG:

SYSTem:PRESet

Set the power level to the highest level used in your measurement.
RF1:POWer:AMPLitude 5dBm

CORRection:PMDevice SANalyzer
CORRection:FLATness:STEP:STARt 26GHZ
CORRection:FLATness:STEP: STOP 30GHZ
CORRection:FLATness:STEP: POINts 20

CORRection:SANalyzer:COMMunicate:TYPE SOCKets

Set the LAN address and protocol parameters for your spectrum analyzer.

CORRection:SANalyzer:COMMunicate:LAN:IP "192.168.1.5"
CORRection:SANalyzer:COMMunicate:LAN:PORT 5025
CORRection:FLATness:CALibrate

CORRection ON

Using a power meter to make the corrections measurement.

On the VXG:
SYSTem:PRESet
RF1:POWer:AMPLitude 5dBm
CORRection:PMDevice PMETer
CORRection:FLATness:STEP:STARt 26GHZ
CORRection:FLATness:STEP:STOP 30GHZ
CORRection:FLATness:STEP:POINts 20
CORRection:SANalyzer:COMMunicate:TYPE USB
Use query CORRection:PMETer: COMMunicate:USB:LIST? foralist of all
connected USB devices.
CORRection:PMETer :COMMunicate:USB:DEVice “instr0”
[Optional] CORRection:PMETer:CALibrate
[Optional] CORRection:PMETer : ZERO

CORRection:FLATness:CALibrate
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CORRection ON

Adding fixture blocks using s2P files

On the VXG:

SYSTem: PRESet

RF1:FREQuency:CW 10GHZ
RF1:POWer:AMPLitude -20dBm

SIGNall:MODE MTONe
SIGNall:MTONe:ARB:NTON 21
SIGNall:MTONe:ARB:FSP 100MHZ

SIGNall ON

RF1:0UTPut : STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:
SYSTem: PRESet
FREQuency:CENTer 10GHZ

FREQuency:SPAN 3GHZ

On the VXG:

Set the path to the s2p data as block 2 (you can use 1 through 4).
CORRection:BLOCk2:FILE "FixtureChannel2"
CORRection:BLOCk2 ON

Add block C with the same file.

CORRection:BLOCk3:FILE "FixtureChannel2"

Change Block C to Embed.

CORRection:BLOCk3:APPLy EMBedding

CORRection:BLOCk3 ON
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Instrument Nonlinear Correction

Instrument Nonlinear Correction (INC) is a digital pre-distortion (DPD) based
correction using a Keysight signal analyzer (N9042B, N9040B, or N9030B) to
compensate for nonlinearities in the VXG. INC is useful in reducing EVM (and
other metrics impacted distortion) at high power levels and extending the
range of the power with linear output of the VXG. INC is a point correction valid
for a given frequency/power/waveform combination and can be used for EVM
and ACP measurements at high power levels (>5 dB). The VXG must have the
N7653APPC PathWave automatic channel response correction and
S-parameter de-embedding license installed.

Instrument nonlinear corrections compensate for nonlinearities in the VXG.
Improvement to EVM will only be seen at power levels where distortion is the
limiting factor. INC will not improve EVM in the area where signal to noise ratio
(SNR) is the limiting factor.

=

—— Limited by distortion

EVM (%)

()

] .
Limited by SNR ——l*h—o—o—o—o—o—o—v—o—“
0

-16 -14 -12 -10 -8 6 -4 -2 0 2 4 6 8 10 12 14 16 18
Set Power (dBm)

Setting Up an INC 1CC 4 GHz, 10 dBm EVM Measurement
On the VXG:

In order to compare before and after correction results, we will start by making
an EVM measurement without applying corrections.

1. Select Preset > Preset to set the instrument to a know state.

2. In the Output area, set Frequency to 4 GHz and Power to
10 dBm.

4.000 000 000 000 00 GHz

10.00 dBm

ALC ON
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3. Select the Signal block to open the Vector Modulation Signal Setup panel.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

(11} r ~— » = c c
waw (&) (-] » Group1:Signal Summary
Hbae ) l: | , p 1: Signal Summary

Enabled < ode Frequency Offset Attenuation

WOW NV WV VWV WV VYV

Fading

Enable

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

5. Set Mode to Waveform File, then select the Waveform File tab in the left
pane.

RF Out (All
(1] > Group 1:Signal Summary » Signal1: Setup i .'

General Mode Signal Attenuation

P —— Waveform File ~ 0dB

T Frequency Offset Power
0Hz 0dB
Markers

Sample Rate
3.000 000 00D 000 000 GHz

Reset Phase Accumulator
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6. In the Waveform Playback Setup area, use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
5G 100MHz 1CC FRI1.wfm

then Select.

£ Back

@ Recent 1[‘* D: » Users > Instrument » Documents ) Keysight » PathWave ) SignalGenerator ) Examples

@ Waveforms Name ~ Date Modified

D THE IR 4000_SamplelQPulseOnOff_50%_wfm.csv Aug 23, 2021, 3:19:46 AM Delete

5G_100MHz_1CC_FR1.wfm Aug 22, 2021, 7:43:56 AM
[@ Rename
5G_100MHz_8CC_FR2.wfm Aug 22, 2021, 7:44:04 AM
5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured wfm Aug 23,2021, 3:19:46 AM
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz.wfm Aug 23, 2021, 3:19:46 AM
5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz.wfm Aug 23, 2021, 3:19:46 AM
5GNR_UXR_Recording_28_GHz.csv Aug 23,2021, 3:19:52 AM
GSM_1C_BURST_SECUREWAVE.wfm Aug 23,2021, 3:19:52 AM
WCDMA_TM1_64DPCH_AC.wfm Aug 23, 2021, 3:19:52 AM

File Properties
Clear Arb Memory Name: 5G_100MHz_1CC_FR1.wfm
‘Sample Rate: 122880000.0 Hz
Scale:
Signal Attenuation: 10.0dB
Occupied Bandwidth: ~ 98280000.0 Hz
Required License(s):

Show files of type  All Supported Formats (*:wfm, *.wiq, *.bin, *.csv, *.txt, *.seq, * mat, *hdf, *.h5, *.inc) Vv

7. Select the General tab > Enable.

LJ:L| » Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation
@ Enabie

Waveform File Waveform File 0dB

Trigger Frequency Offset Power

0 Hz 0dB

Markers

000 000 MHz

Reset Phase Accumulator

8. Select the Home icon and set RF Out to On.
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On the UXA:

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > 5G NR & V2X Mode > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer 5G NR & V2X mode to a
known state.

3. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > 5GNR & V2X Mode > Modulation Analysis
Measurement > OK.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

4. Select Recall (If accessing the X-Series Signal Analyzer remotely, select

the Folder icon at the bottom of the display) Demod Info > Data Type set
to CC Setup > Recall From >
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Signal Studio 5G 100 MHz 1CC FRI1.scp

Recall

Recall from File

1051 PM

211272021 1:46 PM

. | Signal_Studio_5G_100MHz_1CC_FR1.scp

File type.  All Files (* %) Recall

5. The Signal Stuidio_5G_100 MHz_1CC_FR1.scp file automatically sets the
Carrier Frequency to 4 GHz.

6. From the Main menu, select Meas Setup > Advanced tab > Advanced

Demod Setup and set DC Punctured to On, then Close the Advanced
Demod Setup window.

N Component Carrier | CCO
EVM

UL Flatness & IBE Sync Mode CP Auto Cormrelation Calculation

Magnitude & Phese [

Ermor Off
On
1Q Imbalance .
Extended Fequency On e
Lock Range |

jon. |
DC Punctured L
lon Compensat
DC Offset fom CC |4y it kb
Center Symbal Clock Emor | On

Comperston

Cross Carrier

Channel Power 30,0048 Ll
Threshold :

bl o

7. In the Meas Setup window, select the Settings tab > Optimize EVM.
Record the results. For this example EVM is 0.32% and EVM Peak is 1.79%
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5GNR & V2X 1
Modulation Analysis

AlignOff Freq RefExt (S) uW PathBypass

#PNOBest Wide
1 CCO-BWP1 2 CCO-BWP1

tart: 0.00 symbols Stop: 279.00 symbols
4 CCO

KEYSIGHT |nputRF Input Z50 O Atten32 dB TrigFree Run Carrier Ref Freq4.000000000 GHz
L

1Q Meas Time Detected Allocations

Spectrum Raw Main Time

@ CouplingDC Comr CCorr RCal Prelnt off, LNA off #IF Gain: -4 dB CC InfoDL, 1 CC, SISO
Scale/Div 328 subcarriers
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm

Ctr: 4.000000000 GHz Width: 110.6 MHz
Res BW: 100 Hz Info BW: 98.30 MHz Start: 0.00 ns Stop: 22.00 ms|

5 CCO Frame Summary ¥ 6 Error Summary
Power per RE  Num.RB CCO

-26.49 dBm 22 (Channel Power (Active [ Total) 8 A9 dBm / 8 A9 dBm
-26.49 dBm EVM (RMS / Peak) 0.32%/1.79 %

( ] 37 % -26.49 dBm FIEQUETICY N0 (RIS T WOIsl -3 T2 T STUUTIHZ

PBCH DMRS (SS Block 1) 27 % -26.49 dBm Symbol Clock Error 0.000 ppm
H .32 % -26.45 dBm 1Q Offset (SISO) -84 81 dB
-26.45 dBm Time Offset 3314 ms
Sync Correlation 99.6 %

09 £ calle Sync Source SS Block

Freq Error
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KEYSIGHT _nput RF

Coupling: DC
@ Align Auto
| 1 Graph
Scale/Div 10.0 dB

(Center 4.0000 GHz
(#Res BW 100 kHz
2 Metrics v

Total Car Pwr
Total PSD

Offs Freq

A 100.000 MHz
B 200000 MHz

RNl 1k

M9484C VXG and X-Series SA Measurement Guide

7.925 dBm#

Corrections

Instrument Nonlinear Correction

To Measure ACP:

a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK.

b. Select Amplitude > Signal Path tab > and set uyW Path Control to
Low Noise Path Enable (if Option LNP is available on your analyzer).

Record the results for the Lower and Upper ACP results. For this
example -50.9 dBc (lower) and -50.9(upper).

Atten: 8 dB
Preamp: Off

UW Path- LNP, On
PNO: Best Wide

Input Z- 50 O
'Corr CComr RCal
Freq Ref: Ext (S)
NFE: Off

Ref Value 15.00 dBm

Video BW 1.0000 MHz*

Lower
Reference

Jun 30, 2021
22416 PM

Trig: Frea Run
Gate: Off
IF Gain: Low

Measure Trace
Trace Type
Upper
ACP
dBc dBm

-5(0

Carrier Ref Fraq: 4 000000000 GHz
Avg|Hold:=1010

Noisa Comaction: Off

CC Info: DL, 1 CC

| Presel Center Y Scale

'Plﬁe! Adjust
| Attenuation

Span 500 MHz!
Sweep 17.7 ms (5001 pts),

-
Trace Average (

1 -3dB

c. Select Mode/Meas > 5GNR & V2X > Modulation Analysis > OK.

77



General

Waveform File

Trigger

Markers
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On the VXG:

1. Open the Signal block and select the Waveform File tab > Configure to
open the Nonlinear Correction Setup.

RF Out (All) Trigger ’
? v PRESET. v

@ @ > Group 1: Signal Setup

File  CAUser uipa\Documents\Keysight\PathWave\SignalGenerator\Examples\5G_100MHz_1CC_FR1.wfm Select >

Use installed Signal Studio to create waveforms Nonlinear Correction

Digital Video 2020 Update 1.0 v Launch Off Configure »

Sample Rate RMS Power Occupied Bandwidth

122.880 000 000 000 MHz 0.286 585 98.280 000 MHz

2. In the Instrument Nonlinear Correction area, select Measure Correction to
open the Instrument Nonlinear Calibration screen.

[’J’—t] > Signal 1:Setup » Nonlinear Correction

Selected Waveform

‘ C:\Users\folipske . KEYSIGHT\Documents\Keysight\PathWave\SignalGenerator\Examples\5G_100MHz_1CC_FR1.wfm

[ Instrument Nonlinear Correction
To enable, Selected Waveform must

be .inc file. To generate .inc file,
measure or load correction.

Measure Correction Load Correction

\EI DUT Nonlinear Correction

Enable

Mode: Lookup Table

Waveform

3. Under the Receiver tab (opened by default), enter your connection
information and test the connection. For this example, select LAN as the
Connection Type > Enter the IP address for you signal analyzer (for this
example, 141.121.149.32) as the Hostname > Test Connection.
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The Connection status will be displayed in the Notifications area at the
bottom of the main window.

> Ssignal 1: Signal Setup » Nonlines 1 » Instrument Nonlinear Calibration

Calibrations Advanced

Out ——————=RF In

Out > 10M|
141.121.149.32 Test Conneclion

LAN ————— LAN

n will turn on

hislip0

Start Calibration

& REF INT L

4. Select the Calibrations tab and select EVM and ACP for the Calibration
types, then Start Calibration.

RF Out (All
(m > Group 1: Signal Summary » Signal 1:Setup » Nonlinear Correction » Instrument Calibration -

Receiver Calibrations Advanced ST . MR

RF Qut| RFIn
Calibrations Span Offset Max lterations Tolerance
10MHz Ref Out 10MHz Refin

Power 98.280 000 MHz LANH LAN

1’ EVM 98.280 000 MHz -50.00 dB

A Calibration will turn on output
power.

J ACP 08.280 000 MHz 98.280 000 MHz -50.00dB

98.280 000 MHz Start Calibration
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The calibration will take a few minutes to complete. Once done, the INC
file will be created and it will automatically be used in place of the .wfm
file originally loaded. An "I" will be displayed in the Signal block indicating
this status.

| Sional 1
Type S5G_100MHz_1C

[ POWEr U.0UTO0
Status | Playing

On the UXA:
1. Select Optimize EVM.

Note the changes to EVM RMS and EVM Peak values. For this example
EVM RMS is 0.24% (before 0.32%) and EVM Peak is 1.47% (before 1.79%).

KEYSIGHT |Input:RF Input Z: 50 Q Atten: 30 dB Trig: Free Run Carrier Ref Freq: 4.000000000 GHz
L —>— Coupling: DC Corr CCorr RCal Pre- Int off, LNA off #IF Gain: -2 dB CC Info: DL, 1 CC, SISO
Align: Off Freq Ref: Ext (S) uW Path: Bypass
#PNO: Best Wide
1 CCO-BWP1 2 CC0-BWP1
1Q Meas Time Detected Allocations
Scale/Div 328 subcarriers

Start: 0.00 symbols Stop: 279.00 symbol
4 CCO
Raw Main Time

Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm

Ctr: 4.000000000 GHz Width: 110.6 MHz
Res BW: 100 Hz Info BW: 98.30 MHz Start: 0.00 ns

5 CCO Frame Summary ¥ 6 Emor Summary

Power per RE  Num.RB

_26.73 dBm 22 Channal Pawer (Activa [ Total) 2 27 dfe [ 9 27 A0
-26.73 dBm 22 EVM (RMS / Peak) 024 % /147 %
-26.73dBm 42 Frequency Ermor (RMS 7 Worst) -37.U mHz /-588.2 mHz
-26.73 dBm 42 Symbol Clock Error -0.001 ppm
-26.77 dBm 5460 1Q Offset (SISO) -87.11dB
-26.77 dBm 5439 Time Offset 1.262 ms

Sync Correlation 99.6 %

Freq Error =
£00 9 i Sync Source SS Block

To Measure ACP:
a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK.

b. Select Amplitude > Signal Path tab > and set uyW Path Control to
Low Noise Path Enable.
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Note the changes to the Lower and Upper ACP values. For this

example Lower -58.67 dBc (before -50.9 dBc) and Upper
-57.85 dBc (before -50.9).

Input Z: 50 O Anen: 8 dB Trig: Free Run
Comr CCorr RCal Preamp: Off Gate: Off Avg|Hold:>10710
Freq Ret: Bxt (S) uW Path: LNP, On IF Gain: Low Moise Correction: Off
NFE: Off PNO: Best Wide

| PASS [ CC Info: DL, 1 GC P
1 Graph 0 Hz i
Scale/Div 10.0 dB

Ref Value 0.00 dBm Intermal eamp
Full Range

Carrier Ref Freq: 4.000000000 GHz

Off

LW Path Control
LNP Enable

Auto
Man

Center 4.0000 GHz
#

Video BW 1.0000 MHz"

2 Metrics

Total Car Pwr m/98 280 MHz Measure Trace
Total PSD Trace Type Trace Average (Ac
Lower Upper

Reference Reference
Offs Freq

dBm Car# dBc d dBm  Car# Filter
A1 00 MHz H ] - f [4 1 - -49.96 B
B 200.000 MHz 2 6 i 806 27 a

Jun 30, 2021
. 24552 PM
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Setting Up an INC 8CC 28 GHz, 10 dBm EVM Measurement
On the VXG:

In order to compare before and after correction results, we will start by making
an EVM measurement without applying corrections.

1. Select Preset > Preset to set the instrument to a know state.

2. In the Output area, set Frequency to 28 GHz and Power to
10 dBm.

28.000 000 000 000 00 GHz

10.00 dBm

ALC ON

3. Select the Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

1 > Group 1: Signal Summary

Frequency Offset Attenuation

VWOV WV WV WV WYV VY
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5. Set Mode to Waveform File and then select the Waveform File tab in the
left pane.

6. In the Waveform Playback Setup area, use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

5G 100MHz 8cc FR2Z.wfm

then Select.

< Back

® Recent "F D: » Users ) Instrument ) Documents » Keysight > PathWave ) SignalGenerator » Examples

@ Waveforms Name ~ Date Modified

g = compis 4000_SamplelQPulseOnOff_50% wim.csv Aug 23, 2021, 3:19:46 AM s
5G_100MHz_1CC_FR1.wfm Aug 22,2021, 7:43:56 AM

[ Rename
5G_100MHz_8CC_FR2.wfm Aug 22, 2021, 7:44:04 AM

7. Select the General tab > Enable.

@ > Group 1: Signal Summary » Signal 1: Setup

Mode Signal Attenuation

. Enable

i 0dB
Analog Modulation GidEE REediaiog

Frequency Offset Power

Trigger

OHz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

8. Select the Home icon and set RF Out to On.
On the UXA:

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > 5GNR & V2X Mode > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer 5GNR mode to a known
state.
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3. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > 5GNR & V2X Mode > Modulation Analysis
Measurement > OK.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

4. Select Recall (If accessing the X-Series Signal Analyzer remotely, select
the Folder icon at the bottom of the display) Demod Info > Set Data Type
to CC Setup > Recall From >

5G 100 MHz 8CC _FR2.scp

Recall

Se Content
431 KB Scp e

BT KB Scp file

5. The .scp file automatically sets the Carrier Frequency to 28 GHz.

6. Select Meas Setup > Advanced tab > Advanced Demod Setup and set DC
Punctured to On, then Close the Advanced Demod Setup window.

7. Select the Sweep > Single Sweep.
8. Select Meas Setup > Settings tab > Optimize EVM.
It will take a few minutes for the UXA to measure all 8 carriers.

Record the results.
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For this example CCO EVM RMS is 6.21%, EVM Peak is 27.33% and for CC7
EVM RMS is 4.51% and EVM Peak is 15.75%

: ﬁ Amplitude ¥ 5 -
KEYSIGHT Input Z: 50 O Atten: 28 dB Trig: Free Run |Carrler Ref Freq: 28.000000000 GHz Yoch At
Coupling: DC Comr CCorr RCal Preamp: Off #IF Gain: 5 dB CC Info: DL, B CCs, SISO =
. Align Auto Freq Ref Ext (S) W Path- Bypass 28dB
#PNO: Best Wide
v 2 CCT-BWP1
1Q Maas Time

!Y Scale

1 CC0-BWP1
1Q Meas Time

Signal Path

p = 2: 60 kHz NCP 5.948 |-5.948 p=2: 60 kHz NCP
4cCCy

Spectrum Spectrum

écaMDiv 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB

Ref Value 0.00 dBm

Mech Atlen Step
2dB
10dB

Ctr: 27.650000000 GHz Width: 110.6 MHz Ctr: 28.350100000 GHz
Res BW: 377.1 Hz i Res BW: 377.1 Hz Info BW: 98.30 MHz
5 CCO Error Summary ¥ | 6 CCT Error Summary ¥
Channel Power (Active [ Total) -1.73dBm /-1 Channel Power [Active / Total)
EVM (RMS / Peak) 1% /2 EVM (RMS [ Peak)
Frequency Error (RMS / Worst) } Frequency Ermor (RMS / Worst)
Symbol Clock Error 0.012 ppm Symbol Clock Error
IQ Offset 50.82 dB 1Q Offset
5 Time Offset
| Sync Comelation
Sy urce
| Magnitude Error
Jun 29, 2021 |
I3 PM | =

To Measure ACP:

a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK.

b. Select Amplitude > Signal Path tab > and set uW Path Control to
LNP (Low Noise Path) Enable (if your analyzer has Option LNP).

c. Select Sweep > Restart to take a new sweep.
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Note the values of the Lower and Upper ACP. For this example
Lower, at 100 MHz offset is -26.7 dBc and Upper
-27.06 dBc.

KEYSIGHT nput RF Input 7: 50 O Atten: 28 dB Trig: Frea Run (Carvier Ref Freq: 28 000000000 GHz
Coupling: DC Corr CCorr RCal Preamp. Off Gatae: OF Avg|Hold: 10/10
o= Align: Auto Freq Ref: Ext (S) UW Path: LNP, On IF Gain: Low Noise Comection: Off
' PASS | NFE: Oft PNO: Best Wide CC Info: DL, 8 CCs

1 Graph v

Scale/Div 10.0 dB Ref Value 0.00 dBm

:W.E;;h Control
LNP Enable

Auto
Man

Center 28.0000 GHz Video BW 1.0000 MHz" Span 1.198 GHz
FResBW 100 kHz Sweep 42.4 ms (12001 pts)

2 Metrics

Total Car Pwr 6.400 320 MHz Measure Trace ace 1
Total PSD Trace Type Trace Average (Active)
Lower Upper
Reference P Reference
Offs Freq Integ BW dBc c Car# Filter
A 100.000 MHz ~ 98.280 MHz 2217 -27.06
B 200.000 MHz 9 MHz

d. Select Mode/Meas > 5GNR & V2X > Modulation Analysis > OK.
On the VXG:

1. In the Signal block, select Waveform File Mode > Waveform File tab >
Configure to open the Nonlinear Correction Setup.

RF Out (All) Trigger

— H v @ @ @ > Group 1: Signal Summary » Signal 1: Setup . - [i} ?V ERESET)

General
File Jsers\jacquipa\D 1ents\Keysight\PathWave\Signe nerator\Examples\5G_100MHz_8CC_FR2.wfm Select >

Waveform File
Use installed Signal Studio to create waveforms Nonlinear Correction

Trigger Digital Video 2020 Update 1.0 v Launch Off Configure >

Markers Sample Rate RMS Power Scale Occupied Bandwidth

983.040 000 000 000 MHz 0.102 340 85.00 % 983.040 000 MHz

2. In the Instrument Nonlinear Correction area, select Measure Correction to
open the Instrument Nonlinear Calibration screen.

3. Under the Receiver tab (opened by default), enter your connection
information and test the connection. For this example, select LAN as the
Connection Type > Enter the IP address for you signal analyzer (for this
example, 141.121.149.32) as the Hostname > Test Connection.
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The Connection status will be displayed in the Notifications area at the
bottom of the main window.

|"':J » Signal 1: Signal Setup » Nonlinear C: > Instrument Nonlinear Calibration PRESET

receive
Calibrations Advanced Receiver

RF Qut ————» RF In

Hostname or IP A

141.121.149.32 Test Connection
LAN p—————» LAN

A Calibration will turn on outpuf

Start Calibration

5 REF INT 2444 PM _-l"l Connecti Remote Instrument TCP1IP:141.121.149

4. Select the Calibrations tab and select EVM and ACP for the Calibrations,
then Start Calibration.

RF Out (All
(] > Group1:signal Summary > Signal 1:Setup > Nonlinear Correction » Instrument Calibration a 6

M9484C Receiver

Receiver Calibrations Advanced (
RF Qut| RF In
Calibrations Span Max Iterations Tolerance

10MHz Ref Out 10MHz Ref In

Power 983.040 000 MHz LArJL—JMhI

~ EVM 983.040 000 MHz g -50.00 dB

on will turn on output

758.480 000 MHz 870.760 000 MHz -50.00 dB

983.040 000 MHz Start Calibration

On the UXA:
1. Select the Sweep > Restart.
2. Select Optimize EVM.
Note the changes to EVM RMS and EVM Peak values.
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For this example CCO EVM RMS went from 6.21% to 3.13%, EVM Peak
went from 27.33% to 11.68% and for CC7 EVM RMS went from 4.51% to
2.87% and EVM Peak went from 15.75% to 10.55%.

KEYSIGHT |nput RF Input Z: 50 O Alten: 28 dB Trig: Free Run Carrier Ref Freq: 28.000000000 GHz
|Coupling: DC Corr CCorr RCal Preamp: Off #IF Gain: 5 dB CC Info: DL, 8 CCs, SISO
@ Align: Auto Fraq Ref: Ext (S} uW Path: Bypass
#PNO: Best Wide
1 CC0-BWP1 v 2 CCr-BWP1
12 Meas Time 1Q Meas Time

-5.948 W = 2: 60 kHz NCP W = 2: 60 kHz NCP
3CCo

Spectrum ru

Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 0.00 dBm

L Al T L i g adi g " LT L 1 I i
Ctr: 27.650000000 GHz Width: 110.6 MHz Ctr: 28.350100000 GHz Width: 110.6 MHz
| Res BW: 377.1 Hz Iinfo BW: 98.30 MHz Res BW: 377.1 Hz Info BW: 98.30 MHz

I —
| 5 CCO Error Summary ¥ 6 CCT Error Summary ¥

Channel Power (Active / Total) 4.1 dBm Channel Power (Active / Total) -4.26 dBm /-4
EVM (RMS / Peak) 3. EVM (RMS / Peak)
Frequency Error (RMS / Worst) -89 mHz Frequency Emor (RMS / Worst)
Symbol Clock Error -0.001 ppm Symbol Clock Error
1Q Offset 1Q Offset
Time Offset
relation
Sync Source
| Magnitude Emor

To Measure ACP:

a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK.

b. Select Amplitude > Signal Path tab > and set uyW Path Control to
LNP (Low Noise Path) Enable.

c. Select Sweep > Restart to take a new sweep.
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KEYSIGHT c p‘-“.:ﬁ':.}]: De
o e J_L.ign: Auto

1 Graph

Scale/Div 10.0 dB

Center 28.0000 GHz

Total Car Pwr
Total PSD

Offs Freq
A 100.000 MHz
B 200000 MHz

Corrections
Instrument Nonlinear Correction

Note the changes to the Lower and Upper ACP values. For this
example Lower, at 100 MHz offset is -32.27 (before -26.7 dBc) and

Upper -31.15 (before -27.06 dBc).

Input Z: 50 Q
Corr CCorr RCal
Fraq Ref: Ext (S)
NFE: Off

Atten: 28 dB
Preamp: Off

UW Path: LNP, On
PNO: Best Wide

Trig: Free Run
Gate: Off
IF Gain: Low

Carrier Ref Freq: 28.000000000 GHz
Avg|Hold: 10/10

Noise Comection: Off

CC Info DL, 8 CCs

Ref Value 0.00 dBm

Video BW 1.0000 MHz" Span 1.198 GHz

Sweep 42.4 ms (12001 pts)

Measure Trace
Trace Type
Lower Upper
ACP Reference ACP Reference
dBc dBm dBm Car# dBc dBm dBm  Car# Filter
4775 1 2 -4 775 1 dB
4775 1 - 4775 1 3dB

Trace Average (Active)

M9484C VXG and X-Series SA Measurement Guide

weep Time
42 4 ms

Auto
Man

.weep ! easure

Continuous
Single
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M9484C and X-Series Analyzer Measurement Guide

3 Advanced Measurements

— “Channel Bonding” on page 92

— “Generating a Multi-Carrier DVB-S2X Signal for Satellite TV” on
page 93

— “Generating a Wide Band QPSK” on page 107
— “Generating a 5G NR Waveform” on page 116
— “Setting Up 8 Virtual Signal Generators” on page 126
— “Using the VSA Flex Frame to Create a DVB-S2X Signal” on page 136

— “Creating & Analyzing a 5G NR DL 2x2 MIMO Measurement Using Two
UXAs” on page 174

— “Creating and Analyzing a 4x4 MIMO using a UXR Running VSA Software”
on page 196

KEYSIGHT

TECHNOLOGIES
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Channel Bonding

Data requirements are pushing bandwidths and modulation complexity across
many global industries.

— Global data consumption is growing
— |oT drives new data consumption
— Autonomous vehicles require data links

— Satellite networks need to provide 5G backbone in 5G Non-Terrestrial
Networks (NTN)

— New applications generate new sources of data intelligence
The following three examples are showing
— “Generating a Multi-Carrier DVB-S2X Signal for Satellite TV” on page 93
— “Generating a Wide Band QPSK” on page 107
— “Generating a 5G NR Waveform” on page 116
For this measurement example, we are using the following equipment:
— MB9484C with options
— Two channels (M9484C-001 and 002)
— RF bandwidth of 2.5 GHz per channel (M9484C-R25)
— Channel bonding, 5 GHz (M9484C-CB5 and M9484C-PCH)
— PathWave Signal Generation for Custom Modulation (N7608APPC)

— PathWave Automatic Channel Response Correction and S-parameter
De-embedding (N7653APPC)

— Accessories

— Channel Bonding Combiner kit (Y1166A or Y1167A, frequency
dependent)

— N9042B UXA
— Analysis bandwidth of 4 GHz (N9042B-R40)
— 89600 PathWave Vector Signal Analysis software, VSA
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Figure 3-1 Channel Bonding Setup

&l 10 MHz out = Ext Ref In

>

Event 1 out = Trig 1 ln)

Y1166A or
Y1167A

RF out = RF In

Generating a Multi-Carrier DVB-S2X Signal for Satellite TV

DVB-S2X is a digital satellite television broadcast standard. Channel bonding
can be used for UHDTV services where statistical multiplexing is used to allow
many television channels can use the same bandwidth. Other applications
include Direct to Home (DTH), Digital Satellite News Gathering (DSNG) and
professional VSAT.

On the VXG:
1. Connect the equipment as shown above.

2. Select Preset » Preset to set the VXG to a known state.
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If a Synchronization Alignment is required, indicated by in the
bottom left corner, tap or click the warning message and choose Perform

Alignment before proceeding.

b3 5 g ngs
[n] 2 Instrument tings

Instrument Information Global Trigger Synchronization Status

- - . The e globa er for fur s d ct ilizing Global Trigger will be .
1¥0 Configuration s : g - i s nization On

Alignment G ne: ,2022, 01:01:01 AM
" Immediate v

Global Trigger/Sync

Power On/Presel

Reference

1/Q Waveform

Service

Preferences

Perform Alignment Clear Alignment

3. Select the System menu (triple bar icon at the top left of the window), and
then select Configure Channels > 2 Channel Bonded > Add (for 4 channel
instruments only) > Apply > Apply.

RF Out (All)

— EEE [ﬁ @ @ > Configure Channels -

Use the dropdown to configure the available RF Channels into Groups. Any remaining Channels will be set to Independent.

Group Configuration

Independent Remaining RF Channels: 4

1 CHANNEL 2 CHANNELS 4 CHANNELS
Independent 2 Tx Coherent 4 Tx Coherent
2 Channel Bonded (Beta) Nx4 MIMO (Beta)

Nx2 MIMO (Beta)

Cancel

4. Set the Center Frequency to 12 GHz and Power to 0 dBm.
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5. Select the Apps block to open, then select Custom Modulation.

—  [sss ~ RFOut (Al Trigger
— see v E‘IJ > Apps - [% ? v [ereserl v

Keysight PathWave Signal Generation

@ 56 NR @ Custom @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)

Modulation (Beta)

6. In the Custom Modulation setup, select the Carrier tab > Quick Setups >
DVB-S2X > 32APSK > 4+8+4+16APSK 140/180.

@ > Apps : Custom Modulation (Beta)

(> Generate Carrier Waveform
34 Preset |[] Q ps |[» Export 89600 VSA Setup
DVB-S2 >
Custom AS DVB-S2X > 8APSK
Filter APCO25 T16APSK
TETRA 32APSK > 4+12+6APSK Normal 2/3
NXDN 2 64APSK > 4+12+6APSK Short 2/3
dPMR 128APSK > 4+12+6APSK Short 32/45
DECT 256APSK > 4+8+4+16APSK 128/180
DMR 4+8+4+16APSK 132/180

ARIB » 4+8+4+16APSK 140/180

7. From the bottom pane, select Remove Segment to remove the Header.
This will simplify the demonstration.

+ Add Segment — Remove Segment = Move Down
Name Type Number of Symbols Payload Caonstellation Phase Rotation  Shift Bits Per Symbol  Differential Offset
PLHEADER Data a0 180 bits binary data [0001..] QPSK 0 2

Dataseg Data 2000 PN15 DVB-SZX 4+8+4+16APSK 140/180 0 5

FLHEADER DataSeg
0

90 1090 Sym

8. From the left pane, select Custom ASK & PSK & QAM Settings and set the
Symbol Rate to 500 Msps per channel.

Custom IQ Selection 500 Msps

Filter
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9. Select Filter > Alpha to 0.2.

Custom IQ Selection Root Nyquist Vv

Custom ASK & PSK & QAM Settings Aph 0.2

Length(symbol) 32

10. Select the Waveform tab > Basic > Oversampling Ratio to 7 x multiplier
which provides a span of 3.5 GHz.

Each channel is 2.56 GHz for a combined sample rate of 5.12 GHz. This
could be set by entering 5.12 GHz as the User Defined Sample Rate
however; for Multi-carrier it is best to set the Oversampling Ratio.

—_— ase . P
= m B () > Apes
i Apps 56NR % Custom Modulation (Beta) *

(%, Generate Carrier Waveform

Custom Modulation
Marker

Oversampling Ratio

Crest Factor Reduction

11. From the left pane, select Multi Carrier and select Multicarrier Enabled.

12. Open the Frequency Offsets setup screen. For Carrier Index O, set the
Frequency Offset to -1200 MHz, then select Add Rows.

- Add {- Add Rows

Carrier Index Frequency Offset (MHz) Power Offset (dB)

0 -1200
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13. Enter the 1st Frequency Offset of -600 MHz, # of Carriers 4, and Carrier
Spacing 600 MHz. Select Add.

+ Add + Add Rows

1st Frequency Offset -600 MHz

# of Carriers A4~

Carrier Spacing

600 MHz
Add

Carrier Index Frequency Offset (MHz) Power Offset (dB)

-1200

All five carriers will be setup. Select OK to close the Frequency Offsets
dialog.

-+ Add — Remove Clear -} Add Rows

Carrier Index Frequency Offset (MHz) Power Offset (dB)

-1200 0

-600 0

0 0

600
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14. Generate the waveform and select the Spectrum tab from the bottom
pane to ensure the resulting waveform is correct.

(R] > Apps

Custom Modulation (Beta)

Carrier Waveform

Multicarrier Enabled

Number of Carriers

Crest Factor Reduction

Correction

Routing

Power Offsets

Random
0

-1.2GHz,-600MHz,0Hz,600MHz,

0,0,0,0,0

RF Out (All)

[« Import Signal Setup [+ Export Signal Setup

15. Select the Home icon to return to the main window and then select the

Signal Block to open.

16. In the Signal Setup dialog box, notice that new custom modulation file is
already selected (CustomMod G1S1.wfm). Set the Occupied Bandwidth

to 3 GHz.

Waveform Playback Setup

3.500 000 000 000 000 GHz

0.328 625 952 3.000 000 00O 000 GHz

Group 1: Signal
Type CustomMod_G1S1.wim

Power 0.328 625 952
Status Disabled

Configure Channel Bonding »

25.000 000 000 00 GHz T

(o8]
2

0.00 dBm

RF Qut (All}

Triggering & Markers

j Trigger
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17. Select Configure Channel Bonding and configure the Hostname or IP
address for the UXA, then Test Connection. Ensure that you have
successfully connected to the UXA, a message will be displayed in the
Status area at the bottom of the display.

RF Out (All) ~
|'_| u > Group 1: Signal Setup » Channel Bonding Setup u- [T ¢ PRESET
5 1 Y

Receiver Calibrations Advanced M aztolile

O RF In
Connection Type Hostname or IP Address
10MHz Ref Out 10MHz Refin

1
LAN USB uxa-us90420008 Test Connection
N | ‘ LAN

Protocol Address L

HiSLIP ~ hislip0
A Calibration will turn on output
power.

Start Calibration

Group 1: Signal
12.000 000 000 00 GHz

Type CustomMod_G151.wfm
Power 0.325 538 612
Status Disabled 0.00 dBm

B REF INT Locked Oct 10,2022, 12:25:11 PM @ Connection Test to Remote Instrument TCPIP:uxa-us90420008::hislip0:INSTR Successful

18. Select the Calibrations tab and clear the ACP calibration.

In some cases it is not possible (or necessary) to improve the ACP of the
bonded waveform. In these cases, it is best to disable it.

— If the ACP cannot be improved, in some cases, the highest fidelity
bonded waveform will result from Bonding with ACP disabled.

— ACP increases the time it takes to perform Bonding, and if the
receiver does not have sufficient analysis bandwidth to cover the
ACP regions + modulated bandwidth of the waveform, then
frequency-stitching will be performed and this will further increase
the Bonding time.

— With ACP enabled, the resulting signal will typically have
significantly increased bandwidth, sample rate, and number of
samples (as compared to a Bonded signal with ACP disabled).
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Span

5.000 000 000 GHz

5.000 000 000 GHz

5.000 000 000 GHz

— Note that the available ACP region bandwidth is limited by the
bandwidth of the source, so if the available source
bonded-bandwidth is 5 GHz, and the bonded waveform is 5 GHz,
then there is no available BW for performing an ACP calibration.

RF Out (All) Trigger )
4 Y [ir e PRESET

b7

M9484C Receiver

Ll‘lJ > Group 1: Signal Setup » Channel Bonding Setup

Calibrations Advanced

" Combiner Qut———» RF In
Offset Max Iterations Tolerance
10MHz Ref Out——» 10MHz Ref In

0.10dB LAN —{LAN

-50.00 dB
A Calibration will turn on output
power,

-50.00 dB

Start Calibration

19. Select the Advanced tab and set Compaction Off, then Start Calibration.

Source

When the waveform length is short enough, compaction is not needed.
However, for 5G signals (which tend to be relatively long and have a lot of
IQ samples), the calibration time can be long (without compaction). So for
signals with lots of IQ samples, the suggestion is to use compaction as this
will reduce the calibration time. The calibration takes a few minutes to
complete. However, the highest fidelity bonded waveform may result
without compaction. How much compaction to use can be optimized
(none, automatic, or a specified compaction level) by experimenting with
the different settings.

LF.J > Gro
Calibrations Advanced

Calibration Memory Model

19 DC Alignment T - : LAN [ ——P{LAN

A Calibration will turn on output |

Start Calibration

The calibration takes a few minutes to complete.
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Notice that the CustomMod_G1S1.bnd waveform is now playing.

:_Group 1: Signal

Type CustomMod_G1S1.bnd
Power 0.347 909 875
Status [ Playing

On the Signal Analyzer:

1. Select Frequency > Auto Tune to observe the spectrum.

Ensure that signal analyzer is set to Spectrum Analyzer mode > Swept SA
Measurement > View Normal.

+ . Frequency

KEYSIGHT [nputRF \Input Z: 50 O Atten: 6 dB PNO: Fast \Avg Type: Log-Power
L

Coupling: DC |Corr CCormr RCal Pre: Int off, LNA off Gate: Off Trig: Free Run
@ Align: Off \Freq Ref: Ext (S) uW Path: Standard IF Gain: Low
NFE: Adaptive Source: Off Sig Track: Off
i Snedum z S 827526300 GHz

Sl.:aflefDiv 10dB Ref Level -7.00 dBm £3.97 C Swept Span
Y T T Zero Span

| . Full Span

Start Freq
20.863069572 GHz

Stop Freq
29.138332574 GHz

CF Step
827 526300 MHz

Auto
Man

req Offset |
0Hz

Axis Scale
Log
Lin

Center 25.001 GHz Video BW 3.0 MHz Span 8.275 GHz|
Res BW 3.0 MHz Sweep ~15.5 ms (1001 pts)|

2. Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.
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Mode / Measurement / View Selector

1Q Analyzer {|

When Sequencing is On and

there are multiple Screens, all Vector Modulation Analyzer
Screens update in sequence. S
When Sequencing is Off, only i

the selecled Screen updates. SGNR

Power Amplifier

LTE FDD & NB/eMTC & V2X
LTETDD & LTE-ATDD
Phase Noise

W-CDMA with HSPA+
Analeg Demod

Bluetooth

To launch 89600 VSA press the button below.
EMI Receiver

Launch VSA
Remote Language Compatibility

HYOUU SoTware Version
2022 v SCPI Language Compatibility

3. In the Spectrum window, select Center frequency and set to 12 GHz, then
select Auto-range.

File Edit Soawc Input  MeasSetup  Trace Markers  Window

Il \E | ange To Peak Power (Defautt) = g e 2 il A B EvalustehiRSpeed

Measurement running I Beta Features In Use: 1 I EXT REF I CAL OK
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4. From the menu bars, select MeasSetup > Measurement Type: Vector >
General Purpose > Custom I1Q.

File Edit Control Source Input MeasSetup @Trace Markers Window  Utilities
Il ( Frequency... f) = o (51
ResBW...
A: Ch1 Specti Time...
Rng Average...

4
dBm Frequency vs. Time...

Time vs. Time...

LoaMag New Measurement

Duplicate Measurement

Measurements...

Measurement Type: Vector ¥ | Vector
Power Spectrum Analysis
Analog Demod General Purpose
Digital Demod Cellular
Custom 1Q Wireless Connectivity
| B: Ch1 Main Time | Custom OFDM Radar Analysis
i Rng 501 11.3- Channel Quality Other standard formats
Channel Sounding

Flex Frame
g i
Loghag

5. Select MeasSetup > Custom IQ Demod Properties.
a. In the Format tab, select Constellation Edit.
B® Meas01 - Custom IQ Demed Properties ? X
Format Filter Advanced
Save As Quick Setup... Quick Setups...
Constellation  DVB-52X 4+8+4+168APSK 140-130 Edit... Recall...

Symbol Rate 500 MHz

Result Length 500 Symbols

Search Length 5 ms

Pulse Search Enable

Pattern Search Enable

b. Select Preset to Standard Constellation > DVB S2X APSK > 32APSK
(4+8+4+16) > 32APSK 7/9. This is equivalent to the 4+8+4+16APSK
140/180 setting we chose in the Custom Modulation setup.
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c. Select OK to close the Constellation Edit dialog.

stom|Q Meas Time « % | C:Ch1 CustomlQ Err Vect Time ~

2% Constellation Editor

Nermalize RMS

User-defined Symbols ~

Precet To Standard Constellation...

Magnitude

p
8126397173626 | 0.22971334409037113 [450  [o000 |
1 a0 450

1990

d. Turn off Pulse Search Enable (checkbox cleared).

e. Set the Result Length to 2000 Symbols.

Set the Symbol Rate to 500 MHz. The Result Length and Symbol
Rate will adjust the resolution bandwidth to better define the
waveform.

E Meas01 - Custom IQ Demod Properties ? *
Format Filter Advanced

Save As Quick Setup... Quick Setups...

Constellation [ 8 6 } 80 Edit... Recall...

bol Rate | 500 MHz

Result Length | 2 ymbols

Search Length  5prs

Pulse Search Enzble

Pattern Search Enable
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g. Select the Filter tab and set Alpha/BT to 0.2, Filter Length to 33,
and Equalizer Type to Minimize EVM. Close the Custom IQ Demod
Properties window and notice the center carrier is now being
demodulated.

P MeasD1 - Custorn 1Q Demo.., ? *
Format Filter Advanced
Measurement Filter | Root Raised Cosine =

Reference Filter Raised Cosine hd

Alpha/BT 02

Equalizer
Minimize Error Vector ~
Filter Length
Convergence 1E-06
Adaptive Operations
Equalizer Mode
® Run

Hold

6. In the CustomIQMeas Time window, click on I-Q and change to
Constellation, if desired.

A: Ch1 Customl( Meas Time ~ E Ch1Time

Single

Stack 2
Stack 3
Stack 4
Stack b
Gnd £
Grid

Grid
Custom...

Tile Visible
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8. Note the measured EVM value in the CustomIQSyms/Errs window. For this
example, 1.2%rms.

B Custom 1Q - Keysight 89600 V5A Suftware - Press the Mude key Lo swilch applications X

File Edit Contre Source Input MeasSetup Trace Markers Window  Utilities Help
||| »»= "\ RangeToPeak Power (Defautt) ~ om [ W oS- It 3 |E il 19 & il A

A: Ch1 CustomIQ Meas Time ~ E:Chl Time X | C:Chl CustomIQ Err Vect Time

Linkag

~+ % D:Ch1 CustomIQ Syms/Errs

106 M9484C VXG and X-Series SA Measurement Guide



Advanced Measurements
Channel Bonding

Generating a Wide Band QPSK

On the VXG:
1. Connect the equipment as shown in Figure 3-1 on page 93.
2. Select Preset > Preset to set the VXG to a known state.

3. Select the System menu (triple bar tab at the top left of the window), and
then select Configure Channels > Group 1:2 Channel Bonded > Add (for 4
channel instruments only) > Apply.

RF Out (All)

EEE E @ @ > Configure Channels -

Use the dropdown to configure the available RF Channels into Groups. Any remaining Channels will be set to Independent.

Group Configuration

Independent A Remaining RF Channels: 4

1 CHANNEL 2 CHANNELS 4 CHANNELS
Independent 2 Tx Coherent 4 Tx Coherent
2 Channel Bonded (Beta) Nx4 MIMO (Beta)

Nx2 MIMO (Beta)

Cancel

4. Set the Center Frequency to 12 GHz and Power to 0 dBm.

5. Select the Apps block to open, then select Custom Modulation.
= |21 83

D Apps

Keysight PathWave Signal Generation

# Applications

5G NR

Custom Modulation (Beta)
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6. In the Custom Modulation setup, select the Carrier tab > Quick Setups >
DVB-S2 > QPSK.

_. :- > Apps

¥ custom Modulation (Beta) *

(*, Generate Camier  Wavefc
iy Preset [] QuickSetups [ Export 89600 VSA Setup
QPSK
Custom AS 8PSK
Filter > 16APSK >

32APSK >

7. From the bottom pane, select Remove Segment to remove the Header.
This will simplify the demonstration.

8. From the left pane, select Custom ASK & PSK & QAM Settings and set the
Symbol Rate to 3 Gsps per channel.

Custom IQ Selection

Filter

9. Select Filter > Alpha to 0.2.

Custom IQ Selection Filter Root Nyquist v

Custom ASK & PSK & QAM Settings 0.2

Length(symbol) 32

10. Select the Waveform tab > Basic > Select User Defined Sample Rate and
set Sample Rate to 5.12 GSa/s.

Each channel is 2.56 GHz for a combined sample rate of 5.12 GHz.

B 56NR ™ Custom Modulation (Beta)

(%, Generate Waveform

Custom Modulation

Marker v

Sample Rate 5.12 GSa/s

Crest Factor Reduction

108 M9484C VXG and X-Series SA Measurement Guide



Advanced Measurements
Channel Bonding

11. Generate the waveform and select the Spectrum tab from the bottom
pane.

(%, Generate Carrier ‘Waveform [+ Import Signal Setup [+ Export Signal Setup

Marker ser De d Sa e Rate @
Crest Factor Reduction 5.12 Gsa/s

1
Multi Carrier

Correction
faveform Length

Mirror Spectrum

Spectrum | CCDF

rerey - WW%W

12. Select the Home icon to return to the main window and then select the
Signal Block to open.

13. In the Signal Setup dialog box, notice that new custom modulation file is
already selected (CustomMod G1S1.wfm).

14. Set the Occupied Bandwidth to 3.6 GHz (or 1.2 x 3 GHz) and the Sample
Rate to 5.12 GHz Samples per second.

15. Select Configure Channel Bonding and configure the Hostname or IP
address for the UXA, then Test Connection. Ensure that you have
successfully connected to the UXA.
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16. Select the Calibrations tab and clear the ACP calibration.

RF Out (All) Trigger

E Ev @ @ > Group 1:Signal Setup » Channel Bonding Setup = [%. 7 v [PRESET| v/

Receiver Calibrations Advanced LEEE ecaivan

Combiner Qut ——»RF In
Calibration Span Offset Max Iterations Tolerance

10MHz Ref Out ——>10MHz Ref In

Power 4.915 200 000 GHz 0.10dB LAN [—P{LAN

V| EVM 4.915 200 000 GHz -50.00 dB
A Calibration will turn on output power.

42.400 000 MHz 2.478 800 000 GHz -50.00 dB

4.915 200 000 GHz

Start Calibration

| Group 1: Signal |

Type NRSG_G1S1.wfm
Power 0.246 430 036
Status Disabled

12.000 000 000 00 GHz

17. Select Start Calibration.

The calibration takes a few minutes to complete. Note that the VXG
displays an Invalid file selection message. This is because the VXG
no longer sees the .wfm waveform instead the newly calibrated waveform
has a .bnd file extension.

Notice that the CustomMod_G1S1.bnd waveform is now playing.

Group 1: Signal

Type CustomMod_G1S1.bnd

Power 0.347 909 875
Status [»Playing
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On the Signal Analyzer:

1. Select Frequency > Auto Tune to observe the spectrum.

| ﬂ ‘ Frequency

| Center Frequency
11991328814 GHz |

KEYS'GHT Input: RF Input Z: 50 Q Amen: 6 dB PNO: Fast
| L Coupling: DC Corr CCorr RCal Pre: Int off, LNA off Gate: Off
Align: Off Freq Ref Ext (S) uW Path:- Standard IF Gain: Low
NFE: Adaptive Sig Track: Off

- = !. an
1 Spectrum v Mkri 11.091 G} aprseﬁsam GHz

Ref Level -5.00 dBm 24.42 \iBmI P —

‘ Zero Span

Full Span
1arf Freq :
7.608044811 GHz

‘Stop Freq
| 16.374612817 GHz

Avg Type: Log-Power 1|2 4
Trig: Free Run

Scale/Div 10 dB

AUTO TUNE

\CF Slep
876.656801 MHz
Auto

| i Freq Offset

Video BW 3.0 MHz

Span 8.767 GHzi
Sweep ~16.1 ms (1001 pts)|

2. Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.
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3. In the Spectrum window, set the Center Frequency to 12 GHz and
Auto-range.

e Input  MeasS Trace  Markes

ange To Peak P

SR I 3T

B EvalusteNRSpeed

Center

B: Ch1 Main Time

Markers

Measurement running

I Beta Features In Use: 1 I EXT REF I CAL OK

4. From the menu bar, select MeasSetup > Measurement Type > General
Purpose > Custom 1Q.

5. From the menu bar, select MeasSetup > Custom IQ Demod Properties.
a. Select the Format tab and select Constellation Edit.
b. Select Preset to Standard Constellation > PSK > QPSK.
c. Select OK to close the Constellation Edit dialog.

5 Constellation Editor

?
Name PSK Constellation Graph
Symmetry 1
Magnitude RMS Mormalize RMS
Symbol Mapping State Indexes

Constellation States

Add Inset Delete Copy Preset To Standard Constellation...

4 Inde Q M de Phase ol
I O N Y "N
1 6. 7691118863E-17 1 1 0001

1.2246063538223773E-16 1
E-16 -1

1

02 0 04 06 08 1

Show Symbols
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d. Turn off Pulse Search Enable (checkbox cleared).

e. Set the Symbol Rate to 3 GHz.

Format Filter Advanced

Save As Quick Setup... Quick 5etups...

Constellation Edit... Recall...

Symbol Rate || 3 GHz

Result Length | 20

Pulse Search Enabile

Pattern Search Enable

f. Select the Filter tab and set Alpha/BT to 0.2, Filter Length to 33,
Equalizer Type to Minimize Error Vector, and Reset the Filter.

P Meas1 - Custom 1Q Deme..  ? *
Format Filter Advanced
ement Filter  Root Raised Cosine ~
Reference Filter Raised Cosine hd
Alpha/BT 0.2
Equalizer
Equalizer Type ~ Minimize Error Vector =

Filter Length

VErgence 1E-06

ve Operations
Equalizer Mode
® Run

Hold
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6. View the results.

(B Custom 1Q - Keysight 89600 VSA Saftware - Press the Mode key ta switch applications

114

7. In the menu bar, select the Trace Layout icon and select the Grid 2 x 2

format.

cm 3 WEE-l.r
Previous Layout
Single
Slack 2
Stack 3
Stack 4

Stack b

Gnd £

Grid 2x3
Grid 3x2
Custom...

Tile Visible

This allows you to view more measurement details like the EVM results,
which for this example is ~1.6 %rms.
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File Edit Control Source Input MeasSetup Trace Markers Window  Utilities Help
||| »»= "\ RangeToPeak Power (Defautt) ~ s [ A 35 22 1l A

rr Vect Time

D: Ch1 CustomIQ Syms/Errs
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Generating a 5G NR Waveform

On the VXG:

1. Connect the equipment as shown in Figure 3-1 on page 93.

2. Select Preset » Preset to set the VXG to a known state.

If a Synchronization Alignment is required, indicated by in the
bottom left corner, tap or click the warning message and choose Perform

Alignment before proceeding.

instrument Information Synchronization Status

f fi i e fur els utilizing Global Trigger will be .
1/0 Configuration ilizing Global Trigger wi W
Alignment

" Immediate
Global Trigger/Sync
Power On/Preset
Reference
A9 el Synchronization Alignment

Service

Preferences

Perform Alignment Clear Alignment
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3. Select the System menu (triple bar tab at the top left of the window), and
then select Configure Channels > Group 1:2 Channel Bonded > Add (for 4
channel instruments only) > Apply > Apply.

= RF Out (All)
= EEE E @ @ > Configure Channels -

Use the dropdown to configure the available RF Channels into Groups. Any remaining Channels will be set to Independent.

Group Configuration

Independent Remaining RF Channels: 4

1 CHANNEL 2 CHANNELS 4 CHANNELS
Independent 2 Tx Coherent 4 Tx Coherent
2 Channel Bonded (Beta) Nx4 MIMO (Beta)

Nx2 MIMO (Beta)

Cancel

4. Set the Center Frequency to 12 GHz and Power to 0 dBm.
5. Select the Apps block to open, then select 5G NR.

RF Out (All) Trigger

= |#| © Q) > Ao - 7 - =

Keysight PathWave Signal Generation

@ 56 NR @ Custom @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)

Modulation (Beta)

6. Select the Carrier tab.
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7. Select Full-Filled Config and set Bandwidth to FR2 400 MHz, and then
select OK.

Fullfilled Preset Config

Bandwidth FR2 400MHz

Numerology p=3:120 kHz

V' Duplex Type

Modulation

Cancel

Full Filled Configurations is a great place to start creating your waveform.
You can select FR, bandwidth, and modulation format with a fully
allocated PDSCH data channel. This would represent a spectrally correct
signal that is typically used in power amplifier measurements. You can
modify the RB allocations and Slot allocations if fully allocated data
channels are not desired.

8. Select DL Test Model to open. set Bandwidth to FR2 400 MHz and set
Phase Compensation to Off, and then select OK.

NR-FR2-TM1.1
Bandwidth
anawi N = Radiated transmit power
= BS output power
« Transmit ON/OFF power
* TAE
= Unwanted emissions
Duplex Type DD gchL;{med bandwidth
o Operating band unwanted
emissions
Transmitter spurious
emissions
= Receiver spurious emissions

Numerology p=3:120 kHz

Test Model NR-FR2-TM1.1

Number of Layers

DCI/DLSCH Payload Data
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9. Select the Waveform Tab, and set the Time Scale Factor to 10.

Carrier Waveform

Capability Waveform Playback -

Total Number of Antennas 1
Required License Version Date

3GPP Version

User-Defined Sample Rate

Sample Rate

Time Scale Factor

Subframe Offset

CDF

10. Generate the waveform and select the Spectrum tab from the bottom
pane. The waveform will take a moment to finish generating.

RF Out (All)

(%, Generate Carrier Waveform
[-+ Export 89600 VSA Setup

Total Number of Antennas
Marker Required Lic Version Date

Crest Factor Reduction Waveform Comment

AWGN
ample Rate

Routing
Sample Rate

Number of Radio Frames

Subframe Offset

CCDF
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11. Select the folder icon in the right corner of the display, and select Export
Signal Setup (*.scp) file. In the File Name field, create a name for the
setup file, then select Enter. Note the location where you saved this file as
you will need to copy it to the UXA.

i New

~ Open
il Save As

+ Export Waveform

Import Signal Setup (*.scp)

-+ Export Signal Setup (*.scp)

12. Select Export 89600 VSA Setup. In the File Name field, create a name for
the setup file, then select Enter. Note the location where you saved this
file as you will need to copy it to the UXA.

RF Out (All) Trigger

e
= s v (q] > Apps:56NR

& Generate Carrier Waveform

[+ Export 89600 VSA Setup

Total Number of Antennas

To copy the two setup files to the UXA:

a. Select the System menu icon (triple bar), then Switch to Windows.

b. Select the Windows icon (bottom left corner), open File Explorer
and navigate to the setup files and Copy both files.

c. Onthe UXA, select the Windows icon, open File Explorer and Save
the two setup files.

d. On the VXG, select the PathWave SG icon in the Desktop to restore
the PathWave application.

13. Select the Home icon to return to the main window and then select the
Signal Block to open.

14. In the Signal Setup dialog box, notice that new custom modulation file is
already selected (NR5G G1S1.wfm).

15. Select Configure Channel Bonding and configure the Hostname or IP
address for the UXA, then Test Connection. Ensure that you have
successfully connected to the UXA.
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16. Select the Calibrations tab and clear the ACP calibration, then select
Start Calibration.

RF Out (All) Trigger

E ::: v @ @ > Group 1:Signal Setup » Channel Bonding Setup - % '? v EBR-

_ Mo4g4C _ Receiver
Combiner Qut ——»RF In

Receiver Calibrations Advanced

Calibration Span Max Iterations Tolerance
10MHz Ref Out ——3» 10MHz Ref In

Power 4.915 200 000 GHz 0.10dB LAN [€—P{LAN

V| EVM 4.915 200 000 GHz -50.00 dB
A Calibration will turn on output power.

42.400 000 MHz 2.478 800 000 GHz -50.00 dB

4.915 200 000 GHz
Start Calibration

Group 1: Signal

Type NRSG_G1S1.wfm
Power 0.246 430 036
Status Disabled

12.000 000 000 00 GHz

On the Signal Analyzer:

Below are two methods for viewing the results of the 5G NR wideband
waveform.

— Using X-Apps 5G NR & V2X Modulation mode Modulation Analysis
measurement

— Using 89600 VSA
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Using X-Apps 5G NR & V2X 1 Mode
1. Select Frequency > Auto Tune to observe the channel bonded signal.

KEYSIGHT nput:RF Input Z: 50 O Alten: 6 dB PNO: Fast Avg Type: Log-Power
Coupling: DC Cormr CCorr RCal Pre: Int off, LNA off Gate: Off Trig: Free Run
Align: Auto Freq Ref: Ext (S) pW Path: Standard IF Gain: Low
NFE: Adaptive Sig Track: Off {N NNRNN
1 Spectrum Mkr1 13.759 GHz
Scale/Div 10 dB Ref Level -9.00 dBm -32.48 dBm

Center 12.000 GHz Video BW 3.0 MHz Span 10.86 GHz
Res BW 3.0 MHz Sweep ~20.2 ms (1001 pts)

2. From the N9042B select Mode/Meas > 5G NR &V2X Mode > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

3. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known
state.

4. From the N9042B Menu Panel (or the Screen tab), select Mode/Meas > 5G
NR & V2X Mode > Modulation Analysis Measurement > OK.

5. Select Recall (If accessing the N9042B remotely, select the Folder icon at

the bottom of the display) Demod Info > Data Type set to CC Setup >
Recall From.
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6. Navigate to the .scp file you created in step 11 above and select Recall.

Recall Recall from File k‘) (’” ? x

S Mode 5G NR & V2X v
Screen Config + State Size Content
Correction 9/6/2022 4:19 AM

Complex Correction - Instrument 8/23/2022 12:26 PM

Recording [ D 5GNR Channel Bonding scp 91712022 9:54 AM 105 KB Scp file

SCPI Recorder

Recording + State

File name: | 5GNR Channel Bonding.scp | Filetype: | All Supported Files (*.scp;*.sgen;* nrcc;* pwsg;* setx)

7. From the Menu Panel, select Meas Setup > Settings tab > Optimize EVM.
For this example, the EVM RMS is ~1.9%.

Spectrum Anaiyzer 1 G NR & V2 ! 5 :
Swepl SA ' i tod Meas Setup

KEYSIGHT finput #F Alten: 10 d8 Trig: Free Run ‘Carrier Ref Freq. 12.000000000 GHz & e

4 Coupling: DC Pre-Intofl, LINAG  #F Gain Low CC Infa: DL, 1 CC, SISO R i

G sgnon Frag Ref Ext (S) W Path: Bypass cco
#PNO: Best Wide
1CCO-BWP1 | 2
1Q Meas Time | Detected Allocations
| Scale/Div 328 subcarriers Ref Value 0 subcarriers

Meas
Standard

Component
Carmers

Meas Time

Channel
i A Profile
M = 3: 120 kHz 9.968 |Start: 0. Stop: 1119.00 symbol

pect

- e
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm

Cur: 12.000000000 GHz Width: 3.932 GHz 1=t i
Res BW: 1000 Hz Info BW: 3.93 GHz - 0. Stop: 2.20 ms| | "Allow Full Bypass.
5 CCO Frame Summary ¥ 3 in Auto” fo On(in
the Amplitude
Power per RE  Num RB
Channel Power (Active / Total)
EVM (RMS / Peak)
-41.04 dBm Frequency Error (RMS / Worst)
-41.04 dBm Symbol
1Q Offset (SISO)
Time Offset
Sync Gorrelation
Sync Source
i Magnitude Error %
-303 9 mHz Phase Error 0.01rad
559 6 mHz Gain Imbalance

Freq Ermor
4.1 MHZ
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Using 89600 VSA
1. Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

2. In the Spectrum window, set the Center Frequency to 12 GHz and
Auto-range.

Snawce  Input  MeasSetup  Trace  Markers Window  Utities Help

ange To Peak Power (Defaul] = o [ A 55 wds BIEL ¢ ;’: U A B evalusteNRspeed

Mezsurement running I Eieta Features In Use: 1 I EXT REF I CAL OK

3. From the menu bar, select File > Recall Setup > Recall and select the .setx
file you copied over from the VXG.

4. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time
tab and set Time Scale Factor to 10. Close the Demod Properties windows
and observe the results.
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5. In the Spectrum window, set the Span to 4 GHz, then select the
Auto-range icon at the top of the display.

File Edit Control ce Input MeasSetup Trace Markers ndow  Utilities Help
Il || \§ RangeTo Peak Power (Default) ~ o £ B 55 LIt

~ X | C: OFDM D

hmelen 1.72

Power per RE
(dBm)

Num. of
Medulation RBs RNTI

dBrn

In this example, the EVM is ~2%
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Setting Up 8 Virtual Signal Generators

126

The M9484C Option 8SG provides eight virtual signal generators (multiple 1Q
paths to RF) allowing you to emulate up to 8 signals simultaneously with one
channel. This feature is most beneficial in receiver design and test applications
in which the current implementation often involves RF combining of multiple
signal generators due to dynamic range limitations. 8SG can simplify device
characterization where multi-carrier or multi-radio access technology signals
are required.

The VXG must have Option M9484C-8SG (8 virtual signal generators)
installed.

10 MHz out = Ext Ref In

a
g

Event 1 out 2> Tng 1 lnb

RF out= RF In

For this example we will use the following equipment:

— M9484C VXG
— RF bandwidth of 2.5 GHz per channel (M9484C-R25)
— 8 Virtual Signal Generators (M9484C-8SG)

— N7631TAPPC PathWave Signal Generation for 5G NR measurement
application

— X-Series Signal Analyzer
— N9085EMOE 5G NR Measurement application
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On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output area for Channel 1, set Frequency to 2 GHz and Power to
-5 dBm.

2.00000000000000 GHz

-5.00 dBm

3. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

wss T ~, L c g
TR (=) (] > Group 1:Signal Summary
i) =) nl p 1: Signal Summary

Enabled  Signal Mode Frequency Offset Attenuation

WOV OV WV OV WV WV YV

4. Select Group 1 Signal block to open.

| Group 1: Signals
File None selected
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5. Select the Mode drop down menu and select Waveform File and then
select the Waveform File tab on the left side.

RF Out (Al
LI‘L| > Group 1: Signal Summary » Signal 1: Setup - -I

General Mode Signal Attenuation

[P —— Waveform File ~ 0dB

Trigger Frequency Offset Power
0Hz 0dB
Markers
e Rate
00 000 000 000 GHz

Reset Phase Accumulator

6. In the Waveform Playback Setup area, use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
01 _GSM_Framed_slots 1 3 5 off_EDGE Framed_slots © 2 4 6 off_2MHz

separation_WFM1.wfm

then Select.

B o
Name ~ Date Modified
:I e " Delete
s Computer o
— P 01_GSM_Framed_slots 1 3 5 off_EDGE Framed_slots 0 2 4 6 off_2 MHz separation_WFM1.wim Jan 18, 2022, 9:32:20 PM

A_TM1_1 DPCH.wim o [ Rename

D3_LTE full filled_1

07_802.11ac_160

Clear Arb Memory

All Supported Formats (*.wfm, *.wiq, *.bin, *.waveform, *.csv, *.txt, *.seq, *.mat, *.hdf, *.h5, *inc) ~ Cancel
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Whenever you enable a particular waveform file that is not currently
enabled in another I1Q path, it uploads prior to playback. If the file is
already enabled in one or more other 1Q paths, an upload does not occur
and the waveform plays directly.

If you update the |Q data for a particular waveform file, you must first
disable the 1Q paths where the old version of the same file is being used so
that it uploads, replacing the old data.

7. Set the Frequency Offset to the desired value. For this example -1.2 GHz.

The Frequency Offset is the distance from the channel’s RF center
frequency (set in step 2) to the center frequency of the signal. You can
adjust the signal attenuation for each signal to allow scaling the signal
down without disrupting the output.

8. Select the General tab > Enable

@ > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

@ cnable

i 0dB
Analog Modulation =l N 2ol ~

Mute
Tt Frequency Offset Power

0Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

9. From the Menu/Tool & Navigation bar, select Group 1: Signal Summary.

Notice the Remaining Sample Rate has decreased from 3.0 GHz to
2.9956 GHz now that Signal 1 is consuming 4.333 MHz.

L:'LJ » |Group 1: Signal Summary

Enabled  Signal Mode Frequency Offset Attenuation

v Fi Framed_slots -1.2 z 0.00 dB

VOV VYV VYV VYV

10. Repeat step step 5 through step 9 for Signal 2, Signal 3, and Signal 4 with
the following changes.
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— Signal 2

— Waveform:
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\02 W-CDMA TM1 1 DPCH.wfm

— Frequency Offset: -1.0 GHz
— Signal 3

— Waveform:
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\03 LTE full
filled 160AM.wfm

— Frequency Offset: -900 MHz
— Signal 4

— Waveform:
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\04 802.1lac 160 MHzO.wfm

— Frequency Offset: 1.0 GHz

Signal Mode Frequency Offset Attenuation Status
File Framed o ots .. -1 GHz 0.00 dB = Playing
0.00 dB > Playing

> Playing

P Playing

Remainin

11. Signals 5 -7 will be configured using the embedded PathWave Signal
Generation for 5G NR (N7631APPC). Select the Radio Apps icon in the top
left of the window, and then select 5G NR.

Trigger

H|P © () > s - 7

Keysight PathWave Signal Generation

@ 56 NR @ Custom @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)

Modulation (Beta)

12. To create signal 5, select the Carrier tab > Full-filled Config and set
— Bandwidth to FR1 100 MHz
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— Duplex Type to FDD
— Modulation to 64QAM, then select OK

Carrier Wavefi

mn Fultfilled Config | T+ DL Test Model " DL FRC Config + Auto Frequency Offset [-+ Export 896!

FR1 100MHz

p=1:30kHz

Channel Allocation Summary

13. Select the Waveform tab and scroll down to turn Phase Compensation
Off. This will allow the waveform to be offset in frequency without needing
to be re-generated.

(¢, Generate Carrier =~ Waveform

[ Export 89600 VSA Setup

Subframe Offset

Marker Number of Subframes
Crest Factor Reduction Slot Offset in Subframe
AWGN Number of Slots in Subframe

Total Sample Points

Routing

Waveform Length

Mirror Spectrum
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14. From the left pane, select the Routing tab, set the signal number to 5, and
then Generate.

i Apps 56NR *

¢ Generate Carrier Waveform

[+ Export 89600 VSA Setup

Basic Group
Marker
Crest Factor Reduction

AWGN

15. To create signal 6, select the Carrier tab > Full-filled Config and set
Bandwidth to FR2 200 MHz.

16. Select the Waveform tab, then from the left pane, select the Routing tab,
set the signal number to 6, and then Generate.

17. To create signal 7, select the Carrier tab > Full-filled Config and set
Bandwidth to FR2 400 MHz.

18. Select the Waveform tab, then from the left pane, select the Routing tab,
set the signal number to 7, and then Generate.

19. Return to Group 1: Signal Summary by selecting the Home icon > Group1:
Signals and set the Frequency Offset for each of the newly generated 5G
NR signals as follows:

— Signal 5 to -700 MHz
— Signal 6 to -300 MHz
— Signal 7 to 300 MHz

|_F 3 Group 1: Signal Summary
U

Enabled e Frequency Dffset Attenuation Status

v File: 01_GSM_Frai 5 off_EDG lots GHz 0.00dB P Playing

WOOWOW WV VW W
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20. Select the arrow for Signal 8.

21. Select the Mode drop down and select AWGN. Select the AWGN tab and
set Channel Bandwidth to 1.5 GHz.

RF Out (All) Triggar
. [

U:I_| > Group 1: Signal Summary » Signal 8: Setup A
¥

General Channel Bandwidth Power Control Mode

Channel Bandwidth
A —

1.500 000 000 000 GHz Total

[
Flat Bandwidth Channel Noise Power
1.500 000 000 GHz Channel Noise
Bandwidth Ratio Total Power

AWGN

T (2 UG R [¢&——— Flat Bandwidth ———| Freq

22. Select the General tab and set Frequency Offset to -200 MHz and Enable
the AWGN signal.

LI;L| > Group 1: Signal Summary » Signal 8: Setup

General = Mode
'@ cnable .
AWEN AWGN

Mt Frequency Offset

-200.000 000 MHz

Sample Rate
3.000 000 000 DOO 000 GHz

Reset Phase Accumulator

23. Select the Home icon and set RF Out to On by selecting the numbered
channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

Adjustments
Off 2.00000000000000 GHZ
off

Pwrilim Off

-5.00 dBm

ALC OFF
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24. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the Signal Analyzer:
1. Select Mode/Meas > Spectrum Analyzer Mode > Swept SA Measurement.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set the spectrum analyzer to a known state.
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Setting Up

3. Adjust

8 Virtual Signal Generators

the center frequency and span to view all of the signals around the

RF center frequency. For this example, set the Center Frequency to 2 GHz
and Span to 2.5 GHz.

 +|
KEYSIGHT ot 2 Input 2:50 0

Coupling: DC Com CCom RCal Pre: Int off, LNA off Gate: OFf Trig: Free Run

e

Atten: 10 4B PN Fast Avg Type: Log-Power W‘W

[D Mlign: Partial Freq Ref: Ext (S) uW Path: Standard IF Gain: Low Pz 2000000000 GHz

NFE: Adaplive

1 Spectum \l
Scale/Div 10 dB

Sig Track: Off

iSpan
| 2.50000000 GHz

Ref Level 0.00 dBm . | Swept Span

Zero Span

7

Start Freq

000000 MHz

Slop Freq

0. .
4 7-.[:
I

AUTO TUNE

Video BW 3.0 MHz
Sweep 1.67 ms (1001 pts!

4. Adjust the Resolution Bandwidth and Video Bandwidth as needed.

5. Now that 8 waveforms are playing, try some of the following experiments
to see how different settings impact the signals.

Toggle the Enable checkbox for various signals.

Adjust the Frequency Offset of various signals. Note that signals can
overlap.

Set up a Channel Power measurement on the Signal Analyzer.
Observe how changing different signal settings (relative power,
attenuation, mute, enable, etc.) either impact or do not impact Total
Channel Power.

Use the Auto Configure Analyzer feature to demodulate one of the
5G NR signals. Note, the center frequency will need to be manually
adjusted on the Signal Analyzer to match the Frequency Offset of
the signal set on the VXG.

Change Trigger and/or Marker settings.
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Using the VSA Flex Frame to Create a DVB-S2X Signal
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The Flex Frame extension (89601AYAC) for the 89600 VSA software provides a
means of creating complex frames to demodulate and analyze advanced
custom 1Q signals.

A frame can contain a combination of flexible elements, or allocations. Each
allocation can be a Preamble, Pilot, Data or an Idle period. Allocations have
configurable payload PN sequence and modulation type.

As you build the flexible frame in the Frame Definition tab, an Allocation
Summary panel displays the order of each assembled frame part and
allocation, and shows how the total number of symbols are distributed across
the frame.

There are two parts to this example.

The first example uses N7623C Signal Studio for Digital Video. The N7623C
generates a fully coded, full-standard compliant DVB-S2X waveform. Then, we
will use VSA Flex Frame to demod the signal.

The second example uses PathWave N7608C Custom Modulation. Since the
N7623C cannot provide an uncoded signal, we will use the N7608C to
uncoded the signal to perform a Bit Error Rate (BER) measurement.

For this example, we will use the following equipment:

— N7623C Signal Studio for Digital Video (Software release 2020 Update 1.0
or higher

— N7608C Signal Studio for Custom Modulation (Software release 2021 or
higher)

— 89600 VSA Digital Demodulation Analysis, Flex Frame Measurement
(Software release VSA 2022 or higher)
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DVB-S2X PHY Layer Framing

i&—- PLFRAME before PL Scrambling: Total Length = 90(S+1)+P int{(5-1)/16}, (P=36 pilots) —

|Length:1-slot (90 symbols)  Length:1-slot (90 symbols) Length:36 symbols
Modulation: 2/PI BPSK Modulation iDF‘S to APSK) Unmodulated

PLHEADER

’
’ s

; kY For modes
., ¥ requiring piots

[ SOF | PLSCODE |

PLHEADER (90 symbols) includes: + Payload length is multiple slots of 90 symbols each

+ Pilots are grouped in blocks of 36 symbols and

= SOF (Start of Frame): 26 symbols (y1y2...y26): inserted every 16 payload slots

01 1000 1101 0010 1110 1000 0010

« PLS (PHY Layer Signaling) Code: 64 symbols

256 APSK modulation is used in this demo guide. The coding rate is
represented differently between Signal Studio for Digital Video (N7623C),
Signal Studio for Custom modulation (N7608C), and VSA Flex Frame
(89601AYAC). N7608C and 89601AYAC use “Implementation MODCOD” name
and N7623C uses “Canonical MODCOD” name.

In this example, we will use a coding rate of 32/45 in the N7623C which
corresponds to 128/180 in the N7608C and VSA.

N7623C Signal Studio for Digital N7608C Signal Studio for Custom 89601AYAC Flex Frame

Modulation Modulation
256APSK 29/45 256APSK 116/180 256APSK 116/180
256APSK 2/3 256APSK 20/30 Not supported
256APSK 31/45 256APSK 124/180 256APSK 124/180
256APSK 32/45 256APSK 128/180 256APSK 128/180
256APSK 11/15 256APSK 22/30 Not supported
256APSK 3/4 256APSK 135/180 256APSK 135/180
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Part 1: Generating a DVB-52X Waveform Using N/623C Signal
Studio for Digital Modulation

DVB-S2 and DVB-S2X operate in Ku band (10-14 GHz) and Ka band
(18-30 GHz). This example uses a sub-6GHz hardware thus using a center
frequency of 4.5 GHz. Modify the frequency based on the hardware you are
using.

Setting Up the Waveform in Signal Studio for Digital Video
1. From the main menu, select Format > DVB-S2/S2X.

= Keysight Signal Studio for Digital Video - RF Output - O >
File Control System Tools Help
D d 1 DVB-T/H
- Quick Setups DVB-T2
EHardware ~
L Instrument DVB-C, 183 A/C
=8 Waveform Setup) DVE-5 Frequency Offset Pawer
i Carrier 0 I « DVB-52/52X S2X 0.00 Hz 0.00dB
ISDB-T
ISDE-Tmm z
| Hint
ATSC "
ATSC-M/H DTV
1.83 B, DOCSIS DS 12514032 L
DOCSIS 3.1 Downstream Off
DOCSIS 3.1 Upstream oF |
DTMB (CTTB) 2 j
CMMB
B Gaussian B Reference (i3] Acouire H
10% —dB
1% —dB
0.1% —dB
0.01% —dB
0.001% |—dB )
0.0001%/—dB 20.00 dB

2. From the left panel, select Quick Setups > Hardware > Instrument.
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3. Set the Frequency to 4.5 GHz and the Amplitude to -10 dBm.

= Keysight Signal Studio for Digital Video - RF Output* - O X

File Control System Tools Format Help
1
Genarator
Updatetcrlnstru‘ Updatefromlnstru| Loca||- DC Ca| Power S¢

[ Hint

* 1. Confiauration o
Instrument Model Number N5162/MN5172/N5182 EXG/MXG

™
Freausncy 4.500 000 000 000 GHz
Amplitude -10.00 dBm
utout ol

v 3. 1Q
1/Q Adiustments
| Offset
Q Offset
1/Q Gain Balance
Quadrature Anale Adiustment
|/Q Timina Skew Path

L Carrier 0

Q Cg I
/Q Skew
1/Q Delav
Internal Channel Correction
v 4 ALC

ALC On
ALC Bandwidth Auto
Power Search Reference Fixed
RF Durina Power Search Nomal j

4. Under Waveform Setup, select Carrier and configure the DVB-S2/S52X
signal to the following parameters.

Roll of Factor to 0.25

Symbol Rate to 20 MHz
Support DVB-S2X to True
Modulation Type to 256 APSK
Code Rate to 32/45
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This is equivalent to MODCOD 256APSK 128/180 in the VSA.

= Keysight Signal Studio for Digital Video - RF Output* - O X

File Control System Tools Format Help

W= = | 1

- Quick Setups

-Hardware
-Waveform Setup State Format Frequency Offset Power
""" Carrier 0 On DVB-52/52X% 0.00 Hz 0.00dB
| Hint
State On T
Format DVB-52/52X
Freauencv Offset 0.000000 Hz
Initial Phase 0.00 deg
Powar 000de
W 2. DVB-52/52X Settinas

Filter Tvoe Root MNyquist
Roll-off Factar 0.25
Svmbol Rate 20.0000000 MHz
Support DVB-$2X True
VL-SNR Header False
FEC Frame Normal
Modulation Tvoe 256 APSK
Code Rate 32/45
Insert Pilot False
CRC-8 Encoder True
Number of LDPC Blocks 188
Multi-oath Channel OFF

5. In the Waveform Setup window, set the Oversampling Ratio to 2.

This results in a Waveform Length of 3147120. We will use this length
when configuring the signal in VSA Flex Frame.

File Control System Tools Format Help

(= = 1
s~ Quick Setups |Wavef0rm Setup

-Hardware

i eInstrument

E-Waveform Setup Camier | State Format Frequency Offset Power

i Carrier 0 Carier 0 On DVB-52/52X 0.00 Hz 0.00dB
< >
Waveform Setup | Hint
Waveform Lenath 3147120 | j
ast Download e
» 2. Spectrum Control
LY H o " {"HF
2 J
* 3. Impairments in Waveform
Quadrature Anale Adiustment 0.000 deg J
1/Q) Gain Balance 0.000 dB h

CCDF ]Wa\re{orrn ]
B Gaussian B Reference i8] Acquire Ref.

—dB
—dB

T 20.00 dB
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6. From the Control menu, select Generate.

Depending on the signal generator you are using, the steps for
downloading the waveform may be different. If this is the case, go to File >
Export Waveform Data and Save the file. Then load it onto the your signal
generator.

7. Select Control menu > Download to download it to your Signal Generator.

Setting up and Analyzing the Signal Using VSA Flex Frame

Changing settings on the VSA can take longer to take affect than
expected. Wait to change the next setting until the previous setting has
been updated.

1. From the VSA menu bar, select MeasSetup > Measurement Type >
General Purpose > Flex Frame.
2. Set the correct frequency, span, and input range. For this example, set:
— Change the Trace Layout Grid to 2 x 3.

— Change Trace B to Ch1 Spectrum, and set Center Frequency to
4.5 GHz

— Span to 40 MHz
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— Autorange

25 Flex Frame - Keysight PathWave Vector Signal Anatysis (89600 VSA) = a X

ce Input MeasSetup  Trace Markers Window  Utilifies Help

File Edt C
” Fange To Pesk Power (Default) ~ N B L r-i & ':::' || ] | E{} Al *

- X

B: Ch Spectrum H'Ch] CCDF = ¥ | D6 (CCO) FlexFrame Summary

_EVM  Powsr P |
FramePart Mllocation o ¢l Num. of SymbolsModula 5 T

FramaPan

Freq=4.5 GHz

Span = 40 MHz NOTE: The low-resolution spectrum
will get adjusted automatically when
the correct Symbol rate is set in the
next step

Ifeasunemend running
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3. Select MeasSetup > Flex Frame Properties > Carrier Aggregation tab, then
set CCO Absolute Center frequency to 4.5 GHz.

E Meas01 - Flex Frame Properties ? X

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation
Preset Measurement Quick Setups » Save As Quick Setup...

Selected CC for Trace Display: | CCO
Component Carriers

Reference Frequency: 0 Hz

Acquisition Configuration

Channel Statu y Center Fre y Spa
Ch1 v 390.625 kHz 390.625 kHz None

& Overall Status:  Error: unassigned component carriers: [CCO]

The Symbol Rate error will be resolved once the Symbol Rate gets
adjusted in step 5.
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4. At the bottom right portion of the display, select Edit, then select the
Assigned Carriers drop down and select CCO.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Preset Measurement Quick Setups # Save As Quick Setup..

Copy CCO to...

*

4475 GHz z 4525 GHz
Cancel
orrelated EVM

Configure...

Acquisition Configuration

Ch1 @ 45GH:z

@ Overall Status:  No Error

5. In the Flex Frame Properties window, select the Frame Definition tab and
set:

— Frame Type to Periodic
— Symbol Rate to 20 MHz
— Length to 3147120 Symbols

To match the waveform length in Signal Studio.
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For a bursted signal, Frame Type is set to Burst, and the frame
length can be automatically set based on the detected burst length.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

-

Component Carrier: |CCO

All .

195.3125 kHz

Component Carrier Configuration Allocation Summary
Frame Configuration Modulation Index Enabled Frame Part Allocat
0 ] FramePart0 Alloch
Frame Type: Periodic -
Symbol Rate:| 20 MHz

Length: 3079440 Symbols

Frame Parts

4 FramePart0

Allocd

6. In the Component Carrier Configuration area, select the Modulation tab
and set Preferred Bit to Symbol Mapping to Default.

When testing a DUT, if the bit mapping into constellation point is as
defined by DVB-S2X, DVB-RCS2 or 802.11ad/ay standard, selecting the
correct standard under "Bit To Symbol Mapping" is required for accurate
Tx BER measurement. When using Signal Studio, leave it as Default.

Constellation mapping definition between VSA Flex Frame and N7608C
Signal Studio is not aligned. VSA comes with a set of bit mappings (.txt
file) to recall into the N7608C and this is required for successful
demodulation. You can find it under: C:\Program Files\Keysight\
<version>\89600 VSA Software\Help\Signals\FlexFrame.

7. Set the Sequence Type to DVB-S2/S2X PLFRAME.

This selects the scrambling method as described in section 5.5.4 of
EN 302.301-1.
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8. Set both Sequence Index and Reset Symbol to 0.

Component Carrier Configuration

Frame Configuration Modulation

Preferred Bit To Symbol Mapping: {pefauyit

Scrambler: . aF

Scrambler Configuration
Sequence Type: DVB-52/S2X PLFRAME
Sequence Index: 0

Reset Symbol Index: 0

Configure the Preamble (PLHEADER)

Length:1-slot {90 symbols) Length:1-slot (90 symbols) Length:36 symbols
Modulation: 2/P1 BPSK Modulation (QP SK to APSK) nmodulated
PLHEADER — p— ]

!f ~ For modes
, * requiring pliots

PLHEADER

SOF PLSCODE ‘

PLHEADER (90 symbols) includes:

- SOF (Start of Frame): 26 symbols (y1y2...y26):
01 1000 1101 0010 1110 1000 0010

9. Select the Frame Configuration tab and configure the Start of Frame Index
(SOF), 26 symbols long:

— In the Frame Parts area, select AllocO.
— In the Configuration area, set
— Name to SOF
— Type to Preamble
— Sequence to Custom
— Modulation to DVB-S2/S2X n/2BPSK

— Enter the 26 symbols
01100011010010111010000010

(011 000 110 100 101 110 100 000 10)

— In the Location area,

— Clear the End of Frame checkbox
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— Start Symbol to 0
— Total Length to 26
Note that Scrambling is not applied to Preamble.

Frame Parts
Configuration Location
4 FramePart0 9

Alloc Enabled: v Start Symbol: 0

MName: AllocO Last Symbol

— Symbol Index: 25

Type: Preamble - e
-or-

Power Boost: | 0 dB

Total Length: 26 Symbols

Payload
End of Frame

Seguence: Custom

Repeat Pattern

Custom Sequence Type: | Bit Sequence -

Modulation: DVB-52/52X /2 BPSK  +

Include in BER Calculations

01100011010010111010000010

Scrambling

Enabled
Add Frame Part

Add Allocation

Configure the PLS (PHY Layer Signaling) Code 64 symbols long
10. In the Frame Parts area:

— Select Add Allocation
11. In the Configuration area, set:

— Name to PLSCODE

— Type to Preamble

— Sequence to Unknown

— Modulation to DVB-S2/S2Xn/2 BPSK

Notice that Scrambling is not applied to Preamble.

12. In the Location area, set:

— Clear the End of Frame checkbox

— Start Symbol to 26
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— Total Length to 64 Symbols

Frame Parts

4 FramePartD Configuration Location

Enabled: v Start Symbaol:

PLSCODE MName: PLSCODE Last Symbaol

S Symbol Index
Type: Preamble *

- ar-

Power Boost: | (0 dB
er Boo 0 dB Total Length:

Payload .
End of Frame

Sequence: Unknown
Repeat Pattern
Medulation: = pyg-5.

Scrambling

Enabled

Add Frame Part

Add Allocation  Remove Allocation

Configure the Payload
Length:1-slot (90 symbols) Length:1-slot (90 symbols) Length:36 symbols
Modulation: 2/P1 BPSK Modulation (QP SK to APSK) Unmodulated

PLHEADER . 5 . PLHEADER

For modes

requiring pilots

+ Payload length is multiple slots of 90 symbols each

+ Pilots are grouped in blocks of 36 symbols and
inserted every 16 payload slots

13. In the Frame Part area, select Add Allocation.
14. In the Configuration area:
— Name to Data
— Type to Data
— Sequence to Unknown
— Modulation to DVB-S2/S2X APSK
Notice that Scrambling is not applied to Preamble.
— MODCOD to 256APSK Normal 128/180
— Scrambling to Enabled
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15. In the Location area, set:
— Start Symbol to 90
— Last Symbol to End of Frame
— Select Repeat Pattern
— Set Active Symbols to 0:1439

Before the Pilot block, there are 16 payload slots, each 90 symbols
long resulting in 1440 active symbols.

— Repeat every to 1476 Symbols

The 1440 payload symbols are followed by a 36-symbols Pilot block
resulting in a total of 1476 symbols. This will repeat until the end of
the frame length.

Frame Parts

Configuration Location
4 TramePart0 OnTIgUraTic ocatic

AllocO Enabled: ' Start Symboaol: a0

PLSCODE Name: Data Last Symbol

Alloc2 Type: Data

4 FramePart1 P Boost
'ower Boost: |0 dB
Data
Payload
¥ End of Frame
Sequence: Unknown *
| Repeat Pattern

Modulation: | pyvB-52/52% APSK -

Repetition Parameters

MODCOD:  256APSK Normal 128/180 ~ Active Symbols: | 0:1439

Serambling Repeat every 1476 Symbaols

| Enabled

Add Frame Part
Scrambler ID: | g
Add Allocation

Configure the Pilot
16. In the Frame Part area, select Add Allocation.
17. In the Configuration area:
— Name to Pilot
— Type to Pilot
— Sequence to Unknown
— Modulation to QPSK
Pilots are unmodulated, but they are identified by
1=Q=1/2
— Scrambling to Enabled
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18. In the Location area, set:
— Start Symbol to 90
— Last Symbol, select End of Frame
— Select Repeat Pattern
— Set Active Symbols to 1440:1475
Pilot is 36 symbols long following a 1440 symbols long payload.
— Repeat every to 1476 Symbols

The 1440 payload symbols are followed by a 36-symbols Pilot block
resulting in a total of 1476 symbols. This will repeat until the end of
the frame length.

Frame Parts

Configuration Location
4 FramePart0 9

AllocO Enabled: V! Start Symbol: 90

PLSCODE Name: Pilot Last Symbol

ilot Type: Pilot

4 FramePart1
Power Boost. |0 dB
Data
Payload
¥ End of Frame
Sequence: Unknown

+| Repeat Pattern
Modulation: | gpsk
Repetition Parameters
Scrambling Active Symbols: | 1440:1475
B Repeatevery | 1476 Symbols
Scrambler ID: | g
Add Frame Part

Add Allocation | Remove Allocation
Configure Synchronization and Equalization
19. Select the Measurement Control tab, and set:
— Synchronization Source to Auto

By default, SOF is used for synchronization. This can be changed to
"Customized" to add additional frame parts for synchronization.

— Channel Estimation Source to Preamble and Pilots
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Equalization is off by default. You can choose the different frame
parts for channel estimation and equalization.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation
—

Component Carrier; CCO

All

195.3125 kHz

Overall Allocation Control

Frequency Estimation & Equalization & Synchronization

Synchronization Source: Auto

Frequency Estimation Mode: Normal
Equalization Mode: Zero-forcing
Channel Estimation Source: Preamble and Pilots

Normalized Channel Delay Spread: | 10 Symbols

EQ Tracking:

Configure the Analysis Region
20. Select the Time tab, set the Result Length to 8000 Symbols.

Setting the result length to < the waveform length when oversampling
ratio of 1, provides the best performance. In Signal Studio, when
oversampling ratio is set to 1, the waveform length is 8370. Using a result
length of <8370 symbols provides the best EVM performance.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Mecdulation
-

Component Carrier: | CCO

All

Result Length: | 8000 Symbols
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Configure the RRC filter
21. In the Filter tab, set Alpha/BT: to 0.25.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Component Carrier: | CCO ~

All

Measurement Filter: | poot-raised Cosine Length: | 5, Symbols

Reference Filter:

Raised Cosine

Alpha/BT:

Save the Configuration as a Quick Setup
22. In the Carrier Aggregation tab, select Save As Quick Setup.

This saves the measurement settings for future use. Select Share with all
users if you want to share with other users on the PC running the VSA
software.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Preset Measurement Quick Setups  » Save As Quick Setup...

Selected CC for Trace Display: = €CO PR e Quick Setup P %
= !

Component Carriers Name DVB-52X setup|

Reference Freguency: |0 Hz Share with all users

MName ute Center Offse Symbol Rate (014 Cancel

Copy CCO to... *
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23. Close the Properties window and change Trace A to a Constellation
Diagram, then view the results.

8 Flex Frame - Keysight 89600 VSA Software - Press the Mode key to switch applications X

File Edit Control Source Input MeasSetup Trace Markers Window  Utilities Help

|| ) '\_g Range To Peak Power (Default) ~ (%] A BE- 13 t% ‘.:,% [+ || | | 22 u] )\

A: (CCO) FlexFrame Meas Time ~ % % | € (CCO) FlexFrame Syms/Errs « % | E: (CCO) FlexFrame Err Vect Time

~

LinMag

¥ ||| D: (CCO) FlexFrame Summary » % | F:(CCO) FlexFrame Phase Err

POWer ot Symbol Nurn. of Symbals M
2

8000

FramePart  Allocation

EVM
(dB)

FramePart0

You should see a successful demodulation with very low EVM. Multiple
traces and tables are available including Error Vector Spectrum, Error
Vector Time, demod, and BER Bits.

The FlexFrame Summary table is a type of Matrix Table that provides
sortable rows by column, selectable column visibility, and copy/paste and
export functionality to share rows of content or complete tables to
applications like email, text editing or spreadsheet programs.

Right click the column header to display the menu.

F: (CCO) FlexFrame Summary ~

3% [ v
Part  Allocation |'H N I ‘R BB Column Visthility

Partl
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FlexFrame Summary always displays the EVM of each active segment.
Flex Frame Syms/Errs table shows composite EVM of segment(s) selected
under Measurement Control -> Include EVM. By default, it shows all
segments.

D (CC0) FlexFrame Summary

EVM Power
FramePart  ABocation (B} (dBm)

FramePam 54.86 10,99
= 3
)

Mum. of Symbols Modulation Format BER
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Part 2: Generating a DVB-52X Waveform Using the N7/608APPC
Signal Studio for Custom Modulation
For this example, we will use the embedded N7608APPC application on the
M9484C VXG.

The VXG must have the N7608APPC Signal Generation for Custom
Modulation license installed. You can also use N7608C Signal Studio for
Custom Modulation

Setting Up the Waveform in PathWave Custom Modulation

1. Onthe VXG, select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 4.5 GHz and Power to
-10 dBm.

4.500 000 000 000 00 GHz

-10.00 dBm

ALC ON

3. Select the Radio Apps block to open the Vector Modulation Signal Setup
panel.

RF Out (All)

— |5l =l S () > Avps -
Keysight PathWave Signal Generation

@ 5G NR @ Custom

Modulation (Beta)

@ NR-V2X (@ LTE FDD (Beta) @) LTETOD (Beta)
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5. In the Custom Modulation setup, select the Carrier tab > Quick Setups >
DVB-S2X > 256APSK > 256APSK 128/180.

sem -
e e () > 4wes
Custom Modulation

Carrier Waveform [« Import Signal Setup

iy Preset |[] Qui [ Export 89600 VSA Setup

DVB-S2 >
Custom AS DVB-52X b BAPSK
Filter APCO25 > 16APSK
TETRA 32APSK
NXDN > 64APSK >
dPMR 128APSK >
DECT 256APSK > 256APSK 116/180
DMR 256APSK 124/180
ARIB > 256APSK 128/180

r of Symbols i Constellation Phase Rotation shift Bits Per Symbol Differential ~ Offset

ZigBee ’ 256APSK 135/180
DataSeg I | 16QAM 0 4

Wi-SUN(802.15.4g) > 256APSK 20/30

ITU-T G.9959 > 256APSK 22/30

1000 Sym

6. From the left pane, select Custom ASK & PSK & QAM Settings and set the
Symbol Rate to 20 Msps per channel.

(", Generate Carrier Waveform
™y Preset [| QuickSetups [+ Export 89600 VSA Setup

Custom 1Q Selection 20 Msps

7. Select Filter > Alpha to 0.25.
Filter length is 32 symbols, which we will set this value in the VSA.

* Generate Carrier Waveform
y Preset [] QuickSetups [+ Export 89600 VSA Setup

Customn 1Q Selection Filter Root Nyquist v

Customn ASK & PSK & QAM Settings 0.25

Length({symbol) 32
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Configure the PLHEADER (Preamble)

In Part 1, the PLHEADER using n/2-BPSK modulation is split into two: SOF
(Start of Frame) of 26 symbols and PLS (PHY Layer Signaling) of 64 symbols for
a total of 90 symbols. The N7608C by default uses a single segment for
PLHEADER with 90 symbols using QPSK modulation and provides a payload of
180 symbols. For the purpose of this example, we will merge the two. You can
split the PLHEADER into two by adding a segment and provide a payload of
52 symbols for the SOF. Since N7608C doesn't support 1/2-BPSK modulation,
it uses QPSK so it would require a payload of 52 symbols for the SOF, instead
of the 26-symbols used in Part 1.

Default constellation symbol mappings of VSA Flex Frame and N7608C/APPC do not
NOTE match. VSA provides .txt files to load into the N7608C/APPC to match the mapping.

These .txt files are in the VSA installer under:
C:\Program Files\Keysight\<version>\89600 VSA Software\Help\Signals\FlexFrame.

I ¥ 7 | FlexFrame - O B
Home Share View
&« v A « Help » Signals » FlexFrame w @ Search FlexFrame £
* [J Name Date modified Type Size
7 Quick access | | DVB_RCS2 Reference Waveform_ID2.f...  10/15/2021 .48 PM SETX File 189 KB
[ Desktop » a Hw_generated_DVB_52X_64_APSK 8 1.  10/13/2021 1:48 PM HTML Docurment KB
& Downloads # [ 7] Hw_generated_DVB_S2X 64 APSK 8. 1... 12/2/2021 1:41PM  SDFFile 65,541 KB
B Documents # [7] Hw_generated_DVE 52X 64 APSK 8.1.. 11/11/202112:35..  SETXFile 125 KB
= pict ¢ 2] Ideal DVB_S2¥_16_APSK_4 12 _rate 26_... 10/15/20211:42PM  HTML Document 3KB
&= FICIUres —
|_1 ldeal_DVB_52X_16_APSK 412 rate 26_... | 11:41PM SDFFile 36,869 KB
= [7] \deal DVB_52%_16_APSK_4 12_rate 26_.. 10/15/20211:48PM  SETXFile 132 KB
U 2] Ideal DVB_52¥_32_APSK_4 12_16_rate_... 10/15/20211:48PM  HTML Document 1KB
M9424C Demo v [7] \deal DVB_52%_32_APSK_4 12_16_rate .. 12, SDF File 10,006 KB
Users [7] \deal DVB_52%_32_APSK 4 12_16 rate_.. 11/11/ :33.. SETXFile 112 KB
a MixedModulation 0 HTML Document KB
[ This PC = ) ; I
- u MixedModulation.sdf SDF File 5,002 KB
- 30 Objects [} MixedModulation.setx SETX File 108 KB
I Desktop [ psks_DVBRCS2 2021 1:43PM  Text Document 1KE
@] Documents |j PSKE_DVBS2 /2021 1:48 PM - Text Document 1KB
‘ Downloads |:] PSKB_WLAN1Tad 5/2021 1:45 PM  Text Document 1KB
J’ Music I:] QAM16_DVBRCS2 2021 1:48 PM - Text Document 1KB
. |j QAM16_ WLANT1ad Text Document 1KB
| Pictures -
Text Document 2KB
B Videos S —
|_1 QPSK_Default /2021 1:44PM Text Document 1KB
= SystemDrive (C) TS VERCS, 0/15/2021 1:43PM  Text Document ke
= UserData (D), E apsk_pvas2 0/15/2021 1:43PM  Text Document 1KB
NOTE For the convenience of this demonstration, the QPSK text file has already
been copied onto the VXG.

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\QPSK_Default_for FlexFrame Example
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8. From the bottom pane, select the PLHEADER row > QPSK constellation to
open the Constellation Edit window.

-+ Add Segment — Remove Segment + Move Down

Name Type Number of Symbols  Ramp Samples Payload Constellation

Phase Rotation ~ Shift Bits Per Symbol Differential Offset
PLHEADER Data 90 0 180 bits binary data [0001...] QPSK ] 2

DataSeg Data 2000 0 PN15 DVB-S2X 256APSK 128/180 8

M

0 a0

2090 Sym

9. In the Constellation Edit dialog, select Recall.

Quick Setups Insert Delete | Recall § Save Normalize Name | QPSK_Default. Show Rotation c] Show Symbol
Index | Q  Magnitude Phase Symbol

] 0.707 1 45 0000

1 0.707 1 135 0001

2 -0.707 1 -45 0002

3 -0.707 0003

10. Navigate to the text file and choose Select. Select OK to Close the
Constellation Edit dialog.

¢ Back
L= ;
] This Computer ) D: s » Instrument > Documents » Keysight > PathWave > SignalGenerator » Examples »

Name ~ Date Modified

QPSK_Default_for FlexFrame Example.txt Dec 6, 2021, 1:44:04 PM
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11. In the PLHEADER row, under Payload, select 180 bits binary data [0001...]
to open the Segment Payload Edit dialog. Select and copy the 180
symbols. These will be pasted in to the VSA for synchronization. Select OK
to close the dialog box.

Pattern Load from File [ Save to File Clear

0001111000101101000700101110110111101110001000101110007000011110001011010010111000710001000011110111011100
001001011010010001011101110001000011110110100011101000700100001000111010010

Current: 0 Total: 180(Max: 128K bits)

Cancel

12. To configure the Payload, from the DataSeq row, set the Number of
Symbols to 1440.

Name Type Number of Symbols Ramp Samples Payload Constellation Phase Rotation Shift Bits Per Symbol Differential Offset
PLHEADER Data | 90 0 180 bits binary data [0001...] QPSK_Default_for FlexFrame Example 0

DataSeg | Data = 1440 0 PN15 DVB-S2X 256APSK 128/180 0 8

PLIEADER

0 90

1530 Sym

Use 16 payload slots (90 symbols/slot) for the radio frame. These are the
slots prior to Pilot. Pilots are optional and not generated (See part 1 of this
demo guide for a frame with pilot segment).

13. In the DataSeg row, under the Constellation area, select
DVB-S2X256APSK 128/180 to open the Constellation editor, and then
select Normalize.
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It is a good idea to normalize the power. Difference power levels between
data and preamble can result in high EVM.

Insert Delete Recall e | Normalize Name | DVB-S2X 2564 Show Rotation Show Symbol

Q Magnitude Phase  Symbol

0.028 0.285 5.625 0000
-0.028 0.285 -5.625 0010
0.028 0.285 17437 | 0008
-0.028 0.285 -174.3 o018
0.083 0.285 16.87: 0007
-0.083 0.285 -16.87 001
0.083 0.285 163.12 | 0009
-0.083 0.285 -163.1 0019
0.181 0.285 39.37¢ | 0002

-0.181 0.285 -39.37 0012

na nane aan er nnna

14. Close the Constellation editor and select Generate to generate the
waveform. To view the Generated waveform, select the Waveform tab and
select Spectrum.

& () > Apps

Custom Modulation (Beta)

[
7/

* Generate Carrier Waveform [+ Import Signal Setup [+ Export Signal Setup

Marker User Defined Sample Rate
Crest FactorReduction  C'e"sampling Ratio
Number of F
Multi Carrier
Total Sample Points

Correction
Waveform Length

Routing

Mirror Spectrum

—@- spectrum
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15. Select Home to exit the setup panel.

R e

Custom Modulation (Beta)

* Generate Carrier Waveform [« Import Signal Setup  [-» Export Signal Setup

16. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

Setting up and Analyzing the Signal Using VSA Flex Frame

Changing settings on the VSA can take longer to take affect than
expected. Wait to change the next setting until the previous setting has
been updated.

1. From the VSA menu bar, select MeasSetup > General Purpose > Flex
Frame.

2= Flex Frame - Keysight 29600 VSA Software - Press the Mode key to switch applications X

File Edit Control Source Input [|MeasSetupl| Trace Markers Window  Utilities Help
F e 1 -
|| ey | £ i 55 18
Res

Time.. " Syms/Errs | D: (CCO) FlexFrame Summary | E: (CCO) FlexFrame Err Vect Time | F: (CCO) FlexFrame Phase Err | G: (CCO) FlexFrame Mag Error | H: Ch1 CCDF |

7 Duplicate Measurement

Measurements...

Measurement T X Vectar
Flex Frame P Power Spectrum Analysis
| General Purpose: Flex Frame
Digital Demo Cellular
Custom IQ

Custom OFDM

B: Ch1 Spectrum

30
e V| Flex Frame

2. Set the correct frequency, span, and input range. For this example, set:

— Change the Trace Layout Grid to 2 x 3.

— Change Trace B to Ch1 Spectrum, and set Center Frequency to
4.5 GHz

— Span to 40 MHz
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— Autorange

5 Flex Frame - Keysight PathWave Vector Signal Analysis (89600 V54)

e Input MeasSetup  Trace Markers  Window  Utilities_Help

e B (R[S0 H QA

- X

H: Chi CCDF -3 CC0) FlexFrame Summary

_EVM  Power 2 | f
FramePan Mllocation oo ia™t Mum. of Symbols Modula ; T

Freq=4.5 GHz

Span = 40 MHz NOTE: The low-resolution spectrum
will get adjusted automatically when
the correct Symbol rate is set in the
next step

Ifeasuremend running
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3. Select MeasSetup > Flex Frame Properties > Carrier Aggregation tab, then
set CCO Absolute Center frequency to 4.5 GHz.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Preset Measurement Quick Setups » Save As Quick Setup...

Add CC

4.5 GHz 40 MHz

Error; CCO bandwidth (S ot entirely captured within Ch1 bandwidth.
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4. At the bottom right portion of the display, select Edit, then select the
Assigned Carriers drop down and select CCO.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation
Preset Measurement Quick Setups # Save As Quick Setup..

y: |-CECO

Reference Frequency: | 20 GHz

ﬂ Acquisition Configuration

Frequent van: |40 MHz

Ch1 i

& Overall Status: Mo Error
e ——

Cancel

Correlated EVM

Configure...

Acquisition Configuration

@ Overall Status:  No Error

5. In the Flex Frame Properties window, select the Frame Definition tab and
set:

— Frame Type to Periodic
— Symbol Rate to 20 MHz
— Length to 1530 Symbols
This is 90 symbols of PLHEADER plus 1430 symbols of data.
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For a bursted signal, Frame Type is set to Burst, and the frame
length can be automatically set based on the detected burst length.

Measurement Control Time Filter Custorn Modulation

tion

odulation

Configure the Preamble (PLHEADER)
6. Configure the Start of Frame Index (Preamble), 90 symbols long:
— In the Frame Parts area, select AllocO.
— In the Configuration area, set
— Name to PLHEADER
— Type to Preamble
— Sequence to Custom
— Modulation to QPSK

— Enter the 180 symbols you copied over from the Custom
Modulation PLHEADER Payload setup in step 11.

— In the Location area,
— Clear the End of Frame checkbox
— Start Symbol to 0
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— Total Length to 90

Frame Parts

4 FramePartD
PLHEADER
MName: PLHEADER

Type: Preamble

Pow st. 0dB

Total Leng th 90 Symbols

d of Frame

Custom
e Bit Sequence
Modulation: QPSK

R Calculations

Add Frame Part

: Enabled
Add Allocation  Remove Allocation it

7. Configure the Payload 1440 symbols long:

— In the Frame Parts area:

— Select Add Allocation

8. In the Configuration area, set:

— Name to Data

— Type to Data

— Sequence to PN15

— Modulation to DVB-S2/S2X APSK

— MODCOD to 256APSK Normal 128/180

— Select Include in BER Calculations

— Select Autodetect Bit Sequence Offset
9. Inthe Location area, set:

— Start Symbol to 90
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— Last Symbol to End of Frame

Carrier Aggregation Frame Definition Measurement Control Time Custom Modulation

25BAPSK Normal 128/180 ~

tion

Add Frame Part

Add Allocation | Remove Allocation

TIP Include in BER Calculations: BER is supported if the allocation's payload
sequence is either a PN type or a Custom bit sequence.

Autodetect Bit Sequence Offset: Supported when the segment(s) is not used
for synchronization.

If not selected (unchecked), demodulator assumes the bit sequence starts at
the beginning of the allocation.

If selected, demodulator finds the best match to the bit sequence.

Configure Synchronization and Equalization
10. Select the Measurement Control tab, and set:

— Synchronization Source to Auto

By default, PLHEADER is used for synchronization. This can be
changed to "Customized" to also include the Data segment for
synchronization. Calculated BER must be cleared (unchecked) from
Data before selecting if for Synchronization.

— Channel Estimation Source to Preamble Only
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Equalization is off by default. You can choose the different frame
parts for channel estimation and equalization.

Carrier Aggregation Frame Definition Measurement Control Time Filter Customn Modulation

Component Carrier. | CCO

MNormal
Equalizatio

Zero-forcing

Channel Estimation S Preamble Only =

Configure the Analysis Region
11. Select the Time tab, set the Result Length to 1530 Symbols.
90 for the preamble plus 1440 for the data.

Frame Definition Measurement Control Time Filter Custom Modulation

Component Carrier; | CCO

All _

Result Length
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Configure the RRC filter
12. In the Filter tab, set Alpha/BT: to 0.25 and Length to 32 Symbols.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

1t Carrier: CCO

Measurement Filter: Rootrakad Cidina =

Reference Filter:

Raised Cosine

Alpha/BT:

Save the Configuration as a Quick Setup
13. In the Carrier Aggregation tab, select Save As Quick Setup.

This saves the measurement settings for future use. Select Share with all
users if you want to share with other users on the PC running the VSA
software.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Preset Measurement Quick Setups  » Save As Quick Setup...

Selected CC for Trace Display: = CCO E Save Quick Setup ? X

Component Carriers Name DVB-S etup|

Reference Freguency: |0 Hz Share with all users

ute Center Offse Symb (014 Cancel
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14. Close the Properties window and change Trace A to a Constellation
Diagram, then view the results.

T Flex Frame - Keysight 89600 VSA Software - Press the Mode key to switch applications x

File Edit Control Source Input N p Trace Markers Window Utilities Help
[117e] \F Range 1o peak Power (Defauly = cmtE WL R(E O MR A

A: (CCO) FlexFrame Meas Time * % X | C:(CCO) FlexFrame Syms/Errs FlexFrame Err Vect Time

Rng 125.8925 mV
t

‘ ﬂhﬁ"w‘n‘wﬁmﬁ*’

-2.4266055 2.4266055 Start D sym

H: Ch1 CCDF ~ X D:(CCO) FlexFrame Summary = X | F:(CCO) FlexFrame Phase Err

Rng -8 dBm

S
FramePan Allocaton ""‘" - Rng 125.8925 mV

) First Symbol Num. of Symbols M

dBm FramePart0 -14.7 - 1530 deg

gg IW'W‘WMmm]'w}ﬁiwﬂ

Data 4986 -1479 S0 1440

|| |
pled tuFmWr',mH ". W.M‘i

Center 4.5 GHz Span 40 MHz Start 0 sym Stop 1.529 ksym
Res BW 49,9365 kHz TimelLen 76.48438 uSec 4

You should see a successful demodulation with very low EVM. Multiple
traces and tables are available including Error Vector Spectrum, Error
Vector Time, demod, and BER Bits.
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The FlexFrame Summary table always displays EVM of each active
segment. However, "Flex Frame Syms/Errs" Table shows composite EVM
of segment(s) selected under Measurement Control -> Include EVM. By
default, it is all segments.

| C: (CCO) Flexframe Syms/Errs I

Carrier Aggregation Frame Definition Measurement Control Time Filter

mppm
dBm
dBm

Auto
Zero-forcing

Lt Preamble Only =

FramePart  Allocation E MNum. of Symbols Medulation FormaiBER

Normalized Channel Delay Spread: | 10 Symbols

FramePart(
Display
L4 ow EVM in dB

Points per Symbol:

symbol Clodk Error
¥ Compensate IQ Offset
Compensate IQ) Gain Imbalance

¥ Use Multi-carrier Filter

TxBER/RawBER is returned for the Data segment. NOTE: BER is supported
if the allocation's payload sequence is either a PN type or a Custom bit
sequence. Reference and measured bits are returned.

— BER is expressed as a ratio and calculated as Bit Errors/Bit Count.
— Turn On averaging to accumulate bit count.

— Recording with 0% overlap gives gap free BER data (limited by
memory).
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ile Ldit Control e Input  MessSetup  Trace  Markers  Window  Utilities  Help

1 Range To Peak Power (Detault) - L

PEITZI0NG 1 Mbi s o T ortor mm

BER Bils
2 (CC0) FlexFrame Meas BER Bits ~ "

FromePan  Alloc

FramcPan0

FlexFrame Summary always displays the EVM of each active segment.
Flex Frame Syms/Errs table shows composite EVM of segment(s) selected
under Measurement Control -> Include EVM. By default, it shows all
segments.

Dz (CC0) FlexFrame Summary
EVM

Power o
{d8) {dBm) Num. of Symbols Modulation Format BER

FramePanl 5486 1099 000
2B

FramePart  ABocation
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FlexFrame Summary table is a type of Matrix Table that provides sortable
rows by column, selectable column visibility, and copy/paste and export
functionality to share rows of content or complete tables to applications
like email, text editing or spreadsheet programs. Right click the column
header to display the menu.

F: (CCO) FlexFrame Summary ~

FramePart Allocation E‘\g\)‘ z%“:; Num. of Symbols Modulation Format BER . EE Column Visibility

FramePart0 -52.09 -10.99 } Mixed i
SOF 10 -10.88 n/2 BPSK
PLSCODE 3 -11.03 n/2 BPSK s 4 [il] Labels Collapse All
Data 8 -1099 E APSK ol

Pilot | -52.91 -11.05 QPSK =

4 W Al Expand All

4 o Metrics

¥ EVM (dB)

| Power (dBm)

¥ Num. of Symbols

¥ Modulation Format
4 W Bit Errors

v BER

Bit Errors (bit)

Bit Count (bit)

oK

M9484C VXG and X-Series SA Measurement Guide 173



Advanced Measurements
Creating & Analyzing a 5G NR DL 2x2 MIMO Measurement Using Two UXAs

Creating & Analyzing a bG NR DL 2x2 MIMO Measurement Using

Two UXAs

We will create a 5G NR MIMO signal using a VXG with PathWave Signal
Generation, and then analyze it with using both the X-Series 5G NR
measurement application and the 89600 VSA software.

The hardware setup includes a 2-channel VXG and two N9042B UXAs.

Ch2

5I"] (o |
o
g 8 s
g & =
Ch1 Event 1 A
10MHz ref g3
M9484C VXG N9042B UXA
Required Options Required Options
— RF bandwidth of 160 MHz or above — UXAT
B B - - NS042MMOB Multi-box Synchronization for
Two-channel configuration MIMO, Analysis Bandwidth of 160 MHz or
above
— UXAZ2
Analysis Bandwidth of 160 MHz or above
Required Software Recommended Software
— MO9484C Firmware version A.11.01 or higher — NO9042B UXA Firmware version 2023 (XA34)
— 7631APPC PathWave Signal Generation for 5G NR ~ ©F Nigher
— NO9085EMOE 5G NR Measurement application
— 89600 VSA

89601200C for VSA Base Core
89601BHNC for VSA 5G NR
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On the VXG

1. Connect the equipment as shown above.
2. Select Preset » Preset to set the VXG to a known state.

3. Select the System menu (triple bar icon at the top left of the window), and
then select Configure Channels > Nx2 <MIMO > Add > Apply > Apply.

"/ @ @ > Configure Channels RFO[;AH) TIE;' ? v [PRESET v

Use the dropdown to configure the available RF Channels into Groups. Any remaining Channels will be set to Independent.
Group Configuration
Independent Remaining RF Channels: 4
1 CHANNEL 2 CHANNELS 4 CHANNELS
Independent 2 Tx Coherent 4 Tx Coherent

2 Channel Bonded (Beta) Nx4 MIMO (Beta)

Nx2 MIMO (Beta)

4. Set the Frequency to 20 GHz and Power to 0 dBm.

: Adustments [ ! 20.000 000 000 000 00 GH;
S (1775 off |1 Phase 0deg - 4
| [Group 1: Signals el AWGN  Off off

: Pulse Off Corr
| | Nofile selected Swap 18&Q Off AM  Off PwrLim Off
Delay Os q

Adjustments [ Output Mod ) (RF Output

1/Q off | /Q  Off Phase 0deg
AWGN Off - Pulse Off Corr Off

— Swap 18&Q  Off AM  Off PwrLim Off
Delay 0s

20.000 000 000 000 00 GHz

5. Select the Apps block to open, then select 5G NR.

., RFOut(Al)  Trigge
= [#| © R > o L T 0. m

Keysight PathWave Signal Generation

@ 56 NR @ Custom @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)

Modulation (Beta)
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6. Select the Waveform tab and set the Total Number of Antennas 2. This
means that two antenna port signals will be generated.

RF Out (All) Trigger

— EEE , (q] > Apps:56NR - I P

& Generate Carrier Waveform

[ Export 89600 VSA Setup

Marker Required License Version Date
Waveform Comment
Crest Factor Reduction

3GPP Version

AWGN
User-Defined Sample Rate

7. Select the Carriers tab > Cell Specific node, and set Bandwidth to FR2
100 MHz. Keep the rest of the default settings.

Custom Modulation (Beta)

", Generate Carrier Waveform
FulHilled Config T* DL TestModel g™ DL FRC Config < Auto Frequency Offset [+ Export 89600 VSA Setup
General Carrier Type Downlink

Spectrum Control Cell ID 0
FR2 100MHz ~

Numerology Mode Single Numerology v
Downlink

Numerology p=3:120kHz v

Max RB 66
kO ]

Configured Bandwidth

8. Select the Downlink node > SS/PBCH > RB Offset by 60 kHz SCS and set
to 0.
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This automatically changes the Delta Frequency to Carrier Center to
-33.12 MHz. Using 0 RB Offset puts the SSB at the lower edge of the
carrier.

Custom Modulatior
", Generate Carrier Waveform
e Fullfilled Config T~ DLTestModel E" DLFRC Config < Auto Frequency Offset [+ Export 89600 VSA Setup

General BWP E ) Sha ectrum Channel Access

Spectrum Control [l NR-PBCH A dices 0:3

. 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,00,C
Cell-Specific oo MIB

0
DL-SCH
kSSB by subcarrierSpacingCommon 0

B csiRs

Delta Frequency to Carrier Center -33.12 MHz

. LTE-Coexistence f . 0

W Prs PSS Power Boosting 0dB

9. Select the Downlink node > DL-SCH> Transmission Settings and confirm
DMRS ports is set to 0,1. Set Number of DMRS CDM groups without data
to 2.

Number of DMRS CDM groups without data is used to determine how
many resource elements are reserved for DMRS. When this parameter is
changed, the DMRS power boosting is automatically coupled based on
table 4.1-1 of 38.214.

You will see the layer number is updated to 2 and each layer is assigned
with a particular DMRS port. You'll also see that Antenna Ports Generated
is automatically set to PO,P1, which will map the multiple antenna port
signals to different antennas (instruments).

Aodulation (Beta)
* Generate Carrier Waveform
w Fullfilled Config T+ DL Test Model g“ DL FRC Config « Auto Frequency Offset [+ Export 89600 VSA Setup
General Settings Antenna Port(s) Generated
DMRS port(s)
Cell-Specific DCI Resource Allocation Number of Layers

Number of Antenna ports
Modulation and Coding

B csiRs DMRS Settings

Number of Codewords

PTRS Settings

HARQ Settings

10. Select the Resource Allocation node and set:
— Allocated Slots to 2:79
— RB Offset to 20
— RB Number to 20
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DL-SCHO will occupy the RBs 20-40 and DL-SCH1 will occupy the rest of
the resources.

Custom Mo
Carrier Waveform
mn Fullfilled Config T+ DLTestModel @~ DL FRC Config

< Auto Frequency Offset [-+ Export 89600 VSA Setup

General BWP General Settings

First Symbol

Spectrum Control [ SBCH Transmission Settings

Cell-Specific H pci Last Symbol
Bandwidth Part BWP1
Modulation and Coding
RA Type Type 1 ~

B csiRs DMRS Settings
RB Offset 20

5 se .
GIRSSELNgA RB Number 20

HARQ Settings VRB-to-PRB Mapping Non-interleaved

11. Select the Modulation and Coding node and set:
— MCS to 20

— MCS Table to 5.1.3.1-2 (256 QAM)
Notice that modulation is updated to 256 QAM.

ation (Beta)
Carrier Waveform

un Fullfilled Config T+ DLTestModel @~ DLFRC Config < Auto Frequency Offset [+ Export 89600 VSA Setup

General ! er General Settings Channel Coding v

Spectrum Control . C Transmis ettings MCS 20

Table 5.1.3.1

oo Resource Allocation

TB S g Factor 1.0 ~v

Coding Rate

B csiRs DMRS Settings
PTRS Settings

HARQ Settings

12. Select the DMRS Settings node and set DMRS Power Boosting to 3 dB.
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When CDM Group Number is 2, DMRS power boosting becomes 3 dB per

3GPP.

™ Apps S5GNR * Custom Modulation (Beta)

¥ Generate Carrier Waveform

mm FulHfilled Config T+ DLTestModel g~ DLFRC Config < Auto Frequency Offset [+ Export 89600 VSA Setup

General t s General Settings
Spectrum Control 'PBC Transmission Settings
Cell-specific ) Resource Allocation

Modulation and Coding

B LTECoexistence PTRS Settings

H PRS HARQ Settings

5 Configuration
DMRS Duration
DMRS-add-pos
PDSCH Mapping
DMRS-typeA-pos

N_ID_O

0

3dB

Type 1 ~

Single Symbol
]

Type A

CellID

13. Under the DL-SCH 0 node, select the + icon to add a new +DL-SCH

(DL-SCH1).

¢, Generate Carrier W m
ms Fullfilled Config T+ DL Test Model < Auto Frequency Offset [+ Export B9600 VSA Setup
General BWP
um Control [§ F H Transmission Settings

Resource Allocation

Modutation and Coding

[

PTRS Settings
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This will create a conflict between DL-SCHO and DL-SCH1. This will be
resolved in a later step.

Carrier 0, C

& Generate Carrier  Waveform
uH Fullfilled Config T~ DL Test Model g° DL FRC Config +% Auto Frequency Offset [ Export 89600 VSA Setup
S General BWP + .. General Settings n_SCID

Spectrum Control [l SS/PBCH Transmission Settings

DMRS Configuration
Cell-Specific Hoci DL-SCH 1 Resource Allocation

DMRS Duration

Modulation and Coding
DMRS-add-pos

Il cSI-Rs PDSCH Mapping

[l LTE-Coexistence PTRS Settings DMRS-typeA-pos

N_ID_0
ettings
PRS HARQ Settii

% Channel Allocation Summary

CRBpu=3

14. From the Channels node, select DL-SCH > DL-SCH1 > Transmission
Settings and set DMRS port(s) to 0,1. Change the Number of DMRS CDM
groups without data to 2.
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Notice that Number of Layers is updated to 2 and each layer is assigned
with a particular DMRS port. Antenna Ports Generated is automatically
assigned PO,P1, which will map generated multiple antenna port signals
to different antennas (instruments).

Custorn Maodulation (Beta)
", Generate Carrier Waveform
#s Fullfiled Config T+ DLTestModel g° DLFRC Config < Auto Frequency Offset [ Export 89600 VSA Setup

General BWP 4 wew General Settings Antenna Port

Spectrum Control [} SS/PBCH DL-SCHO DMRS port(s)

o — g Number of Layers
cific oo Resource Allocation .

Number of Antenna ports
Modulation and Coding
B csi-Rs DMRS Settings

Number of Codewords

Bl LTE-Coexistence PTRS Settings

B Frs HARQ Settings
15. Select the Resource Allocation node and set:
— Allocated Slots to 2:79
— RB Offset to 45

— RB Number to 18

Notice that this resolves the conflict between DL-SCH channels. (The pink
shading is removed from the Channel Allocation graph. To clear the
conflict error message at the bottom of the display, select the Message
icon (bottom, right corner) and select Clear.

¢ Custom Modulation (Beta)
Carrier waveform
m Fultfilled Config T+ DLTestModel [~ DLFRC Config « Auto Frequency Offset [+ Export 89600 VSA Setup
General BWP i e General Settings
Spectrum Control . J DL-SCH O Transmission Settings
Cell-Specific . DCl
Modulation and Coding
M csi-RS DMRS Settings
RB Offset 45
[l LTE-Coexistence. PTRS Settings 18

l PRs HARQ Settings VREB-to-PRB Mapping Nor-interleaved

Frame0 ~ =3 v g pisplay Detail

Channel Allocation Summary

DL-SCH1
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16. Select the Modulation and Coding node, and set MCS to 20.

Use the default MCS Table to Table 5.1.3.1-1 (64QAM). You will see the
modulation is updated to 64QAM.

Custom Modulation (Beta

nerate Carrier Waveform

#. Fullfilled Config T+ DL TestModel [~ DLFRC Config = Auto Frequency Offset [+ Export 89600 VSA Setup

General Settings Channel Coding
ym Control SS/1 O DL-SCHO Transmission Settings 20
& X 3 (64QAN -
cell-Specific ’ i Resource Allocation s o (DA A
10 v
DMRS Settings
LTE-Cot stence PTRS Settl S
| £ SRS Transport Block Size
M RS HARQ Settings BaseGraph

Channel Allocation Summary Frame0 ~ p=3 v g& pisplay Detail

DL-SCH1

17. Select the Waveform tab > Select Generate.

View the waveform by selecting Spectrum on the bottom display.
Antenna0 v 1Q Spectrum CCDF
-@- Spectrum

100

120

61.44 MHz 61.44 MHz

18. Select the File icon on the top right and select Export Signal Setup (*.scp),
and save the file.
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You will need to copy this setup file to the UXA to speed up demodulation
on the UXA using X-Apps.

RF Out (All) Trigger ?

PRESET |

% New
Open
Save As

Export Waveform

Import Signal Setup (*.scp)

Export Signal Setup (*.scp)

19. Select the Carrier tab and select Export 89600 VSA Setup and save the
file.

You will need to copy this setup file to the UXA to speed up demodulation
on the UXA using the 89600 VSA software.

% Generate Carrier Waveform
m Fullfilled Config T DL TestModel @ DL FRC Config < Auto Frequency Offset [+ Export 89600 VSA Setup
- General Carrier Type Downlink

Spectrum Control Cell ID 0

Bandwidth FR1 100MHz

Single Numerology
Downlink

Numerology p=1:30kHz v

Max RB 273

kO 0

Intra-Cell Guard Band (u = 1)
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20. Select the Home icon and set RF Out to On by selecting the numbered
channel indicator switches, and then select RF Out (All) master control
switch to turn the RF output On for both channels or off for both channels.

| Adjustments ‘_>Output Mod i [ RF Output
| 20.000 000 000 000 00 GHz

‘I/Q off /Q On Phase 0deg

i
([Group1:signals | — aweN  off | Pulse Off — cor off
| | NR5G_Ant0.wfm 0Hz Swap 18&Q Off AM  Off PwrLim Off

Delay 0s 0dBm
! e

4 1/Q Out e S ALC OFF
| Adjustments Output Mod | [RFOutput
J 1/Q off 1/Q  On Phase 0deg
AWGN off — Pulse  Off jt COIT Off
Swap 1&Q Off AM  Off PwrLim Off
Delay 0s

20.000 000 000 000 00 GHz

21. Select the Signal block to open.

| Group 1: Signals
File None selected

22. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

(11} r ~— » ~ c c
- T (&) (-] » Group1:Signal Summary
Hbae ) l: | , p 1: Signal Summary

Enabled  Signal Mode Frequency Offset Aftenuation

WOW NV WV VWV WV VYV

Fading

Enable
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23. Select the Trigger tab and set Trigger Source to Global Trigger.

— EEE v @ @ > Group 1: Signal Summary » Signal 1: Setup
General Trigger Mode Trigger Source Global Trigger

Continuous v Global Trigger v Global Trigger Source
Immediate

Waveform File

Trigger CaptUsMude Synchronization State

Trigger & Run On
Markers

Trioger Delay Edit Global Trigger »
Os

Enable Playback Synchronization

[ Group 1: Signals ‘ [ Adjustments (OutputMod  On|  [RF Output off
No file selected 11Q Off : /Q off Phase 0deg
AWGN off Pulse Off Corr Off
Swap 1&Q Off AM  Off PwrLim Off
Delay 0s L =
e ‘ 1/Q Out

Demodulate the 5G NR 2x2 MIMO in X-Apps

Changing settings on the VSA can take longer to take affect than
expected. Wait to change the next setting until the previous setting has
been updated.

On the Primary UXA:
1. From the N9042B select Mode/Meas > 5G NR &V2X Mode > OK.
If accessing the instrument via a Remote Desktop connection, select the

Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known
state.

3. From the N9042B Menu Panel (or the Screen tab), select Mode/Meas > 5G
NR & V2X Mode > Modulation Analysis Measurement > OK.
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4. From the Menu Panel, select Meas Setup > Radio and turn MIMO On.

Q Meas Setup ¥

Direction
Downlink

MIMO
On Meas
Off Standard

Component
Carmiers

Meas Time
Multi Channel
Config Channel
- Profile

Interfering Signal Advanced
Present -
On
Off Decode

Frequency Offset

iJ
From Edge o

Meas

Span
5.000000 MHz

5. Select Multi Channel Config to open the Configuration dialog box.
— Set Channel 1 IP Address to Local

Enter the IP address for Channel 2

Select Locked for both Channel 1 and Channel 2

Configuration

Advanced Acquesiion

Channel 1

Channel 2

Unused local

Unused local
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Once MIMO mode is ON and both channels are locked, the
secondary N9042B display changes as shown below.

Remote 89600 VSA

A remole computer (or instrument) with hostname "UXA-US90420226 is currenlly controling the local hardware
To resume the local signal analysis aclivities, please release the hardware rom the remole compuler (of instrument)

Instructons 1o release the local hardware

if the local hardware is controbed by the 89600 apphcation
ument) with hostname UXA-US904 20226
and perform Disconnect or "Exil’
4 ~ontrol menu and select "Disconnec
1 [+] mﬂ navigate to l—#- menu and select "Exit

if the local hardware is controlled by the XSA MIMO measurement

Locate the remole C ( st : v = UXA-USS0420226"
Bring up the active XSA application and sel the measurement 1o Single mode
of swilch 10 another measurement, of close the application

6. Select Recall (If accessing the signal analyzer remotely, select the Folder
icon at the bottom of the display) > Demod Info > set Data Type to CC
Setup > Recall From > and Recall the setup file.

You must be in the correct analysis mode to recall the .scp file.

SOMNR DU FRZ 250000 100M sgen

7. Select Trigger > Trigger tab and set Select Trigger Source to External 1
and Trigger Level to 1 V.

Q Trigger

Select Tng Source
External 1

Penodic

Trigger Level Sync Src
100V
Auto/

I?_Tngget Delay | Holdoff

1.000 ps

On
Off

E_‘;nu;:a;er Slope
Positive
Negaln.re

(Tngger ‘Seftings |

8. Select Meas Setup > Settings tab> Optimize EVM.
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Optimize EVM is an immediate action to adjust the hardware settings to
minimize EVM.

L0

Normal method will capture input signal, measure its peak power
then the algorithm will find proper setting combination for
attenuation, preamp and IF Gain.

Iterative method will capture input signal multiple times in a
iteration process, demodulate the signal and calculate EVM for each
iteration and find setting combination for attenuation, preamp and
IF Gain with minimum EVM.

For 5G NR signals, this method is much slower, than normal, but
with achieve better EVM results. You can also manually adjust IF
Gain, Frequency Extender Attenuation (use when measurement
setup includes a V3050A frequency extender).

Meas Setup ¥

Component Camer

CCOo

Avg|Hold Number

10

Averaging
On
oft

Radwo
Meas
Standard

Component
Camers

Average Mode Meas Time

Exponential

Channel

Acquisition Mode Profile

Sequential A

Advanced

Decode

Power
Meas

Optimize EVM

EVM Optimization

Method
Normal
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View the results.

Demodulate the 5G NR 2x2 MIMO Using VSA:

1. Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the Screen tab (at the top
left of the display) to open the Mode/Measurement/View Selector window.
2. To configure the hardware, go to Utilities > Hardware > Configurations.

3. Open the Discovered Instruments tab and verify that the two UXAs are
listed, if not, select the Rediscover Instruments icon.

2= Hardware ? X

Configurations Discovered Instruments

4 TCPIPO
Keysight N9042B Signal Analyzer (TCPIP0:141.121.151.206:inst0:INSTR)
Keysight/Agilent PXA Signal Analyzer (TCPIP0:K-N9030B-42898:inst0:

Keysight/Agilent UXA Signal Analyzer (TCPIPO:k-n9040b-122
Keysight N9042B Signal Analyzer (TCPIPO:uxa-us9042010:
Keysight/Agilent PXA RF Tuner (TCPIPO:K-N9030B-428!
Keysight/Agilent UXA RF Tuner (TCPIPO:k-n9040b-12206:i

b SIM

P USR
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4. In the Configuration tab, select the + icon.

E Hardware ? >

Configurations Discovered Instruments

Current Analyzer Configuration: | Anahzer3 - Channels: Baseband:

Analyzer3

Analyzer

5. Scroll down the Possible Logical Instruments and select Keysight/Agilent
X-Series Signal Analyzer twice.

a. Select the first Keysight/Agilent X-Series Signal Analyzer and then
press the right arrow to move it under the Configuration area.

b. From the middle of the dialog box, select the down arrow next to the
Analyzer and select the IP address of the Primary UXA.

c. Repeat the two steps above for the second signal analyzer but
select the IP address of the Secondary UXA.

2% New Hardware Configuration ? X

1. Select the logical instrument(s) to use. Sources and Analyzers cannot be combined within the same configuration.
Simulate Hardware

Possible Logical Instruments Configuration

£
4 Analyzer - Keysight/Agilent X-Series Signal Analyzer
Keysight VSA Stream
Keysight/Agilent X-Series Signal Analyzer
CXA, EXA, MXA, MXE, PXA,
UXA, CXA-m, UXM Series.
Frequency range depends 3
upon model and options. Hints:
Baseband or RF inputs
depending upon options.

Keysight/Agilent X-Series Signal Analyzer

The primary instrument that has trigger out wired
to trigger in on the other instruments must be
placed first in the configuration.

2. Select the instrument(s) to use for each logical instrument in the configuration.

ABC Keysight NO042B Signal Analyzer TCPIP0::141.121.150.79::inst0:INSTR =~

6. Select OK to create the new configuration.
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7. In the Configurations tab, set the Current Analyzer Configuration, select
the Analyzer number for the new configuration. In this example Analyzer 3.

E Hardware ? X

Configurations Discovered Instruments

Current Analyzer Configuration: Analyzerd Channels:

i+ilgZ &
4 Analyzer Configurations
4 Analyzer
4 Keysight/Agilent X-Series Signal Analyzer
[ MN9042B (TCPIPO:localhost:hislip0:INSTR)
4 Analyzer2
ysight Spectrum Demo
[O% SpectrumDemo (SIM:SpectrumDemo)
4 Analyzer3
4 Keysight/Agilent X-Series Signal Analyzer
[mg] MNO042B (TCPIPD::141.121.15 inst0:INSTR)
4 Analyzerd
gnal Analyzer
r:instl:INSTR)
4 Keysight/Agilent X-Series Signal Analyz

[ N9042B (TCPIP0::141.121.15 st0:INSTR)
=]

8. From the menu bar, select Input > Channels > RF > 2 Channel.

E Vector - Keysight PathWave Vector Signal Analysis (89600 VSA)

File Edit Control Source | Input | MeasSetup Trace Markers Window  Utilities Help

Channels > ﬂ Baseband: 2 Channel » 1 Channel
Analog.. » |¥ | 2Channel

. 3 Channel
Digital... -

~ 4 Channel
Capture...

Correction...

\|,, l| ‘lru fi

“ ) ‘ ,JI il
Data From I| \ 'ﬁ

I
0
Recording... '
Select Switch: None

Switch...
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9. From the menu bar, select File > Recall > Recall Setup and navigate to the
.setx file you save during the VXG waveform generation.

E Vector - Keysight PathWave Vector Signal Analysis (89600 VSA)

File | Edit Control Source Input MeasSetup Trace Markers Wi

Fa Recall Recall Setup...
Preset rdi
D Save
Export
Copy Trace...
= -
(! Print. Ctrl+P

Exit Alt+F4 Recall Demo...

You can also set the frequency and span of both channels under Meas
Setup > Frequency.

If you are using a UXR, Select Autorange.

Auto Range samples the current input signal and then sets the full scale
input range to the minimum range that includes the peak voltage sample
of the input signal.

PR MeasD1 - MeasSetup 7 X
Frequency ResBW Time Average

Measurement Channel:

B: Ch2 Spectrum LCenter:

28 GHz 100 MHz

7| Show Center/Span

¥ Auto Frequency Step

Time Data:

Zoom v Mirror Frequency

B &

I INT REF | AL O

10. From the menu bar, select Input > Trigger and set:

— Style to External
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— Levelto1V

Arizlog Digital Trigaer

Input Trigger Channel B

11. From the menu bar, select MeasSetup > 5G NR Demod Properties>
Advanced tab and select the DC Punctured check box.

As part of conformance test, 3GPP has defined different equalizer training
and tracking for EVM measurements. 3GPP Conformance Test is enabled
by default where Tracking, Equalizer Training and EVM Window, and
Symbol Timing is applied per 3GPP conformance test requirement. For
FR1, no tracking is applied. For FR2, Phase Tracking using PTRS is applied.
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5G NR counts the DC subcarrier as a valid subcarrier for rate-matching
purposes. The network decides if the DC subcarrier is modulated or not.
High LO feedthrough will impact demodulation and EVM performance of
the input signal. This is OFF by default.

Configuration Input & Antenna Time Decode Advanced

| 3GPP Conformance Test
Tracking: Equalizer Training

Transient Period

Length:

Power Change Threshold: . .o

1Q Impairments
1Q Imb. Estimation Mode: = Off
Compensate |Q Offset ¥| DC Punctured
UL Spectrum Flatness
+| Spectrum Flatness Enabled
Test Environment Condition: | Normal ¥ Test Tolerance: | 1.4 dB
Error Vector Unit

Time Domain: | Per Symbol ~ | Freq Domain: | Per Subcarrier ~

12. Close the 5G NR Properties dialog.

13. From the toolbar, select the Auto-Range dropdown and select EVM-Table
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based
on prescribed table/algorithm instead of using EVM in the feedback
loop. This method of EVM auto-range is normally faster than Meas
Based Iteration, but may not achieve the most optimal setup for
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire
measurement, uses the measured EVM in the feedback loop, and
tries to adjust hardware parameters to minimize the EVM. It is the
slowest EVM auto-range method, but it should achieve the most
optimal setup for good EVM.

tup  Trace  Markers  Window  Ublities  Help

mo wmE | RE O H
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Creating and Analyzing a 4x4 MIMO using a UXR Running VSA
Software

Equipment Setup

M9484C front panel Channel 1 Event 2 to UXR rear panel Aux Trig In

M9484C rear panel 10 MHz Out A
to UXR rear panel 10 MHz Ref In

CH1 RF1 Out UXR+

CH2 RF2 Out UXR |
CH3 RF3 Out UXR
CH4 RF4 Out UXR

— M9484C
— Four channels (M9484C-004)

— N763TAPPC PathWave Signal Generation for 5G NR
— UXR0334

— UXR0O00-602: DDC option with 2 GHz BW
— 89600 PathWave Vector Signal Analysis (VSA)

On the VXG:

1. Connect the equipment as shown above.

2. Select Preset » Preset to set the VXG to a known state.
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If a Synchronization Alignment is required, indicated by in the
bottom left corner, tap or click the warning message and choose Perform

Alignment before proceeding.

b3 5 g ngs
[n] 2 Instrument tings

Instrument Information Global Trigger Synchronization Status

- - . The e globa er for fur s d ct ilizing Global Trigger will be .
1¥0 Configuration s : g - i s nization On

Alignment G ne: ,2022, 01:01:01 AM
" Immediate v

Global Trigger/Sync

Power On/Presel

Reference

1/Q Waveform

Service

Preferences

Perform Alignment Clear Alignment

3. In the Output area for all four channels, set the Frequency to 5 GHz and
Power to -10 dBm.

5.000 000 000 000 00 GHz

-10.00 dBm

ALCON

5.000 000 000 000 00 GHz

-10.00 dBm

ALCON

5.000 000 000 000 00 GHz

-10.00 dBm

ALCON

5.000 000 000 000 00 GHz

-10.00 dBm

ALCON
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4. Select the Apps block to open, then select 5G NR.

RF Out (Ally Triguer

(] > Apps X [
@ -

Keysight PathWave Signal Generation

(@) 5GNR (@) custom @) (@) LTEFDD (Beta) @) UTETOD (Beta)
LK “L=  Modulation (Beta) i 17 i

5. Select the Carrier tab > DL Test Model and set the Test Model to
NR-FR1-TM3.1. Leave other settings as default and select OK.

NR-FR1-TM3.1
Bandwidth FR1 100MHz

= Output power dynamics
Numerology p=1:30 kHz
Duplex Type
Freque:

NR-FR1-TM3.1 > EVM for 6

Phase Compensation Auto

DCI/DLSCH Payload Data

6. Select the Waveform tab and set the Total Number of Antennas to 4. This
indicates that two antenna port signals will be generated.
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7. Select Generate to apply the signals to each channel. The expected
spectrum can be observed in the bottom window.

RF Out (All) Trigger

i~ (Q] > Apps:SGNR - 72

¢, Generate Carrier | Waveform
[+ Export 89600 VSA Setup
Capability Waveform Playback

Marker § £
Required License Version Date
Crest Factor Reduction
Waveform Comment
AWGN
3GPP Version
Routing User-Defined Sample Raie
Sample Rate

Time Scale Factor

Number of Radio Frames

Antenna0 v ¢ CCDF

8. To simplify analysis, select Export 89600 VSA Setup and save the file.

Lﬂ_l S Apps:5GNR
*, Generate Carrier Waveform
[+ Export 89600 VSA Setup

Capability Waveform Playback

Marker ¥ : : 4

Required License Version Date
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9. Select the Home icon to return to the main block diagram, and then
select the gray 1, 2, 3, and 4 to turn on each channel.

RF Out (All) Trigg: 'S
" L

% L £V
as [

Adjustments ] Output Mod ¢ | RF Output
. — T E 5.000 000 000 000 00 GHz
Off ! Phase O0deg
AWGN [oli} R Cor  Off
Swap 18&Q Off ) PwrLim Off
Delay os -10.00 dBm

ALC OFF

Adjustments ] ¢ [RF Output
e - T wEm | 5.000 000 000 000 00 GHz
11Q off [ Phase O0deg
AWGN [oli} —— Cor  Off
Swap 18&Q  Off ) PwrLim Off
Delay Os -10.00 dBm

ALC OFF

[ -k
\ | Group 3: Signals Adjustments ! ( | RF Output
= ane | Aclustn : Rtk upg wE 5.000 000 000 000 00 GHz
11Q off [ f Phase 0deg
AWGN [oli} —— e Cor  Off
Swap 18&Q  Off ! PwrLim Off
Delay 0s ; -10.00 dBm

ALC OFF

[ R " 1 i [
Jon & sa R Aduments | OutptMod _On|  \RFOUpt G0 o oo 000 000 000 00 62
3 11Q off [ I/Q On Phase O0deg
AWGN off e Plilse Off Cor  Off
Swap 18Q  Off ! PwrLim Off
Delay 0s ;

-10.00 dBm

ALC OFF

On the UXR
1. Open the VSA software.

To access the VSA software, go to the Windows Start menu and find
Keysight 89600 Software (latest installed version) folder and run the
software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.
3. To configure the hardware, go to Utilities > Hardware > Configurations.

If it is already configured, go to step 10.
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4. Open the Discovered Instruments tab and verify that the UXR is listed, if
not, select the Rediscover Instruments icon.

2= Hardware ? X

Configurations Discovered Instruments

4 TCPIPO
eysight N9042B Signal Analy CPIP0:141.121.151.206::i
-eysight/Agilent PXA Signal Ana
t/Agilent UXA Signz
ght N9042B Signal Anal
ght/Agilent PXA RF Tuner ( =
Keysight/Agilent UXA RF Tuner (TCPIP0:k-n9040b-12206:inst0:INSTR)
b SIM
P USR

5. In the Configuration tab, select the + icon.

E Hardware ? >

Configurations Dhscovered Instruments

Current Analyzer Configuration: | Analyzerd

2
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6. Scroll down the Possible Logical Instruments and select Keysight/Agilent
Infiniium Series Oscilloscope, and then select the right arrow to move it
under Configuration.

2 New Hardware Configuration ? X

1. Select the lo

t Simulate H:

Possible Logical | e Configuration

;
4 Analyzer -
Keysight VSA Stream
Keysight/Agilent Infiniium Series Oscilloscops
fbandwidth from
GHz depending
upon model. 4 Inputs.

Keysight/Agilent Infiniium Series Oscilloscope

Hints

2. Select the instrument(s) to use for each lo strument in the configuration.

ADC Keysight/Agilent Technologies Infiniium Series Scope TCPIPO:localhostzinst0:INSTR =

3. Name the configuration.

Analyzer2

Cancel

7. From the middle of the dialog box, select the UXR to be used.

2. Select the instrument(s) to use for each logical instrument in the configuration

ADC geysight/Agilent Technologies Infiniium Series Scope TCPIPOzlocalhostzinstd:INSTR ~

8. Select OK to create the UXR configuration.
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9. In the Configurations tab, set the Current Analyzer Configuration by
selecting the Analyzer number for the new configuration. In this example
Analyzer 3.

Configurations Discovered Instruments

Current Analyzer Configuration: Analyzer3 Channels: Baseband: 1 Channel

=+ f 6 Analyzer

4 Analyzer Configurations Group Type: Analyzer

4 Keysight/Agilent Infiniium Series Oscilloscope

Infiniium (SIM:Infiniium)

ght/Agilent Infiniium Series Oscilloscope

| mE| Infiniium (SIM:Infiniium)

Analyzer3

4 Keysight/Agilent Infinilum Series Oscilloscope
7 Infiniium (SIM:Infiniium)
ght/Agilent Infiniium Series Oscilloscope

Infiniium (SIM:zInfiniium)

ight VSA Stream

Properties

Stream (USR:Stream)
10. From the menu bar, select Input > Channels > Baseband > 4 Channels.

Input | MeasSetup Trace Markers Window Utilities Help

Channels » Baseband: 4 Channel » Channel

Q 2 Channel
Analog.. 1+jQ »

3 Channel

Digital... Custom...
' [T 4 channel

Capture...
Trigger...
Playback Trig
External M

Extensions...

Us orrection...

Playback User Correction...

Data From

cording...
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11. From the menu bar, select MeasSetup > Frequency and set the Center
Frequency to 5 GHz and Span to 100 MHz on all four channels.

MeasSetup | Trace Markers Window  Utilities Hel

E Meas01 - MeasSetup

Frequency ResBW Time Average

Measurement Channel:
Center: Span:
5 GHz 100 MHz

v Show Center/Span Full Span

| Auto Frequency Step

Time Data:

Zoom Mirror Frequency

12. If External Trigger is available, it is recommended to use it to speed up the
demodulation of the measurement. From the menu bar, select Input >

Trigger and set:
— Style to External
— Levelto1V

Aralog  Digil  Trigger Pl

Input T

Time Criteria: Tirned;
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13. Select File > Recall > Recall Setup and navigate to the setup file you
saved during the VXG 5G NR setup.

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application, or continue with the settings below to
setup the VSA manually.

14. From the menu bar, select MeasSetup > Measurement Type > Cellular >
5G NR > 5G NR Modulation Analysis.

15. To configure the Analysis region, select MeasSetup > 5G NR Demod
Properties > Configuration tab and select Open Test Model > TM3.1 >
Apply > Close.

o]

Configuration Input & Antenna Time = Test Model

Save As Quick Setup.. | Quick Setups... -) Settings changed but not applied.
3GPP Version: Latest (2022-03)
Carriers Link Direction: ® Downlink
Carrier Indexes:
Bandwidth
Configure... + Add Carrie

Bandwidth: FR1 100 MHz
BWP

Channel Reference: | CCO = Displa Duplex Type: DD

Numerology: p=1:30kHz

Test Model: TM3.

i ™11
Modulation Format:

Open Test Model.. T™M1.2
- - T™2.0
3 Cross-Carrelated EVM
Results & Filters o TM2.0a
Confic

TM2.0b

TM3.1
Manually apply settings T™M3.1a
TM3.1b

TM3.2

M9484C VXG and X-Series SA Measurement Guide 205



Advanced Measurements
Creating and Analyzing a 4x4 MIMO using a UXR Running VSA Software

16. Select the PDSCH tab, scroll down, open the Antenna Port tab and set
Antenna Ports Used to 0:3. Repeat for the remaining PDSCH channels by
selecting the corresponding number at the top.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup... | Quick Setups... -

Add PDSCH Remove PDSCH  Clear All Enable Channels...

Bandwidth
PDSCH: . 11(2](]3

BWP
Modulation: QAMG4 Resulting Format: poooobobobDDDDDD
Channel
Transport Block Size: 835976 RB Ref CORESETID: -1 ~  RAType:
SS/PBCH
T 2 ! 5 3RB RB Number:
PDCCH

nip Source Cell ID
PDSCH

nip 1
CSI-RS VRB-To-PRB Mapping: ' Non-Interleaved ~ VRB

CORESET ID: =1

Results & Filters ~ Rate Match Pattemns: None
Custom ModFormat:

Antenna Port
Ref. Antenna Port: 1000 Ant. Det. Threshold:
Use Antenna Ports Index
Antenna Ports Index: Codeword Number:
Antenna Ports Used: | 0:3 DMRS CDM group(s) without data: |

PRB Bundle Size: Wideband

17. To reduce measurement time, select MeasSetup > 5G NR Demod
Properties >Time and set:

— Result Length to 5 Subframes
— Meas Interval to 2 Subframes

— Enable Frame Trigger is present.
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We are using an external trigger for this example so selecting Frame
Trigger is Present will use the external trigger and will speed up the

measurement significantly. If not using an external trigger, set to

Normal.

Configuration Input & Antenna

Analysis Region
Result Length: 5 Subframes
Meas Offset: 2 Subframes
Meas Interval:

Time Scale Factor: 1

Analysis Start Boundary

® Frame
Half-frame
Subframe
Slot

First Slot Index

Timing Diagram

Time Decode Advanced

0 Slots

0 Symbols

0 Symbols

Acquisition Mode
MNormal
Reduced acquisition length
Frame trigger is present

Slot trigger

Result Length 5 Subf. ———

Meas. Interval 3:0
* Meas. Offset 2:0

Frame Boundary

18. At the top of the display, select Autorange.

File Edit Control Source Input

| | C) ,\E All ~| Range To Peak Power (Default) ~

A: OFDM Meas: All Layers

MeasSetup Trace Markers Window

[

Utilities  Help

oo
H &0
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19. Observe the demodulation results.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities Help
|| > ,\\, All ¥ Range To Peak Power (Default) ~ [ A 55- </ H | I 22 u“ A 50% 0%
A: OFDM Meas: All Layers ~

0.5 dBm|

I B: Ch1 Spectrum
5 i

F: Frame Summary

EVM Power per RE Num. of
m Name (% (dBm) Modulation pp 1™ = RNTI - BWP ID

C: Summary

G: DMRS MIMO Info
Meas. Antenna Despread EYMPower TAE Frequency OffsetPhase Offset
Channel %rms) (d (sec) (Hz) (deq)

S Chi 02 134.4p -40.7243

Name

D: OFDM Err Vect Spectrum: All Layers

g -0.5 dBm”

— Trace A: Composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal. See Trace F (Frame Summary) for the list of
channels and modulation formats.

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and
symbol.

— Trace E: Detected Allocations Time showing the detected
allocations of all channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod
Format, Number of RB, RNTI, and BWP ID of the individual
channels/signals.

— Trace G: MIMO Info table shows EVM, power, and time, frequency
and phase offset for each antenna port.
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MIMO Info is a type of Matrix Table that provides sortable rows by
column, selectable column visibility, and copy/paste and export
functionality to share rows of content or complete tables to
applications like email, text editing or spreadsheet programs.

M9484C VXG and X-Series SA Measurement Guide 209



Advanced Measurements
Creating and Analyzing a 4x4 MIMO using a UXR Running VSA Software

210 M9484C VXG and X-Series SA Measurement Guide



M9484C and X-Series Analyzer Measurement Guide

4 Other X-Series Signal Analyzer Measurements

KEYSIGHT

TECHNOLOGIES

“Setting Up a Group Delay Measurement” on page 212
“Setting Up Millimeter-Wave Measurements” on page 222
— “Setting up a 5G NR Millimeter-Wave Measurement” on page 222

— “Setting-up a Millimeter-Wave DVB-S2X 64APSK Measurement” on
page 231

— “Setting-up a Millimeter-Wave 5G NR, 2 GHz BW FR2
Measurement” on page 253

“Using the X-Series Analyzer’s SCPI Recorder Function” on page 277
“Using the X-Series Analyzer’s Preload/Unload Function” on page 290
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Setting Up a Group Delay Measurement

Group delay is a measure of phase distortion. Group delay is the actual transit
time of a signal through a device under test as a function of frequency. When
specifying group delay, it is important to specify the aperture used for the
measurement.

In a group delay measurement:

— The linear phase shift component is converted to a constant value
(representing the average delay).

— The higher order phase shift component is transformed into deviations from
constant group delay (or group delay ripple).

— The deviations in group delay cause signal distortion, just as deviations from
linear phase cause distortion.

— The measurement trace depicts the amount of time it takes for each
frequency to travel through the device under test.

In this measurement example, we will use the M9484C VXG to generate a
wideband modulated signal, drive this through a filter and the N9042B UXA
will analyze the output signal and display the filter characteristics (gain, phase,
and group-delay). Also, all settings to the VXG will be made via the Connection
Management setup in the N9042B/N9056EMOE application.

We will start by running a calibration to remove the fixture characteristics
(cables, connectors, and other passive components) between the source and
the device under test (DUT), in this case the filter. The filter in this example is a
500 MHz bandpass filter, centered at 10.27 GHz. Settings my need to be
adjusted for your filter.

For this example we are using the follow equipment:
— M9484C

— Frequency range to 13.5 GHz (M9484C-514, M9484C-520,
M9484C-532, or M9484C-544, or M9484C-554)

— N9042B (you can also use a N9040B, N9033B, N9030B, N9020B, or
N9021B)

— N9056EMOE Channel Quality/Group Delay Measurement application

— Accessories
— Two 3 dB attenuators

— Baseband filter
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1. Connect the two 3 dB attenuators, cables and adapters between the VXG
and UXA (omitting the filter).

10 MHz out = Ext Ref In

%

Event 1 out > Trig 1 In_

Attenuato Bandpass filter

After running a calibration to remove the effects of the fixturing, we will
insert the filter between the two attenuators.

2. From the N9042B, select Mode/Meas > Channel Quality/Group Delay
Mode > Group Delay Measurement > Quad display View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

The Quad display shows the Spectrum, Gain Phase, Gain Magnitude, and
Group Delay measurements.

3. In the Frequency menu panel, set the Center Frequency to 10.27 GHz and
Span to 1 GHz.

4. In the Meas Setup menu panel, select the Signal Generator tab and
confirm the Center Frequency is set to 10.27 GHz (the frequency of the
filter) and set the Amplitude to +10 dBm.

The power is set to +10 dBm to compensate for the affects of the
attenuators on the edges of the trace.This is because the SNR has been
reduced by the attenuators and without increasing the power you would
be essentially measuring the "noise" at the edges.

5. Select Connection Management.

6. In the New Signal Generator area, specify the Hostname or IP address of
the VXG, then select Add to Generator List > Connect.
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This allows us to setup the VXG directly from the UXA.

Spectrum Analyzer 1 | Q o (> C
Swept SA | Meas Setup =

Connection

Management | Setlings

Connection Management GIose) <

] |
\ Frequency Tone
| 10.270000000 GHz

Auto

Man

Singal Generator List prormrre 4
Amplitude Advanced

Name (Optional) Hostname/IP Address I i | ik

boxer15.srs.is keysight.com Information = | Global

k-m8384b-30137

I Apply Settings to |
_Slgnal Generator )

New Signal Generator

Hostname/IP Add To Generator
o k-m9384b-30137 List

Name (Optional) Delete Selected
Generator

7. Select Apply Settings to Signal Generator to send these settings directly
to the VXG, then Close the Connection Management window.

8. In the Meas Setup menu panel select the Tone tab and set the Number of
Tones to 501 with a Tone Spacing of 1 MHz to provide a 500 MHz
wideband signal.

Q Meas Setup ¥ |- -

Number of Tones |
501
Tone Spacing
1.000000000 MHz =
| Signal
Ref Tone Adjustment | Generator

On
Off Advanced

Configure

Tone Table Global
Measurement i
| Threshold Level
| -60.00 dB

On
Off

| Measurement Range
| 495.99 MHz

Auto
Man

= = —
| Signal Generator

Notice that the span has automatically changed to 626.3 MHz to
accommodate the Tone settings.

9. Select Configure Tone Table. There are lots of settings to choose from, but
we will use these default settings.
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— Fill Type to Random Phase
— Random Seed Type to Fixed
— Random Seed to 0

10. Select Apply Fill and all of the phase points get filled in for the 501 points.
(Originally there were 64.)

11. Select Apply Tones to Signal Generator to setup the multitone signal.

You will notice there is some ripple in the traces.

If there is an Input Overload in the UXA, go to Amplitude > Attenuation tab > and increase
the Mech Atten 2 dB at a time until the overload condition is resolved.

12. Close the Configure Tone table.
13. Select the Calibration tab > Calibrate Tones.

The calibration will calculate the difference between tone definition and
average input trace (magnitude and phase).

14. Once the calibration is complete, connect the filter between the two 3 dB
attenuators to see the response of the filter.

15. For this example, set the Gain Magnitude Scale/Div to 5 dB and the
Group Delay Scale/Div to 1 ns. For your specific measurement adjust the
screen settings to a value that allows you to get the best signal resolution
on your measurement displays.

LA |
KEYSIGHT |nputRF Input Z- 50 O Atten: 12 dB Trig: Free Run Center Freq: 10.270000000 GHz
| Coupling: DC Comr CCorr RCal Pre: Int off, LNA off Avg|Hold:>25/25
L:J Align: Auto/No RF Freq Ref: Ext (S) pW Path: Bypass
Bus Out OF

1 Spectrum v 5 Gain Phase
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 20.00 * Ref Value 0.0 °

el PN | Y I f
| Center 10.2700 GHz Span 626.3 MHz
4 Gain Magnitude v | 6 Group Delay
Scale/Div 5.00 dB Ref Value 0.00 dB | Scale/Div 1.000 ns

|

Mttt |

I
|
|
|
|
i
:}
i

Center 10.2700 GHz Span 62‘5.3 MHzg_eﬂter_:logzgu_Gl:lz Span 626.3 hjl-_E‘
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16. From the menu panel, select Marker > Settings > Marker Settings
Diagram.

17. Activate Marker 1 by setting Marker Mode to Normal and set Marker
Trace to Gain Phase. Click and drag Marker 1 to the Reference Marker 2
position. Activate Marker 2 by setting Marker Mode to Delta, then set
Marker Trace to Gain Phase to put the marker on the Gain Phase
measurement, then Close the window.

The Gain Phase is really input versus output instead of absolute phase.

Marker Settings Diagram

Touch a Marker fo select it.

Reference 2
Marker

Drag a Marker to another Marker's reference position to make it
the reference Marker for that Marker

L Nar Marker Mode Marker Trace
SoIEEL Tl Delta (A) Gain Phase

Marker 2

18. Move Marker 1 to the Peak of the Signal within the bandwidth range of
the signal and Marker 2 to the minimum.

216 M9484C VXG and X-Series SA Measurement Guide



Other X-Series Signal Analyzer Measurements
Setting Up a Group Delay Measurement

This provides the peak-to-peak deviation across this portion of the
bandwidth of the filter. For this example, Peak to Peak Deviation is
54.69 °.

KEYSIGHT |!nputRF Input Z- 50 O Atten: 12 dB Trig: Free Run Center Freq: 10270000000 GHz
Coupling: DC Comr CCorr RCal Pre: Int off, LNA off Avg|Hold:>25/25
(] Align: Auto/No RF Freq Ref Intemal W Path: Bypass
Bus Out Off

1 Spectrum v 5 Gain Phase
Scale/Div 10.00 dB Ref Value 0.00 dBm ‘ Scale/Div 20.00 *

|
|
;

Center 10.2700 GHz ] Span 626.3 MHz|Center 10.2700 GHz _ Span 626.3 MHz|
4 Gain Magnitude 6 Group Delay v
Scale/Div 5.00 dB Ref Value 0.00 dB Scale/Div 1.000 ns Ref Value 0.000 s

Center 10.2700 GHz Span 626.3 MHz Center 10.2700 GHz. ) ) Span 626.3 MHz

19. Go back into the Marker Menu and turn on Marker 3 and set Marker Mode
to Normal and Marker Trace to Avg Group Delay. Drag Marker 3 to Marker
4’s Reference Position. Turn on Marker 4 and set Marker Mode to Delta
and Marker Trace to Avg Group Delay. Close the Marker Settings Diagram.

Marker Settings Diagram

Touch a Marker to select it.

Norm Delta Off

Reference 2
Marker

Drag a Marker to another Marker's reference position to make it
the reference Marker for that Marker

Marker Mode Marker Trace

S arke:
elected Marker Delta (A) Avg Group Delay ¥

ET
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20. Move Marker 3 to the peak of the trace and Marker 4 to the minimum.
For this example, peak to peak Average Group Delay is 4.42 ns.

Center Freq: 10.270000000 GHz
Avg|Hold >25/25

Atten: 12 dB
Pre: Int off, LNA off
pW Path: Bypass

Input Z: 50 O
Comr CCorr RCal
Freq Ref: Internal
Bus Out Off

Trig: Free Run

KEYSIGHT /ineut RF

Coupling: DC
[:) Align: Auto/No RF

5 Gain Phase AMkr

Scale/Div 20.00 *

1 Spectrum \

Scale/Div 10.00 dB Ref Value 0.00 dBm

Center 10.2700 GHz
4 Gain Magnitude
Scale/Div 5.00 dB

Span 626.3 MHz Center 10.2700 GHz
6 Group Delay

Ref Value 0.00 dB | Scale/Div 1 OOD ns

Center 10.2700 GHz Span 525 3 MHz|Center 10.2700 GHz

21. From the menu panel, select Trace > Averaged Trace Off. With Averaged
Trace Off, you can capture smalls spurs that might occur on the trace.

Atten: 12 dB
Pre: Int off, LNA off
pW Path: Bypass

Input Z: 50 O
Comr CComr RCal
Freq Ref Ext (S)
Bus Out Off

Trig: Free Run Center Freq: 10.270000000 GHz

Avg|Hold>25/25

“KEYSIGHT _fnput i

Coupling: DC
Align: Auto/No RF

1 Spectrum v

Scale/Div 10.00 dB Ref Value 0.00 dBm

Center 10.2700 GHz
4 Gain Magnitude

Scale/Div 5.00 dB Ref Value 0.00 dB

Center 10.2700 GHz

218

5 Gain Phase
Scale/Div 20.00 *

ety |
Span 626.3 MHz|Center 10.2700 GHz

! 6 Group Delay
| Scale/Div 1.000 ns

=

Span 626 3 MHz|Center 10.2700 GHz

Mkr2 10

Span 626.3 MHz

[Center102700GHz = Span626.3 MHz MHz
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22. Turn Instantaneous Trace Off and Averaged Trace On then set the
Aperture to 10% to get a smoother result, but lose a little bit more at the
beginning and the end of the 500 MHz band.

The Group Delay Aperture is the span over which the math of the delta
phase over delta frequency is calculated.

i + Q Trace
KEYSIGHT [nputRF Input Z-50 0 Atten- 12 dB Trig: Free Run Center Freq- 10.270000000 GHz

upling: Com CCorr RCal Pre: Int off, LNA off AvglHold: 21725 Instantaneous Trace
) F Freq Ref: Ext (S) W Path: Bypass o
Bus Out Off Off

1 Spectrum 5 Gain Phase | Averaged Trace

On
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 20.00 * Off

Reference Trace i
On
Off

Aperture
100 %

Center 10.2700 GHz
4 Gain Magnitude

Span 626.3 MHz/Center 10.2700 GHz Span 626.3 MHz

6 Group Delay v
Scale/Div 5.00 dB Ref Value 0.00 dB | Scale/Div 1.000 ns
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23. Now set Aperture to a very narrow aperture of 1%. Any deviation or noise
in the phase trace will show up a lot more. However as it averages down,
the noise will average away.

Q Trace
Input Z: 50 O Atten: 12 dB Trig: Free Run Center Freq: 10.270000000 GHz l 7
Corr CCorr RCal Pre: Int off, LNA off AvglHold 18725 nstantaneous Trace
Freq Ref: Ext (S) uW Path: Bypass | On
Bus Out Off i Off

1 Spectrum 5 Gain Phase L va’;.xgged Trace
: n
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 20.00 ° i Off

|Reference Trace =
On
Off
§Apeﬁure
1.00 %

Center 10.2700 GHz Span 626.3 MHz|Center 10.2700 GHz
4 Gain Magnitude | 6 Group Delay
Scale/Div 5.00 dB Ref Value 0.00 dB Scale/Div 1.000 ns

24, From the N9042B, select Mode/Meas > Channel Quality/Group Delay
Mode > Group Delay Measurement > 3x2 View.

The 3x2 View will add the RF Envelope (Instantaneous Envelope) and
Metrics. Other interesting Views to look are the 1Q Waveform that is similar
to the RF Envelope, or add the Phase View. Phase only is the absolute
phase of the tone.
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KEYSIGHT |!nput RF Input Z- 50 O Atten: 12 dB Trig: Free Run Center Freq: 10270000000 GHz
Coupling: D! Comr CComr RCal Pre: Int off, LNA off Avg|Hold >25/25
Align: Aut { Freq Ref: Ext (S) pW Path: Bypass
Bus Out: Off

1 Spectrum 5 Gain Phase
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 20.00 °

Center 10.2700 GHz Span 626.3 MHz Center 10.2700 GHz
4 Gain Magnitude 6 Group Delay
Scale/Div 5.00 dB Ref Value 0.00 dB Scale/Div 1.000 ns

Center 10.2700 GHz ] ] ] ___ Span 626.3 MHz Center 10.2700 GHz ) ] Span 626.3 MHz

3 RF Envelope 1‘ 9 Metrics

Scale/Div 10.00 dB Ref Value 0.00 dBm
e P SR e R S R PO R R e S RS e

Basic Sample Averaged
Signal Power -4.17 dBm -4.18 dBm
Frequency Error 0Hz 0Hz
Clock Error 0.0001 ppm 0.0009 ppm
Time Offset 152.3146 ns 595.5620 ns

Group Delay Sample Averaged Max Hold
30.166 us| RMS 67.1852 ps 67.1886 ps 673144

| =
Meas Time 30.166 ps (23615 pts) 1 R90A n< 1a01A1

M9484C VXG and X-Series SA Measurement Guide 221



Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

Setting Up Millimeter-Wave Measurements

The V3080A Vector Signal Generator Frequency Extenders are designed to
extend the frequency range of Keysight's M9484C for millimeter-wave
applications up to 110 GHz.

The V3050A Signal Analyzer Frequency Extenders are unbanded, preselected
devices designed to extend the frequency range of Keysight's N9042B UXA for
millimeter-wave applications up to 110 GHz.

We will connect the output of the M9848C VXG to the V3080A, then connect
the output of the V3080A to the input of the V3050A, and finally connect the
VV3050A to the UXA to measure frequencies at 60 GHz and above. For complete
setup instructions, refer to the V3080A Startup Guide.

Trigger 1

in ( N9042B
— M9484C | o

™\

[ooo

ol

ngh IF USB-C [||2=88 ©
In \ ooog ©
ooog ©

[c = 50 B9 % e=

000000

000000 ac

o)

000000 00
2o

"SRF Input

High LO
Igom LO Out
USB-C USB-C
IF Out V3050A V3080A IF/RF
Pass Thru In
TmmFtoF
Cable
Setting up a 5G NR Millimeter-Wave Measurement
The VXG must have the N7631APPC Signal Generation for 5G NR license
NOTE installed.
On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 60 GHz and Power to
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.
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4. Select 5G NR to enter the 5G NR signal mode.

Trigger

o, RF Out (All)
ssn | D
= | =) () > Avps -

Keysight PathWave Signal Generation

@ 56 NR @ Custom @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)

. Modulation (Beta)

5. In the 5G NR setup, select the Waveform tab and observe the Phase
Compensation and Radio Frequency settings.
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Phase Compensation is applied by default at baseband for RF
up-conversion. This means it depends on the carrier frequency, and the
waveform should only be played at the carrier frequency it was generated
for, unlike conventional Signal Studio waveforms, which are independent
from carrier frequency. Phase Compensation is set to Auto by default. The
frequency is coupled with the VXG frequency setting. You can select
Manual to specify a different frequency, or turn it off.

RF Out (All)

@ @ > Apps: 56 NR

[» Export 89600 VSA Setup
Number of Slots in Subframe
Waveform
Total Sample Points
Waveform Length

Mirror Spectrum

Phase Compensation

Radio Frequency

TIP Some applications, like power amplifier measurements use the same
waveform at different frequencies and can be time consuming to generate a
separate waveform for each frequency. In this case, you would turn Phase
Compensation Off, so the waveform becomes independent from the carrier
frequency. You need to do the same on the analysis side, or the demodulation
will fail.

6. Select the Carrier tab.

7. Select DL Test Model and set Bandwidth to
FR2 400 MHz and Test Model to NR-FR2-TM3.1a.
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Notice that the description of the currently selected test model appears to
the right. These test models are defined in the section 3GPP TS 4.9.2 of
38.141.

Downlink Test Model (Base Station Tx Test based on 38.141 v17.5.0)

Bandwidth e wva NR-FR2-TM3.1a

¢ Qutput power dynamics
o Total power dynamic
Numerology p=3:120 kHz range (upper OFDM
symbol power limit at
max power with all
> DuplexType 256QAM PRBs
allocated)
» Transmitted signal quality
NR-FR2-TM3.1a o Frequency error
o EVM for 256QAM

modulation (at max
Phase Compensation Auto power)

DCI/DLSCH Payload Data PN23

8. Select OK to exit the Downlink Test Model setup.

9. Select Generate to generate the Waveform, and then select Home to exit
the setup panel.

A— ssm RF Out (All) Trigger o
= # B © » , /&=
# Apps  5GNR

C Generate Carrier Waveform B
[ Export 89600 VSA Setup

Capability Waveform Playback v
Marker Total Number of Antennas 1

CrostFactor Reduetion Required License Version Date

Waveform Comment
AWGN
3GPP Version
Routing
User-Defined Sample Rate
Sample Rate

Time Scale Factor

Q Spectrum CCDF

-@- spectrum

491.52 MHz

10. Set RF Out to On by selecting the numbered channel indicator switch.
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This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

11. Select the System menu (triple bar tab at the top left of the window) to
open the System Menu and then select Configure Analyzer.

RF Out (All) Trigger (5}

[ 1L > /7 N
e !Dj © () > Configure Analyzer - [‘77 ry .

The M9484C system works with Keysight X-Series Signal Analyzers. Once a remote signal analyzer is connected, use the [Auto Configure Analyzer] button to automatically set up the analyzer to measure
the desired signal from the source.

Auto

\: Configure :
\  Analyzer /

MMB’AC Output Channel

: : : - v

Click to access source interface Click to change connection

TCPIP::hislip0:INSTR

12. In the System Configuration setup, click on the Remote Signal Analyzer
block (on far right) to setup the communication channel to the Keysight
X-Series Signal Analyzer.

S\

Click to change connection

13. Set Connection Type to LAN.

14. In the Connect Remote X-Series Signal Analyzer setup, enter the
Hostname or IP Address for the signal analyzer.

15. Under Set Protocol, select HiSLIP and use the Remote name hislipO.
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16. Select Test Connection to verify, then Back.

— ~ —~ RF Out (All) Trigger
— & = @ > Configure Analyzer > Remote Instrument - ,

Connection Type Hostname or IP Address

®) LAN 141.121.149.32 Test Connection

Protocol
Type Address

HisLIP v hislip0

17. Select Auto Configure Analyzer to send the VXG settings to the analyzer.

Auto
Configure
Analyzer

18. On the N9042B, select Meas Setup > Optimize EVM.
ﬁ Meas Setup ¥

[Component Carrier

Radio
Meas
Standard

Component

Carriers

Meas Time
| SEs Channel
| Acquisition Mode Profile

| Sequential " Advanced

Decode

Power
Meas

Optimize EVM

EVM Optimizalion
| Method
Normal

Iterative

Optimize EVM is an immediate action to adjust the hardware settings to
minimize EVM.

— Normal method will capture input signal, measure its peak power
then the algorithm will find proper setting combination for
attenuation, preamp and IF Gain.
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— lterative method will capture input signal multiple times in a
iteration process, demodulate the signal and calculate EVM for each
iteration and find setting combination for attenuation, preamp and
IF Gain with minimum EVM.

For 5G NR signals, this method is much slower, than normal, but
with achieve better EVM results. You can also manually adjust IF
Gain, Frequency Extender Attenuation (use when measurement
setup includes a V3050A frequency extender).

19. View the results on the signal analyzer.

Q Amplitude Al

KEYSIGHT 3 Input Z: 50 Q Atten: 14 dB Trig: Free Run Carrier Ref Freq: 60.000000000 GHz ‘M_hAﬂ - <
up Corr CCorr RCal Pre: Int off, LNAoff  #IF Gain: -10 dB CC Info: DL, 1 CC, SISO |Mech Atten ﬁ Y Scale
G Align: Light Freq Ref. Ext (S) W Path: FByp, On |
#PNO: Best Wide
1 CCO-BWP1 v 2 CCO-BWP1
1Q Meas Time Detected Allocations

Scale/Div 328 subcarriers | | Signal Path
r |

A

-5.948 M= 3: 120 kHz 5.948 |Start: 0.00 symbols : 1119.00 symbols
3cco 4 CCO
Spectrum Raw Main Time
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm

Adjust Atten for Min"m
Clipping i
\‘Rﬂ;tarl Meas

[ {on Adjust Atten
Ctr: 60.000000000 GHz Width: 393.2 MHz | - =) . 3 [ On

Res BW: 100 Hz Info BW: 393.22 MHz Start: 0.00 ns Stop: 22.00 ms Off

5 CCO Frame Summary ¥ IG Error Summary :;Adjust e
EVM Power per RE  Num.RB CCo Mech + Elec
111% 4494dBm | 16896 | Channel Power (Active /Total) -9.95dBm /1124 dBm JL_BEE= o
111 % -44.95 dBm 16896 EVM (RMS / Peak) 1.11%/4.49% |
P P1 1.10 % -44 95 dBm 8496 Frequency Error (RMS / Worst) 1.06 Hz /861 Hz
PDCCH (DL BWP 1 1.21% -45.51 dBm 192 | Symbol Clock Error 0.000 ppm
1.18% -45.51 dBm 192 1Q Offset (SISO) -74.08 dB —
Freq Error Time Offset 5.8¢ Mech Atten Step
Subframe 1 279 Hz Sync Correlation I ‘
Cuihfrnma 2 081 L |_Syne Source *DS( - 1 10 dB

il Jan 24, 2023 7 L e o b w A |
H E) - ? 192,53 PM A Full Bypass Enabled;Maximum safe input power reduced wss (W e I‘.

20. Change the frequency and power level of the M9484C and frequency of
the N9042A to view other results. Remember to Optimize EVM after each
change.
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This measurement was done at 70 GHz, - 10 dBm.

ﬁ Meas Setup

KEYSIGHT |Input: Ext RF Input Z: 50 O Atten: 12 dB Trig: Free Run |Carrier Ref Freq: 70.000000000 GHz Component Carrier

Coupling: DC Comr CCoarr RCal Pre: Int off, LNA off #IF Gain: -15 dB |CC Info: DL, 1 CC, SISO
Align: Light Freq Ref: Ext (S) pW Path: FByp, On
#PNO: Best Wide
1CCO-BWP1 2 CCO-BWP1
1Q Meas Time Detected Allocations
Scale/Div 328 subcarriers

| | I Standard
B Component

5.948 | Start: 0.00 symbols Stop: 1119.00 sym
4 CCO
Raw Main Time
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm

} - E i Advanced
! Decode
| Power

Ctr: 70.000000000 GHz Width: 393.2 MHz Meas

|
Res BW: 100 Hz __Info BW: 393.22 MHz iSlzrt: 0.00 ns Stop: 22.00 ms| f»

5 CCO Frame Summary ¥ 6 Emor Summary Optimize EVM

EVM Power per RE  Num.RB cco |EVM Optimization
1.45 % -45.51 dBm 16896 Channel Power (Active / Total) -10.51 dBm/-11.80 dBm i
1.45 % -45.51 dBm EVM (RMS / Peak) 1.45%/6.13% I
| 1.44 % -45.51 dBm Frequency Error (RMS / Worst) 217.2mHz /6.71 Hz r
PDCCI 1.34 % -44 57 dBm Symbol Clock Error 0.000 ppm For best EVM, set
LK -44 57 dBm 1Q Offset (SISO) -71.44 dB “Allow Full Bypass
Time Offset 7117 ms in Auto” to On(in
Freq Error B the Amplitude menu)
Subframe 1 2 Sync Correlation 99.9 |
Subdenran Sync Source PDSCH DMRS
Jan 24, 2023

- e s wa [}
20312 PM A Full Bypass Enabled;Maximum safe input power reduced wau| L%

This measurement was done at 80 GHz, - 10 dBm.

Q Meas Setup ¥
KEYSIGHT |nput: ExtRF Input Z: 50 Q Atten: 16 dB Trig: Free Run Carrier Ref Freq: 80.000000000 GHz Gomponent Carrier
L Coupling: DC Comr CCorr RCal Pre: Int off, LNA off #IF Gain: -14 dB CC Info: DL, 1 CC, SISO o
Align: Ligl Freq Ref: Ext () WW Path: FByp, On cco
#PNO: Best Spurs
1 CCO0-BWP1 2 CCO-BWP1
1Q Meas Time Detected Allocations 2 AvglHold Number
Scale/Div 328 subcarriers B
Radio

] ‘ | i .
| ‘ | ‘ | 1 Meas
_ | ‘ | | N standard
i i Component
| } | | Carriers

. F . Start: 0.00 symbols Stop: 1119.00 symbols| |Average Mode Meas Time

3cco 4cCo

| Spectrum Raw Main Time Channel
Scale/Div 10.00 dB Ref Value 0.00 dBm | Scale/Div 10.00 dB Ref Value 10.00 dBm i 1 Profile

Exponential

Advanced

Decode

Power
Meas

[Res BW: 100 Hz Info BW: 393.22 MHz Start: 0.00 ns Stop: 22.00 ms| |

5 CCO Frame Summary ¥ 6 Eror Summary

EVM Powerper RE  Num.RB cco i aﬁmgjp"m'za“"“
143 % -46.70 dBm 16896 Channel Power (Active / Total) -11.70 dBm/-12.99 dBm )
143% 46.70 dBm 16896 EVM (RMS / Peak) 1.43%/549% lterative
H PTI ) 1.42 % -46.71 dBm 8496 Frequency Error (RMS / Worst)  -649.7 mHz / 11.00 Hz i

PDCCH (DL BWP 1) 151% -47.34 dBm 192 Symbol Clock Error 0.000 ppm | For best EVM, set

152 % -47.34 dBm 192 1Q Offset (SISO) 71.59 dB “f‘g‘;“l"'UFt'g gm:ss

Freq Eror Time Offset Liellims the Amplitude menu)

Subframe 1 11.00 Hz Sync Correlation 999 % b |
Crihframn. ORT 0 midx Sync Source PDSCH DMRS

7~ Jan 24 2023 - e ey . ) i
q ( - ? 2:12:46 PM A Full Bypass Enabled;Maximum safe input power reduced
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This measurement was done at 85 GHz, - 10 dBm.

ﬁ Meas Setup
KEYSIGHT |nput ExtRF Input Z: 50 O Atten: 4 dB Trig: Free Run Carrier Ref Freq: 85.000000000 GHz i
L C ing: DC Corr CCorr RCal Pre: Int off, LNA off #IF Gain: -5 dB CC Info: DL, 1 CC, SISO e e
GO aign: Light Freq Ref: Ext (5) W Path: FByp, On cco
#PNO: Best Spurs
1 CC0-BWP1 2 CC0-BWP1
1Q Meas Time Detected Allocations
Scale/Div 328 subcarriers g
Radio

| ‘ Meas
i ‘ | d Standard
‘ . A—
i | ¥ Component
‘ Carriers
i

19.00 symbols| | Average Mode Meas Time

| Exponential
Raw Main Time | e

Channel

Scale/Div 10.00 dB Ref Value 0.00 dBm [ scale/Div 10.00 dB Ref Value 10.00 dBm ;'ch(.’is.ﬁm Mode @ Frofie

Advanced

Decode

| P | Power
Ctr: 85.000000000 GHz Width: 393.2 MHz| | i . N i | Meas
Res BW: 100 Hz __Info BW: 393.22 MHz 5 Stop: 22.00 ms|

5 CCO Frame Summary ¥ 6 Error Summary

Power per RE  Num.RB cco
-56.04 dBm 16896 Channel Power (Active / Total) -21.04 dBm/-22.34 dBm
-56.05 dBm 96 EVM (RMS / Peak) 1.07 %/ 4.53 %
F PT WP 1) % -56.04 dBm Frequency Error (RMS / Worst) 1.40Hz /9.41Hz I
PDCCH (DL BWP 1) % 1dBm Symbol Clock Error 0.000 ppm For best EVM, set
-56.00 dBm 1Q Offset (SISO) 74.75 dB “Allow Full Bypass

Time Offset 3457 ms in Auto™ to On(in

Freq Error the Amplitude menu) |
L ———

Subframe 1 240 Hz Sync Correlation 99.9
Shfeoran 0 [WERTS Sync Source PDSCH DMRS
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Setting-up a Millimeter-Wave DVB-5S2X 64APSK Measurement

The VXG must have the N7608C Signal Studio for Custom Modulation
license installed.

Setting up the VXG

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 81 GHz and Power to
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.

RF Out (All)

— | =G (0 > Aws -

Keysight PathWave Signal Generation

@ 5G NR @) Custom @ NR-V2X (@ LTE FDD (Beta) @) LTETOD (Beta)

Modulation (Beta)

5. Select the Carrier tab.
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6. In the Custom Modulation setup, select the Carrier tab > Quick Setups >
DVB-S2X > 64APSK > 4+12+20+28APSK 132/180.

(R > Aers

Custom Modulation (Beta)

Carrier Waveform [+ Import Signal Setup  [~» Export Signal Setup

i Preset ] Qu s | [+ Export 89600 VSA Setup

DVB-82 >

Custom AS DVB-S2X >

Filter APCO25 >
TETRA
NXDN B4APSK > 16+16+16+16APSK 128/180
dPMR 128APSK > 8+16+20+20APSK 7/9
DECT 256APSK > 8+16+20+20APSK 4/5

- Add Se¢ t
DMR 8+16+20+20APSK 5/6

Name s Ramp Samples Constellation Phase Rotation  Shift Bits Per Symbol Differential Offset
ARIB s 4412+20+28APSK 132/180
PLHEADER 0 e

ZigBee >
DataSeg 0 PN15 DVB-S2X 4+12+20+28APSK 132/180 0 6

QPSK 0 2

Wi-SUN(802.15.4g) >

= ITU-T G.9959 > DataSeg

0 90 2090 Sym

7. From the left pane, select Custom ASK & PSK & QAM Settings and set the
Symbol Rate to 400 Msps per channel.

R > s

™ Apps Custom Modulation (Beta)

* Generate Carrier Waveform [« Import Signal Setup  [-» Export Signal Setup

i Preset || QuickSetups [+ Export 89600 VSA Setup

Custom 1Q Selection 1 400 Msps

Filter

8. Select Filter > Alpha to 0.1.
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We will match these settings in the UXA setup.

¥, Generate Carrier Waveform [« Import Signal Setup [+ Export Signal Setup

iy Preset  [] QuickSetups [+ Export 89600 VSA Setup

Custom IQ Selection Filter Root Nyquist

Custom AS 5K & QAM Settings 0.1

Length(symbol) 32

-+ Add Segment — Remove Segment + Move Down

Name Type Number of Symbols  Ramp Samples Payload Constellation Phase Rotation  Shift Bits Per Symbol Differential Offsef
PLHEADER Data 90 0 180 bits binary data [0001...] QPsK 0 2

DataSeg Data | 2000 0 PN15 DVB-S2X 4+12+20+28APSK 132/180 0 6

.

2090 Sym

9. Select the Waveform tab, then Generate to generate the Waveform, and
then select Home to exit the setup panel.

i

™ Apps Custom Modulation (Beta)

* Generate Carrier Waveform \w Import Signal Setup | + Export Signal Setup

Marker User Defined Sample Rate

- Oversampling Ratio
Crest Factor Reduction i

Number of Frames
Multi Carrier

Total Sample Points
Correction

waveform Length

Routing

Mirror Spectrum

10. Set RF Out to On by selecting the numbered channel indicator switch.
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This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

Setting Up the UXA Using X-Apps

1. Using Spectrum Analyzer Swept SA mode, set Frequency to 81 GHz and
Span to 500 MHz.

2. Select Marker > Marker Function tab > Band Function and select to Band
Power.

3. Set Marker Frequency to 81 GHz.
4. Set Band Span to 400 MHz.

R
k ¢ a Marker v | BN
KEYS|GHT Input: Ext RF Input Z: 50 O Atten: 0 dB PNO: Fast |Avg Type: Power (RMS) ]T| 2
Coupling: DC Corr CCorr RCal Pre: Int off, LNA off Gate: Off |Trig: Free Run
;j Align: Auto Freq Ref: Ext (S) pW Path: Standard IF Gain: Low W
NFE: Adaptive Sig Track: Off

—_— Marker Frequency o
5 3 N CH- Settings
Mkr1 81 P”m GHz|¥ 41 000000000 GHz
Scale/Div 10 dB Ref Level -12.00 dBm Band Power -12.72 dBm|ik * Peak
oJs Band Function |
8 y Search
Band Power
Pk Search
Band Span Config
400.000000 MHz

s 1 | ————| Properties
: : IJW ; ® Band Left
! 80.800000000 GHz | e %

Select Marker
|| Marker 1

Band Right
81.200000000 GHz |
!

f

Meas at Mkr Window
On
Off

| | | | | | | N dB Points
‘ -3.01dB

Span 500.0 MHz
Sweep (SW Pre) ~2.39 ms (1001 pts)

Center 81.0000 GHz| Video BW 300 kHz*
Res BW 3.0 MHz

5. Select Mode/Meas > Vector Modulation Analyzer Mode > Digital Demod
Measurement > Dual Segment View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.
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Mode / Measurement / View Selector Screen Name Spectrum Analyzer 1

Sequencer Measureme

ital Demod
EMI Receiver

Custom OFDM
‘When Sequencing is On and Channel Quality / Group Delay
there are multiple Screens, all
Screens update in sequence. /EDGE /EDG
When Sequencing is Off, only SR e e Bvo .
the selected Screen updates. 1Q Waveform
LTE FDD & NB/eMTC & V2X

Monitor Spectrum

Channel Power
LTE TDD & LTE-ATDD

Occupied BW
Noise Figure

Power Stat CCDF
5G NR & V2X

Power Amplifier

Pulse

Spurious Emissions
Remote Language Compatibility

PAVT
SCPI Language Compatibility

To launch 89600 VSA press the button below. eclar Modulation Analyzer I

Launch VSA W-CDMA with HSPA+

89600 Software Version
2024 BETA1 A

WLAN

6. Select Frequency and set to 81 GHz.

a Frequency

Center Frequency
81.000000000 GHz

M9484C VXG and X-Series SA Measurement Guide

Normal

Demod Traces
Demod Error
Results Summary
Eye Diagram
Dual Segment

Frame Summary

Autosaved

Cancel
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7. Select Meas Setup >Meas Standard tab > Presel to Std, and then select
Digital Video > DVB-S2X > 64-APSK Code Rate 132/180 (11/15), then OK
to close the window.

Spectrum Analyzer 1 ’ gzl
Swept SA mod N ﬁ Meas Setup v

Radio Standard P

8-APSK

Cellular Code Rate 100/180 (5/9) < Preset To Std

8-APSK
Code Rate 104/180 (26/45) Frame

Wireless Networking

- 3 16-APSK
Digital Video Code Rate 3/5 Meas Time

Radio VB-S2X Lol

Code Rate 13/18 Demod

16-APSK ;
Others Code Rate 18/30 (3/5-L) Advanced

16-APSK
Code Rate 20/30 (2/3-L) BER

16-APSK
Code Rale 23/36 Limits.

16-APSK ;
Code Rate 25/36 Global

16-APSK
Code Rate 26/45

16-APSK
Code Rate 28/45
Press OK to execute the selected
16-APSK preset and exit this dialog
Code Rate 90/180 (1/2)

16APSK
Code Rate 96/180 (8/15)
16-APSK

Code Rate 100/180 (5/9)

8. Select BW and set to Info BW to 440 MHz.

Info BW
440,00 MHz
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9. Select Meas Setup > Demod tab and set the Symbol Rate to 400 MHz and
Filter Alpha to 0.1 for both Segment 1 and Segment 2 to match the
settings in the Custom Modulation Setup.

gvpig{ u:;nAAnalyzer i + n Meas Setup
KEYSIGHT Inpul:.Exl Rli Input Z: 50 O Atten: 10 dB Format: Custom IQ / Custom 1Q C|.=: 81.000000000 GHz Selected Segment
L Coupling: DC Comr CCorr RCal Pre: Int off, LNA off Sym Rate: 400 MHz / 400 MHz Trig: Free Run
|Align: OFf Freq Ref: Ext (S) W Path: Bypass Meas Intvi- 90 / 1000 symbols Segment 2
Info BW: 440 MHz Equalizer: Off / Off
1 Spectrum v

2 Raw Main Time v Settings
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB

Ref Value 10.00 dBm Modulation
Format

| Symbol Rate
400.0000000 MHz Frame

Meas
Standard

|Points / Symbol

5 Meas Time
Ctr: 81.000000000 GHz Width: 440 MHz

Res BW: 1.122 kHz Actual Info BW: 440 MHz Start: -143.64 ns
3 Seg1_lQ Meas Time
(Const)

Stop: 3.36 ms
o 4 Seg2_IQ Meas Time Meas Filter
(Const) Root Raised Cosine ¥ | Advanced

RefrFlller : BER
Raised Gosine v

Filter Alpha Limits
0.10

Global

{ Advanced Setup
3.718

3.718 |-3.718 3.718

) ) Constellation
5 Seg1_Metrics ¥ | TX Power -12.11 dBm 6 Seg2_Metrics ¥ | TX Power -12.11 dBm Settings
EVM 6.96 %rms 30.55 %pk EVM 8.10 %rms 21.10 %pk

Mag Error 4.86 %rms -23.69 %pk Mag Error 5.89 %ms 19.08 %pk

Phase Error 2.85 %pk -16.97 °pk Phase Error 7.59 %pk 43.60 °pk

Freq Error -7 78 kHz Freq Error 986.30 Hz

Clock Error -1.11Hz Clock Error -10.00 kHz

11Q Offset -31.65dB 11Q Offset -57.24dB

SNR (MER) 23.15dB SNR (MER) 19.00 dB

Quad Error 0.18° Quad Error 0.06"°

Gain Imb. -0.08 dB Gain Imb. -0.04 dB

10. Select the Meas Time tab and note that Meas Interval for Segment 1 is set
to 90 symbols, the same as the Header setting in the Custom Modulation
setup. Select Segment 2 and set Meas Interval to 2000 symbols to match
the Data Segment in the Custom Modulation setup.

ﬁ Meas Setup ¥

selected Segment
Segment 2

ttings
| Meas Interval L

2000 symbols | Meas

- r— = Standard
| Meas Offset

90.00 symbols Frame

[ Meas Offset
| Reference

| Rel To Sync Pattern
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11. Select the Frame tab > Segment Config Diagram and set Equalizer to turn
on for both Segment 1 and Segment 2, then Close the window.

Spectrum Analyzer 1 v ¥ ﬁ

Swept SA Meas Setup ¥

Segment Config Diagram

|Search Length
Seg Name  Modulation Format Symbol Rate Meas Offset Meas Interval Meas Offset Ref Equalizer [Sync Sez 3.36 ms

Settings

| Meas

1| Segt Custom 1Q 400.0000000 MHz 90 symbols Segment Number Standard

.
2 Seg2 Custom 1Q 400.0000000 MHz  90.00 symbols 2000 symbols || Rel To Sync Pattern gmeni Config

( Se
B —————————————] Diagram

Meas Time

Frame Length 5.225 ps | Demod
Sync Pattern Start

Eurs! Search gedvanced
Threshold |
| -15.00 dB BER

Sync Search
i Limits.

Seq?2 5.000 ps Sync Offset Global

0 symbols

( Sync Pattern

12. Select Amplitude > Signal Path tab > select Allow Full Bypass in Auto to
turn On.

Notice that is recommended in the Meas Setup > Settings tab to turn this
on for best EVM results.

Q Amplitude v

Y Scale

Q Meas Setup ¥

| Avg|Hold Number
10

| Attenuation

“| Meas
Standard

I.nternél Preamp
Low Band

On
off

LNA
On
Off

. Averaging
On
Off

Average Mode
Exponential Meas Time

Frame

= Optimize EVM Deniog
uW Path Control
UW Presel Bypass ¥
Auto
Man

EVM Optimization
Method | Advanced
Normal

BER

For best EVM, set
"Allow Full Bypass
in Auto” to On(in Limits
the Amplitude menu}

Allow Full Bypass
in Auto

On

Off

Global
Auto Couple

Meas Preset

238 M9484C VXG and X-Series SA Measurement Guide



Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

13. At the top of the display, select Equalizer On/Off. From the dropdown,
select Equalizer Reset.

| Spectrum Analyzer 1
| Swept SA
KEYSIGHT |nput: Ext RF Input Z: 50 O Atten: 10 dB Format: Custom 1Q / Custom I1Q CF: 81.000000000 GHz
Coupling: DC Corr CCorr RCal |Pre: Int off, LNA off Sym Rate: 400 MHz / 400 MHz Trig: Free Run
@ Align: Auto Freq Ref: Ext (S) MW Path: FByp, On Meas Intvl: G0 12000 symbols
Info BW: 440 MHz Equalizer: On / On
1 Spectmm v Selected Segment | Mkr1 8 0 GHz
Scale/Div 10 dB Ref Level 0.00 dBm || SS9ment2 'l Band Power -12.56 dBm
S \ Modulation Format
 Custom 1Q r

400.0000000 MHz

‘ | | | ' Meas Interval
T
|

2000 symbols

; AL G R T

| } 1 I I Equalizer Reset I

i

Center 81.0000 GHz Video BW 300 kHz" Span 500.0 MHz
Res BW 3.0 MHz Sweep (SW Pre) ~2.39 ms (1001 pts)

M9484C VXG and X-Series SA Measurement Guide 239



Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

14. In the Seg2_IQ Meas Time display, notice that the constellation diagram
goes off the display. To adjust the scaling, select the left side of the
window and set the Scale/Div to .3 (300.00 m per division) > Enter.

Spectrum Analyzer 1
Swept SA

KEYSIGHT

1 Spectrum
Scale/Div 10.00 dB

Ref Value 0.00 dBm

Ctr: 81.000000000 GHz

Res BW: 1.122 kHz
3 Seg1_lQ Meas Time
(Const)

-3.718
5 Seg1_Metrics

EVM

Mag Error
Phase Error
Freq Error
Clock Error
11Q Offset
SNR (MER)
Quad Error
Gain Imb.

Spectrum Analyzer 1
Swept SA

Actual Info BW: 440 MHz

A

¥ | TXPower

1.17 %rms
0.88 %rms
0.44 %pk

KEYSIGHT nput: ExtRF

o

1 Spectrum
Scale/Div 10.00 dB

ling: DC

oupl
Align: Auto

Ref Value 0.00 dBm

Ctr: 81.000000000 GHz

Res BW: 1.122 kHz
3 Seg1_lQ Meas Time
(Const)

-3.718
5 Seg1_Metrics

EVM

Mag Error
Phase Emor
Freq Error
Clock Error
1/Q Offset
SNR (MER)
Quad Error
Gain Imb.

240

Actual Info

¥ | TX Power

1.23 %rms
0.91 %rms
0.48 %pk

Atten: 10 dB

Pre: Int off, LNA off
MW Path: FByp, On
Info BW: 440 MHz

Input Z: 50 O
Corr CCorr RCal
Freq Ref: Ext (S)

2 Raw Main Time
Scale/Div 10.00 dB

Width: 440 MHz |
Start: -143.64 ns.

4 Seg2_|1Q Meas Time

(Const)

3.718-3.718

11.62 dBm 6 Seg2_Metrics

EVM

Mag Error
Phase Error
Freq Error
Clock Error
11Q Offset
SNR (MER)
Quad Error
Gain Imb.

258 %pk
-2.35 %pk
-1.41 °pk

533 kHz |
-47.93 mHz
-38.62 dB
38.63dB

Input Z: 50 Q
Corr CCorr RCal
Freq Ref: Ext (S)

/Atten: 10 dB

Pre: Int off, LNA off
MW Path: FByp, On
Info BW: 440 MHz

2 Raw Main Time
Scale/Div 10.00 dB

Scale/Div

I 84 ns
IG Meas Time

Clock Error
1/Q Offset
SNR (MER)
Quad Error
Gain Imb.

49.60 mHz
-37.90 dB
38.19dB
0.09°
-0.01 dB

Format: Custom IQ / Custom 1Q.
Sym Rate: 400 MHz / 400 MHz
|Meas Intvl: 90 / 2000 symbols
Equalizer: On / On

A

A

v

Format: Custom 1Q / Custom I1Q
Sym Rate: 400 MHz / 400 MHz
Meas Intvl: 90 / 2000 symbols
Equalizer: On / On

A

|CF: 81.000000000 GHz
Trig: Free Run

Ref Value 10.00 dBm

_Slqn: 3.36 ms

TX Power 11.62 dBm

0.80 %rms
0.52 %rms
0.72 %pk

2.42 %pk
2.31 %pk
526 °pk

22914 Hz |
-360.44 Hz
-71.15dB
39.60 dB
0.02°
0.00 dB

CF: 81.000000000 GHz
Trig: Free Run

Ref Value 10.00 dBm

Stop: 3.36 ms|

TX Power 11.63 dBm

0.81 %rms
0.54 %rms
0.75 %pk

311 %pk
1.90 %pk
-5.54 °pk
4731Hz
156.65 Hz
-70.91 dB
39.53 dB
0.04°
0.00 dB
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You must set this value to 300 instead of .3, the scaling gets changed to
250 k per division instead of 250 m per division.

4 Seg2_1Q Meas Time
(Const)

v

Scale/Div
300.00

15. Select Meas Setup > Settings tab > Optimize EVM.

The default setting uses the Normal method for Optimize EVM. This is a
quick way to improve your measurement results. The EVM will continue to
reduce as the UXA continues to sweep. This is because the Equalizer is
correcting for linear distortions in the measurement setup.

gvp;z%tirusrg Analyzer1 | 7 v Meas Setup ¥ % ..t_
KEYSIGHT [ Input Z: 50 Atten: 10 dB Format: Custom IQ / Custom 1Q CF: 81.000000000 GHz :
Coupl > Corr CCorr RCal Pre: Int off, LNA off Sym Rate: 400 MHz / 400 MHz Trig: Free Run
Align: Auto Freq Ref: Ext (S) pW Path: FByp, On Meas Intvl: 90 / 2000 symbols
/Info BW: 440 MHz Equalizer: On / On

1 Spectrum v 2 Raw Main Time v

Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm Meas

Standard

Ctr: 81.000000000 GHz Width: 440 MHz [
Res BW: 1.122 kHz Actual Info BW: 440 MHz Start: -143.64 ns.

3 Seg1_IQ Meas Time o 4 Seg2_1Q Meas Time
(Const) [(SLLEN

Slup: 3.36 ms
| EVM Optimization |
Method
Normal

For best EVM, set
"Allow Full Bypass

in Auto” to On(in

the Amplitude menu) §

-3.718

5 Seg1_Metrics Y | TXPower -11.68 dBm 6 Seg2_Metrics Y TXPower -11.68 dBm

EVM 1.19 %rms 2.17 %pk EVM 0.89 %rms 14.40 %pk
wag error U7 Yertis -2.17 %pk Widg Effor UB3 el s 14.39 %pk
Phase Ermror 0.47 %pk -1.24 °pk Phase Emor 0.75 %pk 6.35 “pk
Freq Error 270 kHz Freq Error 17.94 Hz
Clock Error 37.85mHz Clock Error -158.18 Hz
1/Q Offset -37.66 dB 1/Q Offset -69.78 dB
SNR (MER) 38.51 dB SNR (MER) 38.62dB
Quad Emror 0.19° Quad Emor 0.01°
Gain Imb -0.01 dB Gain Imb. 0.00 dB
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You can also set EVM Optimization Method Iterative mode, then select
either segment for optimization. This method takes a few minutes to
complete. For the example below, we set the Optimization Target to
Segment 2. Notice how the EVM went from .89% to .74%.

|Spectrum Analyzer 1 ol
Swept SA i i i | Meas Setup

KEYSIGHT [Input: Ext RF Input Z: 50 O \Atten: 10 dB Format: Custom |Q / Custom 1Q  |CF: 81.000000000 GHz
Coupling: DC Corr CCorr RCal Pre: Int off, LNA off Sym Rate: 400 MHz / 400 MHz Trig: Free Run
Align: Auta Freq Ref: Ext (S) pW Path: FByp, On Meas Intvl: 90 / 2000 symbols
Info BW: 440 MHz Equalizer: On / On

1 Spectrum v 2 Raw Main Time v

Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm

| Exponential ¥ | Meas Time

Ctr: 81.000000000 GHz Width: 440 MHz | | | | | : Optimize EVM l ‘
Res BW: 1.122 kHz Actual Info BW: 440 MHz Start: -143.64 ns Stop: 3.36 ms| | | Demod

3 Seg1_IQ Meas Time 4 3eg2_|Q Meas Time VM Optimization i
(Const) (Const) Method 1 Advanced

For best EVM, set

"Allow Full Bypass
-3.718 3.718 |-4.461 I Aoz . Qi
- - - || the Amplitude menu)

5 Seg1_Metrics ¥ | TX Power 11.58 dBm 6 Seg2_Metrics Y | TX Power 11.58 dBm e -

EVM 1.16 %rms 2.19 %pk EVM 0.74 %rms 2.08 %pk Bl toe

Mag Error 0.85 %ms -2.04 %pk Mag Erfor US0%ms Z 00U %pK I’ h
Phase Error 0.45 %pk -1.02 °pk Phase Error 0.68 %pk -4.88 °pk
Freq Error 3.71kHz Freq Error -107 74 Hz N

Clock Error -26.32 mHz Clock Error -1712Hz

1/Q Offset -38.20dB 1/1Q Offset -70.82 dB

SNR (MER) 38.75dB SNR (MER) 40.29 dB

Quad Error 0.19° Quad Error -0.02°

Gain Imb. -0.01dB || Gain Imb. 0.00dB | |

TIP You can also manually adjust to optimize EVM.

— Select Amplitude menu > Attenuation > Frequency Extender Atten.
Use the step keys to increase and decrease the attenuation by 2 dB
per step. After each increment, wait for the update to determine
where the lowest EVM point is achieved.

— Select Meas Setup > Advanced > IF Gain Other. Use the step keys to
increase and decrease the attenuation by 1 dB per step. After each
increment, wait for the display to updated to determine where the
lowest EVM point is achieved.

In this example, we found the optimum settings were 10 dB of Mechanical
Attenuation and -8 dB of IF Gain. We will use these settings in the 89600 VSA
setup.
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Setting Up the UXA Using 89600 VSA

Changing settings on the VSA can take longer to take affect than
expected. Pausing the measurement until all settings have been made will
help speed up the time. Wait to change the next setting until the previous
setting has been updated.

1. Open the VSA software.

To access the VSA software, go to the Windows Start menu and find
Keysight 89600 Software (latest installed version) folder and run the
software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.

3. From the menu bar, select Input > Channels > External Mixer > 1 Channel.

ﬁ Vector - Keysight 83600 V5A Software - Press the Mode key to switch applicatic

File Edit Control Source [Input | MeasSetup Trace Markers Wi
' Channels 3 RF 3
J[¥] 1Channel | V| External Mixer: 1 Channel  »/

Custom..,

Analog..
Digital...
Capture...
Trigger...
Playback Trigger...
External Mixer...
Extensions..,

User Correction...

Playback User Correction...

Switch...

4. In the Spectrum window, select Center and set the Center Frequency to
81 GHz. and Span to 1 GHz.

A: Ch1 Spectrum ~
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5. From the menu bar, select Input > Extensions and set:

— Microwave Path Control to Full Bypass
— Phase Noise Optimization to Best Wide Offset

File Edit Control Source | Input | MeasSetup Trace Markers  Window  Utilities  Help

1 [ &) T eas01 - Analyzer

A: (CCO) FlexFram  Analog Digital Capture Trigger Playback Trigger External Mixer

Logical Instrument:

LO Dither Off

Path Control Full Bypass

e Optimization Best Wide Offset
rection Off
Wideband IF Qutput Off
4 Parameters Influenced by the Measurement Type
4 Range
Control Methad Attenuation

| B: Ch1 Spectrum IF Gain

Mechanical Attenuation
102 Preamplifier / LNA

Mechanical Attenuation

Selects the mechanical attenuation in dB of the analyzer.
Loghdag y

— |F Gain to -8 dB

— Select the External Mixer tab and set Input Attenuation to 10 dB

These are the optimized settings we used in the
measurement.

Analog Digital Capture Trigger Playback Trigger External Mixer

Measurement/Logical Channel: .

gnal Analyzer Frequency Extender

Harmonic Table:

Input Attenuation:
10dE

Cable IF Loss:

0.26 dB

Mixer Paths:
Normal
USB Mixer

Serial Number: US62160117
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6. From the menu bar, select MeasSetup > General Purpose > Flex Frame.

2= Flex Frame - Keysight 29600 VSA Software - Press the Mode key to switch applications X

File Edit Control Source Input [|MeasSetupl| Trace Markers Window  Utilities Help

| || Frequency... 3 o £ W EE- W2t
ResBW., : )
Timew ve Syms/Errs | D: (CCO) FlexFrame Summary | E: (CCO) FlexFrame Err Vect Time | F: (CCO) FlexFrame Phase Err | G (CCO) FlexFrame Mag Error | Hi Ch1 CCDF |

Averag
F C NOT FOUND
requency

Time vs. Time...

New Measurement

Duplicate Measurement

Measurements...

Measurement Type: | Flex Vectar

Flex Frame Prope; Spectrum Analysis

General Purpose: Flex Frame

Cellular
Custom IQ Wireless Connectivity
Custom OFDM Radar Anal
B: Ch1 Spectrum Channel Quality Other standard formats
Channel Sounding

e V| Flex Frame

7. Change the Trace Layout Grid to 2 x 3.

E Flex Frame - Keysight 89600 V5A Software - Press the Mode key to switch applications

File Edit Control Source Input MeasSetup Trace Markers Window  Utilities Help

=] - ot R %L
Gi (CCO) FlexFrame Mag Error P syout ame Syms/Errs
Single
Stack 2
Stack 3
Stack 4
Stack 6

Tile Visible

8. Select MeasSetup > Flex Frame Properties > Carrier Aggregation tab, and
set:

— CCO Absolute Center frequency to 81 GHz
— Symbol Rate to 400 MHz.
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— Edit dropdown and set Assigned Carriers to CCO.

MeasSetup | Trace [ . z = : : = =
Carrier Aggregation Frame Definition Measurement Control Time Filter Customn Modulation

AT - Preset Measurement CQuick Setups * Save As Quick Setup...
LU) Flexrrame 3y

Selected CC for Trace Display: = CCO

Component Carriers

Symbol Rate ed Channels

5 Acquisition Configuration

Frequency Span: |2 GHz
Chan &
Chi1 g : 2 GHz
v CCo

® Overall Status:  Error: unassigned compo

Cross-Correlated EVM

Configure...

Acquisition Configuration

verall Status:  Error: unassigned component carriers: [CCO!

9. In the Flex Frame Properties window, select the Frame Definition tab.
Under Component Carrier Configuration, select the Modulation tab, and
then set Preferred Bit to Symbol Mapping to DVB-S2X.

E Measl1 - Flex Frame Properties
Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Component Carrier,

All

80 GHz

Carrier Configuration Allocation Summary
Configuration || Modulation | Enabled Frame Part

i FramePartl

Preferred Bit To Symbol Mapping:  pegayi

Default
Scrambler: . o DVB-52X
Scrambler Configuration 802.11ad/ay
e DVB-52/52X PLFRAME

Sequence Index: 0

246 M9484C VXG and X-Series SA Measurement Guide



Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

10. In the Frame Definition tab, under Component Carrier Configuration,
select the Frame Configuration tab and set Symbol Rate to 400 MHz and
Length to 2090 Symbols.

Carrier Aggregation Frame Definition Measurement Control Time Filter Customn Modulation
Component Carrier | CCO -

All

Component Carrier Configuration

Frame Configuration Modulation ed Frame Part Allocation
FramePart0 Alloch
Frame Type: Eoaat

Symbol Rate: .l

Length:

11. To configure the Pilot:
— In the Frame Parts area, select AllocO
— In the Configuration area, set

Name to PLHEADER

Type to Pilot

Sequence to Custom
Modulation to QPSK

Select Include BER Calculations
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— Go back into the VXG Custom Modulation setup Carrier

tab and select PLHEADER Payload to open and copy the
symbols.

Custom Modulation

(%, Generate Carrier Waveform [+ Import Signal Setup [+ Export Signal Sett

(4 Preset [] QuickSetups [-» Export 89600 VSA Setup

Pattern v
Customn ASK & PSK & QAM Settings

Fiter & Load from File [*] save to File

000111100010110100010010711107110111101110007100
010111000100001111000101101001011100010001000
011110111011100001001011010010001011101110001
00001111011071000111010001001000010007111010010

-}~ Add Segment — Remove Segment + Move Down

Name Type Number of Symbols Ramp Samples Payload

PLHEADER Data = 90 (1] 180 bits binary data [0001..]

Current: 180 Total: 180 (Max: 128K bits)
DataSeg Data | 2000 PN15 -S

View updates

— Paste the symbols you copied over from the Custom
Modulation PLHEADER Payload setup.

— In the Location area,
— Clear the End of Frame checkbox

— Start Symbol to 0
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— Total Length to 90

E Meas01 - Flex Frame Properties

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Component Car “onfiguration Allocation Summary

Frame Configuration Modulation Index  Enabled Frame Part Allocation

0 J FramePartD PLHeader

Frame Type: | gyt

Symbol Rate: | 400 MHz

Length: 2 ymbaols Auto

Frame Parts

4 FramePartD = + Add Allocation Configuration Location
PLHeader Enabled: v Start Symbaol:
Marme: PLHeader Last Symbol

Symbol Index:
Type: Pilat e :
- Bf=
Power Boost: | () dB
Total Length: 90
Payload
End of Frame
Sequence: Custom
Repeat Pattern

Custom Sequence Type: | Bit Sequence

Modulation: QPSK
¥ Include in BER Calculations

Autodetect Bit Sequence Offset

Scrambling

12. In the Frame Parts area, select Add Allocation and set:
— Name to Data
— Type to Data
— Sequence to PN15
— Modulation to DVB S2/52X APSK
— MODCOD to 4+12+20+ 28APSK Normal 132/180

— Select Include in BER Calculations
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— In the Location area, set Start Symbol to 90.

Carrier Aggregation Frame Definition Measurement Control Time Filter Customn Modulation

Compaonent Carrier Configuration n Summary
Frame Configuration Modulation

¢ | Enabled Frame Part

A cation
0 J FramePart) PLHeader
Burst -

Frame Type:

J FramePartl Data
Symbol Rate: | 400 MHz

Length:

Frame Parts

4 FramePartD |+ Add Allocation Ceuligiing Location
PLHeader Enabled: I Start Symbolk: 90
Data Name: Data Last Symbol

Type: Data
Power Boost: | () dB

CEVILEL

#! End of Frame
Sequence: PMN15 -

Repeat Pattern
Modulation: DVB-52/S2X APSK

MODCOD: 4+12+20+28APSK Normal 132/180 =

#! Include in BER Calculations
Autodetect Bit Sequence Offset

Scrambling

Enabled
Add Frame Part

Add Allocation  Remove Allocation

13. In the Measurement Control tab, and set:

— Channel Estimation Source to Allocations with Known Sequences
— Select Initial Equalization

— Normalized Channel Delay Spread to 20 Symbols
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— Clear the Show EVM in dB checkbox

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

81.54 GHz

all Allocation Control

Frame Part = A n Include in EVIM ulate BER

FramePart0 PLHEADER Pilot ) ¥

FramePartl Data Data J +

Frequency Estimation & Equalization & Synchronization

Synchronization Source: Auto

Frequency Estimation Mode: Nairal

Equalization Mode: Zero-forcing

Channel Estimation Source: Allocations with Known Sequences = ! Initial Equalization |

Normalized Channel Delay Spread:

EQ Tracking:

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Component Carrier: | CCO

Search Length: | 10.45 ps : ymbols

Result Length: | 2000 Symbols
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15. In the Filter tab, set Alpha BT to 0.1 and Length to 32 Symbols and then
close the Flex Frame Properties window.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Component Carrier; | CCO

All

80,5 GHz 815 GHz

Measurement Filter: Length:

Root-raised Cosine  ~ 32 Symbols

Reference Filter: Raised Cosine

Alpha/ET: 0.1

16. View the results of the measurement. Try to improve EVM by adjusting
the IF Gain and Mechanical Attenuation settings in the Input >Extensions
and the Input > External Mixer windows.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities Help

Il . cmem WAL R0 R A

A: (CCO) FlexFrame Meas Time | G: (CCO) FlexFrame Mag Error + % | C: (CCO) FlexFrame Syms/Errs + % | B (CCO) FlexFrame Err Vect Time

Linhag

B: Ch1 Spectrum | H: Ch1 CCDF = » % | D:i(CCO) FlexFrame Summary » % | Fi(CCO) FlexFrame Phase Err
EVM Power
(

FramePart Allocation ., First Symbol Num. of Symbals Mc

(dBm)
FramePartd

PLHeader
Data

L
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Setting-up a Millimeter-Wave 5G NR, 2 GHz BW FR2 Measurement

This measurement example will show you how to configure and analyze a
2000 MHz 5G NR, FR2, signal. 3GPP Rel-17 introduced a new frequency band
52.6 - 71 GHz, with new numerology (480 kHz, 960 kHz) and new bandwidth
(800 MHz, 1600 MHz, 2000 MHz). Support for these new
numerologies/bandwidths was added in VSA2023 Update 2.0 release and will
be part of PWSG 2023 Update 1.0.

Software Requirements

PathWave Signal Generation for 5G NR N7631APPC 2023U1 or later
89600 VSA software 8960T1BHNC VSA2023U2 or later

Using the graphical user interface
On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 70 GHz and Power to
-10 dBm.

Waveform generation and analysis speed will be very slow since we are
generating and analyzing a 2 GHz wide NR signal. (That is, 5 times more
data compared to a 400 MHz 5G NR signal.) To improve some
demodulation speed, use VSA2024, which has some speed improvement
and also use an external trigger for demodulation. (N9042B rear panel
Trigger 1 In to M9484C rear panel 10 MHz Ref Out.) Furthermore, to
improve VSA setup speed Stop the measurement until all parameters are
correctly configured, then run the measurement (Control menu > Stop).

3. Select the Radio Apps block to open the mode selection panel.

4, Select 5G NR.

= = © (nl > Apps RFO‘"(.W m[‘? D

Keysight PathWave Signal Generation

@ 56 NR @ Custom @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)

Modulation (Beta)

5. Select the Waveform tab and turn off Phase Compensation so the same
waveform can be used at different frequencies.
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Phase compensation is applied by default at baseband for RF
up-conversion. This means, it depends on carrier frequency, so a
waveform needs to be generated per carrier frequency unlike conventional
waveforms which are independent from carrier frequency. Phase
Compensation default is set to AUTO. The frequency is coupled with VXG
frequency setting. You can select Manual to specify different frequency or
turn it OFF so it is not frequency dependent.

PATH E Filev B Ssystem v

X

(Al Home 56 NR

¢ Generate 4 Generate & Download Carrier Waveform Hardware

[+ Export 89600 VSA Setup
11T Svaie ravw
Number of Radio Frames
Subframe Offset
Number of Subframes
Slot Offset in Subframe
Number of Slots in Subframe
Total Sample Points
Waveform Length
Mirror Spectrum

Off v

Marker
Marker 1 Source Waveform Start v
Marker 2 Source Frame Start v

Marker 3 Source
Marker 4 Source
v Crest Factor Reduction

6. To configure the Downlink carrier, select the Carrier tab > Full-filled
Config and set:

— Bandwidth to FR2 2000 MHz

— Duplex Type to TDD

— Number of Downlink slots to 59
— Number of Uplink Slots to 18

— Modulation to 256 QAM
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— Select OK to close the window.

PATH 3 Filev = system -

(A Home 5GNR % Fullfilled Pre

Generate + Generate & D Bandwidth FR2 2000MHz

HH Fullfilled Config | T DL Tes Numerology 1 = 6:960 kHz

ST [t

v Duplex Type
~ Carrier 0 (DL)

BWP Setup Duplex Type

Channel Setup

Transmission Periodicity

Number of Downlink Slots

Number of Downlink
Symbols

Number of Uplink Slots
Number of Uplink Symbols

ol Channel Allocation < Number of Special Slots

CRBu =1

TDD Slot Allocation
250 -
2004
00 2560AM

150 o mem

100 Cancel

These parameters are based on 3GPP endorsed Test Model for
2000 MHz bandwidth.

59 Downlink Slots UL Slats! ... 59 Dowwnlink Slats UL =lats

& sym. B sym.

A
J

1.25 ms

A

10 ms (1 Frame)
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7. Under the Carrier (DL) side tab, scroll down and set Cell ID to 201.

¢ Generate 4

uH Fullfilled Config
G il
v Carrier 0 (DL)

BWP Setup

Channel Setup

Generate & Download

T~ DL Test Model

Carrier Waveform

E° DL FRC Config

v General
Enabled
Frequency Offset
Timing Offset
Power Boosting
Initial Phase

v Spectrum Control
DC Punctured
Window Beta
Windowing Method
Baseband Filter

v Cell-Specific
Carrier Type

<% Auto Frequency Offset

Hardware

[+ Export 89600 VSA Setup

0.01
Centered at Symbol Boundary v
@

Downlink
201

8. Select Channel Setup > SS/PBCH and set Active Indices to 0:63.

Sic o
~ Carrier 0 (DL)
BWP Setup

Channel Setup

N Channel Allocation Summary

CRBp =6
148 -
120

i

30+

90,
60

0
0

DL-SCH

v §S/PBCH Block
Name
Enabled
Antenna Port Weight
Numerology
SS Block Pattern
Periodicity
Half Frame Index

CSI-RS PRS

Lmax
Shared Spectrum Channel Access

Power Boosting of each SS Block
RB Offset by 60 kHz SCS
PSS Power Boosting

RIM-RS LTE-Coexistence

SS/PBCHO
v
1
p=6:960 kHz v

10ms v
0
64

0:63
0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1024

0dB

FrameQ v py=6 v

640 Slot

With RB Offset by 60 kHz SCS set to 1024 and kSSB by
subcarrierSpacingCommon set to 0, the SSB is set to the center of the
carrier. This is shown in the Channel Allocation graph at the bottom of the
window. If you set it to 0, the SSB will be set in the lower band of the
carrier.
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Unlike LTE, there is no fixed frequency location for SS/PBCH in NR. By
default, PWSG transmits SS/PBCH (20 RB or 240 subcarriers wide)
centered at the carrier bandwidth (2000 MHz channel BW in this
example). This is a very important parameter since it shows were the
SS/PBCH is located within the channel bandwidth in the frequency
domain and it is relative to common resource block 0 (CRBO).

9. Select DL-SCH > DL-SCHO_D.

You should see DL-SCHO_D and DL-SCHO-S. These are configured from
the Full-filled Config settings above. We will make a couple edits to the
Reference Signal configurations.

(©, Generate < Generate & Download Carrier Waveform Hardware

uH Fullfilled Config T* DL Test Model §“ DL FRC Config «# Auto Frequency Offset [= Export 89600 VSA Setup

+ o SS/PBCH DCI DL-SCH CSI-RS PRS RIM-RS LTE-Coexistence T

~ Carrier 0 (DL) Name Enabled Slot Symbol BWP PRB Allocation RNTI Coding
BWP Setup DL-SCHO_D v 0:58,80:138,160:218,240:298,320:378 4... 0:13 BWP1 RATypel, 0:147 il On
Channel Setup DL-SCHO_S v 59,139,219,299,379,459,539,619 0:5 BWP1 RATypel, 0:147 1 (0]

— Confirm Allocated Slots is set to
0:58,80:138,160:218,240:298,320:378,400:458,480:538,560:618

These values will be used in the VSA/X-App. You can copy these
values for easier setup later.

v~ Resource Allocation
Allocated Slots 0:58,80:138,160:218,240:298,320:378

First Symbol 0
Last Symbol 13

— Confirm that MCS Table is set to 256QAM and MCS to 20. MCS
table, MCS value, scaling factor, etc. must match with the VSA (or
X-App) for successful decoding (CRC pass/fail).

— Set DMRS-add-pos to 1. Additional DMRS is transmitted on a
symbol before the last symbol.

— Select PTRS Enabled. For FR2, PTRS is used for phase tracking.
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— Set Time Density to 4.

SS/PBCH DCI DL-SCH CSI-RS PRS RIM-RS LTE-Coexistence + )]

Name Enabled Slot Symbol BWP PRB Allocation RNTI
DL-SCHO_D v 0:58,80:138,160:218,240:298,320:378 4... 0:13 BWP1 RATypel, 0:147 1
DL-SCHO_S v 59,139,219,299,379,459,539,619 0:5 BWP1 RATypel, 0:147 1

| Modulation and Coding
Channel Coding v
MCS Table Table 5.1.3.1-2 (256QAM) v
MCS 20
TB Scaling Factor 1.0 v
xOverhead 0 v
Coding Rate
Modulation
Transport Block Size
BaseGraph

Payload Data
DMRS Settings

DMRS-Downlink-r16
n_SCID 0
N_ID_0 Cell ID
N_ID_1 Cell ID
DMRS PowerBoosting 0dB
DMRS Configuration Type1 v
DMRS Duration Single Symbol v
DMRS-add-pos 1
PDSCH Mapping Type A v
DMRS-typeA-pos 2 v
DMRS Mapping Reference CRBO v
PTRS Settings

v
PTRS PowerBoosting 0dB
PTRS port(s)
Frequency Density (K_PTRS) b) o
Time Density (L_PTRS) 4 v
PTRS RE Offset
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10. Select DL-SCHO_S. Set PTRS Enabled and Time Density to 4. Confirm that
Allocated Slots is set to 59,139,219,299,379,459,539,619.

SS/PBCH DCI DL-SCH CSI-RS PRS RIM-RS LTE-Coexistence +

Name Enabled Slot Symbol BWP PRB Allocation

DL-SCHO_D v 0:58,80:138,160:218,240:298,320:378,4... 0:13  BWP1 RATypel, 0:147

DL-SCHO_S v 59,139,219,299,379,459,539,619 0:5 BWP1 RATypel, 0:147

TB Scaling Factor 1.0 v
xOverhead 0 v
Coding Rate
Modulation
Transport Block Size
BaseGraph
Payload Data
DMRS Settings
DMRS-Downlink-r16
n_SCID 0
N_ID_0 Cell ID
N_ID_1 Cell ID
DMRS PowerBoosting 0dB
DMRS Configuration Type 1 v
DMRS Duration Single Symbol v
DMRS-add-pos [4]
PDSCH Mapping Type A v
DMRS-typeA-pos 2 v
DMRS Mapping Reference CRBO v
PTRS Settings
PTRS Enabled v
PTRS PowerBoosting 0dB
PTRS port(s)
Frequency Density (K_PTRS) 2 v

4 v

PTRS RE Offset

11. Select the Waveform tab, then Generate to generate the Waveform, and
then select Home to exit the setup panel.
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TIP When using 89600 VSA software for demodulation, you can export the VSA
setup file from PathWave to demodulate the waveform quickly and easily or
export the setup file into X-Apps.

(A Home 56NR

> -
& Generate | v Carrier Waveform

[+ Export 89600 VSA Setup

Vv Basic
Total Number of Antennas 1
Playback License Mode PC License v
Required License Version Date
Waveform Comment
3GPP Version
User-Defined Sample Rate
Sample Rate
Time Scale Factor
Number of Radio Frames
Subframe Offset
Number of Subframes
Slot Offset in Subframe
Number of Slots in Subframe
Total Sample Points
Waveform Length
Mirror Spectrum

Phase Compensation

(o]} Spectrum CCDF

—@-— Spectrum

1.11 GHz

12. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.
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Setting Up the UXA Using 89600 VSA

Changing settings on the VSA can take longer to take affect than
expected. Stopping the measurement (Control menu > Stop) until all
settings have been made will help speed up the setup time.

1. Open the VSA software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window, then select Launch VSA.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.

3. From the menu bar, select Input > Channels > External Mixer > 1 Channel.

£ Vector - Keysight 83600 VSA Software - Press the Mode key to switch applicatic

File Edit Control Source .Input MeasSetup  Trace  Markers Wi

Channels 3 RF »
Analog... [ ¥| 1Channel | v’l External Mixer: 1 Channel  »|
Digital... Custom,.,

Capture...
Trigger...
Playback Trigger...

External Mixer..,

Playback User Correction...
Data From
Recording...

Select Switch: None

Switch...

4. In the Spectrum window, select Center and set the Center Frequency to
70 GHz.

Notice there is an OV1 error indicator. The OVx indicator appears when
the trace was created from data that contained an ADC overload. We will
resolve this in step 7.

ource Input MeasSetup Trace Markers Window Utilities Help

i o WE-.E R
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5. From the menu bar, select Input > Trigger and set Style to External and
Level to 500 mV.

Using the External Trigger will help to improve the demod speed.

e | Input | MeasSetup Trace Markers Window  Utilities Help

PR Meas01 - Analyzer ? X
Analog Digital Capture Trigger Playback Trigger External Mixer Extensions

Input Trigger Channel: |1 v
Entry Channel: . 1

Style

External

Holdoff:

Conventional 0s

Time Criteria: Timel: Time:

Trigger Out
Desired: Actual:

Trigger Out 1 T Trigger Out 1

6. Select the Extensions tab and set:
— |F Path to 2 GHz
— Microwave Path Control to Full Bypass

— Phase Noise Optimization to Best Wide Offset

Analog Digital Capture Trigger Playback Trigger External Mixer Extensions

Logical Instrument: Preset All

. Show All

4 Misc
Adc Dither Off
Capture Bit Packing Auto
Ext Reference Lock Bandwidth 15 Hz
External Trigger Location Trigger 1 In
IF Path 2 GHz
IF Path Auto Manual
Instrument User Corrections Off

LO Dither Off

rave Path Control Full Bypass

Viode

Moise Optimization Best Wide Offset
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7. Select the External Mixer tab and set Input Attenuation to approximately
20 dB, or a level where the overload flag disappears. This is to bring the
waveform up on the spectrum display.

File Edit Contrel Source Input MeasSetup Trace Markers Window Utilities Help

Il ] @fm mams [R50 I H . R M A o ox

A: Ch1 Spectrum

BB Meas01 - Analyzer ? X

Digital  Capture  Trigger  Playback Trigger | ExternalMixer | Extensions

al Channek: .

ion:

B: Ch1 Main Time ~

Mixer Paths:

LogMag
u.l‘l |' .\Mﬂ Mlﬂ. MM U”IP '{rwlﬂw\\"‘r' “\ l'u\”" \'\ﬂ‘.,\‘lw,“l Normal

USB Mixer
USB Mixer detected

Pyl &

Ijl
A

: US62160117

aliml

8. In the Spectrum window, right click on the Spectrum display and select
Auto Scale.

= Vector - Keysight 89600 VSA Software - Press the Mode key to switch applications

File Edit Contrel Source Input MeasSetup Trace Markers Window Utilities Help

el I = -

A:Ch1 Spectrum ~

& <
<> Auto Scale

Marker1 = + o
(N |

Normal - AR FEE ‘
: t

l””l\ I

- - ﬂ'u RNLT A i by Aol i
W'u\”lﬂl'q\\ .v.‘l |~|w ‘\'". f 'lﬁ.w.wq |n"|.ﬁ.pﬁ"lr'W'.f"'f"r,r.l'l' W|FJ‘H’J.1“JWV\'I ‘{_‘\,{th “I‘\lﬂ\‘l s W,l“\l h\‘ W ml “J{[rhw'w,”,. W‘ﬂ’ Mﬂﬂl "“'I ﬁl'l,ﬂﬂ'r"ﬁ ,‘1 0 i|ur i 'I' ‘l. U\“’ﬁ ﬁ\‘}' “A’ ﬂm‘w “

iy T 1
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9. From the menu bar, select MeasSetup > Cellular > 5G NR > 5G NR
Modulation Analysis.

File Edit Control Source Input |MeasSetup || Trace Markers Window  Utilities

= c BB~

New Measurement

Duplicate Measurement

Measurements...

Measurement Type: Analog Demod

Analog Demod Properties... ver Spectrum Anal
General Purpose

/EDGE/EDGE Evolution

| Eh )-5CDMA Other standard formats

1« 0
NB-loT

LTE

LTE Advanced
3G NR

Pre-5G Power Spectrum

Loghdag

Adjacent Channel Power

Spectral Emi

10. Change the Trace Layout Grid to 2 x 3. Right click on the Spectrum
window and select Auto Scale to bring the waveform back up on the
display.

E Flex Frame - Keysight 89600 VSA Software - Press the Mode key to switch applications

File Edit Control Source Input MeasSetup Trace Markers Window  Utilities Help

s . op o WEE-I R

A (CCO) FlexFrame Meas Time | G: (CCO) FlexFrame Mag Error Previous Layout ame Syms/Errs

Single
Stack 2
Stack 3

Stack 4

Stack &
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11. Select the Control menu > Stop to stop the measurement until all
parameters have configured. This will greatly improve setup speed.

File Edit}] Control

Switch Mode
Record

) Sweep

12. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Carriers panel and set:

— Cell ID to 201 (or select the box to the right to Auto Detect the cell
ID)

— Bandwidth to FR2 2000 MHz

— Frequency for Phase Compensation to Disabled.

Cell ID is carried on PSS and SSS so the SS/PBCH must be transmitted
and enabled for Auto Cell ID to work and must be a Downlink since
SS/PBCH is only transmitted in the DL.

P Meas01 - 56 NR Demod Properties ? X
Configuration Input & Antenna Time Decode  Advanced
Save As Quick Setup...  Quick Setups... -
Carriers Link Direction: '@ Downlink Uplink
T + Add Carrier Allow Multiple Carrier Definitions
Reference: | CCO ~| Display: CCO =
Cell ID Bandwidth

201 FR2 2000 MHz

Configure...
Results & Filters

Manually apply settings

13. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Bandwidth panel. This section of the Ul is to configure Resource Grid for
each Numerology. Numerology is set to p = 6:960 kHz.
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For FR2 2000 MHz, only the 960 kHz subcarrier spacing is available. This is
why the other numerologies are not shown. The Max RB is 148 RB. We will
use this value when we configure BWP, SS/PBCH, and PDSCH parameters.

P Meas01 - 56 NR Demod Properties ? X

Configuration Input & Antenna Time Decode  Advanced

Save As Quick Setup...  Quick Setups... -

Carriers
Bandwidth: = FR2 2000 MHz ~
Bandwidth

BWP
Grid Start Grid Size Grid Enabled

0RB 148 RB J

RIM-RS

Results & Filters

Manually apply s

14. Select MeasSetup > 5G NR Demod Properties > Configuration tab > BWP
panel. We will use the default settings for DL-BWP 1.

This section of the Ul is to configure the DL BWP allocation within the
component carrier and the control resource set (CORESET). CORESET is
used for PDCCH configuration and there is no PDCCH in this measurement
example, so we don't need to make changes.

A CC with 2000 MHz at FR2 has a max RB of 148 for 960 kHz numerology.
In this example, the DL-BWP uses the full carrier bandwidth of 148 RBs

M9484C VXG and X-Series SA Measurement Guide



Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

When using multiple BWPs within a single component carrier, you will
spread the total 148 RBs across the multiple BWPs.

B MeasD1 - 56 NR Demod Properties 7 X

Configuration Input & Antenna ~ Time  Decode  Advanced

Save As Quick Setup...  Quick Setups... -

Carriers
Initial-DL-BWP 0
Bandwidth
+|DL-BWP p = 6:960 kHz
BWP
DL u = 6:960 kHz
4 Channel
DL-BW 3 p = 6:960 kHz

PDSCH | Initial-UL-BWP 0 W= 61960 kHz

e CORESETs

RIM-RS
Add CORESET

CORESET: .

CORESET ID: |1 BWPID: BWP1 =

Results & Filters

| Mumber: = DMRS Scrambling ID: -1

r16 Configured CCE To REG Mapping Type: | Nen-interleaved

Allocated RE Groups (6l

Precoder Granularity: Same as REG bundle -

Manually apply settings

15. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Channel > SS/PBCH.

Configuration & Ante Time Decode Advanced

Save As Quick Setup...  Quick Setups... -

Allocation and Symbol Auto Detection
v H PDSCH PDCCH

Carriers

Bandwidth

Copy Auto to Manual
BWP B

Referenc

PDSCH IQ Ref: Demod

4 Channel

'BCH

Synchronization Config

PDCCH
Sync Source: | Auto - Source ID:

PDSCH

Sync Mode: | CP Autocorrelation - Ignore MIB Data
C5I-RS

Surmmary

EREES SS/PBCH PDCCH PDSCH CSI-RS

Results & Filters On

Manually apply settings

The auto detected parameters are returned in the Summary table trace.
Once you see what has been auto detected and are happy with what you
see, you can do "Copy Auto to Manual" to copy the detected parameters
into the SS/PBCH settings. See image below.
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The auto detected SSB parameters are returned in the Summary table.
"Copy Auto to Manual" will copy these detected parameters into the
SS/PBCH settings.

16. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Channel > SS/PBCH.

PSS and PBCH Power boosting cannot be auto detected, you must enter
power boosting values under SS/PBCH. We will use the default values.
Notice that the remaining values are grayed out as we are in Auto
Detection mode.

Note that the frequency location of a SSBlock is not fixed. In our software,
the default value of 1024RB and kSSB of 0 subcarriers places it in the
center of the carrier bandwidth. If you set RB Offset to 0 dB, it places the
SSB on the lower edge of the carrier bandwidth

Configuration Input 8 Antenna Time Decode Advanced

Save As Quick Setup...  Quick Setups... -

Carriers <
Bandwidth
BWP
4 Channel
SS/PBCH
PDCCH
PDSCH
CSI-RS

RIM-RS

0dB PBCH power boosting | 0 dB

Results & Filters

Manually apply settings
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17. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Channel > PDSCH and set:

— MCS Table to Table 256QAM
— MCSto 20

Transport Block Size value must match the PathWave 5G NR
settings for successful decoding (CRC result).

— Allocated Slots to
0:58,80:138,160:218,240:298,320:378,400:458,480:538,560:618

TIP You can copy/paste these values from PathWave 5G NR Signal Generation.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup...  Quick Setups...

Carriers Add PDSCH Enable Channels...

Bandwidth . '
PDSCH:
BWP
5 | Enabled BWPID | BWPT ~ RNTI: | 1 on:  R17 Latest (2022-09) ~
Channel
Modulation and Coding | Time/Freq Allocation
Modulation and Coding Time/Freq Allocation
RV Index: 0 Frame Period: 1 Frames
MCS Table: Table 2560AM ~ Allocated Slots:
MCS:
3 5 or 5
Results & Filters 1H Scaling Facior
Code Rate:
Modulation:

Transport Block Size:

nip Source Cell ID

VRB-To-PRE Mapping: | Non-Interleaved = VR
RESET ID:
Rate Match Patterns: None
Custom ModFormat:
148 -

Allocated RBs
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PATH B File~ E Systemv BB B
(Ml Home 56NR *

Generate v Generate & Download Carrier Waveform

uH Fullfilled Config T DL TestModel [° DL FRC Config <8+ Auto Frequency Offset [ Export 89600 VSA Setup

= [ SS/PBCH DCI DL-SCH CSI-RS PRS RIM-RS LTE-Coexistence =

v Carrier 0 (DL) Name Enabled Slot Symbol BWP PRB Allocation
BWP Setup DL-SCHO_D v 0:58,80:138,160:218,240:298,320:378,4... 0:13 BWP1 RATypel, 0:147
Channel Setup DL-SCHO_S v 59,139,219,299,379,459,539,619 05 BWP1 RATypel, 0:147

Scrambling v
RNTI 1
n_ID Cell ID
v Transmission Settings
DMRS port(s) 0
PRB Bundle Size Wideband v
User Defined Precoding
Number of Layers
Number of Antenna ports

Antenna Port(s) Generated

Number of Codewords
v Resource Allocation

18. Scroll Down to RS Sequence and set:
— DMRS AddPos to Pos1
— Select Enable PTRS
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— LPTRS to 4

Configuration Input & Antenna Time Decode  Advanced

Save As Quick Setup...  Quick Setups... -

Carriers Add PDSCH Enable Channels...

Bandwidth .
PDSCH: .

BWP B Het CUR - A Ivne:
o Transport Block Size: RB Ret CORESED IL: = - KA lype:

Channel Tra . :_ RB Mumber:

nip Source Cell ID

no

— VRE-To-PRE Mapping: | Non-Interleaved = VRE-To-PRE Interleaver:
CORESET ID: -1

Rate Match Patterns: ELE
Custom ModFormat: | Off

RIM-RS

Results & Filters Unused RBs Allocated RBEs

Antenna Port

RS Sequence
Typel - 5-Downlink-r16 | Enable PTRS
1 s 3 ource Cell ID KPTRS
Single-Symbol ~ 0 LPTRS
Pos1 v Nip 0 PTRS RE Offset
= Np' 0 AdditionalDMRS-DL-Alt

DMRS Init Option: MR Standard =~ ~ DMRS Init:

19. Select Add PDSCH and then select PDSCH 1. Set:
— MCS Table to Table 256 QAM
— MCSto20

Transport Block Size value must match the PathWave 5G NR
settings for successful decoding (CRC result). The Value depends
on parameters in this section and the RNTI value of the PDSCH
much also match. This will not affect EVM.

— Allocated Slots to 59:80:619
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— Last Symbol to 5

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup... | Quick Setups...

Carriers Add PDSCH | Remove PDSCH  Clear All Enable Channels...

Bandwidth o
PDSCH: 0 .
BEW et

4 Channel

Modulation and Coding | Time/Freg Alloca

Modulation and Coding Time/Freq Allocation
RV Index: 0 Frame Period: 1 Frames
MICS Table: Table 2560AM ~ Allocated Slots:
Slot Format:
RIM-RS TB Scaling Factor 5:
ilters TypeA Pos:
Target Cod ; 0 2 Last Symbol:

Modulation: ulting Format:

Transport Block Size: 4 : ESET ID: -1

nip Source

nio
To-PRB Mapping: | Non-Interleaved
RESET ID:

Rate Match Patterns: None
om ModFormat:

20. Scroll Down to RS Sequence and set:
— DMRS AddPos to Pos1
— Select Enable PTRS
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— LPTRS to 4

Configuration Input & Antenna Time Decode  Advanced

Save As Quick Setup...  Quick Setups...

Carriers Add PDSCH Remove PDSCH  Clear All Enable Channels...

Bandwidth S = .
PDSCH: 0

BWP 42
Transport Block Size:
Channel - - 1B Offset: RE Number:
' Cell ID
PDCCH
PDSCH _‘; VRB-To-PRE Mapping: = Non-Interleaved -
c|_pe Rate Match Patterns: None
CSI-RS Cus . | Off
RIM-RS

Results & Filters Unused RBs Allocated RBs

Antenna Port

RS Sequence

DMRS Config Typel DMRS-Downlink-r16 | Enable PTRS

DMRS Max Length | 1 N Souie Cell ID - KPTRS 2

DMRS Length Single-Symbol Mscid: ] LPTRS 4
DMRS AddPos Posl - 3 :,':' 0 PTRS RE Offset 00
DMRS Map Ref N 0 AdditionalDMRS-DL-Alt

DMRS Init Option: MR Standard = DMRS Init:

21. In the Time tab set:
— Result Length to 4 Subframes
— Meas Interval to 1 Subframes

We are reducing the analysis region since a 2000 MHz carrier has a
large amount of data resulting in very slow demod speed. (That is,
5x more data than 400 MHz carrier.)

— Acquisition Mode to Frame Trigger is Present
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We are using an external trigger for this example, so selecting
"Frame Trigger is Present" will use the external trigger and will
speed up the measurement significantly.

Meas01 - 5G NR Demod Properties ? x
Configuration Input & Antenna Time Decode Advanced
gion
Result Length: 4 Subframes
Mea et: 0 Subframes
Meas Interval: 1 Subframes

Time Scale Factor: 1

Analysis Start Boundary Acquisition Mode
Normal
® Frame
Reduced acquisition length
Half-frame
® Frame trigger
Subframe
Slot trigger is pre:
Slot

First Slot Index: O Use Periodic Trigger

Time/Spectrum,/CCDF Data Source
e All
Enabled Channels

EVM Included Channels

Timing Diagram

——— Result Length 4 Subf. -

Frame Boundary

22. Select the Advanced tab:
— Clear the 3GPP Conformance checkbox

— In the Tracking area, set Tracking Source to RS + Data and select
Phase

— In the Equalizer Training area, set Signal Source to RS + Data and
clear the Freq Moving Avg. Filter checkbox.

— Turn on DC Punctured.
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5G NR counts the DC subcarrier as a valid subcarrier for
rate-matching purposes. High LO feedthrough will impact
demodulation and EVM performance of the input.

Configuration Input & Antenna Time Decode Advanced

3GPP Conformance Test Low SMNR Mode
Tracking: Equalizer Training
Amplitude Signal Source: | RS+Data
+| Phase

— Time Basist | Per Frame -
Timing

Tracking Source: | RS+Data Freq Moving Avg. Filter 1o ps

EVM Window and Symbol Timing Transient Period
EVM Window Length Mode:
Window Length in Samples:
Vindow Length in Sample: ety
nbol Time Adjustment Mode: | Max of EVM Window Start/End ~

. Power Change Threshold: .
FT Duration:

Signal Repetition Pattern

Repetition Pattern: | Standard ~ | First Slot: | 0
10 Impairments

1 Imb. Estimation Mode: | Off

Compensate |Q Offset + DC Punctured

UL Spectrum Flatness

| Spectrum Flatness Enabled

Test Environment Condition: = Mormal + Test Tolerance: | 1.4 dB
Error Vector Unit

Time Domain: Per Symbol ~ FreqDomain: | Per Subcarrier ~

23. Close the 5G NR Demod Properties window and select Control > Restart
to restart the measurement.

24, View the results of the measurement. Try to improve EVM by adjusting
the Mechanical Attenuation setting until the OV1 indicator goes away in
the IF Gain and Mechanical Attenuation settings in the Input >Extensions
and the Input > External Mixer windows.

For this example, the optimum settings were Input Attenuation set to
8 dB and IF gain set to -12 dB.
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File Edit Contro Source Input MeasSetup Trace Markers Window Utilities Help
|| ¢ - E @ b R e

» % | G Summary x| E: OFDM Detected Allocations Time: All Layers

TimeLen 1
D: OFDM Err Vect Spectrum: All Layers ~ - X

Power per RE

Num. of _
(dBm) RBs

Modulation

Linkag
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Using the X-Series Analyzer’s SCPI Recorder Function

The SCPI Recorder feature allows you to view active recording content, and
edit the content. Right-click or touch and hold on any Ul control to display a
menu allowing you to record the SCPI associated with the control. You can also
record a series of commands. These commands can be viewed and edited
directly, or you can also play, save/recall for future use.

For this example, we will generate a simple 5G NR 100 MHz signal.

Using the graphical user interface
On the VXG:
1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 3.5 GHz and Power to
0 dBm.

3. Select the Radio Apps block to open the mode selection panel.

4, Select 5G NR.

RFOW(Al)  Trigger
@ > Apps - [l}, /v [y

Keysight PathWave Signal Generation

@ 56 NR @ Custom @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)

Modulation (Beta)
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5. Select the Carrier tab > DL Test Model and set Test Model to
NR-FR1-TM3.1b, leave the remain settings at their default values, and
select OK.

NRFR1-TM3.1b
Bandwidth FR1 100MHz

= Output power dynamics

Numerology p=1:30kHz

allocated)
Duplex Type « Transmitted signal quality
o Freque r
QAM modulation (at

NR-FR1-TM3.1b max pow

Phase Compensation Auto

DCI/DLSCH Payload Data PN23
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6. Select the Waveform tab, then Generate to generate the Waveform, and
then select Home to exit the setup panel.

(A Home 56NR

> -
& Generate | v Carrier Waveform

[+ Export 89600 VSA Setup

Vv Basic
Total Number of Antennas 1
Playback License Mode PC License v
Required License Version Date
Waveform Comment
3GPP Version
User-Defined Sample Rate
Sample Rate
Time Scale Factor
Number of Radio Frames
Subframe Offset
Number of Subframes
Slot Offset in Subframe
Number of Slots in Subframe
Total Sample Points
Waveform Length
Mirror Spectrum

Phase Compensation

Q Spectrum CCDF

0

-20
—@- Spectrum

-40

-60

-80

-100

-120

7. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:
1. Select Mode/Meas > 5G NR &V2X Mode > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known
state.
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3. From the N9042B Menu Panel (or the Screen tab), select Mode/Meas > 5G
NR & V2X Mode > Modulation Analysis Measurement > OK.

4. Select Frequency and set Carrier Reference Frequency to 3.5 GHz.

— Touch and hold the Carrier Reference Frequency function for at
least one second on the touch screen or if using a mouse pointer
and right click to open the menu.

Q Frequency

Carrier Reference
Frequency

3.500000000 GHz

Add to User Menu

Help on this setting

Show SCPI Command

Add to SCPI Recorder

Start SCPI Recorder

— Select Show SCPI Command.
The SCPI command for this function is displayed in the dialog box.

Carrier Reference Frequency x

:SENSe:CCARrier:REFerence 3500000000

OK Copy

Select Copy to copy the current SCPI command string for further
use.

If you use Windows Remote Desktop or a VNC viewer with clipboard
synchronization enabled, you can copy the SCPI command into the
clipboard. This makes SCPI commands available on the fly via a
simple copy/paste operation.

— Select Help on this setting to open the SCPI syntax document page.
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You will see the background information for that setting including
allowed values, SCPI command and examples, and other useful
information.

K1 [ [PN K2 RES

Carrier Reference Frequency

The parameter sets the reference frequency of all the carriers. The center frequencies of carriers are defined as
offset frequency from this value.

Remote [ :SENSe]:CCARrier:REFerence <freqg>

Command [:SENSe]:CCARrier:REFerence?

Example :CCAR:REF 2GHz
:CCAR:REF?
Preset 1 GHz
State Saved in instrument state
Saved
Min Depends on instrument minimum center frequency. Same as Center Frequency
Max Depends on instrument maximum center frequency. Same as Center Frequency

To Start Continuous SCPI Recording:

The SCPI Recorder supports an automatic mode of operation. In this mode, a
series of manual operations can be added to the list automatically without any
further user activity. You can start the recording process by enabling the
Continuous SCPI Recording, then disable it to stop recording after completing
all configuration steps. This is normally the best choice for fast and convenient
SCPI list recording.

There are two ways to start continuous SCPI recording:
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System Settings

System

11O Config

Preload / Unload
Modes

User Interface

Power On

Restore Defaults

Alignments

Licensing

Security

Diagnostics

Service

Other X-Series Signal Analyzer Measurements
Using the X-Series Analyzer's SCPI Recorder Function

— From the System Settings > SCPI Recorder.

Function Label

5G NR & V2X 1 o+
Modulation Analysis

KEYSIGHT
C Qo

1 CC0-BWP1
1Q Meas Time

Spectrum
Scale/Div 10.00 dB

Ctr: 3.500000000 GHz
Res BW: 100 Hz

5 CCO Frame Summary ¥

EVM

282

Input: Ext RF
Coupling: DC
\Align: Off

Power per RE

Input Z: 50 O

Ref Value 0.00 dBm

Info BW: 98.30 MHz

Num.RB

Corr CCorr RCal
Freq Ref: Int (S)

Atten: 10 dB
Pre: Int off, LNA off
uW Path: Bypass

SCPI Recorder

SCPI

Trig: Free Run
#IF Gain: Low

#PNO: Best Wide

Width: 110.6 MHz

2 CC0-BWP1
Detected Allocations
Scale/Div 328 subcarriers

Start: 0.00 symbols
4 CCO

Raw Main Time
Scale/Div 10.00 dB

Start: 0.00 ns

6 Emor Summary

Channel Power (Active / Total)
EVM (RMS / Peak)

Frequency Error (RMS / Worst)
Symbol Clock Error

1Q Offset (SISO)

Time Offset

Sync Correlation

Sync Source

From the context sensitive menu of the function key.

Carrier Ref Freq: 3.500000000 GHz

CC Info: DL, 1 CC, SISO

Ref Value 10.00 dBm

NODATA

Stop: 1.00 symbols

Stop: 22.00 ms|

ac ? X

Continuous SCPI
Recording

On

Off
Recording Limit
250

v
Frequency Range
FR1 A
Duplex Mode
v

TDD
SCS
p=1:30kHz
Auto
Man

RB Alloc Preset
Fulfilled QPSK v

Component
Carriers

Meas Time

Channel
Profile

Advanced

Remove from User Menu

Help on this setting

Show SCPI Command

Add to SCPI Recorder

Start SGPI Recorder
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1. Select Mode Preset to set 5G NR V2X mode to a known state.

2. For this example, select the System Settings icon (Gear wheel on top right
of the display) > SCPI Recorder > Continuous SCPI Recording On. Close
the System Settings window by selecting the "X" at the top of the window.

System Settings SCPI Recorder f“‘*" 9 x

{ o

W Continuous SCPI
Syeem Recording
On
1/0 Config Off

Recording Limit
Preload / Unload 250
Modes

User Interface
Power On
Restore Defaults
Alignments
Licensing
Security
Diagnostics

Service

3. Select Mode/Meas > 5G NR &V2X Mode > Modulation Analysis
Measurement > Normal View > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

4. Select Frequency > Carrier Reference Frequency and set to 3.5 GHz.
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5. Select Meas Setup > Meas Standard > RB Alloc Preset > DL NR-TM3.1 >

DL NR-TM3.1b (1024QAM) > OK.

|+

KEYSIGHT Input: RF
L EI) Coupling: AC

Align: Off
1 CCO-BWP1
1Q Meas Time

.624
3 Ccco

Spectrum Y

Scale/Div 10.00 dB Ref Value 0.00 dBm

tr: 3.500000000 GHz
Res BW: 100 Hz

KEYSIGHT lnput RF
L [:] Coupling: AC

Align: Off
| 1 CCo-BWP1
1Q Meas Time

\J
Spectrum

Scale/Div 10.00 dB Ref Value 0.00 dBm

Ctr: 3.500000000 GHz
Res BW: 100 Hz

284

Input Z: 50 O
Corr CCorrRCal
Freq Ref: Ext (S)

Atten: 14 dB (e4)
Preamp: Off
PW Path: Standard
#PNO: Best Wide
2cco
| Raw Main Time
Scale/Div 10.00 dB

Trig: Free Run
#IF Gain: Low

Carrier Ref Freq: 3.500000000 GHz
CC Infe: DL, 1 CC, SISO

Configuration
Fulfilled DL NR-TM3.1 (64 QAM)
DL NR-TM1.1
DL NR-TM1.2
DL NR-TM2

DL NR-TM3.1

DL NR-TM3.2

I
| I ——

DL NR-TM3.3

Width: 110.6 MH

6. Select Apply Preset (to All CCs).

Input Z: 50 O
Corr CCorr RCal
Freq Ref: Ext (S)

Atten: 14 dB (ed)
Preamp: Off
pW Path: Standard
#PNO: Best Wide
|2 cco
Raw Main Time
| Scale/Div 10.00 dB

Trig: Free Run
#IF Gain: Low

Carrier Ref Freq: 3.500000000 GHz
|CC Info: DL, 1 CC, SISO

u
I
: !

3.624 |Start: 0.00 ns

4 Error Summary

CCO0

| Channel Power (Active / Total) -10.29 dBm/-10.29 dBm
| EVM (RMS / Peak)

Frequency Error (RMS / Worst)
| Symbol Clock Error

IQ Offset (SISO)
| Time Offset

Sync Correlation

Sync Source

Magnitude Error

Phase Error

Width: 110.6 MHz

DL NR-TM3.1a (256 QAM) |RB Alochicse:

————
DL NR-TM3.1b (1024 QAM)

Stop: 22.00 ms| |

fe;

Meas Setup v

Bandwidth 1
100 MHz

JFrequency Range

FR1

e

Duplex Mode

10D v Componen

| Carriers
SCS
u=1:30kHz

Auto
Man

Meas Time

Channel
Profile

| Advanced
Fulfilled QPSK v

<Advanced Preset Decode

Parameters
- Power

Apply Preset pive-
(oAl CCs) )

Meas Setup

| Component
Carriers

| Meas Time

! Channel
| Profile

Advanced
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7. Select the Settings side tab and select Optimize EVM.

\KEYSIGHT gputl_RF e
Oupiing:
L GJ ;Aligr?: 0?1

1 CCO-BWP1
1Q Meas Time

Input Z: 50 O
Corr CCorr RCal
[Freq Ref: Ext (S)

Spectrum
Scale/Div 10.00 dB Ref Value 0.00 dBm

Ctr: 3500000000 GHz
Res BW: 100 Hz

Input Z: 50 Q
Corr CCorr RCal
Freq Ref: Ext (S)

KEYSIGHT Input RF
L Cpupllng: AC
Align: Off

| 1 ccoBwP1
1Q Meas Time

-3.624
3 CCo
Spectrum
Scale/Div 10.00 dB Ref Value 0.00 dBm

p=1:30 kHz

v

Width: 110.6 MHz| Magnitude Error

ﬁ Meas Setup
\Alten: 12 dB Trig: Free Run Carrier Ref Freq: 3.500000000 GHz Component Carrier
Preamp: Off #IF Gain: 3 dB CC Info: DL, 1 CC, SISO
pW Path: Bypass | _CCO
#PNO:- Best Wide |
2CCo
Raw Main Time | Avg|Hold Number

: 110
Scale/Div 10.00dB ) ) = Radio

Meas
§ Standard

Component
Carriers

| Average Mode Meas Time
Exponential vl
I = Channel
3.624 [Start: 0.00 ns = Chann

4 Error Summary o »
vance
CCO0
-0.58 dBm /-0.58 dBm
020%/1.27 %
33.4 mHz / 370.0 mHz
0.000 ppm
-89.08 dB
7.732 ms
100.0 %
PDSCHDMRS |f
0.14 %
0.00 rad

| Channel Power (Active / Total)
| EVM (RMS / Peak)

Frequency Error (RMS / Worst)
| Symbol Clock Error

IQ Offset (SISO)
| Time Offset

Sync Correlation

Sync Source

Decode

Power
Meas

Phase Error

e e e

Sweep

Atten: 12 dB

Preamp: Off

UW Path: Bypass

#PNO: Best Wide
2cco
Raw Main Time
Scale/Div 10.00 dB

Carrier Ref Freq: 3.500000000 GHz
CC Info: DL, 1 CC, SISO

Trig: Free Run

#IF Gain: 3dB Sweep / Measure

Continuous
Single

 Stop: 22.00 ms

|
|
!
|
[

3.624 |Start: 0.00 ns

4 Error Summary

CCco

Ctr: 3.500000000 GHz
Res BW: 100 Hz

Channel Power (Active / Total)

EVM (RMS / Peak)

Frequency Error (RMS / Worst)

Symbol Clock Error
1Q Offset (SISO)
Time Offset

Sync Correlation
Sync Source

Width: 110.6 MHz Magnitude Error
Phase Error
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-0.56 dBm / -0.56 dBm
0.20%/1.39 %
77.7 mHz / -466.7 mHz

0.000 ppm
-85.41dB
6.636 ms

100.0 %

PDSCH DMRS

0.14 %
0.00 rad
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9. Select the System Settings icon (Gear wheel on top right of the display) >
SCPI Recorder > Continuous SCPI Recording Off. Close the System
Settings window by selecting the "X".

System Settings SCPI Recorder " - 2 x

Function Label SCPI Continuous SCPI
! Recording

Active Mode & Measurement :INST:CONF:NR5SG:EVM on
/O Config off

Eecording Limit
250

System

Preload / Unload Query Operation Complete *OPC?
Modes |

Measurement Switch :CONF:EVM:NDEF Play
User Interface

Query Operation Complete *OPC? Copy
Power On |

Carrier Reference Frequency :SENSe:CCARrier:REFerence 3500000000
Restore Defaults

RB Alloc Preset :SENSe:RADio:STANdard:PRESet:RBALIoc DLTM3DOT1B

Alignments

Move Down
Apply Preset (to All CCs) :SENSe:RADio:STANdard:PRESet:IMMediate

Licensing Delete Row
Optimize EVM :SENSe:EVM:OPTimize

Security | - Delete Al
Sweep / Measure :INITiate:CONTinuous 0

Diagnostics
Restart ZINITiate:RESTart

Service

Manual Recording, Edit, Save and Play Functions

The SCPI Recorder supports manual recording of a list consisting of SCPI
commands comprising any number of parameter variations when Continuous
SCPI Recording is off. In this mode, the user can decide which SCPI commands
should be added to the SCPI list. This mode of recording is helpful if a certain
configuration must be figured out, and you only want to record the final,
correct settings and not every variation or keystroke.
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. Touch and hold the any function for at least one second on the touch

screen or if using a mouse pointer and right click to open the menu and
select Add to SCPI Recorder. For this is example we will change EVM

Optimization Method to Iterative.

+

Input Z: 50 Q
Corr CCorr RCal
Freq Ref: Ext (S)

Atten: 14 dB (ed)
Preamp: Off
pW Path: Standard
#PNO: Best Wide
|2 cco
| Raw Main Time
| Scale/Div 10.00 dB

Carrier Ref Freq: 3500000000 GHz
CC Info: DL, 1 CC, SISO

Trig: Free Run
#IF Gain: Low

KEYSIGHT |Input RF
Coupling: AC
Align: Off

-3.624

3CC0
Spectrum
Scale/Div 10.00 dB Ref Value 0.00 dBm

p=1: 30 kHz

v

3.624 |Start: 0.00 ns Stop: 22.00 ms|

4 Error Summary

CCco
-0.58 dBm / -0.58 dBm
0.34%/1.71%
347.2 mHz / 748.5 mHz
0.000 ppm
-83.40 dB
4.985 ms
100.0 %
PDSCH DMRS
0.24 %
0.01 rad

Channel Power (Active / Total)
EVM (RMS / Peak)
Frequency Error (RMS / Worst)
Symbol Clock Error
| 1Q Offset (SISO)
Time Offset
| Sync Correlation
Sync Source
Magnitude Error
Phase Error

i

Ctr: 3.500000000 GHz Width: 110.6 MHz

Res BW: 100 Hz

e

Meas Setup

o]

Component Carrier

_#l Radio

N Veas
Standard

i
-

iﬂvefaging

| ,.

Component

Help on this setting
Show SCPI Command
Add to SCPI Recorder
Start SCPI Recorder

|EVM Optimization
Method
Iterative

2. To view the newly added command, go to System Settings icon (Gear

wheel on top right of the display) > SCPI Recorder.
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From the SCPI Recorder provides several operations to edit the SCPI list
you created. You can Play, Copy, Move Up or Down the selected SCPI
command, Delete the command, or Delete All the commands.

System Settings SCPI Recorder

Function Label SCPI Continuous SCPI
. |Recording

Active Mode & Measurement INST:CONF:NR5G:EVM 82
1/0 Config L ! )
Recording Limit
250

System

Preload / Unload Query Operation Complete *OPC?

Modes

EVM Optimization Method :SENSe:EVM:OPTMethod ITERative Play
User Interface

Copy
Power On

Restore Defaults

Alignments
Move Down

Licensing Delete Row

Security Delete All

Diagnostics

The recorded SCPI list can be exported as a script file in .TXT format via
the Save/Recall function at the bottom of the main window.

iy - Magnitude Error 0. o
Ctr: 3.500000000 GHz Width: 110.6 MHz
Phase Error 0.00 rad

Res BW: 100 Hz T
1| Mar 22, 2023 w X
L ) & - ? 11:26:20 AM ¥4
SCPI Recorder
State
Save To File >
Screen Config + State

Measurement Data

Correction

Screen Image

Recording

Recording + State

Component Carrier
Setup
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Using the X-Series Analyzer's SCPI Recorder Function

There are two ways to playback SCPI commands. One is recalling from a
script file. And another one is pressing the 'Play' button in 'SCPI Recorder'
tab view.

Recalling SCPI script file allows you to play back a series of operations in
the same or another instrument, which helps you setup complex
measurement scenarios quickly and easily.

To recall the SCPI recording, go to Save/Recall and navigate to the saved
file.

| < SCPI Recorder Recall from File

S ';1 Computer ) D: :,\. Users ) Instrument ) Documents ) ScpiRecording \

Screen Config + State Name /A Date Size Content

aTeon [ 5GNR 100 MHz waveform b 3/2212023 11:41 AM 60B Txtfile

Complex Correction

Recording

Recording + State

Demod Info
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Using the X-Series Analyzer’s Preload/Unload Function

System Settings

System

/0 Config

User Interface

Power On

Restore Defaults

Alignments

Licensing

Security

Diagnostics

Service

SCPI Recorder

290

The Preload/Unload function allows you to flexibly configure which
applications should be preloaded when the software starts up, or also unload
any previously loaded applications. This can help to save startup time or
system memory as needed.

1. Select the System Settings icon (Gear wheel on top right of the display) >
Preload/Unload.

Preload / Unload Modes

a9 [?] X

To reduce the analyzer startup time, check only the Modes you want to preload. Selected (checked) Modes will be preload at the next
startup.
If you encounter out of memory error, unload unused Modes. It helps you keep using the analyzer program without having to restart it.

Power On Mode Spectrum Analyzer il

Preload | Loaded  Unload Mode ANST:SEL

Preload: Select All

Spectrum Analyzer SA
et P o Preload: Deselect All

Real-Time SA RTSA

Move Up

EMI Receiver EMI Move Down

IQ Analyzer BASIC Unload
WCDMA WCDMA
GSM/EDGE EDGEGSM
Phase Noise PNOISE
Noise Figure NFIG

Analog Demod ADEMOD

Bluetooth BT

— Power On Mode displays a list of licensed Applications. Use this
control to change the factory default Power-On Mode. The
instrument will execute the selected Application after power up.
Selecting the Power-On Mode here automatically enables that
Mode for preloading

— Select All, Deselect All toggles the Preload checkbox state for all
applications listed, except for the Power-On application.

— Move Up, Move Down allows you to reorder the listed applications
in the table. This is the order in which they are displayed in the
Mode/Measurement/View Selector dialog.

— Unload Mode unloads the specified mode.

— Loaded Modes returns a list of loaded modes.
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5 B5G New Radio (NR) Measurements using X-Apps

This section includes the following topics:

— “5G Waveform, EVM, and ACP Analysis Using X-Applications” on page 292

KEYSIGHT

TECHNOLOGIES

— “Setting Up Triggers on the Signal Analyzer using 5G NR Mode” on

page 292

“Setting Up a 1 CC 28 GHz EVM Measurement” on page 294
“Setting up an 8 CC 28 GHz EVM Measurement” on page 301
“Setting Up a1 CC 3.5 GHz ACP Measurement” on page 311

“Using PathWave N7631APPC to Create a Waveform File then
Automatically Configure the Analyzer to View the Results” on
page 316
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5G Waveform, EVM, and ACP Analysis Using X-Applications

5G Waveform, EVM, and ACP Analysis Using X-Applications

The VXG enables 5G testing with a low error vector magnitude (EVM) at high
frequencies. The VXG has extremely good EVM at high power levels. However,
not all signal analyzers can capture this low value. We will use the X-Series
signal analyzer with the 5G NR X-Series application to observe EVM and
adjacent channel power (ACP).

Setting Up Triggers on the Signal Analyzer using 5G NR Mode

Refer to “Equipment Setup” on page 11 for connecting the instruments and
NOTE accessing the VXG SFP.

Setting Up Triggers on the X-Series Signal Analyzer

Using the graphical user interface
1. On the signal analyzer, select Mode/Meas > 5G NR & V2X mode.

If accessing the instrument via a Remote Desktop connection, select the
NOTE Screen tab (at the top of the display) to open the

Mode/Measurement/View Selector window.

2. Select Mode Preset to set 5G NR mode to a known state.

3. Select Mode/Meas > 5G NR V2X Mode > Modulation Analysis
Measurement.

4. From the Menu Panel (on the top right of the display), select Trigger and
set Select Trigger Source to External 1 and Trigger Levelto 1 V.

ﬁ Trigger Y

Select Tng Source L
External 1 v J I

Trigger Level
100V |
{{Awtal
Tngger []e|ay | Holdoff
1.0 ps
On
Off

Trigger Slope

Paositive
Negative

< Trigger Seﬂjm_]s
Diagram
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Using the equivalent SCPI commands

On the X-Series Signal Analyzer:

INSTrument : CONFigure:NR5G

SYSTem:PRESet

Change the current window to 5G NR Modulation Analysis Measurement Mode
INSTrument : CONFigure:NR5G:EVM

TRIGger:EVM:SOURce EXTernall

TRIGger:EXTernall:LEVel 1V
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Setting Up a 1 CC 28 GHz EVM Measurement

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the Signal
Analyzer using 5G NR Mode” on page 292.

On the VXG:
1. Select Preset > Preset to set the instrument to a known state.

2. In the Output 1 area, set Frequency to 28 GHz and Power to
5 dBm.

28.00000000000 GHz

5.00 dBm
ALC ON

3. Select Group 1: Signals block to open.

Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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Enabled  Signal Mode

Fading

General
Waveform File
Trigger

Markers

5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

Frequency Offset Attenuation

>
?
>
?
>
?
>
>

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_|_|_| > Group 1: Signal Summary » Signal 1: Setup

Mode Signal Attenuation

Waveform File 0dB

Frequency Offset Power

0 Hz 0dB

Sample Rate
3.000 000 000 000 000 GHz

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples
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and choose
S5GNR 1CC FR2 120kHz SCS 100MHz 256QAM DCPunctured
_28GHz.wfm > Select.

.1& C: > Users > jacquipa » Documents ) Keysight > PathWave ) SignalGenerator » Examples ><

A4
O Recent Name ~ Date Modified

Delete
@ Waveforms
4000_SamplelQPulseOnOff_50%_wfm.csv May 8, 2020, 10:55:50 AM

L] 7his computer 56_100MHz_1CC_FR1.wfm Aug 22,2021, 11:43:56 PM ) Rename

5G_100MHz_8CC_FR2.wfm Aug 22,2021, 11:44:04 PM Clear Arb
Memory

5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured.wfm Jul 10,2019, 6:47:40 PM
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz.wfm Jul 14, 2019, 7:07:46 PM
AllFormats v

5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_1.wfm Nov 20, 2022, 11:17:24 PM

5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz.wfm Jul 14,2019, 7:05:20 PM Select

d. Select the General tab > Enable.

LJ:L| » Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation
@ Enabie

Waveform File Waveform File 0dB

Trigger Frequency Offset Power
0Hz 0dB
Markers

) 000 000 000 MHz

Reset Phase Accumulator

6. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

» Group 1: Signal Summary » Signal 1: Setup

7. Select the Adjustments block and select Optimize Dynamic Range with
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW This setting filters the system
RF flatness correction coefficients over the instantaneous bandwidth
indicated in the waveform header (or in the “Occupied Bandwidth”
settings area under the Signal block > Occupied Bandwidth setting).
This has the potential to improve EVM performance by not having to
correct for flatness errors outside the requested bandwidth. For
example, if RF flatness correction was done at 2 GHz, but you are
only interested in an 800 MHz section, then applying the correction
flatness to that portion only can improve signal to noise ratio, and
therefore EVM when there is a lot of hardware roll off.
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Enable System RF Flatness Correction - Disabling this function
disables the factory calibrated RF channel flatness equalizer.
Depending on the hardware channel response, this may hurt or
improve the EVM. This is due to the dynamic range implications as it
relates to signal to noise ratio. The greater the RF hardware
variations in flatness, the greater the amount of correction is
required, the greater the correction effectively reduces the number of
resolution DAC bits that can be used, which degrades the signal to
noise ratio and therefore potentially EVM. The trade-off is to balance
between flatness and signal to noise ratio.

@ > Output 1: Adjustments

General 1/Q Common Delay Optimizations

5 O0s —
1/Q Adjustments W| Optimize Dynamic Range with OBW

AWGN Swap1&Q
\f Enable System RF Flatness Correction

8. Close the Adjustments Setup by either selecting the Back or the Home
icon at the top of the display.

I.J:L] > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

10. For two channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.
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On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

1. Select Recall (If accessing the signal analyzer remotely, select the Folder
icon at the bottom of the display) Demod Info > Set Data Type to CC Setup
> Recall From >

5GNR_1CC FR2 120kHz SCS 100MHz 256QAM DC punctured
28GHz 34.scp

Recall

Recall {_ Demod Info Recall from File e ?2 X
SR @ Computer ) D: » Users ) Instrument ) Documents Y NR5G ) data y Example setup demo files > Mode 5G NR v

Screen Config + State Name A Date Size Content
Correction D 4-carrier_APSK scp 1/30/2020 10:56 AM 402 KB Scp file
Complex Correction D 4-carrier_APSK setx 1/30/2020 10:56 AM 594 KB Setx file
Recording D 5G_100MHz_8CC_FR2.scp 3/3/2021 10:51 PM 431 KB Scp file
Recording + State D 5G_MIMO . setx 1/30/2020 10:56 AM 133 KB Setx file

D 5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured.scp 9/21/2018 3:53 PM 274 KB Scp file

D S5GNR_1CC_FR1_30kHz_SCS5_100MHz_256QAM_DC Punctured setx 8/30/2018 4:57 PM 90 KB Setx file

[™ seNR_1GC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz scp 2/21/2019 1:58 PM 455 KB Scp file

D 5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz setx 2/21/2019 2:01 PM 131 KB Setx file
D 5GNR_2x2_MIMO_VXG_Scope_Updated.scp 5/15/2019 12:14 PM 74 KB Scp file
D 5GNR_2x2_MIMO_VXG_Scope_Updated setx 5/15/2019 12:14 PM 135 KB Setx file

D 5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected 28GHz scp 2/21/2019 1:48 PM 455 KB Scp file

[™ 56NR_8CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz setx 2/21/2019 1:05 PM 131 KB Setx file

D Jacquie setx 8/23/2021 10:24 AM 131 KB Setx file

File name: | Jacquie setx File type:  All Supported Files (*.scp;*.sgen;* nrcc;* pwsg,* setx) Recall

2. Select Meas Setup > Meas Time and set:
— Search Length to 10 ms
— Result Length to 2 Sub Frame
— Frame Trigger to On

3. Select the Settings tab > Optimize EVM.
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The Optimize EVM function automatically sets the combination of
preamplification, mechanical and electronic attenuation, and IF gain based
on the measured signal peak level.

EVM should be less than 1%.

KEYSIGHT nput RF Inpu12:500 Aten 124D Tiig: Extenal 1 Carier Ref Feq; 26.000000000 GHz
4 Coupling: DC [ m—— —— #F Gain: 4 dB C Info: Downiink,  CCs, SISO
G ign:Auo FreqRet Ext(S) W Path:Bypass

#PNO: Best Wide

1CCO-BWP1 g 2 CCO-BWP1 .
[ Detected Allocations
ScalelDiv 99 subcarriers. Ref Value -99 subcarriers

u=3:120kHz 5.973 |Start: 0.00 symbols w=3:120kHz Stop: 223.00 symbols|
acco

Raw Main Time
Scale/Div 10.00 dB Ref Value -15.00 dBm ScalelDiv 10.00 dB Ref Value 25.00 dBm

il o]

Ctr: 28 GHz Width: 110.6 MHz]
Res BW: 5 kHz Info BW: 98.30 MHz start: 0.00 Stop: 10.10 ms,

5.CCO Frame Summary ¥

EVM  PowerperRE  NumRB

P
PDCCH (BWP1)

Sync Source:
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 28GHZ
RF1:POWer:AMPLitude 5dBm
SIGNall:MODE WAVeform

Navigate to the desired waveform file.

SIGNall:WAVeform “D:\Users\Instrument\Documents\demo
waveforms

5GNR_1CC FR2 120kHz SCS 100MHz 256QAM DC punctured
28GHz 34.scp”

SIGNall ON

IQO:CORR:0OPT:DYN:RANG:OBW ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal
AnalyzerX-Series Signal Analyzer or the PC running the VSA application.

MMEMory:LOAD:EVM: SETup CCO,
“D:\Users\Instrument\Documents\NR5G\data\NRSGEvm\CarrierSetu
p\5GNR 1CC FR2 120kHz

SCS 100MHz 256QAM DCpunctured 28GHz.scp”

EVM:CCARrier(:TIME: LENGth:SEARch 10ms
EVM:CCARrier0:TIME: LENGth:RESult 2
EVM:CCARrier0:FRAMe:TRIGger ON
EVM:CCARrier0:DC:PUNCture ON
EVM:CCARrier0:PHASe:COMPensation:AUTO OFF
EVM:CCARrier(:PHASe:COMPensation:FREQuency 0 Hz

EVM:OPTimize
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Setting up an 8 CC 28 GHz EVM Measurement

This procedure shows you how to use the X-Series signal analyzer with the
5G NR & V2X X-Series application to observe EVM on an eight-carrier
waveform.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the Signal
Analyzer using 5G NR Mode” on page 292.

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 28 GHz and Amplitude to 5 dBm.

28.00000000000 GHz

5.00 dBm

ALC ON

3. Select Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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HH -

Enabled  Signal Mode Frequency Offset Aftenuation

?
2
>
>
>
?
>
?

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_|:|_| > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform File Waveform File 0dB

Trigger Freguency Offset Power
0Hz 0dB
Markers

Sample Rate
3.000 000 000 000 000 GHz

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose

5GNR_8CC_FR2 120kHz SCS 100MHz 256QAM Corrected 28GHz.
wfm

then Select.
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d. Select the General tab > Enable.

— EEE [[_:]/ LJ:L| > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

(@ cnable

Waveform File Waveform File v 0dB

Trigger MULE Frequency Offset Power
0Hz 0dB
Markers
Sample Rate
122.880 000 000 DOO MHz

Reset Phase Accumulator

6. Close the Signal Setup by selecting the Home icon at the top of the
display.

> Group 1: Signal Summary » Signal 1: Setup

()

7. Select the Adjustments block and select Optimize Dynamic Range with
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW This setting filters the system
RF flatness correction coefficients over the instantaneous bandwidth
indicated in the waveform header (or in the “Occupied Bandwidth”
settings area under the Signal block > Occupied Bandwidth setting).
This has the potential to improve EVM performance by not having to
correct for flatness errors outside the requested bandwidth. For
example, if RF flatness correction was done at 2 GHz, but you are
only interested in an 800 MHz section, then applying the correction
flatness to that portion only can improve signal to noise ratio, and
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction - Disabling this function
disables the factory calibrated RF channel flatness equalizer.
Depending on the hardware channel response, this may hurt or
improve the EVM. This is due to the dynamic range implications as it
relates to signal to noise ratio. The greater the RF hardware
variations in flatness, the greater the amount of correction is
required, the greater the correction effectively reduces the number of
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resolution DAC bits that can be used, which degrades the signal to
noise ratio and therefore potentially EVM. The trade-off is to balance
between flatness and signal to noise ratio.

@ > Output 1: Adjustments

General 1/Q Common Delay Optimizations
: Os —
1/Q Adjustments W| Optimize Dynamic Range with OBW

it Swap|&Q
¥ Enable System RF Flatness Correction

8. Close the Adjustments Setup by either selecting the Back or the Home
icon at the top of the display.

I.J:L] > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

10. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (Al

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.
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On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the signal analyzer or the PC running
the VSA application.

1. Select Recall (If accessing the signal analyzer remotely, select the Folder
icon at the bottom of the display) > Demod Info > set Data Type to CC
Setup > Recall From >
S5GNR 8CC FR2 120kHz SCS 100MHz 256QAM Corrected 28GHz
_34.scp > Recall.

You must be in the correct analysis mode (in this case, 5G NR & V2X1
>Modulation Analysis mode) to recall the .scp file.

{ Demod info Recall from File

e e T A ST TN
4 [ Computer Use Instrument ) Documents ) NR: data ) NRSGEvm ) CamerSetup )

State
Screen Config + State Name A Date Size Gantent
Correction [ 1cc_FR1_30kHz SCS_100MHz_2560AM_DC Punctured 1/7/2020 4:38 PM 90 KB Setx file
Complex Correction [™ 1cc_Fr1_30kHz 100MHz_256QAM_DC Punctured 1/7/2020 4:38 PM 6MB Wim file
Recording [™ 1cc_FR2_120kHz SCS_100MHz_256QAM_DC Puncture 1/7/2020 4:38 PM 131 KB Setx file
Recording + State [™ 1cC_FR2__120kHz SCS_100MHz_2560AM_DG Punctur 1/7/2020 4:38 PM 455 KB Scp file
[™ 1cC_FR2__120kHz SCS_100MHz_256QAM_DC Punclur 1772020 4:38 PM 6MB Wim file
[™ s6_1oomHz_scc_FR2scp /372021 10:61 PN 431KB Scp file
[ scc_Frz_120 _100MHz_256QAM_Comected_2¢ ) 4:38 PN 131 KB Setx file
. [ 8cC_FR2_ 120kHz SCS_100MHz_2560AM Corrected £ 1/7/2020 4:38 PM 455 KB Scp file
[ scc_FRz_ 120kHz SCS_100MHz 2560AM Conrected 38 PM 49 MB Wim file
[ A1 3nrce 511812020 3:06 58 KB Nrce file
[™ scc_Frz__120kHz SCS_100MH OAM_Corrected_ 1/7/2020 4:38 PM 153 KB Setx file
[™ signal_Studio_5G_100MHz_1GC_FR1.scp 2/112/2021 1:46 PM B7 KB Scp file

[™ vxG_a1_3_Config sgen 6/16/2020 10:53 AM 904 KB Sgen file

File name. | BCC_FR2__120kHz SCS_100MHz_256QAM_Cormrected 2BGHz scp File type: | All Files (*.%)

2. Select Meas Setup > Meas Time tab and set:
— Search Length to 10 ms
— Result Length to 2 Sub Frame

— Frame Trigger to On

3. Select Meas Setup > Advanced tab > Advanced Demod Setup and verify
that both Multi-Carrier Filter and DC Punctured are on.
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The multi-carrier filter is used to filter out the unwanted carriers and
minimize leakage into the component carrier of interest.

4. Ensure that RF for Phase Compensation is not selected and the value is
0 Hz, then Close the Advanced Settings table.

Component Camer |CCO

Sync Mode CP Auto Correlation

Extended Frequency
Lock Range G

DC Punctured

DC Offset from CC
Center

RF for Phase

AUTO

Compe N AUTO

el Power
Threshold

Report EVM in DB

Time Scale Factor

5. Select Meas Setup > Settings tab > Optimize EVM.
It will take a couple of minutes for the UXA to measure all 8 carriers.

If you are getting a "Sync Error; Sync not found" or "Input Overload -
NOTE Detected; ADC over range" message), go to Amplitude > Attenuation > and

increase the Mechanical Attenuation by 2 dB until the Sync Error is resold.

Notice that the Error Summary measurement has a scroll bar allowing you
to view the results of all 8 component carriers.
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Input: RF \Input Z: 50 O Atten: 10 dB Trig: External 1 Camrier Ref Freq: 12.000000000 GHz
Coupling: DC Comr CCorr RCal Pre: Int off, LNA off #IF Gain- -14 dB CC Info: DL, 8 CCs, SISO
@ Align: Auto Freq Ref: Ext (S) pW Path: Bypass
#PNO: Best Wide

1 CC0-BWP1 2 CC0-BWP1
1Q Meas Time Detected Allocations

Scale/Div 328 subcarriers

L3 R

-5.948 p=3:120 kHz 5.948 |Start: 0.00 symbols Stop: 223.00 symbols
3 CCo 4CCO

Spectrum Raw Main Time

Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm

Ctr: 28 GHz Width: 110.6 MHz
Res BW: 500 Hz Info BW: 98.30 MHz Start: 0.00 ns Stop: 10.10 ms|

5 CCO Frame Summary Y 6 Emor Summary

Power per RE Num.RB CcCco CC1
-35.10 dBm Channel Power (Active / Total) -6.11dBm/-6.11dBm  -6.04dBm/-6.
-35.10 dBm VM (RMS / Peak) 0.76 %/ 2.80 %
PBCH (S5 Bl ) 5 % -35.07 dBm Frequency Error (RMS / Worst) -764 7 mHz / -727.7 mHz
13 dBm
-35.08 dBm
-35.08 dBm

sync Correlation
p—
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 28GHZ
RF1:POWer:AMPLitude 5dBm
SIGNall:MODE WAVeform

Navigate to the desired waveform file.

SIGNall:WAVeform “D:\Users\Instrument\Documents\demo
waveforms\5GNR_8CC_FR2_120kHz_SCS_lOOMHz_Corrected_28GHz.wfm

”

SIGNall ON

IQO:CORR:0OPT:DYN:RANG:OBW ON
IQO:CORR:CHANNel : FLATness ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC
running the VSA application.

Navigate to the desired waveform file.

MMEMory:LOAD:EVM: SETup CCO,
“D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\8CC FR2 120kHz SCS 100MHz 256QAM Corrected 28GHz 34.scp ”

EVM:CCARrierQ:TIME: LENGth:SEARch 10ms
EVM:CCARrier(:TIME:LENGth:RESult 2
EVM:CCARrier0:FRAMe:TRIGger ON
EVM:CCARrier0:MCFilter ON
EVM:CCARrier0:DC:PUNCture ON
EVM:CCARrier(:PHASe:COMPensation:AUTO OFF

EVM:CCARrier(:PHASe:COMPensation: FREQuency 0 Hz
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To Optimize EVM for Multi-Carrier Waveforms
POWer :ATTenuation 0dB
[POWer :ATTenuation 2dB], ..

EVM:IF:GAIN:LEVel 0dB
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To View the Results of Two Carriers

Set the top right window (Window 2) to display 1Q Meas Time
DISPlay:EVM:WINDow2 :DATA MTIM

Set the top right window to display Component Carrier 1
DISPlay:EVM:WINDow?2 :CCARrier CCl

Set the middle right window to display the FFT of the Raw Main Time waveform
DISPlay:EVM:WINDow4 :DATA SPEC
DISPlay:EVM:WINDow4:CCARrier CCl1

Set the bottom right window to display a table of general measurement numeric results
DISPlay:EVM:WINDow6 :DATA DRES
DISPlay:EVM:WINDow6:CCARrier CC1

Set the bottom left window to display the error summary for CCO

DISPlay:EVM:WINDowb :DATA DRES
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Setting Upa 1 CC 3.5 GHz ACP Measurement

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the Signal
Analyzer using 5G NR Mode” on page 292.

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 3.5 GHz and Amplitude to 0 dBm.

3.50000000000 GHz

0.00 dBm

ALC ON
3. Select Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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(11} r ~— » = c c
waw (&) (-] » Group:Signal Summary
Hbae ) l: | , p 1: Signal Summary

Enabled  Signal Mode Frequency Offset Aftenuation

?
2
>
>
>
?
>
?

Fading

Enable

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_|:|_| > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform File Waveform File 0dB

Trigger Freguency Offset Power
0Hz 0dB
Markers

Sample Rate
3.000 000 000 000 000 GHz

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose

5GNR_1CC_FR1 30kHz SCS_100MHz 256QAM DCPunctured.
wfm

then Select.
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d. Select the General tab > Enable.

sy Group 1: Signal Summa signal 1: Setu
(Al p 1: Sig ry > sig p

General Mode Signal Attenuation

(@ Enable

Waveform File Waveform File v 0dB

Trigger Mute Frequency Offset Power
0 Hz 0dB
Markers
Sample Rate
122.880 000 000 D00 MHz

Reset Phase Accumulator

6. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

7. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set 5G NR V2X mode to a known state.

2. Select Mode/Meas > 5G NR & V2X Mode > ACP Measurement.
If accessing the instrument via a Remote Desktop connection, select the

Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

3. Select Frequency and set Carrier Reference Frequency to 3.5 GHz.
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KEYSIGHT
=
| PASS

Input: RF

Coupling: DC

Align: Auto
NFE: Off

1 Graph
Scale/Div 10.0 dB

i#Res BW 100 kHz
2 Metrics A

Total Car Pwr -1.598 dBm/760.320 MHz
Total PSD —

Offs Freq
A | 100.000 MHz
B | 200.000 MHz

Integ BW
98.280 MHz
98.280 MHz

314

Input Z: 50 O
Cormr CCorr RCal
Freq Ref: Ext (S)

Atten: 10 dB

Pre: Int off, LNA off
uW Path: Standard
PNO: Best Wide

Ref Value -5.00 dBm

Video BW 1.0000 MHZz"

Lower
ACP
dBm
-57.69
5833

Reference
dBm Car#
-4.580 )
-4 580 5

dBc
53N
-53.76

Trig: Free Run
Gate: Off
IF Gain: Low

Carrier Ref Freq: 3.500000000 GHz
Avg|Hold:>10/10

Noise Comection: Off

CC Info: DL, 8 CCs

Sweep 42.4 ms (12001 pts})|

Measure Trace
Trace Type

Trace 1
Trace Average (Active)

Upper
ACP
dBm
-b8.15
5827

Reference

dBm Car# Filter
-4.580 5 -3dB
-4 580 5 -3dB

dBc
-53.57
-53.69
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 3.5GHZ
RF1:POWer:AMPLitude 0dBm
SIGNall:MODE WAVeform

SIGNall:WAVeform “D:\Users\Instrument\Documents\MCS demo
waveforms\5GNR 1CC FR1 30kHz SCS 100MHz 256QAM DCPunctured.w
fmll

SIGNall ON

DM:OPTimization:CHANnel ACP

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALI :OUTPut ON

On the X-Series Signal Analyzer:
SYSTem:PRESet

INSTrument : CONFigure: NR5G:ACP
CCARrier:REFerence 3.5GHZ

ACPower :CORRection:NOISe ON
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Using PathWave N763TAPPC to Create a Waveform File then
Automatically Configure the Analyzer to View the Results

PathWave software tools can be used to create, download, and playback
waveforms through the VXG.

This example shows you how to create and analyze a 5G NR signal using the
embedded PathWave software and then automatically configure the analyzer
to make the measurement.

The VXG must have the N7631APPC Signal Generation for 5G NR license
installed.
On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 28 GHz and Power to
-10 dBm.

28.00000000000 GHz

-10.00 dBm

4. Select 5G NR to enter the 5G NR signal mode.

RF Out (All) Trigger ,P

= | © Q) > o = >+ Em-

Keysight PathWave Signal Generation

@ 56 NR @ Custom @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)

. Modulation (Beta)

5. In the 5G NR setup, select the Waveform tab and observe the Phase
Compensation and Radio Frequency settings.

Phase Compensation is applied by default at baseband for RF
up-conversion. This means it depends on the carrier frequency, and the
waveform should only be played at the carrier frequency it was generated
for, unlike conventional Signal Studio waveforms, which are independent
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from carrier frequency. Phase Compensation is set to Auto by default. The
frequency is coupled with the VXG frequency setting. You can select
Manual to specify a different frequency, or turn it off.

RF Out (All}

U‘LI S Apps:5GNR

(%, Generate Carrier | Waveform

[ Export 89600 VSA Setup

Subframe Offset
Marker Number of Subframes
Crest Factor Reduction Slot Offset in Subframe

Number of ¢
AWGN

Total Sample Points
Routing

Waveform Length

Mirror Spectrum

Phase Compensation

Radio Frequency

TIP Some applications, like power amplifier measurements use the same
waveform at different frequencies and can be time consuming to generate a
separate waveform for each frequency. In this case, you would turn Phase
Compensation Off, so the waveform becomes independent from the carrier
frequency. You need to do the same on the analysis side, or the demodulation
will fail.

6. Select the Carrier tab.

7. Select Full-Filled Config and set Bandwidth to
FR2 100 MHz, Numerology to p= 3:120 kHz, and Modulation to 256 QAM.

If you have a signal analyzer with demodulation bandwidth that is wide
enough to cover the other FR2 bandwidths, 200 MHz or 400 MHz, you can
choose to use a wider bandwidth.

Full Filled Configurations is a great place to start creating your waveform.

You can select FR, bandwidth, and modulation format with a fully
allocated PDSCH data channel. This would represent a spectrally correct

M9484C VXG and X-Series SA Measurement Guide 317



5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

signal that is typically used in power amplifier measurements. You can
modify the RB allocations and Slot allocations if fully allocated data
channels are not desired.

Fullfille

Bandwidth FRZ 100MHz

Numerology p=3:120 kHz

V' Duplex Type

Duplex Type

8. Select OK to exit the Full Filled Config setup.

9. From the Carrier panel (in the left pane), select Spectrum Control > DC
Punctured On.

When DC Punctured is enabled, the DC subcarrier is excluded from the
measurement results. This is often helpful to avoid obscuring
measurement results with artifacts of LO feedthrough.

(", Generate Carrier Waveform

m# Fullfilled Config T* DLTestModel g~ DL FRC Config < Auto Frequency Offset [ Export 89600 VSA Setup

= anh General IC F i R4

Window Beta 0.01

Windowing Method Centered at Symbol Boundary

Cell-Specific

Baseband Filter v
Downlink

10. From the Carrier panel (in the left pane), select Downlink > SS PBCH > SS
PBCH Block and set Lmax to 64 and Active Indices to = 0:7.
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w0 Fullilled Config T+ DLTestModel E~ DL FRC Config

General
Spectrum Control

Cell-Specific

& Generate

wa Fullfiled Config 1* DLTestModel g" DL FRC Config

General
Spectrum Control

Cell-Specific
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Instead of transmitting all 64 beams, we enable only 8 of them by setting
Active Indices to 0:7.

Carrier Waveform

< Auto Frequency Offset [-» Export 89600 VSA Setup
BWP

|
M pc

DL-SCH

Numerology P=3:120kHz ~

NR-PBCH SS Block Pattern

Perio
MiB

Lmax
Shared Spectrum Channel Access
M csirs =

B LTE-Coexistence Power Boosting of

M Prs

0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

RB Offset by 60 kH. 46

Lmax sets the maximum number of possible SS/PBCH blocks in a transmission
opportunity. This value is fixed for a given carrier bandwidth. Typically, higher
frequency and bandwidth carriers use a larger set of SS/PBCH opportunities to
support a larger set of antenna beams.Lmax is either 4 or 8 for FR1 and 64 for
FR2.

11. From the Carrier panel (in the left pane), select Downlink > DL-SCH >
DL-SCHO > Modulation and Coding and set MCS Table to Table 5.1.3.1-2
(256QAM) and MCS to 20.

The Modulation Coding Scheme (MCS) specifies the modulation, coding
and overall spectral efficiency of the PDSCH as specified in 3GPP Table
5.1.3.1.

Carrier  Waveform [« Import Signal Setup [ Export Signal Setup

< Auto Frequency Offset [ Export 89600 VSA Setup
BWP General Settings 1 v

M ss/PBCH MCs 20

M oci

Transmission Settings

MCS Table Table 5.1.3.1-2 (256QAM) v

Resource Allocation
TB Scaling Factor 1.0 v

Coding Rate

M csiRs

DMRS Settings
Modulation

-Coexistence. ettings
LTE-Coexi PTRS Setting

Transport Block Size

M PRS HARO Settinas

Rasefiranh
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12. Select Generate to generate the Waveform, and then select Home to exit
the setup panel.

¢ Generate Carrier Waveform [« Import Signal Setup [+ Export Signal Setup
W Full-filled Config T DLTestModel @" DL FRC Config < Auto Frequency Offset [» Export 89600 VSA Setup

General BWP . General Settings v

Spectrum Control  [Jl] SS/PBCH Transmission Settings Mmcs 20

3 e
Cell-Specific H oci Resource Allocation pless Table 5.1.3.1-2 (256QAM)

TB Scaling Factor 10 v

Coding Rate

B csi-RsS DMRS Settings
Modulation

Il LTE-Coexistence AL Transport Block Size

M PRS HARO Settinas Racafranh

' Channel Allocation  Summary Frame0 v p=3 v @ Display Detail

DL-SCHO

13. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.
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Setup Auto Configure Analyzer

1. Select the System menu (triple bar tab at the top left of the window) to
open the System Menu and then select Configure Analyzer.

RF Out (All) Trigger )

[ 1L p- o 7N
HH Fj © [m) > Configure Analyzer - [Z‘f' Cy .

The M9484C system works with Keysight X-Series Signal Analyzers. Once a remote signal analyzer is connected, use the [Auto Configure Analyzer] button 1o automatically set up the analyzer to measure
the desired signal from the source.

Auto

\: Configure ‘
\ Analyzer /

M94§ 4C Output Channel

: : ) o v

Click to access source interface Click to change connection

TCPIP::zhislip0:INSTR

2. In the System Configuration setup, select the Remote Signal Analyzer
block (on far right) to setup the communication channel to the Keysight
X-Series Signal Analyzer.

S\

Click to change connection

3. Set Connection Type to LAN.

4. In the Connect Remote X-Series Signal Analyzer setup, enter the
Hostname or IP Address for the signal analyzer.

5. Under Set Protocol, select HiSLIP and use the Remote name hislipO.
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6. Select Test Connection to verify, then the Back icon to go back to the
main Configure Analyzer display.

RF Out (All) “Trigger
r 2

@ > Configure Analyzer » Remote Instrument PRESET -

Connection Type Hostname or IP Address

@) LAN | 141.121.149.32 Test Connection

Protocol

Type Address
HisLIP v hislip0

7. Select Auto Configure Analyzer to send the VXG settings to the analyzer.

| Auto
|  Configure
Analyzer

8. View the results on the signal analyzer.

nput P nputz:500 Aten 1268 Tig Extomal 1 Carior RofFeg; 25000000000 GHz
'L(EYS'GHT Coupling: DC [ m—— —— #F Gain: 4 dB C Info: Downiink,  CCs, SISO
G ign:Auo FreqRet Ext(S) W Path:Bypass
FPNO:Bost Wide
TCcoBwPt y 2CCoBwPT p
K Deteced Alocations
ScalelDiv 98 subcarriers Ref Value -99 subcarriers

u=3:120kHz tart: 0.00 symbols w=3:120kHz Stop: 223.00 symbols|

Ref Value -15.00 dBm . Ref Value 25.00 dBm

Width: 110.6 MHz]
Info BW: 98.30 MHz Star Stop: 10.10 ms,

P RS
PDCCH (BWP1)

The System Configuration selection brings up a screen that lets you perform a
Generation-to-Analysis work flow. The “Auto Configure Analyzer” button will
automatically transfer the setup from the source to a Keysight X-Series signal
analyzer, in order to measure the desired signal from the source. If you are gen-
erating a 3GPP 5G New Radio signal, and the 5G New Radio application is
licensed on the analyzer, the analyzer will perform demodulation of the signal.
Otherwise, the analyzer will auto-tune on the signal being generated. The Key-
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sight X-Series Signal Analyzer requires firmware version x.24.00 or greater.

More About the 5G NR Traces

— Trace 1: shows the composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal. See Trace 6 (Frame Summary) for the list of channels.
Again, when enabling BWP, SS Block is grayed out. When enabling SS
Block, channels withing BWP are grayed out.

— Trace 2: shows the envelope of the captured raw data. This data is
unprocessed and includes additional points acquired for settling of the
filters involved in subsequent processing, such as the demodulation
filtering.

— Trace 3: shows the FTT of the Raw Main Time waveform.
— Trace 4: shows the general measurement numeric results.

— Trace 5: shows the detected allocations of all channels/signals within the
measurement interval (2 Subframes in this example).

— Trace 6: shows EVM, Power, and Number of RB of the individual
channels/signals.

TIP The Frame Summary table shows Num. RB for PDSCH of 1056 and 1016 for
PDSCH-DMRS. The signal configuration has only 66 RBs. The RB result in the
Frame Summary Table is per Slot. In this example procedure, we changed the
measurement interval to 2 Subframes, which is 16 slots for 120 kHz
numerology (8 slots/subframe). 66 * 16 = 1056. For PDSCH-DMRS, the value
is 1016 because two of the 16 slots overlap with the SS Block which occupies
20 RBs resulting in 20 RBs being punctured from DMRS in these two slots.
Therefore, the total RB Number for DMRS is 1056 - 20 * 2 = 1016.
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Using the equivalent SCPI commands

On the VXG:
SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude

RADio:SELect NR5G

RADio:NR5G:WAVeform:

Select p = 3: 120kHz:

RADio:
RADio:

RADio:
"0:7"

RADio:
RADio:
RADio:

GROup:

NR5G:
NR5G:

NR5G:

NR5G:
NR5G:

NR5G:

WAVeform:
WAVeform:

WAVeform:

WAVeform:
WAVeform:

WAVeform:

SIGNall ON

RF1:0UTPut ON

-10dBm

CCARrier:

CCARrier:
CCARrier:

CCARrier:

CCARrier:

CCARrier:

GENerate

BWIDth FR2BW100M

SNUMerology MU3
DLINk:SSBLock:LMAX 64

DLINk:SSBLock:ACTive:INDices

DLINk:SCHO:MCS 20
DLINk:SCHO:MCS:TABLe TABLeb52

For multi-channel instruments, set RF Out (all) to On.

RFALI :OUTPut ON
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6 5G NR Measurements Using the VSA Software

This section includes the following topics:

— “BG Waveform and EVM Analysis Using VSA Software” on page 326

KEYSIGHT

TECHNOLOGIES

“Setting Up a1 CC 28 GHz EVM Measurement” on page 326
“Setting Up an 8 CC 28 GHz EVM Measurement” on page 339

“Creating a Basic 5G NR Signal Using PathWave N7631APPC
Embedded Software” on page 349

“Creating a DL MIMO Signal Using PathWave N7631APPC Signal
Generation” on page 369
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5G Waveform and EVM Analysis Using VSA Software

The VXG enables 5G testing with a low error vector magnitude (EVM) at high
frequencies. The VXG has extremely good EVM at high power levels. However,
not all signal analyzers can capture this low value. We will use the X-Series
Signal Analyzer with the Vector Signal Analysis (VSA) software to observe EVM.

Setting Up a 1 CC 28 GHz EVM Measurement

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11.
On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output 1 area, set Frequency to 28 GHz and Power to
5 dBm.

28.00000000000 GHz

5.00 dBm

ALC ON

3. Select Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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[ 1 » Group 1: Signal Summary

Frequency Offset Attenuation

?
2
>
>
>
?
>
?

Fading

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_|:|_| > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform File Waveform File 0dB

Trigger Frequency Offset Power
0 Hz 0dB
Markers

Sample Rate
3.000 000 000 DOO 00D GHZ

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
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5GNR_1CC_FR2 120kHz SCS 100MHz 256QAM DCPunctured
_28GHz.wfm
then Select.

< Back

@ Recent 4[\ C: > Users > jacquipa » Documents ) Keysight > PathWave ) SignalGenerator » Examples

@ Waveforms Name = Date Modified

D This Computer

4000_SamplelQPulseOn0ff_50%_wfm.csv May 8, 2020, 10:55:50 AM
5G_100MHz_1CC_FR1.wfm Aug 22,2021, 11:43:56 PM
5G_100MHz_8CC_FR2.wfm Aug 22,2021, 11:44:03 PM
5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured.wfm Jul 10, 2019, 6:47:40 PM
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz.wfm Jul 14,2019, 7:07:46 PM
S5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_1.wfm Nov 20, 2022, 11:17:24 PM
5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz.wfm Jul 14, 2019, 7:05:20 PM
5GNR_UXR_Recording_28_GHz.csv May 20, 2019, 3:29:44 PM

GSM_1C_BURST_SECUREWAVE.wfm Jul 18,2013, 11:49:36 AM

Clear Arb Memory File Properties
Name 5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz.wfm
Sample Rate: 122880000.0 Hz
Scale: 85.0
Occupied Bandwidth:  N/A
Required License(s)

Show files of type  All Formats (*.wfm, *.wig, *.bin, *.waveform, *.cs, *.txt, *.seq, *.mat, *.hdf, *.h5, *.inc) v Select Cancel

d. Select the General tab > Enable.

[l > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation
@ cnabie

Waveform File Waveform File 0 dB

Mute Bt
Trigger ower

0 dB
Markers

122.880 000 D00 000 MHz

Reset Phase Accumulator

6. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

lJl] » Group 1: Signal Summary » Signal 1: Setup
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7. Select the Adjustments block and select Optimize Dynamic Range with
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW This setting filters the system
RF flatness correction coefficients over the instantaneous bandwidth
indicated in the waveform header (or in the “Occupied Bandwidth”
settings area under the Signal block > Occupied Bandwidth setting).
This has the potential to improve EVM performance by not having to
correct for flatness errors outside the requested bandwidth. For
example, if RF flatness correction was done at 2 GHz, but you are
only interested in an 800 MHz section, then applying the correction
flatness to that portion only can improve signal to noise ratio, and
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction - Disabling this function
disables the factory calibrated RF channel flatness equalizer.
Depending on the hardware channel response, this may hurt or
improve the EVM. This is due to the dynamic range implications as it
relates to signal to noise ratio. The greater the RF hardware
variations in flatness, the greater the amount of correction is
required, the greater the correction effectively reduces the number of
resolution DAC bits that can be used, which degrades the signal to
noise ratio and therefore potentially EVM. The trade-off is to balance
between flatness and signal to noise ratio.

@ > Output 1: Adjustments

General 1/Q Common Delay Optimizations
5 O0s —
1/Q Adjustments W| Optimize Dynamic Range with OBW

AWGN Swap | &Q _
v’ Enable System RF Flatness Correction

8. Close the Adjustments Setup by either selecting the Back or the Home
icon at the top of the display.

LJ:LJ > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.
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10. For two channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

1. Select Recall (If accessing the signal analyzer remotely, select the Folder
icon at the bottom of the display) Demod Info > Set Data Type to CC Setup
> Recall From >

5GNR_1CC_FR2 120kHz SCS 100MHz 2560AM DC punctured
28GHz_34.scp >Recall

Recall < Demod Info

Recall from File lr) c ? x
Sl @ Computer ) D: S Users Y Instrument ) Documents » NR5G ) data ) Example setup demo files :) A 4

Screen Config + State

Mode 5G NR

Name A Date Size Content

Correction

Complex Correction

Recording

Recording + State

330

D 4-carrier_APSK scp

D 4-carrier_APSK.setx

[™ s6_100MHz_8cC_FR2.scp

[ se_mMO setx

[ sGNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured.scp

D SGNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured setx

[ 56NR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz scp

D 5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz setx
D S5GNR_2x2 MIMO VXG_Scope_ Updated.scp

D 5GNR_2x2_ MIMO_VXG_Scope_Updated.setx

D 5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_GCorrected_28GHz scp
D 5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_DC Punctured_28GHz setx

D Jacquie. setx

File name: | Jacquie setx File type:

1/30/2020 10:56 AM

1/30/2020 10:56 AM

3/3/2021 10:51 PM

1/30/2020 10:56 AM

9/21/2018 3:53 PM

8/30/2018 4:57 PM

2/21/2019 1:58 PM

2/21/2019 2:01 PM

5/15/2019 12:14 PM

5/15/2019 12:14 PM

2/21/2019 1:48 PM

2/21/2019 1:06 PM

8/23/2021 10:24 AM

402 KB Scp file

594 KB Setx file

431 KB Scp file

133 KB Setx file

274 KB Scp file

90 KB Setx file

455 KB Scp file

131 KB Setx file

T4 KB Scp file

135 KB Setx file

455 KB Scp file

131 KB Setx file

131 KB Setx file

All Supported Files (*.scp,* sgen;* nrcc;* pwsg,* setx) Recall
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2. Select Meas Setup > Meas Time and set:
— Search Length to 10 ms
— Result Length to 2 Sub Frame

— Frame Trigger to On

3. Ensure that RF for Phase Compensation Auto is not selected and the value
is 0 Hz. Close the Advanced Settings table.

4. Select the Settings tab > Optimize EVM.

The Optimize EVM function automatically sets the combination of
preamplification, mechanical and electronic attenuation, and IF gain based
on the measured signal peak level.

EVM should be less than 1%.

InputZ:50Q Atien: 12 4B TTrg: Extemal 1 (Carrir Ref Freq: 26.000000000 GHz
Corrections: Off Preamp: OFf #F Gain: 4 4B CC Info: Downiink, 8 CCs, SISO
Freq Ref: Ext (S) W Path Bypass

#PNO: Best Wide

1CCO-BWP1
10 Meas Time

Ref Value -99 subcarriers

u=3:120kHz

Ref Value -15.00 dBm Ref Value 25.00 dBm

Info BW: 98.30 MHz Star Stop: 10.10 ms,

On the X-Series Signal Analyzer:
— Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.
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In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known
state.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC
running the VSA application.

2. Select File > Recall > Recall Setup and navigate to
5GNR_1CC_FR2 120kHz SCS_100MHz 256QAM DC
Punctured 28GHz.setx

3. From the toolbar, select the Pause Icon. m

Pausing the measurement will help to speed up the setup time.
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4. From the menu bar, select Input > Trigger and set Style to External and
Level to 1.0 V.

Digital Trigager

Extemal
Slope:
Pasitive

Holt
Tirne Criteria: Timel: Tirmed:

sk Trigger

LEmpl ;

Fraquency Offset Amplitude Offset

Upper 0Kz 0nde

Lawer | 0 Hz 0de

Trigger Gut 1
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5. Select the Extensions tab and change the External Trigger location to
Trigger 1 In (if using an N9040B with Option H1G, select Trigger 3) and
Phase Noise Optimization to Best Wide Offset.

Analog Digital Capture Trigger

Logical Instrument:

Adc Dither
Capture Bit Packing
Ext Reference Lock Bandwidth

External Trigger Location

Playback Trigger External Mixer Extensions
Preset All

Show All

Off

Auto

15 Hz
Trigger 1 In

IF Path 1GHz
IF Path Auto Manual
Instrument User Corrections Off
LO Dither Off
Microwave Path Control Preselector Bypass
Mixer Mode Normal
Phase Noise Optimization Best Close In
Best Close In
Best Wide Offset
of the ¢ Fast Tuning
Balanced

Spur Avoidance

6. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time
tab.

— Set Result Length to 10 Subframes.

— Set Meas Interval to 2 Subframes.
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— Select Frame Trigger is Present.

Configuration Input & Antenna Time Decode Advanced

Analysis Region
Result Length: 5 Subframes 0 Slots
Meas Offset: 2 Subframes 0 Symbols
Meas Interval: 3 Subframes 0 Symbols

Time Scale Factor: 1

Analysis Start Boundary Acqguisition Mode
Normal
® Frame
. Reduced acquisition length
Half-frame
) ® Frame tri
Subframe

Slot

First Slot Index: ()

Timing Diagram

Result Length 5 Subf. ————

E Meas. Interval 3:0
* Meas. Offset 2.0

Frame Boundary

7. From the toolbar, select the Auto-Range dropdown and select EVM-Table
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based
on prescribed table/algorithm instead of using EVM in the feedback
loop. This method of EVM auto-range is normally faster than Meas
Based Iteration, but may not achieve the most optimal setup for
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire
measurement, uses the measured EVM in the feedback loop, and
tries to adjust hardware parameters to minimize the EVM. It is the
slowest EVM auto-range method, but it should achieve the most
optimal setup for good EVM.

File Edt Control Source [nput  MeasSetup  Trace Markers  Window  Ubilities  Help

[| [\ em - meE wE (e[

8. Select the Auto-Range icon to run the measurement for EVM optimization.
This may take a few minutes to complete.
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Control Source Input MeasSetup Trace Markers Window Utlities

: i W E O IR A

+ X | C: OFDM Detected Allocations Time

1111

~ X | D:OFDM Err Vect Spectrum X | F:Frame Summary

Power
R Ewm Modula- Num. of
. (G%rms) on  Res NI

per
(4Bm)

LinMag
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 28GHZ
RF1:POWer:AMPLitude 5dBm
SIGNall:MODE WAVeform

SIGNall:WAVeform “D:\Users\Instrument\Documents\MCS demo
waveforms
5GNR 1CC FR2 120kHz SCS 100MHz 2560QAM DCPunctured 28GHz.wfm”

SIGNall ON

IQO:CORR:OPT:DYN: RANG: OBW ON
IQ0:CORR:CHAN:FLAT ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:
INSTrument:SELect VSA89601

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC
running the VSA application.

SYSTem:PRESet

MMEMory: LOAD
“D:Users\Instrument\Documentts\NR5G\data\NR5GEvm\Carrier
Setup\5GNR 1CC FR2 120kHz

SCS _100MHz 256QAM DCPunctured 28GHz.setx”

INITiate:PAUSe

INPut:TRIGger:STYle "EXTERNAL"

INPut:TRIGger:LEVel :EXTernal 1V
INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut :EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1
Set the 5G NR Demod Result Length to 10 Subframes:
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NR5G:RLENgth 10
NR5G: SUBFrame: INTerval 2
Set the Acquisition Mode to “Frame Trigger is Present”

nr5g:FRAMe : TRIGger:ENABled 1
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Setting Up an 8 CC 28 GHz EVM Measurement

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11.

Using the graphical user interface

On the VXG:
1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 28 GHz and Amplitude to 5 dBm.

28.00000000000 GHz

5.00 dBm
ALC ON

3. Select Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

" > Group 1: Signal Summary

Frequency Offset Attenuation

?
2
?
?
?
?
>
?
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5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_|_|_| Y Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform File Waveform File 0dB

Trigger Freguency Offset Power
0 Hz 0dB
Markers
Sample Rate
3.000 000 000 DOO 00D GHZ

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose

5GNR_8CC FR2 120kHz SCS 100MHz 256QAM Corrected 28GHz.
wfm

then Select.
d. Select the General tab > Enable.

Group 1: Signal Summa Signal 1: Setu
[al p 1: Sig ry > Sig p

General Mode Signal Attenuation
@ cnable -
Waveform File Waveform File 0dB

Mute et :
Trigger Frequency Offset Power

0Hz 0 dB
Markers

Sample Rate
122.880 000 D00 000 MHz

Reset Phase Accumulator
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6. Close the Signal Setup by selecting the Home icon at the top of the
display.

> Group 1: Signal Summary » Signal 1: Setup

()

7. Select the Adjustments block and select Optimize Dynamic Range with
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW This setting filters the system
RF flatness correction coefficients over the instantaneous bandwidth
indicated in the waveform header (or in the “Occupied Bandwidth”
settings area under the Signal block > Occupied Bandwidth setting).
This has the potential to improve EVM performance by not having to
correct for flatness errors outside the requested bandwidth. For
example, if RF flatness correction was done at 2 GHz, but you are
only interested in an 800 MHz section, then applying the correction
flatness to that portion only can improve signal to noise ratio, and
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction - Disabling this function
disables the factory calibrated RF channel flatness equalizer.
Depending on the hardware channel response, this may hurt or
improve the EVM. This is due to the dynamic range implications as it
relates to signal to noise ratio. The greater the RF hardware
variations in flatness, the greater the amount of correction is
required, the greater the correction effectively reduces the number of
resolution DAC bits that can be used, which degrades the signal to
noise ratio and therefore potentially EVM. The trade-off is to balance
between flatness and signal to noise ratio.

@ > Output 1: Adjustments

General 1/Q Common Delay Optimizations
: Os —
1/Q Adjustments W| Optimize Dynamic Range with OBW

AWGN Swap | &Q
\f Enable System RF Flatness Correction

8. Close the Adjustments Setup by either selecting the Back or the Home
icon at the top of the display.

I.J:L] > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.
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This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

10. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the X-Series Signal Analyzer:
— Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known
state.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

2. Select File > Recall > Recall Setup and navigate to

D:Users\Instrument\Documents\NR5G\data\NR5GEvm\Carrier Setup,
then open
5GNR_8CC_FR2 120kHz SCS 100MHz 256QAM Corrected 1.setx

3. From the toolbar, select the Pause Icon. m

Pausing the measurement will help to speed up the setup time.
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4. From the menu bar, select Input > Trigger and set Style to FreeRun.

Analog Digital Capture Trigger

Input Trigger Channel: 1 >
Entry Channel: . 1

Style
Free Run

Slope:
Holdoff Style:
Time Criteria:
Trige

Des
Trigger Qut 1

Playback Trigger

External Mixer Exten

Holdoff:

Timel: Time2:

Actual:

T | Trigger Out 1

5. Select the Extensions tab and change Phase Noise Optimization to Best
Wide Offset. (For an N9040B only, set External Trigger Location to Trigger

31n.)

Analeg Digital Capture

Legical Instrument:

4 Misc
Adc Dither
Capture Bit Packing
Ext Reference Lock Bandwidth
External Tnigger Location
IF Path
IF Path Auto
Instrument User Corrections
LO Dither
Microwave Path Control
Mixer Mode

Phase Moise Optimization

Phase Noise Optimization
Optimizes the 5 istribution
ffeet of the «

analyzer model
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Trigger

Playback Trigger External Mixer Bxtensions

Preset All

Show All

Off
Auto
15 Hz
Trigger 1 In
1GHz

Manual
Off
Off
Preselector Bypass
Normal
Best Close In
Best Close In
Best Wide Offset
Fast Tuning
Balanced

Spur Avoidance
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6. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time
tab.

— Set Result Length to 10 Subframes.
— Set Meas Interval to 2 Subframes.

figuration Input & Antenna Time Decode A

10 Subframes 0 Slots

0 Subframes 0 Symbols

Meas Interval: 2 Subframes mbols

Time Scale Factor: 1

start Boundary Acquisition Mode
® Naormal
® Frame

Reduced acquisition length
Half-frame

- Frame trigger is present
Subframe

Slot trigger is present
Slot

First Slot In 0 Use Periodic Trigger

7. Select the Advanced tab select DC Punctured to On.

Configuration Input & Antenna Time Decode Advanced

Transient Period

Length:

Power Change Threshold:

1Q Impairments
1Q Imb. Estimation Mode: = Off
Compensate |Q Offset ¥| DC Punctured

UL Spectrum Flatness

+| Spectrum Flatness Enabled

Test Environment Condition: | Normal ~ Test Tolerance: 1.4 dB
Error Vector Unit
Time Domain: | per Symbol ~ Freq Domain: | per Subcarrier ~

MIMO Condition Number

Control: | Off *  RB Granula

Auto Set Span Report EVM in dB

Independent SSB/BWP Measurement Extend Frequency Lock Range | 480 kHz

¥| Multicarrier Filter On ¥| Compensate Symbol Clock Offset

| Per Slot Channel Frequency Response
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8. In the bottom center trace window, select the Trace Data menu and select
Demod: > CC Summary.

v ¥ DeCCSummary =

9. In the Spectrum trace window (bottom left window), select Center and
change the frequency to 28 GHz.

10. From the toolbar, select the Autorange dropdown and select EVM-Table
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based
on prescribed table/algorithm instead of using EVM in the feedback
loop. This method of EVM auto-range is normally faster than Meas
Based Iteration, but may not achieve the most optimal setup for
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire
measurement, uses the measured EVM in the feedback loop, and
tries to adjust hardware parameters to minimize the EVM. It is the
slowest EVM auto-range method, but it should achieve the most
optimal setup for good EVM.

File Edt Confrol Source [nput  MeasSetup  Trace Markers Window Utilities  Help

I :' \§ e ; @ = B RO @ Ml A s o

11. Select the Autorange icon to run the measurement for EVM optimization
on all eight channels. This may take a few minutes to complete.
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File Edit Control Source Input MeasSetup Trace Markers Window  Utiities Help
[] [ "\ EM- Meas Based hteration ~ O [ Bl 5 It M

A (CO iye -+ % | G (CCO) OFDM Detected Allocations Time: All Layers

D: CC Summary ~ x F Frame Summary

TAE Min 8 ps between CC4 and Cl EVM  Power per RE

Num. of
o o 0 Modulation RNTI
TAE Max ps between CC1and %rms) (dBm) RBs

Channel Rel Center
req

Freq. Em
Power  Power o Srer

116415p 1

D: CC Summary ~
TAE Min 08 ps between CC4 and CCO
TAE Max 04 ps between CC1and CCO

Channel Rel. EVM TAE
Power Power .,

(B fdm) peTmshfisec)
0.00 g
0.14
0.0

116415 p
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Using the equivalent SCPI commands
On the VXG:

SYSTem: PRESet

RF1:FREQuency:CW 28GHZ
RF1:POWer:AMPLitude 5dBm
SIGNall:MODE WAVeform

SIGNall:WAVeform “D:\Users\Instrument\Documents\MCS demo
waveforms\5GNR 8CC FR2 120kHz SCS 100MHz Corrected 28GHz.wfm

”

SIGNall ON

IQO:CORR:0OPT:DYN:RANG:OBW ON
IQ0:CORR:CHAN: FLAT ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer
INSTrument:SELect VSA89601

MMEMory: LOAD: DEMO
"D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\1CC FR2 120kHz SCS 100MHz 2560AM DC Punctured 28GHz.setx"

INITiate:PAUSe

INPut:TRIGger:STYLe "External"

INPut:TRIGger:LEVel :EXTernal 1V
INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut :EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1
NR5G:RLENgth 10

NR5G: SUBFrame: INTerval 2

NR5G:FRAMe : TRIGger:ENABled 1

NR5G:CAGGregation:CONFigure "Contiguous8CC"

NR5G:DC: PUNCtured 1

NR5G:MCFilter:ENABled 1
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FREQuency:CENTer 28 GHz
INPut :ANALog:CRITeria:RANGe:AUTO "EVM", -1
All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.
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Creating a Basic 5G NR Signal Using PathWave N7631APPC
Embedded Software

PathWave software tools can be used to create, download, and playback
waveforms through the VXG.

This example shows you how to create and analyze a 5G NR signal using the
embedded PathWave software. Your VXG must include the N763TAPPC
license.

The VXG must have the N7631APPC Signal Generation for 5G NR license
installed.

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 28 GHz and Power to
-10 dBm.

28.00000000000 GHz

-10.00 dBm

ALC OFF

3. Select the Radio Apps block to open the Vector Modulation Signal Setup
panel.

4. Select 5G NR to enter 5GNR Signal Mode.

RFOut(All)  Trigger

= | © Q) > o -

Keysight PathWave Signal Generation

@ 5G NR @ auos(;glr:mn o @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)
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(%, Generate

[ Export 89600 VSA Setup

Marker
Crest Factor Reduction
AWGN

Routing

TIP
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5. In the 5G NR setup, select the Waveform tab and observe the Phase
Compensation and Radio Frequency settings.

RF Out (All}

[..I‘l] > Apps:5GNR .

Carrier Waveform

Number of Subframes

Slot Offset in Subframe
Number of Slots in Subframe
Total Sample Points
Waveform Length

Mirror Spectrum

Phase Compensation

Radio Frequency

Phase Compensation is applied by default at baseband for RF up-conversion.
This means the waveform generation is per the carrier frequency, unlike
conventional Signal Studio waveforms, which are independent from carrier
frequency. Phase Compensation is set to Auto by default. The frequency is
coupled with the VXG frequency setting under the Instrument node. You can
select Manual to specify a different frequency, or turn it off.

Some applications, like power amplifier measurements use the same
waveform at different frequencies and can be time consuming to generate a
separate waveform for each frequency. In this case, you would turn Phase
Compensation Off, so the waveform becomes independent from the carrier
frequency. You need to do the same on the analysis side, or the demodulation
will fail.

350

6. Select the Carriers tab.

7. Select the Full-Filled Config tab and set Bandwidth to FR2 100 MHz,
Numerology to p = 3: 120 kHz, and Modulation to 256QAM.

If you have a signal analyzer with demodulation bandwidth that is wide
enough to cover the other FR2 bandwidths, 200 MHz or 400 MHz, you can
choose to use a wider bandwidth.

Full Filled Configurations is a great place to start creating your waveform.

You can select FR, bandwidth, and modulation format with a fully
allocated PDSCH data channel. This would represent a spectrally correct
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signal that is typically used in power amplifier measurements. You can
modify the RB allocations and Slot allocations if fully allocated data
channels are not desired.

Bandwidth FRZ 100MHz

Numerology p=3:120 kHz

V' Duplex Type

Duplex Type

8. Select OK to exit the Full Filled Config setup.

9. From the Carrier panel (in the left pane), select Downlink > SS PBCH > SS
PBCH Block and change Lmax to 64 and Active Indices to = 0:7.

Instead of transmitting all 64 beams, we enable only 8 of them be setting
Active Indices to 0:7.

¢, Generate Carrier Waveform
w0 Fullilled Config T+ DLTestModel E~ DL FRC Config < Auto Freguency Offset [-» Export 89600 VSA Setup
General BWP 5/ PE 3 Numerology p=3:120kHz ~

spectrum Control [l S5 NR-PBCH
Periodicity
Cell-Specific M pc MIB =
Lmax
DL-SCH
Shared Spectrum Channel Access

[l csiRs ; 07

. LTE-Coexistence Power Boosting of each SS Block 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

RB Offset by 60 kHz SCS 46

M Prs

Lmax sets the maximum number of possible SS/PBCH blocks in a transmission
opportunity. This value is fixed for a given carrier bandwidth. Typically, higher
frequency and bandwidth carriers use a larger set of SS/PBCH opportunities to
support a larger set of antenna beams.Lmax is either 4 or 8 for FR1 and 64 for

FR2.
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10. From the Carrier panel (in the left pane), select Downlink > DL-SCHs >
DL-SCHO > Modulation and Coding and verify that MCS Table is set to
Table 5.1.3.1-2 (256QAM) and MCS to 20.

& Generate Carrier Waveform [« Import Signal Setup [+ Export Signal Setup
w# Fullfilled Config T+ DLTestModel g DL FRC Config <~ Auto Frequency Offset [ Export 83600 VSA Setup

General BWP } General Settings v

Spectrum Control  [l] SS/PBCH Transmission Settings MCS 20

S 20 )
Cell-Specific M oci Resource Allocation MosTaile Table 5.1.3.1-2 (256QAM)

TB Scaling Factor 10 v

Coding Rate
M csi-RS DMRS Settings
Modulation

Il LTE-Coexistence ARSI Transport Block Size

M PrRs HARO Settinas Rasefiranh

11. Select Generate to generate the Waveform.

& Generate Carrier Waveform [« Import Signal Setup [+ Export Signal Setup
wn Fullfiled Config T DLTestModel g DLFRCConfig < AutoFrequencyOffset [ Export 89600 VSA Setup
General BWP General Settings v

spectrum Control [l SS/PBCH Transmission Settings Mcs 20

MCS Tabl 51312 (256 >
Cell-Specific | el Resource Allocation ave Table 5.1.3.1-2 (256QAM)

TB Scaling Factor 10 v

Coding Rate

M csiRs DMRS Settings
Modulation

Il LTE-Coexistence PTRS Settings Transport Block Size

M PR HAROQ Settinas Racafranh

V' Channel Allocation  Summary Frame0 v p=3 v ¥ Display Detail

DL-SCHO

12. Select the Home icon to return to the main window and set RF Out to On
by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:
— Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.
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In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known
state.

2. Set the Center Frequency to 28 GHz > Span to 100 MHz, then select Auto

Range.

Auto Range samples the current input signal and then sets the full scale
input range to the minimum range that includes the peak voltage sample
of the input signal.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities Help

D [l @ I Range To Peak Power (Defauty ~ = IR 5: YO I R Ul A | 50% o%

, i
\ | ‘l“M “M\l‘f\“ ”v'u

“ |

W‘w 4 N

3. From the toolbar, select the Pause Icon. !]I

TIP Pausing the measurement will help to speed up the setup time.
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4. From the menu bar, select Input > Trigger and set Style to External and
Level to 1.0 V.

Digital ~ Trigger P

Tirmed:

Freguen

(zrapl acc)
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5. Select the Extensions tab and change the External Trigger location to
Trigger 1 In or Trigger 3 In (Use Trigger 3 if your N9040B has Option H1G,
1 GHz BW) and set Phase Noise Optimization to Best Wide Offset.

Analog  Digital ~ Tagger Pl igger  Ecternal Mier

Logical Ins!

Auto
Auto
15Hz

Trigger 3 In

Off

Off

Preselector Bypass
Normal

Best Wide Offset

6. From the menu bar, select MeasSetup > Measure Type Cellular > 5G NR >
5G NR Modulation Analysis.

7. From the menu bar, select MeasSetup > 5G NR Demod Properties >
Configuration tab.

P Meas01 - 56 NR Demod Properties ? X
Configuration Time Decode Advanced

Save As Quick Setup...  Quick Setups...

Signal Carrier Type:  ‘® Downlink Uplink

e Apply Test Model...
BWP Aggregation

4 Channel Configure... Add Carrier

Reference: CCO =
PDCCH
R Cell ID
0

C5I-RS

Manually apply settings

TIP Use Quick Setups for convenient saving and loading of common
configurations. Quick Setups are factory supplied configurations and cannot
be deleted by users. (This includes Signal Studio Downlink and Uplink
defaults.)
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Save As Quick Setup (saved by the user) can be specific to the current user or
can be made available to others users. These setups can also be deleted.

8. Select the Carrier panel.

The Carrier dialog is used to configure component carrier level
parameters: Cell ID, Bandwidth, and Resource Grid for each Numerology.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups... -

Carriers Link Direction: (® Downlink Uplink

Bandwidth W iple Carrier Definitions
Tt N e Allow Multiple Carrier Definitions

BWP
4 Channel Reference: | CCO = Display: | CCO ~

SS/PBCH _ ) _ _
> Cell ID Bandwidth Carrier Center

PDCCH
v FR2 100 MHz  ~ | 20 GHz

PDSCH
CSI-RS Open Test Model...
Cross-Correlated EVM

Results & Filters )
Configure...

— SetCellIDto O

When the checkbox is selected, Cell ID auto-detection is enabled
for the carrier.

Cell ID is carried on PSS and SSS so the SS/PBCH must be transmitted
and enabled for Auto Cell ID to work. It must also be a downlink since
SS/PBCH is only transmitted on a downlink.
— Set Bandwidth to FR2 100 MHz
9. Select the Bandwidth panel and set Numerology to p = 3: 120 kHz

For FR2 100 MHz, the Max RB for 120 kHz numerology is
66 RB. This value will be used when we configure BWP, SS/PBCH, and
PDSCH.
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FR2 only uses 60, 120, or 240 kHz numerologies. This is why 15 and
30 kHz numerologies do not show under the Resource Grid.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup... Quick Setups.., CC0: CDO

Carriers

Bandwidth: FRZ1DOMHz =
Bandwidth
Resource Grid

WP

Numerology Gnd Start G Gnd Enabled
4 Channel

pu=2:60kH= ORE

Results & Filters

10. Select the BWP pane, then enable DL-BWP.

This section is used to configure the Downlink BWP allocation within the
component carrier and the control resource set (CORESET). CORESET is
used for PDCCH configuration and will not be used in this example. We
will use the default values of:

— Numerology p= 3: 120 kHz
— RB offset 0 RB
— RB Number 66 RB
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A component carrier with 100 MHz at FR2 has a maximum RB of 66
for 120 kHz numerology. In this example, DL-BWP uses the full
carrier bandwidth of 66 RBs as shown below.

Cenfiguration I Time Decode

Save As Quick Setup...  Quick Setups... CCo:CD0
Chigiases

Advanced

Initial-DL-BWP 0
J|DL-BWP
DL-BWP

DL-BWP

o|Inshal-UL-BWP 0

CORESETs

Filters

Add CORESET

pping Type: | Non-interleaved

Precoder Granularity: Same as REG bundle ~

TIP VSA supports a single BWP within a component carrier (CC). Signal Studio
and X-Apps support multiple BWPs within a CC. You can use VSA
multi-measurement to analyze multiple BWPs simultaneously.

11. Select the Channel pane > SS/PBCH, enable SS/PBCH and set the
following parameters:

— Lmax to L64

Lmax specifies the maximum number of SS/PBCH Blocks (that is,
beams) in an SS Block period.

— FR1 up to 3 GHz, Lmax = 4
— FR1 3to 6 GHz, Lmax =8

— FR2 6 to 52.6 GHz, Lmax = 64
— SSB Transmitted to 0:7
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For this example, we will not use all 64 SS Blocks; we will activate
only 8 of them. You can also select the Auto Detect Active Block
and set the Det Power Threshold to auto detect the active SS
Blocks.

Cenfiguration Input & Antenna Time Decode Advanced

Save As Cuick Setup..  Quick Setups... CC0: CDO

Carriers | 55/PBCH
Bandwidth B = 55B Transmitted:
BWP

Chamnel

RE Offset{60kHz): | 46RE
kSSEB{BlkHz) 0
Periodicrty: W ms

Results 8 Filters 5 ver boosting | OdB PBCH power boosting

IGPP Version: Latest (2

These following settings use the default values.

RB Offset(60kHz) = 46 RB

— kSSB(60kHz) =0
— Periodicity = 10 ms

Numerology = u=3 = 120 kHz

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup... Quick Setups... CCo: CDO

Carriers
Bandwidth a0 i - el o7
BWP er Threshold; | -30
4 Channel

MNumerclogy: u=3:120kHz ~

from center

Boosting

Results & Filters swer boosting | 0 dB PBCH power boosting | 0 dB

3GPP Version: | Latest (2019-06) =
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The frequency location of an SS Block is not fixed. The default value of 46
RB and kSSB of 0 subcarriers places it in the center of the carrier
bandwidth. This value is calculated based on the 60 kHz numerology as
defined by 3GPP (15 and 30 kHz sub-carrier spacing uses 15 kHz
numerology, 120 and 240 kHz spacing uses 60 kHz numerology.)

For example, to calculate the 120 kHz sub-carrier spacing, the value
would be

66RB/2 = 33 RB

This is the center of the carrier bandwidth. However, the SS Block is
20 RB wide, so the start of the SS Block is 23 RB.

23 RBin 120 kHz is 23 * 2 = 46 RB in 60 kHz
This is the default value used in the VSA software for 120 kHz numerology.

12. From the Channel pane, select PDSCH and then set the following

parameters:

— Under Modulation and Config section, set MCS Table to Table
256QAM and MCS to 20.

Configuration Time Decode Advanced

Save As Quick Setup... | Quick Setups...

Add PDSCH Remove PDSC

PDSCH: a

| Enabled RNTI: |1 3GPP Version: | Latest (2018-09/12) ~

Modulation and Coding | Time/Freq Allocation

popoopoobDDDDDDDD

Typel -
nip Source Cell ID B ORB RB Mumber: | 66 RB
np

CORESET ID:

RS Sequence

Power Boosting
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TIP 3GPP has different Tables for PDSCH MCS.
Table 5.1.3.1-2 has 256 QAM as maximum modulation
Table 5.1.3.1-3 has 64 QAM as maximum modulation

Table 5.1.3.1-1 has 64 QAM as maximum modulation, and is for low
spectrum efficiency (LowSE).

See 3GPP TS38.214 for more information.

— Under the Time/Freq Allocation section, set
— Allocated Slots to 0:79
— Slot Format to 0
— First Symbol to 0
— Last Symbol to 13
— RB Offset to O RB
— RB Number to 66 RB

B MeasD1 - 56 NR Demod Properties 7 ?
Configuration Time Decode Advanced
Save As Quick Setup...  Quick Setups...
Signal

Add PDSCH

Carrier
o PDSCH: a

4 Channel : L . § )
Modulation and Coding | Time/Freq Allocation

lation and Coding Time/Freq Allocation
] Allocate s 0:79

Table: Table 2560AM
MCS:
TB Scaling Factor 5: Mapping Type
Coding Rate: 0.6 5 First Symbol:
Modulation: ) 5 Resulting Format: DDDDDDDDDDDDDD
Transport Block Size: RA Type: Typel -
nip Source Cell ID Off: 0RB RE Number: | 66 RB
np

CORESET ID:

RS Sequence

Power Boosting

Antenna Port
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We will use the default values for RS Sequence, Power Boosting, and
Antenna Port. Power s would not change the DMRS sequences, but they
might be interested in modifying Power Boosting.

13. Select the Time tab and set:
— Result Length to 10 Subframes.
— Meas Interval to 2 Subframes.

— Select Frame Trigger is Present.

Configuration Input & Antenna Time Decode Advanced

Analysis Region
Result Length: 5 Subframes 0 Slots
Meas Offset: 2 Subframes 0 Symbols
Meas Interval: 3 Subframes 0 Symbols

Time Scale Factor: q

Analysis Start Boundary Acquisition Mode

Mormal
® Frame
- Reduced acquisition length
Half-frame
) Frame trigger is present
Subframe
Slot trigger is present
Slot

First Slot Index: 0

Timing Diagram

Result Length 5 Subf. ——

E Meas. Interval 3:0
* Meas. Offset 220

Frame Boundary

14. Select the Advanced Settings tab and select DC Punctured.

5G NR counts the DC subcarrier as a valid subcarrier for rate-matching
purposes. The network decides if the DC subcarrier is modulated or not.
High LO feedthrough will impact demodulation and EVM performance of
the input signal. This setting is off by default.

Use Extend Frequency Lock Range if you cannot lock to the input signal.

Compensate Symbol Clock Offset is used along with timing track to
compensate for clock error in the input signal. The Symbol Clock Error
result is reported in the Summary trace.
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3GPP Conformance Test > Phase is enabled by default. It is specified in
the 3GPP requirement and is used to compensate for phase differences

between symbols caused by up conversion or down conversion. Getting
this setting wrong will cause demod issues.

Configuration Input & Antenna Time Decode Advanced

19 RS

Transient Period

Length:

: R Power Change Threshold: 1
% of FFT Duration: -3.125 %

1Q Impairments

IQ Imb. Estimation Mode: = Off

Compensate |Q Offset +| DC Punctured
UL Spectrum Flatness
| Spectrum Flat Enabled

Test Environment Condition: | Normal * Test Tolerance: | 1.4 dB

Error Vector Unit

Time Domain: | Per Symbol ~ Freq Domain:

Per Subcarrier ~

MIMO Condition Number

Control: = Off ¥ | RB Granularity: 1

Auto Set Span Report EVM in dB
Independent SSB/BWP Measurement v Extend Frequency Lock Range | 480 kHz
Multicarrier Filter On v Compensate Symbol Clock Offset

Per Slot Channel Frequency Response
15. From the menu bar, select Window > Trace Layout > Tile Visible.

This will display all six 5G NR traces on the display.

16. Select the Auto-Range icon to run the measurement for EVM
optimization. This may take a few minutes to complete.

M9484C VXG and X-Series SA Measurement Guide 363



TIP

5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

The VSA has color coding based on channel type, marker coupling to pinpoint
error, symbol level analysis (by changing the measurement interval, and
measurement offset into a single symbol).

e Ea
|

‘A: OFDM M

364

T G Som G e =
| \3 e

Markers
e A

gea3s RIS 0 MR Ml A s

More About the 5G NR Traces

Trace A: shows the composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal.

Trace B: shows the frequency spectrum.

Trace C: shows the composite error metrics. You can also see the
automatically detected Cell ID value and the Channel Power.

Trace D: shows the EVM versus subcarrier and symbol.

Trace E: shows the detected allocations of all channels/signals within the
measurement interval. (For this example, 2 Subframes) You can see the 8
active SS Blocks in the first four slots.

Trace F: shows the frame summary: EVM Power per RE, Modulation format,
Number of RB and RTNI of the individual channels/signals.

For more information on these traces, see the Online help.
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Trace Filtering

The VSA has per-trace filtering to filter by subsegments and channels.
Subsegment refers to Layers, (in case of MIMO), BWP, and SS Block. In the
downlink, Layers in DL-BWP and SS Block are presented as subsegments. In
the uplink, Layers in UL-BWP are presented as subsegments.

The following traces can be filtered by subsegments and channel types.
— OFDM Meas

— OFDM Ref

— FError Vector Spectrum

— Error Vector Time

— Detected Allocations Time trace can be filtered per channel only

The rest of the traces do not support per-trace filtering.

A Simple Example

We will apply per-trace filtering to Error Vector Spectrum (Trace D) and
Detected Allocations Time (Trace E) traces.

1. From the menu bar, select Trace > Digital Demod.

2. In the Trace Dialog, select Trace D (OFDM Error Vector Spectrum) from the
dropdown.

3. In the Filtered SubSegments area, clear the Layer0 check box.
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This allows you to take a look at SS Block. You can also filter with SS
Block Channels/Signals you want to see by using the Filtered Channel

Type.

Format Coupling ¥ Scale X Scale Average Digital Demod
TraceD ~| + | Visible

Ideal State

Symbol Table Format:

Hex Shape:

Symbol Table Bit Order: e

Auto

Symbol Shape:

Bars

Eye Length: Code Order:

2 Bit Reverse

Time Unit:

sym Show 2D Avg Line
Frequency Unit:

carrier

Filtered SubSegments: Filtered Channel Types:

Select All Clear All Select All Clear All

4. Select Trace E (OFDM Detected Allocations Time) from the Trace dialog.
5. In the Filtered SubSegments area, clear the SS Block0 check box.

This alloys you to look at Layer 0 information, which is the DL-BWP
information.

. In the Filter Channel Types area, Clear All selections, then select just

PDSCH-DMRS.
You now see a gap in two of the DMRS symbols. Why is this?

Notice that the Frame Summary table shows Num. of RBs for PDSCH of
1056 and 1016 for PDSCH-DMRS. The signal configuration only had 66
RBs. Why the change in the measurement result?

The RB result in the Frame Summary table is per Slot. In this example, we
changed the measurement interval to 2 Subframes, which is 16 slots for
120 kHz numerology (8slots/subframe). 66*16=1056. For PDSCH-DMRS,
the value is 1016 because of the 16 slots overlap with the SS Block, which
occupies 20 RBs. This results in 20 RBs being punctured from DMRS in
these two slots, so the total RB Number for DMRS is 1056-20*2 = 1016.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude -10dBm

RADio:SELect NR5G
RADi0:NR5G:WAVeform:CCARrier :BWIDth FR2BW100M
RADi10:NR5G:WAVeform:CCARrier:SNUMerology MU3
RADi0:NR5G:WAVeform:CCARrier :DLINk:SSBLock:LMAX 64

RADio0:NR5G:WAVeform:CCARrier:DLINk:SSBLock:ACTive:INDices
"O:7"

RADio:NR5G:WAVeform:CCARrier :DLINk:SCHO:MCS 20
RADi0:NR5G:WAVeform:CCARrier :DLINk:SCHO:MCS:TABLe TABLeb52
RADi10:NR5G:WAVeform:GENerate

GROup:SIGNall ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.
RFALL :0OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:SELect VSA89601

SYSTem:PRESet

FREQuency:CENTer 28 GHz

INPut : ANALog: RANGe : AUTO

INITiate:PAUSe

INPut:TRIGger:STYLe "External"
INPut:TRIGger:LEVel :EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2 (This will
set it to Trigger 3)

NR5G: FRAMe : TRIGger:ENABled 1
INPut :EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

MEASure:CONFigure NR5G
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NR5G:CCARrier:CIDentity:AUTO 1 |OR| NR5G:CCARrier:CIDentity

0

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G

NR5G:
NR5G:
NR5G:
NR5G:

NR5G:

NR5G

NR5G:
NR5G:
NR5G:
NR5G:

NR5G:

CCARrier:TBANdwidth

DBWP:ENABled 1

"FRTwolOOMHz"

DBWP:NUMerology "Mu3"

DBWP:ROFFset 0
DBWP: RNUMber 66
SSBLock:ENABled 1
SSBLock:LMAX "L64"

SSBLock:AINDexes "0

27"

DBWP:PDSCh1:MCS:TABLe "Table2"

DBWP:PDSChl :MCS 20

CCAR:PDSCH1:SFI O

:DBWP:PDSChl:SLOT:ALLocated "0:79"

CCAR:PDSCH1:SINDex:FIRSt O

CCAR:PDSCH1:SINDex:LAST 13

CCAR:PDSCH1 :ROFFset

CCAR:PDSCHI : RNUMber

:RLENgth 10

SUBFrame: INTerval 2

0
66

FRAMe : TRIGger:ENABled 1

DC:PUNCtured 1

MCFilter:ENABled 1

FREQuency:LOCK:EXTended 1

NR5G:COMPensate: SYMBol :CLOCk:0OFFset 1

DISPlay:LAYout 3,2

INPut:ANALog:CRITeria:RANGe:AUTO "EVM", -1
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Creating a DL MIMO Signal Using PathWave N763TAPPC Signal
Generation

The VXG must have the N7631APPC Signal Generation for 5G NR license
installed.

This procedure will show you how to configure and analyze a downlink (DL)
multiple input, multiple output (MIMO) signal using PathWave Signal
Generation and the 89600 VSA software. The hardware setup below includes a
2-channel VXG signal generator and a 2+ channel, 33 GHz or higher Infiniium
UXR-Series Oscilloscope.

TIP If you do not have access to a Keysight Infiniium UXR Real-Time Oscilloscope,
a UXR recording waveform file has been included in the Example waveform
file folder:

D:\Users\Instrument\Documents\Keysight\PathlWave
\SignalGenerator\Examples

You will need to copy the 5GNR_UXR_Recording_28GHz.sdf file to the
X-Series Signal Analyzer or the PC running the VSA application. Steps have
been included below to successfully run the recording.

Hardware Requirement

— 2 channel M9484C VXG

— UXR with DDC option:
— UXR000-601: 160 MHz BW or
— UXR000-602: 2 GHz BW

Hardware accelerated DDC decimates oscilloscope captures in real-time
enabling deep captures and fast measurement speed.

Software Requirements

PathWave Signal Generation for 5G NR N7631APPC Use latest release from Keysight.com
89600 VSA software 89601BHNC VSA2023U2 or later

Equipment Setup for the M9484C

— M9484B CH1 front panel RF Out to UXR front panel CH1
— M9344B CH2 front panel RF Out to UXR front panel CH3
— M9484C front panel Channel T Event 2 to UXR rear panel Aux Trig In
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M9484C rear panel 10 MHz Out
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<o

instrument Information
1/0 Configuration
Alignment

Global Trigger/Sync
Power On/Presel
Reference

1/Q Waveform

Service

Preferences
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— MO9484C rear panel 10 MHz Out to UXR rear panel 10 MHz Ref In.

M9484C front panel Channel 1 Event 2 to UXR rear panel Aux Trig In

CH1 RF1 Out +

CH2 RF2 Out UXR

m9484c_UXR_4chan

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

If a Synchronization Alignment is required, indicated by A SYNCAN g

bottom left corner, tap or click the warning message and choose Perform
Alignment before proceeding.

I ] » Instrume
L

Global Trigger

channels utilizing Global Trigger will be

Immediate

Trigge;

Perform Alignment Clear Alignment
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2. In the Menu/Tool Bar, select the Triple Bar icon (top left corner of the
display, and then select Configure Channels. Change the signal
configuration from Independent to 2 Tx Coherent > Add > Apply > Apply.

RF Out (All) Trigger
{ 1 :‘:‘ 'J

V

LJ:LJ > Configure Channels

PRESET

Use the dropdown to configure the available RF Channels into Groups. Any remaining Channels will be set to Independent.
Group Configuration
Independent Add Remaining RF Channels: 4
1 CHANNEL 2 CHANNELS 4 CHANNELS
Independent 2 Tx Coherent 4 Tx Coherent

Nx2 MIMO (Beta) Nx4 MIMO (Beta)

3. In the Output area for both Channel 1 and Channel 2, set Frequency to
28 GHz, or the frequency you are using, and Power to 0 dBm.

28.00000000000 GHz

0.00 dBm
ALC ON

4. Select the Apps block to open, then select 5G NR.

Trigger

., RF Out (All)
esn | D
= B =) () > Avps -

Keysight PathWave Signal Generation

@ 56 NR @ Custom @ NR-V2X @ LTE FDD (Beta) @ LTE TDD (Beta)

Modulation (Beta)
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5. Select the Waveform tab and set the Total Number of Antennas 2. This
means that two antenna port signals will be generated.

RF Out (All) Trigger

oo
= s , (m] > Apps:56NR

& Generate Carrier Waveform

[+ Export 89600 VSA Setup

Marker Required License Version Date

Waveform Comment
Crest Factor Reduction

3GPP Version

AWGN
User-Defined Sample Rate

6. Select the Carriers tab > Cell Specific node, and set Bandwidth to FR2
100 MHz. Keep the rest of the default settings.

Custom M
* Generate Carrier Waveform
mn Fultilled Config T+ DLTestModel §* DL FRC Config « Auto Frequency Offset [+ Export 89600 VSA Setup
General Carrier Type Downlink
Spectrum Control CelliD 0
FR2 100MHz
Numerclogy Mode Single Numerology ~
Downlink
Numerology H=3:120kHz ~
Max RB 66

kO 0

Configured Bandwidth

7. Select the Downlink node > SS/PBCH > RB Offset by 60 kHz SCS and set
to 0.
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This automatically changes the Delta Frequency to Carrier Center to
-33.12 MHz. Using 0 RB Offset puts the SSB at the lower edge of the
carrier.

¥ Apps 56NR * Custom Modulation (Beta)
* Generate Carrier Waveform

e Fullfilled Config T~ DLTestModel E" DLFRC Config < Auto Frequency Offset [+ Export 89600 VSA Setup

General BWP E ) Shared Spectrum Channel Ac

um Control [l NR-PBCH Active Indices 0:3

. Power Boosting of each SS Block 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,C
secific oo MIB

0
DL-SCH

0
B csiRs

-33.12 MHz

. LTE-Coexistence 0

W Prs PSS Powe sting 0dB

8. Select the Downlink node > DL-SCH> Transmission Settings and confirm
DMRS ports is set to 0,1. Set Number of DMRS CDM groups without data
to 2.

You will see the layer number is updated to 2 and each layer is assigned
with a particular DMRS port. You'll also see that Antenna Ports Generated
is automatically set to PO,P1, which will map the multiple antenna port
signals to different antennas (instruments).

Custom Madulation (Beta)
*, Generate Carrier Waveform
w Fullfilled Config T+ DL Test Model g“ DL FRC Config « Auto Frequency Offset [+ Export 89600 VSA Setup
General BWP ' cee General Settings Antenna ) Generated

Spectrum Control [ 88

Number of Layers

Cell-Specific . DCl Resource Allocation

Number of Antenna ports
Modulation and Coding

B csiRs DMRS Settings
B LTE-Coexistence PTRS Settings

B PRs HARQ Settings

9. Select the Resource Allocation node and set:
— Allocated Slots to 2:79
— RB Offset to 20
— RB Number to 20
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DL-SCHO will occupy the RBs 20-40 and DL-SCH1 will occupy the rest of
the resources.

™ Apps SGNR * Custom Modulation (Beta)
*, Generate Carrier Waveform
mn Fullfilled Config T+ DLTestModel @~ DL FRC Config < Auto Frequency Offset [-+ Export 89600 VSA Setup

General BWP } en General Settings

spectrum Control [ 3C Transmission Settings First Symbol

Cell-Specific . DCl
Bandwidth Part BWP1
Modulation and Coding
RA Type Type 1 ~
B csiRs DMRS Settings
RB Offset 20

5 se .
GIRSSELNgA RB Number 20

HARQ Settings VRB-to-PRB Mapping Non-interleaved

10. Select the Modulation and Coding node and set:
— MCS to 20

— MCS Table to 5.1.3.1-2 (256 QAM)
Notice that modulation is updated to 256 QAM.

¥ Apps S5GNR * Custom Modulation (Beta)
* Generate Carrier Waveform
un Fullfilled Config T+ DLTestModel @~ DLFRC Config < Auto Frequency Offset [+ Export 89600 VSA Setup
General BWP + e General Settings Channel Coding v

Spectrum Control . SS/PBCH Transmission Settings MCS 20

: Table 5.1.3.1
Cell-Specific ol Resource Allocation ikl

Scaling Factor 1.0 v

Coding Rate
B csiRs DMRS Settings
Modulation

. LTE-Coexistence PTRS Settings Transport Block Si
ansport Block Size

. PRS HARQ Settings BaseGraph

11. Select the DMRS Settings node and notice that DMRS Power Boosting is
set to 3 dB.
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When CDM Group Number is 2, DMRS power boosting becomes 3 dB per

3GPP.

Aodulation (Beta)

¥ Generate Carrier Waveform

#H FulHfilled Config Y+ DLTestModel g~ DL FRC Config « Auto Frequency Offset [-» Export 89600 VSA Setup

BWP } s General Settings
Spectrum Control ] SS/PBCH Transmission Settings
Cell c H oci Resource Allocation
Modulation and Coding
B csiRs
. LTE-Coexistence PTRS Settings

I PRS HARQ Settings

DMRS PowerBoosting
DMRS Configuration

DMRS Duration

0

3dB

Type 1 w

Single Symbol
]

Type A v

12. Under the DL-SCH 0 node, select the + icon to add a new +DL-SCH

(DL-SCH1).

¢, Generate Carrier W m
ms Fullfilled Config T+ DL Test Model < Auto Frequency Offset [+ Export B9600 VSA Setup
General BWP
um Control [§ F H Transmission Settings

Resource Allocation

Modutation and Coding

[

PTRS Settings

M9484C VXG and X-Series SA Measurement Guide

v

v
Cell ID

1

[« Import Signal Setup

375



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

This will create a conflict between DL-SCHO and DL-SCH1. This will be
resolved in a later step.

-arrier 0, DI

fff] Generate Carrier Waveform
B Fullfilled Config T DL Test Model @" DL FRC Config <% Auto Frequency Offset [ Export 89600 VSA Setup
+ e General BWP + e General Settings n_SCID

Spectrum Control  [Jl] SS/PBCH S Transmission Settings

DMRS Configuration
Cell-Specific . DCI DL-SCH 1 Resource Allocation

DMRS Duration

Modulation and Coding
DMRS-add-pos

[l csi-rRs PDSCH Mapping

B LTE-Coexistence PTRS Settings DMRS-typeA-pos

N_ID_0
B Prs HARQ Settings

Vv Channel Allocation Summary
CRBu=3
DL-SCHO

DL-SCH1

13. From the Channels node, select DL-SCH > DL-SCH1 > Transmission
Settings and set DMRS port(s) to 0,1. Change the Number of DMRS CDM
groups without data to 2.
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Notice that Number of Layers is updated to 2 and each layer is assigned
with a particular DMRS port. Antenna Ports Generated is automatically
assigned PO,P1, which will map generated multiple antenna port signals
to different antennas (instruments).

™ Apps *  Custorn Madulation (Beta)
(", Generate Carrier Waveform
m Fullfilled Config T+ DLTestModel g~ DL FRC Config < Auto Frequency Offset [ Export 89600 VSA Setup

General BWP : ees General Settings Antenna Port(s)

Spectrum Control ] SS/PBCH DL-SCHO DMRS

S " Number of Layers
Cell-Specific H oo Resource Allocation :

Number of Antenna ports
Modulation and Coding
B CcSiRS DMRS Settings
Number of Codewords

B LTE-Coexistence PTRS Settings

H PRs HARQ Settings

14. Select the Resource Allocation node and set:
— Allocated Slots to 2:79
— RB Offset to 45
— RB Number to 18
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Notice that this resolves the conflict between DL-SCH channels. (The pink
shading is removed from the Channel Allocation graph. To clear the
conflict error message at the bottom of the display, select the Message

icon (bottom, right corner) and select Clear.

“  Custom Modulati

te Carrier waveform

m Fultfilled Config T+ DLTestModel g~ DLFRC Config < Auto Frequency Offset [+ Export 89600 VSA Setup

General BWP General Settings Alloc lots

Spectrum Control PBCH DL-SCHO Transmission Settings f

W oci

Cell-Specific
th Part
Modulation and Coding’

[l csirs
| &g
M FRrs

DMRS Settings

PTRS Settings

HARQ Settings

Channel Allocation Summary Frame0 ~ =3 v g pisplay Detail

DL-SCH1

B REFINT Locked

15. Select the Modulation and Coding node, and set MCS to 20.

Use the default MCS Table to Table 5.1.3.1-1 (64QAM). You will see the
modulation is updated to 64QAM.

Custom Modulation (Beta

e Carrier

mm Fulfilled Config T+ DL TestModel = DL FRC Config

DL-SCH O

N Channel Allocation Summary

« Auto Frequency Offset

waveform
[+ Export 89600 VSA Setup

General Settings Channel Coding v

Transmission Settings 20

able 5.1.3.1-1 (64QA v
Resource Allocation L A G L)

TB Scaling Factor 1.0 ~
Coding Rate

DMRS Settings
Modu

PTRS Settings
9 Transport Block Size

HARQ Settings BaseGraph

Frame0 ~ p=3

¥ [ Display Detail

DL-SCH1
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16. Select the Waveform tab > Marker and notice that Marker 2 Source is set
to Frame Start. Select Generate.

™ Apps *  Custom Modulation (Beta)

> Generate Carrier Waveform

[-» Export 89600 VSA Setup

Basic 1 Waveform Start ~
Ma ce Frame Start

= = = e Mé

Crest Factor Reduction

AWGN

Routing

17. In the bottom panel, select Spectrum.

You should see a spectrum like the one below.

i Apps 56NR * Custom M
. Generate Carrier Waveform
[+ Export 89600 VSA Setup
Basic Waveform Start
Frame Start
Crest Factor Reduction
AWGN

Routing

Antenna 0 ~

18. Return to the Carriers tab and select Export 89600 VSA Setup. Save the
.setx file to a USB drive to transfer to the VSA. We will also set up the
89600 VSA manually in the next section.
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19. Select the Home icon and set RF Out to On by selecting the numbered
channel indicator switches, and then select RF Out (All) master control
switch to turn the RF output On for both channels or off for both channels.

RF Out (All)

Adjustments

1/Q off /Q  On s BI0000" 28.00000000000 GHz

AWGN off « AM  Off Atten  Auto
Swap 1&Q Off Pulse Off Corr off
Delay  0.000s PwiLim Off 0.00 dBm

ALC OFF

Signal 1

Type 5GNR

Power 0.00dB

Status ¥ Waiting For Generation

Adjustments RF Output

1/Q off /Q On Phase 0.000° 2 SIDUONOURD0I 2
AWGN  Off ! AM  Off Atten  Auto

Swap 1&Q Off |_Internal Pulse Off Corr off

Delay 0.000s PwrLim Off 0.00 dBm

ALC OFF

‘ 1/Q Out

To Setup the VSA Using the Infinilum UXR Real Time Scope

There are two different VSA setup process.

— If you have access to a Keysight Infinilum UXR Real Time Scope continue to the
first step below.

— If you do not have access to a Keysight Infinilum UXR Real-Time
Oscilloscope, a UXR recorded waveform file has been included in the
Example waveform file folder of the VXG. Go to “To setup the VSA Using
a UXR Recorded Waveform File” on page 401

To analyze the signal using the VSA on the UXR307944

1. Open the VSA software.

To access the VSA software, go to the Windows Start menu and find
Keysight 89600 Software (latest installed version) folder and run the
software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.
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2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.

3. To configure the hardware, go to Utilities > Hardware > Configurations.
If it is already configured, go to step 10.

4. Open the Discovered Instruments tab and verify that the UXR is listed, if
not, select the Rediscover Instruments icon.

2= Hardware ? X

Configurations Discovered Instruments

4 TCPIPO
Keysight N9042B Signal Analyzer
t/Agilent PXA Signal Al

Keysi

Keysight/Agilent UXA RF Tuner (TCPIPO:k-n8040b-1220i
b SIM
P USR

5. In the Configuration tab, select the + icon.

E Hardware ? >

Config 5 scovered Instruments

Current Analyzer Configuration: Anahyzer3 - Channels: Baseband: 2 Channed

+ 1.7

4 Analyrer Configurations Analyzer3

Anal
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6. Scroll down the Possible Logical Instruments and select Keysight/Agilent
Infiniium Series Oscilloscope, and then select the right arrow to move it
under Configuration.

PR New Hardware Configuration ? X
1. Select the
t Simulate
—_— Configuration

'
-

Keysight/Agilent Infiniium Series Oscilloscope

dwidth from
z depending
. 4 Inputs.
Hints

2. Select the instrument(s) to use for each logical instrument in the configuration.

ADC Keysight/Agilent Technologies Infiniium Series Scope TCPIPO:localhostzinst0:INSTR =

3. Name the configuration.

Analyzer2

Cancel

7. From the middle of the dialog box, select the UXR to be used.

2. Select the instrumenty(s) to use for each logical instrument in the configuration

ADC Keysight/Agilent Technologies Infiniium Series Scope TCPIPO:localhostinst0:INSTR ~

8. Select OK to create the UXR configuration.
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9. In the Configurations tab, set the Current Analyzer Configuration, select
the Analyzer number for the new configuration. In this example Analyzer 3.

Configurations Discovered Instruments

Current Analyzer Configuration: Analyzer3 Channels: Baseband: 1 Channel

+ f 6 3 Analyzer

4 Analyzer Configurations Group Type: Analyzer

ht/Agilent Infiniilum Series Oscilloscope

Infiniium (SIM:Infiniium)

ht/Agilent Infiniilum Series Oscilloscope
Infiniium (SIM:Infiniium)
Analyzer3
4 Keysight/Agilent Infinilum Series Oscilloscope

Infiniium (SIM:Infiniium)

ht/Agilent Infinilum Series Oscilloscope

Infiniium (SIM:zInfiniium)

es Oscilloscope

4 Keysight VSA Stream

Stream (

Properties

The following steps perform the exact same function as loading the setup
file you exported the VSA Setup File. At this point you can follow the steps
below, or simply select File > Recall > Recall Setup and select the file you
saved to the VXG.

M9484C VXG and X-Series SA Measurement Guide 383



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

10. From the menu bar, select Input > Channels > RF > 2 Channels.

E Vector - Keysight PathWave Vector Signal Analysis (89600 VSA)

File Edit Control Source | Input | MeasSetup Trace Markers Window  Utilities Help

|| C) Channels > ﬂ Baseband: 2 Channel » 1 Channel
_ 1+jQ » | ¥ | 2Channel

Analog...
A: Ch1 Spectrum ~ T 3 Channel

ng -1 dBm S;i::lld 4 Channel

Trigger...

Playback Trigger...

External Mixer...

Extensions...

User Correction...

Playback User Correction... T |""|"|. R

| i H"'.J" ||||r|| I M'“'q N

AT ' |\| |1 |

Il

Data From
Recording..
Select Switch: None

Switch...

11. Set the center frequency of both channels to 28 GHz, or the frequency
you are using, and span to 100 MHz.

You can also set the frequency and span of both channels under Meas
Setup > Frequency.

If you are using a UXR, Select Autorange.

Auto Range samples the current input signal and then sets the full scale
input range to the minimum range that includes the peak voltage sample
of the input signal.

BB Vector - Keysight £3600

R Meas01 - MeasSetup ? X
Frequency ResBW Time Average

Measurement Channel:

Center:
28 GHz 100 MHz

#| Show Center/Span

¥ Auto Frequency Step

Time Data: v

Zoom - Mirror Frequency

B &

Measuement paused I INT REF | AL O

-Il A D m € & I giﬁi
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12. From the menu bar, select Input > Trigger and set:
— Style to External
— Levelto1V

Anzlog Digital Trigaer I ger Exte et Extensions

Input

13. From the menu bar, select MeasSetup > Measurement Type > Cellular >
5G NR > 5G NR Modulation Analysis.

14. Change the trace layout to Grid 2x3.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities Help

B = 8-l ‘
- - 5 Previous Layout
A: OFDM Meas + X | G Summary

Single
Stack 2
Stack 3

Stack 4

Stack 6

Grid 2x2
Grid 2x3
Grid 3x2
Custom...

Tile Visible
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To improve setup speed, Pause the measurement until all parameters are
correctly configured, then run the measurement.

386

15. Select MeasSetup > 5G NR Demod Properties > Configuration tab and set

that Bandwidth FR2 100 MHz, Carrier Center and Frequency for Phase
compensation are set to 28 GHz. Select the Cell ID checkbox.

- ] emod Properties 7 *
guration Input & Antenna Time ode Advanced
Save As Quick Setup_.  Quidl

Carriers Link Direction:  ® Downlink Uplink

Bandwidth e + Add Carrier Allow Multiple Carrier Definitions

BWP
4 Channel Reference: CCO = Display: CCO =
Jandwidth
FR2 100 MHz ~ | 28 GHz
Model...

related EVM

Configure...

Manually apply settings

Cell ID is carried on PSS and SSS so that SS/PBCH must be transmitted
and enabled for Auto Cell ID to work and must be a Downlink since
SS/PBCH is only transmitted in the DL.

Phase compensation is per the 3GPP requirement, and is enabled by
default. It is used to compensate for phase differences between symbols
caused by upconversion or downconversion. Getting this setting wrong
will cause a demod issue. For this example, it is ON and it is applied at the
center frequency.

16. Select the Bandwidth pane and confirm that numerology is set to

p=3:120 kHz.
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The Bandwidth panel is used to configure the Resource Grid for each
Numerology. Note that for FR2 100 MHz, the Max RB for 120 kHz

Numerology is 66 RB. We will use this value when we configure the
PDSCH parameters.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup...  Quick Setups... -

Carriers

Bandwidth: ~ FR2 100 MHz ~
Bandwidth

Resource Grid
BWP

Numerology Grid Start Grid Size Grid Enabled

4 Channel

0RB

P =4:240kHz: ORB 34 RB
Ref. Point A:  -47.52 MHz at -47.52 MHz from center
Results & Filters .
LTE-CRS Rate Match

Manually apply settings

17. Select the BWP pane and confirm that DL-BWP ID 1 is enabled.
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For each BWP allocation, configure the numerology (i) and RB allocation
information. In this example, we will use the default 120 kHz numerology,
RB Offset = 0 and RB number = 66 RB for a 100 MHz bandwidth signal.

= Meas01 - 5G NR Demod Properties ? X

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups... -

Carriers
Initial-DL-BWP
Bandwidth
+|DL-BWP
BWP
DL-BWP

4 Channel DL-BWP

RB Offset RB Number

¥ Initial-UL-BWP H=3:120kHz ORB 66 RB

CORESETs

Results & Filters
Add CORESET

CORESET: .

CORESET ID: |1 BWP ID: BWP1 ~
Symbol Number: = DMRS Scrambling ID: -1
RB Offset-r16 Configured CCE To REG Mapping Type: | Non-interleaved
RB Offset-R16:
Allocated RB Groups (

Precoder Granularity: Same as REG bundle ~

18. Select the Channel pane > SS/PBCH and set:
a. RB Offset (60 kHz) to O RB
b. Periodicity to 10 ms
c. Lmax to L64

d. SSB Transmitted to 0:3

For this example we will use 4 of the 64 SS/PBCH Blocks (beams). In an
SSBlock, the period is different fr the different numerologies.

— FR1 up to 3 GHz, L=4
— FR1 3 GHz to 7.125 GHz, L8
— FR2-1,FR2-2,L =64
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The frequency location of an SSBlock is not fixed. In the VSA software, a
default value of 46 RB and kSSB of 0 subcarriers places it in the center of
the carrier bandwidth. Using O RB Offset puts the SSB at the lower edge
of the carrier.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups... -

Carriers V| SS/PBCH

Bandwidth Lmax: L64 * | SSB Transmitted:

BWP | Auto Detect Active Block Det Power Threshold: | -3

Channel
RB Offset(60kHz): Al Numerology:
SS/PBCH
KSSB(60kHz): 0 SCS Common:
PDCCH

PDSCH Periodicity: 10 ms ~ | Half Frame Index: 0

P z bandwidth -33.12 MHz from center
CSI-RS

Results & Filters
PSS power boosting | 0dB PBCH power boosting | 0 dB

3GPP Version: = R16 Latest (2021-12) ~

19. To configure the PDSCHO, select the PDSCH pane and for PDSCH 0, set:
— MCS Table to Table 256 QAM
— MCS to 20
3GPP has different Tables for PDSCH MCS.
— Table 5.1.3.1-1 has 64QAM as max modulation
— Table 5.1.3.1-2 has 264QAM as max modulation
— Table 5.1.3.1-4 has 1024QAM as max modulation

— Table 5.1.3.1-3 has 64QAM as max modulation and is for
low spectrum efficiency (LowSE). See 3GPP TS38.214 for
more information.

— Allocated Slots to 2:79
— RB Offset to 20 RB
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Carriers
Bandwidth
BWP
Channel
SS/PBCH

PDCCH

CSI-RS

Results & Filters
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— RB Number to 20 RB

Add PDSCH

PDSCH: .

| Enabled

BWPID BWP1 ~

Enable Channels...

3GPP Version: | R16 Latest (2021-12) ~

Modulation and Coding | Time/Freq Allocation

Modulation and Coding

RV Index:

MCS Table:

MCS:

TB Scaling Factor S:
xOverhead:

Target Code Rate:

Modulation:

Transport Block Size:

nip Source
nip

CORESET ID:

Custom ModFormat:

0

Table 640AM

0.5537109375
QAMG4

10248

Cell ID

Time/Freq Allocation
Frame Period: 1 Frames
Allocated Slots: 279

Slot Format: 0: D,D,D,D,D,DDDDLDD.DD
DL X Symbols:
Mapping Type

TypeA v TypeA Pos:

First Symbaol: 0 Last Symbol:
Resulting Format: ppopoDDDDDDDDDDD
RB Ref CORESET ID: =1 - RA Type:

RB Offset: RB Number:

VRB-To-PRB Mapping: | Non-Interleaved ~| VR
Rate Match Patterns: None Edit...
«—BWP Max RB: 66

16.5
Unused RBs

3 5
Allocated RBs

20. Scroll down and select the Antenna Port dropdown and set:

— Antenna Ports Used,1 to 0:1

— DMRS CDM Group(s) without data to 2 (to match the PathWave
setup)

21. Under the RS Sequence dropdown, we will use the default settings for
DMRS and PTRS. However, this is where you would change the RS

settings.

22. Select the Power Boosting dropdown and verify that DMRS Power
Boosting has automatically been set to 3 dB.
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When "DMRS CDM group without data" is set to 2, the DMRS power
boosting becomes 3 dB per 3GPP definition.

Carriers Add PDSCH

Bandwidth
PDSCH: .

BWP

Enable Channels...

——BWP K

165

Channel
Unused RBs

.5
Allocated RBs

SS/PBCH
PDCCH Antenna Port

Ref. Antenna Port: 1000 = Ant. Det. Threshold:
Use Antenna Ports Index

Antenna Ports Index: 0 Codeword Number:

Antenna P d: |01 DMRS CDM gr ithout data:

PRB Bundle Size: Wideband

RS Sequence

DMRS Config

DMRS Max Length 1
DMRS Length
DMRS AddPos Pos0

DMRS Map Ref

Single-Symbol

DMRS-Downlink-r16
Nip" "™ Source Cell ID
Nscid: 0

0
Nip

Nip'

Enable PTRS
KPTRS
LPTRS
PTRS RE Offset

Additional DMRS-DL-Alt

DMRS Init Option: NR Standard DMRS Init:

Power Boosting

Power Boosting: 0 dB DMRS Power Boosting: | 3 PTRS Power Boosting:

23. To add and configure PDSCH1, select Add PDSCH.
24, Select PDSCH1 and set:

MCS Table to Table 64 QAM

MCS to 20

Allocated Slots to 2:79

RB Offset to 45 RB

M9484C VXG and X-Series SA Measurement Guide 391



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

— RB Number to 18 RB

Save As Quick Setup..  Quick Setups... -H

Carriers Add PDSCH | Remove PDSCH  Clear All Enable Channels...

Bandwidth
PDSCH: 0 .
BWP

_ + Enabled BWPID BWP1 ~ RNTIE: 1 3GPP Version: | R16 Latest (2021-12) ~
Channel

SS/PBCH . . . .
Modulation and Coding | Time/Freq Allocation

e Modulation and Coding Time/Freq Allocation
PDSCH RV Index: 0 Frame Period: 1 Frames
CSI-RS MCS e Table 64QAM Allocated Slots: 2:79
P s 2 s MCS: Slot Format:
TB Scaling Factor S: DL X Symboals:
xOverhead: Mapping Type TypeA - TypeA Pos:
Target Code Rate: J 375 First Symbol: ] Last Symbol:

Modulation: Resulting Format: DDDDDDDDDDDDDD

Transport Block Size: 1B Ref CORESET ID: =1 w RA Type:

T 5 A 3 45 R RB Number:

nip Source Cell ID

25. Scroll down and open the Antenna Port dropdown and set:
— Antenna Ports Used to 0:1
— DMRS CDM group(s) without data to 2.
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26. Select the Power Boosting dropdown and verify that DMRS Power
Boosting is set to 3 dB.

Save As Quick Setup.. Quick Setups... -

Carriers Add PDSCH Remove PDSCH  Clear All Enable Channels...

Bandwidth
PDSCH: 0 .

BWP

Channel

5
Unused RBs Allocated RBs

SS/PBCH
PDCCH Antenna Port

PDSCH Ref. Antenna Port: 1000 Ant. Det. Threshold:
CSI-RS Use Antenna Ports Index

. Antenna Ports Index; Codeword Number: 1
Results & Filters
Antenna Ports Used: | 0:1 DMRS CDM group(s) without data: 2

PRB Bundle Size: Wideband

RS Sequence
DMRS Config DMRS-Downlink-r16 Enable PTRS
DMRS Max Length 1 Nie”™™ Source Cell ID KPTRS
DMRS Length Single-Symbol Nscid: ] LPTRS
DMRS AddPos Pos0 Ng' 0 PTRS RE Offset
DMRS Map Ref Nip' 0 AdditionalDMRS-DL-Alt

DMRS Init Option: NR Standard DMRS Init:

Power Boosting

Power Boosting: 0 dB DMRS Power Boosting: | 3 PTRS Power Boosting:

Now you should see the demodulated signal and EVM results per layer in
the Frame Summary for PDSCHO and PDSCH]1.

27. To configure the Analysis region, select the Time tab and set:
— Result Length to 5 Subframes
— Meas Interval to 2 Subframes

— Enable Frame Trigger is present.
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We are using an external trigger for this example so selecting Frame
Trigger is Present will use the external trigger and will speed up the
measurement significantly. If not using an external trigger, set to
Normal.

Configuration Input & Antenna Time Decode Advanced

Analysis Region
Result Length: 5 Subframes 0 Slots
Meas Offset: 2 Subframes 0 Symbols
Meas Interval: 3 Subframes 0 Symbols

Time Scale Factor: 1

Analysis Start Boundary Acqguisition Mode
Normal
® Frame
. Reduced acquisition length

Half-frame

Subframe
Slot trigger is present

Slot

First Slot Index: 0

Timing Diagram

Result Length 5 Subf. ————

E Meas. Interval 3:0
* Meas. Offset 2.0

Frame Boundary

TIP To improve setup speed
Live measurement:

— Use external frame trigger and enable Frame trigger is
present. The real frame boundary must be within +50 ps of
the external trigger.

— If external frame trigger is not available, use Reduced
acquisition length. The reduced acquisition length may fail
to synchronize in scenarios where > 1 frame SSB
periodicity are defined, unless hardware triggering is used.

— Change Analysis Start Boundary to Subframe.

— Reduce Result Length and Measurement Interval.
Playback mode

— Reduce the Result Length and Measurement Interval.

— Set Analysis Start Boundary to Subframe.

— Reduce the number of active traces.
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28. To configure the PBCH and PDSCH decoding, select the Decode tab and
set.

— PBCH Decode to Decoded TB
— PDSCH Decode to Decoded TB
— PDSCH Decoder Algorithm to Offset Min Sum (default)

VSA2023U2 or later releases support a user selectable Decoder Algorithm.

Offset Min-Sum (Default) - Specifies the layered belief propagation
algorithm with offset min-sum approximation. This is faster but less
accurate than Belief Propagation.

Belief Propagation - Specifies the belief-passing or message-passing
algorithm. This is better for accuracy but slow. Use for receiver sensitivity
test where the SNR is very small.

For successful PDSCH decoding (i.e. CRC pass), make sure the RNTI
values (used for scrambling) and Transport Block Size matches between
the transmitted signal and VSA. (Transport block size depends on MCS
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH
channel setting).

2= Meas01 - 56 NR Demod Properties ? X
Configuration Input & Antenna Time Decode Advanced

DL Decode Settings

PBCH Decode: Decoded TB » | PDCCH Decode: = off (Scrambled Bits) ~

PDSCH Decode: Decoded TB o

PDSCH Decoder Algorithm: = Offset Min Sum

Decode Advanced Settings

Number of Iterations:

29. Select the Advanced tab and select the DC Punctured check box.

As part of conformance test, 3GPP has defined different equalizer training
and tracking for EVM measurements. 3GPP Conformance Test is enabled
by default where Tracking, Equalizer Training and EVM Window, and
Symbol Timing is applied per 3GPP conformance test requirement. For
FR1, no tracking is applied. For FR2, Phase Tracking using PTRS is applied.
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5G NR counts the DC subcarrier as a valid subcarrier for rate-matching
purposes. The network decides if the DC subcarrier is modulated or not.
High LO feedthrough will impact demodulation and EVM performance of
the input signal. This is OFF by default.

Configuration Input & Antenna Time Decode Advanced

| 3GPP Conformance Test

Tracking: Equalizer Training

Transient Period

Length:

Power Change Threshold: .

1Q Impairments
1Q Imb. Estimation Mode: = Off

Compensate |Q Offset ¥| DC Punctured
UL Spectrum Flatness

+| Spectrum Flatness Enabled

Test Environment Condition: | Normal ¥ Test Tolerance: | 1.4 dB

Error Vector Unit

Time Domain: | Per Symbol ~ | Freq Domain: | Per Subcarrier ~
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30. Close the 5G NR Properties dialog, start and new sweep to update the
display, then view the results.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities Help

Il : Bloes w1z ([R]7L 0 [ F1 0 Q Dl A so% ox

B: Ch1 Spectrum ~ X D:OFDM Err Vect Spectrum: All Layers ~ X | F: Frame Summary
dBm

Brr* EVM Power per RE Num. of

Name Modulation RBs

(%rms) (dBm)

Linkiag

— Trace A: Composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal. See Trace F (Frame Summary) for the list of
channels and modulation formats.

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and
symbol.

— Trace E: Detected Allocations Time showing the detected
allocations of all channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod
Format, Number of RB, RNTI, and BWP ID of the individual
channels/signals.

One of the most powerful tools in the 89600 VSA is the coupling of
markers across different measurements, traces, and domains. Coupled
markers allow you to understand the identity and characteristics of a
symbol simultaneously in time, frequency, and error.

Place a marker on Traces A, D, and E and couple the markers (Markers >
Couple Markers), and then show the results in a markers window (Window
> Markers).
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Right click on Trace D and select Peak. The exact symbol associated with
this peak EVM can now be understood in terms of time domain symbol
index, frequency domain subcarrier number, channel type, modulation
format, IQ magnitude, and phase values. Other parameters are shown in
the Marker window.

Change the traces so you can see the Constellation diagram, MIMO Info
table, Frame Summary Table (or Slot Summary Table), Summary table, 3D
Power, Decoded Info plus any additional traces.

A OFDM Meas

— Trace C: MIMO Info table shows EVM, power, and time, frequency
and phase offset for each antenna port.

MIMO Info is a type of Matrix Table that provides sortable rows by column,
selectable column visibility, and copy/paste and export functionality to
share rows of content or complete tables to applications like email, text
editing or spreadsheet programs.

— Trace E: 3D trace showing resource element (RE) power per symbol
and per subcarrier. This is very useful when verifying base station
systems, for example, to make sure the power per each RE is
balanced. You can use a marker to read the power and channel
information. A marker on this trace cannot be coupled with other
traces.

— Press the mouse wheel and rotate the wheel forward to
zoom in, backward to zoom out.

— Hold left-click of the mouse for panning. Note: If marker is
enabled (i.e. not a normal pointer), you will need to hold
Alt in order to pan.
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— Use right click to auto scale, enable the marker, and
change the display to different axes.

— Trace F: The Decoded Info table provides CRC pass/fail for PDSCH
and PBCH plus the high layer information that is carried on PBCH.

If CRC of PDSCH fails, make sure the Transport Block Size matches
between the transmitted signal and VSA (this depends on MCS
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH
channel setting). Also, make sure the RNTI values match since RNTI
is used for scrambling.

Result and Display Filtering

Meas Setup > NR Demod Properties > Configuration tab > Results & Filters
panel.

E= MeasD1 - 5G NR Demad Properties ? b4

Results & Filters
Results & Filters table has three configurable columns

Quick Setups.. 841

Color - sets the color for each channel (affects all traces that
display channel-specific information)
¢ By default colors are kept as they were in previous
release.
Is Displayed - Enables or disables the display of the channel in
all traces (supplements the per-Trace filtering under Trace ->
Digital Demaod)
¢ Uncheck a box to filter the channel out of the trace
results. This setting does not affect any EVM
calculations.
EVM Include - Includes or excludes the channel in the EVM
calculations. This also affects trace filtering.
Marmichy Eppliactongs Note 1: Frame Summary table doesn't get affected by Results & Filters
settings except for the color setting.

You can try to change colors of some of the channels, and/or filtering out
all channels/signals except for SSBlock (PSS, SSS & PBCH) etc.
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Clear (Uncheck) "Inactive" and "DC" to remove the inactive resources
(subcarriers, symbols) and the DC subcarrier from the display and see the
change in the 3D plot:

Before: After:

| Ex RE Power 3D ~ s E: RE Power 3D *
™
e
med

You can now auto-scale the 3D plot and only see the active
channels/signals being displayed.

Per-Trace Filtering
Trace > Digital Demod

In addition to the Results & Filters, VSA also has per-trace filtering to
filter by subsegments and/or channels. Subsegment means MIMO Layers,
BWP and SSBlock.

The following traces can be filtered by subsegments:
OFDM Meas
OFDM Ref

— Error Vector Spectrum

— Error Vector Time
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— Detected Allocations Time trace

o Window Utilties  Help

A BE- %S¢ il H :E A

mm | G OFDM Datected Allocations Time: A Layers

iz OFIM Fer Ve

A AL " AL RN
P S P e R L

Lok #1122 MMt lBetn Features In Lisec |

To setup the VSA Using a UXR Recorded Waveform File
1. Open the VSA software.

To access the VSA software, go to the Windows Start menu and find
Keysight 89600 Software (latest installed version) folder and run the
software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.
3. To configure the hardware, go to Utilities > Hardware > Configurations.

If it is already configured, continue with step 9.
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4. In the Configuration tab, select the + icon.

ﬁ Hardware

Configurations Dhscovered Instruments

Current Analyzer Configuration: |Anahyzerd

Channels:  Baseband: 2 Channel

A

Analyzer3

5. Inthe New Hardware Configuration dialog, select Simulate Hardware
and scroll down the Possible Logical Instruments and select

Keysight/Agilent Infiniium Series Oscilloscope, and then select the right
arrow to move it under Configuration.

:ﬁ Mew Hardware Configuration ?
1 Select the | yment(s) to use
¥ Simulate Har

Pessible Logical Instruments

Configuration
- g

Keysi
trum Analyzer

um Analyzer

Fi T g E
Keysight/Agilent Infiniium Series Oscilloscope
cith from

nfiguration.

SiMEzInfiniium =

ame the configuration.

Cancel

6. From the middle of the dialog box, select the UXR to be used.

2. Select the instrument(s) to use for each logical instrument in the configuration

ADC Keysight/Agilent Technologies Infiniium Series Scope TCPIPO=localhost:inst(:INSTR ~

7. Select OK to create the UXR configuration.
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8. In the Configurations tab, set the Current Analyzer Configuration, select
the Analyzer number for the new configuration. In this example Analyzer 3.

Configurations Discovered Instruments

Current Analyzer Configuration: Analyzer3 Channels: Baseband: 1 Channel

+ f G < Analyzer

4 Analyzer Configurations Group Type: Analyzer

Oscilloscope

eysight/Agilent Infiniium S Oscilloscope
Infiniium (SIM::Infir
Analyzer3
4 Keysight/Agilent Infiniium Series Oscilloscope

Infiniium (SIM:Infiniium)
4 Keysight/Agilent Infiniiun Oscilloscope
Infiniium (SIM:Infiniium})

ght VSA Stream

CH Stream (USR:Stream)

Oscilloscope

Infiniium (SIM:Ir

eysight VSA Stream

Properties

Stream (USR:Stream)

9. If you do not have access to a Keysight Infiniium UXR Real-Time
Oscilloscope, a UXR recorded waveform file has been included in the
Examples waveform file folder on the VXG.

Go to: D: \Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

Copy the MIMO_UXR_Recording.sdf file to the signal analyzer or the PC
running the VSA application.

10. From the Menu Bar, select File > Recall > Recall Recording and select
MIMO UXR Recording.sdf.

Recalling the recording will setup all of the parameters described below. If
you want to become familiar with the VSA setup, continue on with the
remaining steps.
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11. From the menu bar, select Input > Extensions > Sample Mode >FullRate
DDC.

Analog Digital Trigger Playback Trigger External Mixer Extensions
Logical Instrument: Preset

n Show All

4 Misc

CustomTrigCommand

CustomTrigType

Hardware DDC Sample Rate NaN
__Resamplelocation Driver
‘ SampleMode FullRateDdc
UserSampleRate 1E+09
UserSCPIPreset

12. From the menu bar, select Input > Channels > RF > 2 Channels.

E Vector - Keysight PathWave Vector Signal Analysis (89600 VSA)

File Edit Control Source | Input | MeasSetup Trace Markers Window Utilities Help
|| C) Channels » ﬂ Baseband: 2 Channel » 1 Channel

e 1+jQ y ¥ | 2Channe|
A: Ch1 Spectrum ~

Digital.. Custom... 3 Channel
ng -1 dBm c 3}3 - 4 Channel

Trigger...

Playback Trigger...

External Mix

Extensions...

User Correction...

Playback User Correction... i

N 1l ,‘|I.‘Illln| il 1
.~.J',|'I.,|| ||,"l-"J I'III I'ill ”l ‘ I"-..ll

My

fia |r'|,.

Data From
Recording...
Select Switch: None

Switch...

13. Set the center frequency of both channels to 28 GHz and span to
100 MHz.

You can also set the frequency and span of both channels under Meas
Setup > Frequency.
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If you are using a UXR, Select Autorange.

Autorange does not work if you are simulating the waveform with the UXR
recording. Continue with the next step.

Auto Range samples the current input signal and then sets the full scale
input range to the minimum range that includes the peak voltage sample
of the input signal.

P MeasD1 - MeasSetup T X

Frequency ResBW Time Average

Measurement Channel:
Center:

28 GHz 100 MHz

¥ Show Center/5pan

| Auto Frequency Step

Time Data: v

Zoom v Mirror Frequency

s el

Pime @

14. From the menu bar, select MeasSetup > Measurement Type > Cellular >
5G NR > 5G NR Modulation Analysis.

15. Change the trace layout to Grid 2x3.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities Help

B BRI R
A; OFDM Meas « X | C: Summary Previous Layout

Single
Stack 2
Stack 3
Stack 4
Stack 6
Grid 2x2
Grid 2x3
Grid 3x2

Custom...

Tile Visible
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16. Select MeasSetup > 5G NR Demod Properties > Configuration tab and set
Bandwidth to FR2 100 MHz, Carrier Center and Frequency for Phase
compensation are set to 28 GHz. Select the Cell ID checkbox.

Advanced

Link Direction:  ® Downlink Uplink

Allow Multiple Carrier Definitions

Configure... =+ Add Carrier

4 Channel Reference: CCO = Display: CCO =

FR2 100 MHz ~ | 28 GHz

Cell ID is carried on PSS and SSS so that SS/PBCH must be transmitted
and enabled for Auto Cell ID to work and must be a Downlink since
SS/PBCH is only transmitted in the DL.

Phase compensation is per the 3GPP requirement, and is enabled by
default. It is used to compensate for phase differences between symbols
caused by upconversion or downconversion. Getting this setting wrong
will cause a demod issue. For this example, it is ON and it is applied at the
center frequency.

17. Select the Bandwidth pane and confirm that numerology is set to
p=3:120 kHz.
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The Bandwidth panel is used to configure the Resource Grid for each
Numerology. Note that for FR2 100 MHz, the Max RB for 120 kHz
Numerology is 66 RB. We will use this value when we configure the
PDSCH parameters.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups... -

Carriers i ;
Bandwidth: | FR2 100 MHz ~
Bandwidth
Resource Grid
BWP
Numerology Grid Start Grid Size Grid Enabled
4 Channel

u=2:60kHz ORB

p=3:120kHz: ORB 66 RB

u=4:240kHz: ORB 34 RB

Ref. Point A: -47.52 MHz at -47.52 MHz from center
Results & Filters

LTE-CRS Rate Match

Manually apply settings

18. Select the BWP pane and confirm that DL-BWP ID 1 is enabled.
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For each BWP allocation, configure the numerology (i) as well as RB
allocation information. In this lab, we will use the default 120 kHz
numerology, RB Offset = 0 and RB number = 66 RB for a 100 MHz
bandwidth signal.

= Meas01 - 5G NR Demod Properties ? X

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups... -

Carriers
Initial-DL-BWP
Bandwidth
+|DL-BWP
BWP
DL-BWP

Channel
DL-BWP

RB Offset RB Number

¥ Initial-UL-BWP H=3:120kHz ORB 66 RB

CORESETs

Results & Filters
Add CORESET

CORESET: .

CORESET ID: |1 BWP ID: BWP1 ~
Symbol Number: = DMRS Scrambling ID: -1
RB Offset-r16 Configured CCE To REG Mapping Type: | Non-interleaved
RB Offset-R16:
Allocated RB Groups ({

Precoder Granularity: Same as REG bundle ~

19. Select the Channel pane > SS/PBCH and set:
a. RB Offset (60 kHz) to O RB
b. Periodicity to 10 ms
c. Lmax to L64
d. SSB Transmitted to 0:3

For this example we will use 4 of the 64 SS/PBCH Blocks (beams). In an
SSBlock, the period is different fr the different numerologies.

— FR1 up to 3 GHz, L=4
— FR1 3 GHzto 7.125 GHz, L8
— FR2-1,FR2-2,L =64
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The frequency location of an SSBlock is not fixed. In the VSA software, a
default value of 46RB and kSSB of 0 subcarriers places it in the center of
the carrier bandwidth. Using O RB Offset puts the SSB at the lower edge
of the carrier.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups... -

Carriers V| SS/PBCH
Bandwidth Lmax: L64 * | SSB Transmitted:

BWP | Auto Detect Active Block Det Power Threshold: | -3

Channel
Numerology:
SS/PBCH

i SCS Common:
PDCCH

PDSCH eric '8 ~ | Half Frame Index: 0

P bandwidth -33.12 MHz from center
CSI-RS

Results & Filters REEr BREsing
PSS power boosting 0 dB PBCH power boosting | 0 dB

3GPP Version: = R16 Latest (2021-12) ~

20. To configure the PDSCHO, select the PDSCH pane and for PDSCH 0, set:
— MCS Table to Table 256 QAM
— MCS to 20
3GPP has different Tables for PDSCH MCS
— Table 5.1.3.1-1 has 64QAM as max modulation
— Table 5.1.3.1-2 has 264QAM as max modulation
— Table 5.1.3.1-4 has 1024QAM as max modulation

— Table 5.1.3.1-3 has 64QAM as max modulation and is for
low spectrum efficiency (LowSE). See 3GPP TS38.214 for
more information.

— Allocated Slots to 2:79
— RB Offset to 20 RB
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Carriers
Bandwidth
BWP
Channel
SS/PBCH

PDCCH

CSI-RS

Results & Filters
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— RB Number to 20 RB

Add PDSCH

PDSCH: .

| Enabled

BWPID BWP1 ~

Enable Channels...

3GPP Version: | R16 Latest (2021-12) ~

Modulation and Coding | Time/Freq Allocation

Modulation and Coding

RV Index:

MCS Table:

MCS:

TB Scaling Factor S:
xOverhead:

Target Code Rate:

Modulation:

Transport Block Size:

nip Source
nip

CORESET ID:

Custom ModFormat:

0

Table 640AM

0.5537109375
QAMG4

10248

Cell ID

Time/Freq Allocation
Frame Period: 1 Frames
Allocated Slots: 279

Slot Format: 0: D,D,D,D,D,DDDDLDD.DD
DL X Symbols:
Mapping Type

TypeA v TypeA Pos:

First Symbaol: 0 Last Symbol:
Resulting Format: ppopoDDDDDDDDDDD
RB Ref CORESET ID: =1 - RA Type:

RB Offset: RB Number:

VRB-To-PRB Mapping: | Non-Interleaved ~| VR
Rate Match Patterns: None Edit...
«—BWP Max RB: 66

16.5
Unused RBs

3 5
Allocated RBs

21. Scroll down and select the Antenna Port dropdown and set:

— Antenna Ports Used,1 to 0:1

— DMRS CDM Group(s) without data to 2 (to match the PathWave
setup)

22. Under the RS Sequence dropdown, DMRS and PTRS are default settings,
but this is where you would change the RS settings.

23. Select the Power Boosting dropdown and verify that DMRS Power
Boosting has automatically been set to 3 dB.
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When "DMRS CDM group without data" is set to 2, the DMRS power
boosting becomes 3 dB per 3GPP definition.

Carriers Add PDSCH
Bandwidth
BWP

Channel

Antenna Port

Ref. Antenna Port: 1000
Use Antenna Ports Index

B Antenna Ports Inde
Results & Filters

PRB Bundle Wideband

RS Sequence
DMRS Config
DMRS Max Length 1
DMRS Length Single-Symbol
DMRS AddPos Pos0

DMRS Map Ref

Enable Channels...

Ant. Det. Threshold:

Codeword Number:

DMRS-Downlink-r16

DMRS )
Nip Source Cell ID
Nscid: 0

0
Nip

Nip'

——BWP Max RB: 66 ———

165
Unused RBs

E 5
Allocated RBs

Enable PTRS
KPTRS
LPTRS
PTRS RE Offset

Additional DMRS-DL-Alt

DMRS Init Option: NR Standard DMRS Init:

Power Boosting

Power Boosting: 0 dB DMRS Power Boosting: | 3 dB PTRS Power Boosting:

24, To add and configure PDSCH1, select Add PDSCH.
25. Select PDSCH1 and set:

MCS Table to Table 64 QAM

MCS to 20

Allocated Slots to 2:79

RB Offset to 45 RB
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— RB Number to 18 RB

Save As Quick Setup..  Quick Setups... -H

Carriers Add PDSCH | Remove PDSCH  Clear All Enable Channels...

Bandwidth
PDSCH: 0 .
BWP

_ | Enabled BWPID BWP1 - RNTE: | 1 3GPP Version: | R16 Latest (2021-12) ~
4 Channel
SS/PBCH . - . .
Modulation and Coding | Time/Freq Allocation

PDCCH - R B .
- Modulation and Coding Time/Freq Allocation

PDSCH RV Index: 0 Frame Period: 1 Frames

CSIR: MCS Table: Table 64QAM Allocated Slots: 27

Results & Filters MCS: Slot Format:
TB Scaling Factor S: DL X Symbols:
xOverhead: Mapping Type TypeA v TypeA Pos:
Target Code Rate: 553 375 First Symbol: ] Last Symbol:
Modulation: Resulting Format: ppDDDDDDDDDDDD
Transport Block RB Ref CORESET ID: =1l A RA Type:

i 5 RB Offset: RB Number:

nip Source Cell ID

26. Scroll down and open the Antenna Port dropdown and set:
— Antenna Ports Used to 0:1
— DMRS CDM group(s) without data to 2.
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Carriers

Bandwidth

BWP

Channel

Results & Filters
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27. Select the Power Boosting dropdown and verify that DMRS Power
Boosting is set to 3 dB.

Quick Setups... -

Add PDSCH Remove PDSCH  Clear All Enable Channels...

PDSCH: 0 .

165 495
Unused RBs Allocated RBs
Antenna Port

Ref. Antenna Port: 1000 - Ant. Det. Threshold:
Use Antenna Ports Index

Antenna Ports Index: 0 Codeword Number:

Antenna Ports | (0 DMRS CDM group(:

PRB Bundle Size: Wideband -

RS Sequence
DMRS Config DMRS-Downlink-r16 Enable PTRS
DMRS Max Length 1 Np  Source Cell ID KPTRS
DMRS Length Single-Symbol Nscid: 0 LPTRS
DMRS AddPos Pos0 N,DD 0 PTRS RE Offset
DMRS Map Ref Nio' 0 AdditionalDMRS-DL-Alt

DMRS Init Option: NR Standard DMRS Init:

Power Boosting

Power Boosting: | 0 dB DMRS Power Boosting: | 3 PTRS Power Boosting: 0 dB

28. To configure the Analysis region, select the Time tab and set:
— Result Length to 5 Subframes
— Meas Interval to 2 Subframes

— Enable Frame Trigger is present. NOTE: if using the UXR recording,
leave Frame Trigger set to Normal.
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The example measurement above uses an external trigger thus we
would use Frame Trigger is Present to speed up the measurement
significantly. If not using an external trigger or are using the UXR
recording, set to Normal.

Configuration Input & Antenna Time Decode Advanced

Analy gion
Result Length: 5 Subframes 0 Slots
Meas Offset: 2 Subframes 0 Symbols
Meas Interval: 3 Subframes 0 Symbols

Time Scale Factor: 1

Analysis Start Boundary Acqguisition Mode

Normal
® Frame
. Reduced acquisition length
Half-frame
) ris present
Subframe
Slot trigger is present
Slot

First Slot Index: 0

Timing Diagram

Result Length 5 Subf. ————

Frame Boundary

TIP To improve setup speed
Live measurement:

— Use external frame trigger and enable Frame trigger is
present. The real frame boundary must be within +50 ps of
the external trigger.

— If external frame trigger is not available, use Reduced
acquisition length. The reduced acquisition length may fail
to synchronize in scenarios where > 1 frame SSB
periodicity are defined, unless hardware triggering is used.

— Change Analysis Start Boundary to Subframe.

— Reduce Result Length and Measurement Interval.
Playback mode

— Reduce the Result Length and Measurement Interval.

— Set Analysis Start Boundary to Subframe.
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— Reduce the number of active traces.

29. To configure the PBCH and PDSCH decoding, select the Decode tab and
set.

— PBCH Decode to Decoded TB
— PDSCH Decode to Decoded TB
— PDSCH Decoder Algorithm to Offset Min Sum (default)

VSA2023U2 or later releases support user selectable Decoder Algorithm.

Offset Min-Sum (Default) - Specifies the layered belief propagation
algorithm with offset min-sum approximation. This is faster but less
accurate than Belief Propagation.

Belief Propagation - Specifies the belief-passing or message-passing
algorithm. This is better for accuracy but slow. Use for receiver sensitivity
test where the SNR is very small.

For successful PDSCH decoding (i.e. CRC pass), make sure the RNTI
values (used for scrambling) and Transport Block Size matches between
the transmitted signal and VSA. (Transport block size depends on MCS
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH
channel setting).

= Mess01 - 56 NR Demod Properties ? X
Configuration Input & Antenna Time Decode Advanced

DL Decode Settings

PBCH Decode: Decoded TB + | PDCCH Decode: | off (Scrambled Bits) ~

PDSCH Decode: Decoded TB >

PDSCH Decoder Algorithm: = Offset Min Sum

Decode Advanced Settings

Number of Iterations:

30. Select the Advanced tab and select the DC Punctured check box.
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As part of conformance test, 3GPP has defined different equalizer training
and tracking for EVM measurements. 3GPP Conformance Test is enabled
by default where Tracking, Equalizer Training and EVM Window, and
Symbol Timing is applied per 3GPP conformance test requirement. For
FR1, no tracking is applied. For FR2, Phase Tracking using PTRS is applied.

5G NR counts the DC subcarrier as a valid subcarrier for rate-matching
purposes. The network decides if the DC subcarrier is modulated or not.
High LO feedthrough will impact demodulation and EVM performance of
the input signal. This is OFF by default.

Configuration Input & Antenna Time Decode Advanced

| 3GPP Conformance Test

Tracking: Equalizer Training

Transient Period

Length:

Power Change Threshold:

1Q Impairments

1Q Imb. Estimation Mode: | Off
Compensate 1Q Offset ¥ DC Punctured

UL Spectrum Flatness
+| Spectrum Flatness Enabled

Test Environment Condition: | Normal ¥ Test Tolerance: | 1.4 dB

Error Vector Unit

Time Domain: = Per Symbol ~ Freq Domain: | Per Subcarrier -
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31. Close the 5G NR Properties dialog to view the results.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities Help

Il : Bloes w1z ([R]7L 0 [ F1 0 Q Dl A so% ox

B: Ch1 Spectrum ~ X D:OFDM Err Vect Spectrum: All Layers ~ X | F: Frame Summary

-1dBm ing -2 n EVM Power per RE Num. of

Name Modulation

(%rms) (dBm) RBs

Linkiag

— Trace A: Composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal. See Trace F (Frame Summary) for the list of
channels and modulation formats.

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and
symbol.

— Trace E: Detected Allocations Time showing the detected
allocations of all channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod
Format, Number of RB, RNTI, and BWP ID of the individual
channels/signals.

One of the most powerful tools in the 89600 VSA is the coupling of
markers across different measurements, traces, and domains. Coupled
markers allow you to understand the identity and characteristics of a
symbol simultaneously in time, frequency, and error.

Place a marker on Traces A, D, and E and couple the markers (Markers >
Couple Markers), and then show the results in a markers window (Window
> Markers).
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Right click on Trace D and select Peak. The exact symbol associated with
this peak EVM can now be understood in terms of time domain symbol
index, frequency domain subcarrier number, channel type, modulation
format, IQ magnitude, and phase values. Other parameters are shown in
the Marker window.

Change the traces so you can see the Constellation diagram, MIMO Info
table, Frame Summary Table (or Slot Summary Table), Summary table, 3D
Power, Decoded Info plus any additional traces.

A OFDM Meas

— Trace C: MIMO Info table shows EVM, power, and time, frequency
and phase offset for each antenna port.

MIMO Info is a type of Matrix Table that provides sortable rows by column,
selectable column visibility, and copy/paste and export functionality to
share rows of content or complete tables to applications like email, text
editing or spreadsheet programs.

— Trace E: 3D trace showing resource element (RE) power per symbol
and per subcarrier. This is very useful when verifying base station
systems, for example, to make sure the power per each RE is
balanced. You can use a marker to read the power and channel
information. A marker on this trace cannot be coupled with other
traces.

— Press the mouse wheel and rotate the wheel forward to
zoom in, backward to zoom out.

— Hold left-click of the mouse for panning. Note: If marker is
enabled (i.e. not a normal pointer), you will need to hold
Alt in order to pan.
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— Use right click to auto scale, enable the marker, and
change the display to different axes.

— Trace F: The Decoded Info table provides CRC pass/fail for PDSCH
and PBCH plus the high layer information that is carried on PBCH.

If CRC of PDSCH fails, make sure the Transport Block Size matches
between the transmitted signal and VSA (this depends on MCS
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH
channel setting). Also, make sure the RNTI values match since RNTI
is used for scrambling.

Working with Traces

— Trace A: Composite constellation diagram showing different modulation
formats for the different channels/signals present in the transmitted signal.
See Trace F (Frame Summary) for the list of channels and modulation
formats.

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and
symbol.

— Trace E: Detected Allocations Time showing the detected allocations of all
channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod Format,
Number of RB, RNTI, and BWP ID of the individual channels/signals.

One of the most powerful tools in the 89600 VSA is the coupling of markers
across different measurements, traces, and domains. Coupled markers allow
you to understand the identity and characteristics of a symbol simultaneously
in time, frequency, and error.

Place a marker on Traces A, D, and E and couple the markers (Markers >
Couple Markers), and then show the results in a markers window (Window >
Markers).

Right click on Trace D and select Peak. The exact symbol associated with this
peak EVM can now be understood in terms of time domain symbol index,
frequency domain subcarrier number, channel type, modulation format, 1Q
magnitude, and phase values. Other parameters are shown in the Marker
window.
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Change the traces so you can see the Constellation diagram, MIMO Info table,
Frame Summary Table (or Slot Summary Table), Summary table, 3D Power,
Decoded Info plus any additional traces.

— Trace C: MIMO Info table shows EVM, power, and time, frequency and
phase offset for each antenna port.

MIMO Info is a type of Matrix Table that provides sortable rows by column,
selectable column visibility, and copy/paste and export functionality to
share rows of content or complete tables to applications like email, text
editing or spreadsheet programs.

— Trace E: 3D trace showing resource element (RE) power per symbol and per
subcarrier. This is very useful when verifying base station systems, for
example, to make sure the power per each RE is balanced. You can use a
marker to read the power and channel information. A marker on this trace
cannot be coupled with other traces.

— Press the mouse wheel and rotate the wheel forward to zoom in,
backward to zoom out.

— Hold left-click of the mouse for panning. Note: If marker is enabled
(i.e. not a normal pointer), you will need to hold Alt in order to pan.

— Use right click to auto scale, enable the marker, and change the
display to different axes.

— Trace F: The Decoded Info table provides CRC pass/fail for PDSCH and
PBCH plus the high layer information that is carried on PBCH.
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If CRC of PDSCH fails, make sure the Transport Block Size matches
between the transmitted signal and VSA (this depends on MCS table, MCS
value, TB Scaling Factor S, and xOverhead under PDSCH channel setting).
Also, make sure the RNTI values match since RNTI is used for scrambling.

Result and Display Filtering

Meas Setup > NR Demod Properties > Configuration tab > Results & Filters
panel.

E= MeasD1 - 5G NR Demad Properties ? ®

14 2l
Results & Filters
Input & Antenna Time Decode Advanced

= e Results & Filters table has three configurable columns
Color - sets the color for each channel (affects all traces that
display channel-specific information)
e By default colors are kept as they were in previous
release.
Is Displayed - Enables or disables the display of the channel in
all traces (supplements the per-Trace filtering under Trace ->
Digital Demod)
¢ Uncheck a box to filter the channel out of the trace
results. This setting does not affect any EVM
calculations.
EVM Include - Includes or excludes the channel in the EVM
calculations. This also affects trace filtering.
Manually apply settings Note 1: Frame Summary table doesn’t get affected by Results & Filters
settings except for the color setfing.

roscH1_DMRs [

You can try to change colors of some of the channels, and/or filtering out all
channels/signals except for SSBlock (PSS, SSS & PBCH) etc.

Clear (Uncheck) "Inactive" and "DC" to remove the inactive resources
(subcarriers, symbols) and the DC subcarrier from the display and see the
change in the 3D plot:

Before: After:

[EREE £ [E-REPower3D ~
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You can now auto-scale the 3D plot and only see the active channels/signals
being displayed.

Per-Trace Filtering
Trace > Digital Demod

In addition to the Results & Filters, VSA also has per-trace filtering to filter by
subsegments and/or channels. Subsegment means MIMO Layers, BWP and
SSBlock.

The following traces can be filtered by subsegments:
— OFDM Meas

— OFDM Ref

— Error Vector Spectrum

— Error Vector Time

— Detected Allocations Time trace

& i A

= OFDM Detected Allocations Time: A Layers

3 OFDM Ert Viect Tir i OHDA Fer Mee! Tiere: AR Layets

Lok #1122 MMt lBetn Features In Lisec |
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Using the equivalent SCPI commands

On the VXG:
SYSTem:PRESet

RF1:FREQuency:CW 28GHz

RF1:POWer:AMPLitude 0dBm

RF2:FREQuency:CW 28GHz

RF2:POWer:AMPLitude 0dBm

CONFigure TX2

SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal

:MODE

:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:

:NR5G:

NR

CCARrier0
CCARrier0
CCARrier0

CCARrier0

CCARrier0:

CCARrierQ:

CCARrier0

CCARrier0

CCARrier0:

CCARrier0

CCARrier0

CCARrier0:

CCARrier0

CCARrier0

CCARrier0:

CCARrier0

CCARrier0

CCARrier0:

CCARrier0
CCARrier0

CCARrier0

CCARrier0:

CCARrier0
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:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:TYPE DL
:CIDentity OMIMO
:NUM:MODE SINGLE

:BWID FR1IBW100M

SNUM MU1
SNUM:RB:NUMB 273

SSBL:PERiodicity P10MS

SSBL:RB:OFFSet 0

DLINk:SCHO:DMRS:PORT '0,1"'

SCHO:SLOT "2:19"

SCHO:RB:OFFSet 2

DLINk:SCHO:RB:NUMBer 80

SCHO :MCS:TABL TABL52

SCHO:MCS 20

DLINk:SCHO:DMRS:POWer 3

SCHO : ADD

SCH1:DMRS:PORT 'O, 1"

DLINk:SCHI :DMRS:CGWD:COUN 2

SCH1:SLOT "2:19"

SCH1:RB:0OFFSet 150

SCH1 :RB:NUMBer 100

DLINk:SCH1:MCS:TABL TABL51

SCH1:MCS 20
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SIGNal:NR5G:WAVeform:GENerate

SIGNal ON
SIGNal:NR5G:TRIGger:SYNC:MARKer M2
RE1:0UTPut ON

RF2:0UTPut ON

RFALI :OUTPut ON

On the Analyzer:

INSTrument:SELect VSA89601
SYSTem:PRESet

FREQuency:CENTer 28 GHz

FREQuency:SPAN 122.88 MHz

INPut : ANALog: RANGe: AUTO

INITiate:PAUSe

INP:CHAN:CONF RF,RF

MEASure:CONFigure NR5G
NR5G:DBWP:ENABled 1
NR5G:SSBLock:ENABled 1
NR5G:SSBLock:ROFFset O

NR5G: SSBLock:PERiodicity "PeriodlOMilliseconds"
NR5G:DBWP: PDSChl :MCS: TABLe "Table2"
NR5G:DBWP:PDSCh1:MCS 20

NR5G:DBWP: PDSCh1:SLOT:ALLocated "2:19"
NR5G:CCARrier:PDSChl:ROFFset 40
NR5G:CCARrier:PDSChl:RNUMber 80
NR5G:CCARrier:PDSChl:ANTenna:PORT:USED 3
NR5G:CCARrier:PDSChl :RCGNumber "Two"
NR5G:DBWP: PDSCh1 : BPOWer : DMRS 3
NR5G:DBWP: PDSCh2 :MCS: TABLe "Tablel"
NR5G:DBWP: PDSCh2:MCS 20
NR5G:DBWP: PDSCh2: SLOT:ALLocated "2:19"

NR5G:CCARrier:PDSCh2:ROFFset 150
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NR5G:CCARrier:PDSCh2:RNUMber 100
NR5G:CCARrier:PDSCh2:ANTenna:PORT:USED 3
NR5G:CCARrier:PDSCh2:RCGNumber "Two"

NR5G: DBWP: PDSCh2 : BPOWer : DMRS 2

NR5G:RLENgth 10

NR5G: SUBFrame: INTerval 2
NR5G:FRAMe : TRIGger:ENABled 1

NR5G:DC: PUNCtured 1

NR5G:MCFilter:ENABled 1

NR5G:COMPensate: SYMBol:CLOCk:0OFFset 1
INPut:TRIGger:STYLe "External"
INPut:TRIGger:LEVel :EXTernal 1V
INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2
INPut :EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1
NR5G:FRAMe : TRIGger:ENABled 1

NR5G:DECode :MODE "DecodedTB"

DISPlay:LAYout 3,2
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